Problemas con el touchpad, a veces no funciona.

Spanish Forum

Moderator: JCSenar

Post Reply
wichowolf
Level 1
Level 1
Posts: 11
Joined: Fri Apr 20, 2018 3:35 pm

Problemas con el touchpad, a veces no funciona.

Post by wichowolf » Tue Jul 17, 2018 9:51 pm

Hola, cuando inicio normalmente Mint Cinnamon mi touchpad a veces no funciona como deberia. Estaba utilizando el kernel 4.10.0-38 y pensé que ese era el problema así que justo acabo de actualizar al 4.13.0-45 y el problema persiste. Que puedo hacer para solucionarlo? Gracias.

Este es el resultado de inxi -Fxznr

Code: Select all

System:    Host: lc-linux Kernel: 4.13.0-45-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.6 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: HP (portable) product: HP Stream 11 Pro G4 EE
           Mobo: HP model: 8426 v: 65.06 Bios: Insyde v: F.02 date: 10/19/2017
CPU:       Dual core Intel Celeron N3350 (-MCP-) cache: 1024 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 4377
           clock speeds: max: 2400 MHz 1: 1701 MHz 2: 1291 MHz
Graphics:  Card: Intel Device 5a85 bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.06hz
           GLX Renderer: Mesa DRI Intel HD Graphics 500 (Broxton 2x6)
           GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio:     Card Intel Device 5a98 driver: snd_hda_intel bus-ID: 00:0e.0
           Sound: Advanced Linux Sound Architecture v: k4.13.0-45-generic
Network:   Card: Intel Wireless 7265 driver: iwlwifi bus-ID: 02:00.0
           IF: wlo1 state: up mac: <filter>
Drives:    HDD Total Size: NA (-) ID-1: /dev/mmcblk0 model: N/A size: 62.5GB
Partition: ID-1: / size: 53G used: 25G (49%) fs: ext4 dev: /dev/mmcblk0p2
           ID-2: swap-1 size: 4.13GB used: 0.00GB (0%) fs: swap dev: /dev/dm-0
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 47.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Repos:     Active apt sources in file: /etc/apt/sources.list.d/google-chrome.list
           deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
           Active apt sources in file: /etc/apt/sources.list.d/miktex.list
           deb http://miktex.org/download/ubuntu xenial universe
           Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://mirrors.evowise.com/linuxmint/packages sylvia main upstream import backport
           deb http://ubuntu.ucr.ac.cr/ubuntu xenial main restricted universe multiverse
           deb http://ubuntu.ucr.ac.cr/ubuntu xenial-updates main restricted universe multiverse
           deb http://ubuntu.ucr.ac.cr/ubuntu xenial-backports main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ xenial-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ xenial partner
           Active apt sources in file: /etc/apt/sources.list.d/skype-stable.list
           deb [arch=amd64] https://repo.skype.com/deb stable main
           Active apt sources in file: /etc/apt/sources.list.d/smathot-cogscinl-xenial.list
           deb http://ppa.launchpad.net/smathot/cogscinl/ubuntu xenial main
           deb-src http://ppa.launchpad.net/smathot/cogscinl/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/spotify.list
           deb http://repository.spotify.com stable non-free
Info:      Processes: 220 Uptime: 8 min Memory: 2962.3/3786.0MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
Last edited by wichowolf on Wed Jul 18, 2018 11:41 am, edited 2 times in total.

User avatar
JOPETA
Level 13
Level 13
Posts: 4538
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Problemas con el touchpad, a veces no funciona.

Post by JOPETA » Wed Jul 18, 2018 4:09 am

¡Hola wichowolf , Bienvenid@ al foro! :D

Deberías aclarar el "a veces", es decir ¿cuándo no funciona?, si funciona en el GRUB y al logearte y luego no, si después de suspender, de usar el teclado, ...Añade si además tienes problemas con los gráficos, en la navegación por internet, al reproducir vídeos de HD, etc.

Tu equipo puede que apenas tenga un año y aunque el kernel 4.13 debería funcionar, considerando además que le queda sólo un mes de soporte, tal vez debas probar con el kernel 4.15- (evita el 4.15-0-24) instalando de la forma gráfica recomendada.

Antes comprueba que en la BIOS tienes desactivado el Secure Boot y que lo indicado aquí no soluciona tu problema.

En la página de soporte tienes una actualización de la BIOS de hace apenas un mes. Entiende que es una operación muy delicada sobre todo si no tienes costumbre de hacerlo (ojea esto). Además puede ser innecesario, si el Windows pre-instalado no tiene problemas con sus actualizaciones de software y controladores y en Linux si la actualización del kernel y firmware asociado tiene resultado, tienes instalado el iucode-tool y actualizas el microcode de Intel. Dependerá de tu configuración de las actualizaciones (Gestor de actualizaciones>Editar>Preferencias) que lo hagas de forma automática.

Si el microcode de Intel no está disponible en el Administrador de Controladores deberás comprobarlo e instalarlo desde el Gestor de paquetes Synaptic (paquete intel-microcode). :wink:
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

wichowolf
Level 1
Level 1
Posts: 11
Joined: Fri Apr 20, 2018 3:35 pm

Re: Problemas con el touchpad, a veces no funciona.

Post by wichowolf » Wed Jul 18, 2018 12:07 pm

Gracias JOPETA, lo siento por no haberme explicado bien. El touchpad funciona pero no como debería, unos minutos después de haber iniciado sesión, o se queda pillado o no se mueve todo el recorrido, o da doble clicks a lo loco. Si, también tengo problemas al reproducir vídeos y utilizar otras aplicaciones a la vez. El otro día use skype y se quedaba pillado todo el tiempo,al punto que tenia que reiniciar mi ordenador. Que recomiendas?

Por cierto, porque mencionas Windows?

Este es el resultado de dmesg | grep microcode

Code: Select all

[    0.000000] microcode: microcode updated early to revision 0x2c, date = 2017-03-25
[    4.934586] microcode: sig=0x506c9, pf=0x1, revision=0x2c
[    4.934637] microcode: Microcode Update Driver: v2.2.
La opción para actualizar el microcode me aparece en "Driver Manager" pero no me deja aplicar los cambios, la opción no me aparece resaltada.

User avatar
JOPETA
Level 13
Level 13
Posts: 4538
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Problemas con el touchpad, a veces no funciona.

Post by JOPETA » Wed Jul 18, 2018 12:55 pm

wichowolf wrote:
Wed Jul 18, 2018 12:07 pm
Que recomiendas?
Ya lo hice>>actualizar el kernel al 4.15.0-X (20, 22 o 23 evitando el 4.15.0-24) y esperar al nuevo prometido si esto no lo mejora (se han descartado por no pasar el control de calidad el 25, 26, 27 y creo que ahora están probando el 28...osea que sin prisas).
wichowolf wrote:
Wed Jul 18, 2018 12:07 pm
Por cierto, porque mencionas Windows?
Por que tu modelo sólo es vendido con el Windows 10 y Windows 10S preinstalados. Aunque puede que también lo vendan sin sistema es decir solo con el DOS, o con otro Windows, por vendedores locales la página de soporte solo da soporte para esos sistemas. 2+2=... :D
wichowolf wrote:
Wed Jul 18, 2018 12:07 pm
La opción para actualizar el microcode me aparece en "Driver Manager" pero no me deja aplicar los cambios, la opción no me aparece resaltada.
Puede ser debido a las dificultades gráficas mencionadas. ¿Has probado como te indico desde el Gestor de Paquetes Synaptic o el Gestor de Software? Fíjate que la revisón del microcode es anterior incluso a la fecha de tu BIOS. La actual versión tanto para LM 18 como LM 17 es la 3.20180425.1. Solo podrás instalarlo si inicias con un kernel con soporte actual y al 4.13 le quedan dos telediarios.

Por otra parte de existir algún otro problema (mira aquí ) ejecutando el mintdrivers desde la terminal daría la cara. Con gksudo creo que aún podrías gksudo mintdrivers o con pkexec mint-drivers en todo caso .

Me pregunto si lo propuesto aquí por Pjotr respeto al modesetting mejoraría los resultados o tendrá algo que ver. Desinstala completamente xserver-xorg-video-intel desde Synaptic ya que estás, si lo tienes instalado y si no haz la comprobación que te indica.
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

wichowolf
Level 1
Level 1
Posts: 11
Joined: Fri Apr 20, 2018 3:35 pm

Re: Problemas con el touchpad, a veces no funciona.

Post by wichowolf » Wed Jul 18, 2018 3:31 pm

Muchas Gracias JOPETA. Bueno, he hecho lo que has sugerido, actualize el kernel al 4.15.0-15. Aqui esta el reporte.

Code: Select all

System:    Host: lc-linux Kernel: 4.15.0-15-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.6 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: HP (portable) product: HP Stream 11 Pro G4 EE
           Mobo: HP model: 8426 v: 65.06 Bios: Insyde v: F.02 date: 10/19/2017
CPU:       Dual core Intel Celeron N3350 (-MCP-) cache: 1024 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 4377
           clock speeds: max: 2400 MHz 1: 1362 MHz 2: 1369 MHz
Graphics:  Card: Intel Device 5a85 bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.06hz
           GLX Renderer: Mesa DRI Intel HD Graphics 500 (Broxton 2x6)
           GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio:     Card Intel Device 5a98 driver: snd_hda_intel bus-ID: 00:0e.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-15-generic
Network:   Card: Intel Wireless 7265 driver: iwlwifi bus-ID: 02:00.0
           IF: wlo1 state: up mac: <filter>
Drives:    HDD Total Size: NA (-) ID-1: /dev/mmcblk0 model: N/A size: 62.5GB
Partition: ID-1: / size: 53G used: 26G (52%) fs: ext4 dev: /dev/mmcblk0p2
           ID-2: swap-1 size: 4.13GB used: 0.03GB (1%) fs: swap dev: /dev/dm-0
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 41.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Repos:     Active apt sources in file: /etc/apt/sources.list.d/google-chrome.list
           deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
           Active apt sources in file: /etc/apt/sources.list.d/miktex.list
           deb http://miktex.org/download/ubuntu xenial universe
           Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://mirrors.evowise.com/linuxmint/packages sylvia main upstream import backport
           deb http://ubuntu.ucr.ac.cr/ubuntu xenial main restricted universe multiverse
           deb http://ubuntu.ucr.ac.cr/ubuntu xenial-updates main restricted universe multiverse
           deb http://ubuntu.ucr.ac.cr/ubuntu xenial-backports main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ xenial-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ xenial partner
           Active apt sources in file: /etc/apt/sources.list.d/skype-stable.list
           deb [arch=amd64] https://repo.skype.com/deb stable main
           Active apt sources in file: /etc/apt/sources.list.d/smathot-cogscinl-xenial.list
           deb http://ppa.launchpad.net/smathot/cogscinl/ubuntu xenial main
           deb-src http://ppa.launchpad.net/smathot/cogscinl/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/spotify.list
           deb http://repository.spotify.com stable non-free
Info:      Processes: 244 Uptime: 8 min Memory: 2806.6/3785.8MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
No pude utlizar los kernel 4.15.0-X (20, 22 o 23) porque no iniciaban sesión y el sistema se quedaba pillado en una pantalla negra que decia "initramfs".

Con respecto al microcode, segun synaptics tengo instalado el 3.20180425.1.Pero el reporte dice lo siguiente, mantiene la fecha del 2017. A que crees que se deba esto?

Code: Select all

[    0.000000] microcode: microcode updated early to revision 0x2c, date = 2017-03-25
[    4.354627] microcode: sig=0x506c9, pf=0x1, revision=0x2c
[    4.354729] microcode: Microcode Update Driver: v2.2.

También ya desinstale completamente xserver-xorg-video-intel desde Synaptic y seguí lo propuesto por Pjotr respeto al modesetting. Todavia no he notado mejoría.

User avatar
JOPETA
Level 13
Level 13
Posts: 4538
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Problemas con el touchpad, a veces no funciona.

Post by JOPETA » Wed Jul 18, 2018 4:24 pm

1)Nos hemos apartado del tema touchpad del que no dices ni mu.

2)Sobre la permanencia de la referencia al kernel anterior es muy comentado en otros foros y cada uno da una explicación/solucion. La explicación de Intel es que en algnos caso depende de los fabricantes/BIOS que el kernel carge el microcode demasiado pronto y propoociona un enlace directo para su descarga y algunas instrucciones aunque la recomendación de Ubutnu es no descargalo y menos proceder a la instalción de la forma indicada.

La verdad es que en mi caso coincido en alguna premisas pero nunca tuve que hacer tales cosas. Seguiré mirando pero por ahora prueba con lo siguiente desde la teminal iniciando con el el kernel 4.15 que hayas instalado

Code: Select all

sudo apt-get install  build-essential dkms iucode-tool linux-firmware
sudo apt-get update
sudo apt-get install --reinstall intel-microcode 
sudo update-initramfs -u
sudo reboot
Compruebas los resultados. pero tampoco veo que se comunique ningún error en la carga del kernel como muchos de los casos que he mirado.
Last edited by JOPETA on Wed Jul 18, 2018 5:21 pm, edited 1 time in total.
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

wichowolf
Level 1
Level 1
Posts: 11
Joined: Fri Apr 20, 2018 3:35 pm

Re: Problemas con el touchpad, a veces no funciona.

Post by wichowolf » Wed Jul 18, 2018 5:09 pm

1) Despues de actualizar el kernel al 4.15, actualizar el microcode a 3.20180425.1 y desinstalar el xserver-xorg-video-intel, el touchpad sigue dando los mismos problemas. Incluso ahora ya he tenido que reiniciar el portatil dos veces porque el touchpad ha dejado de funcionar completamente.

2) Despues de ejecutar el comando que mencionaste:

Code: Select all

sudo apt-get install  build-essentials dkms iucode-tool linux-firmware
sudo apt-get update
sudo apt-get install --reinstall intel-microcode 
sudo update-initramfs -u
sudo reboot
Hay que cambiar "install build-essentials" a "install build-essential" de lo contrario da error. Los resultados son:

Code: Select all

System:    Host: lc-linux Kernel: 4.15.0-15-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.6 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: HP (portable) product: HP Stream 11 Pro G4 EE
           Mobo: HP model: 8426 v: 65.06 Bios: Insyde v: F.02 date: 10/19/2017
CPU:       Dual core Intel Celeron N3350 (-MCP-) cache: 1024 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 4377
           clock speeds: max: 2400 MHz 1: 2288 MHz 2: 2288 MHz
Graphics:  Card: Intel Device 5a85 bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.06hz
           GLX Renderer: Mesa DRI Intel HD Graphics 500 (Broxton 2x6)
           GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio:     Card Intel Device 5a98 driver: snd_hda_intel bus-ID: 00:0e.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-15-generic
Network:   Card: Intel Wireless 7265 driver: iwlwifi bus-ID: 02:00.0
           IF: wlo1 state: up mac: <filter>
Drives:    HDD Total Size: NA (-) ID-1: /dev/mmcblk0 model: N/A size: 62.5GB
Partition: ID-1: / size: 53G used: 26G (52%) fs: ext4 dev: /dev/mmcblk0p2
           ID-2: swap-1 size: 4.13GB used: 0.00GB (0%) fs: swap dev: /dev/dm-0
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 68.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Repos:     Active apt sources in file: /etc/apt/sources.list.d/google-chrome.list
           deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
           Active apt sources in file: /etc/apt/sources.list.d/miktex.list
           deb http://miktex.org/download/ubuntu xenial universe
           Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://mirrors.evowise.com/linuxmint/packages sylvia main upstream import backport
           deb http://ubuntu.ucr.ac.cr/ubuntu xenial main restricted universe multiverse
           deb http://ubuntu.ucr.ac.cr/ubuntu xenial-updates main restricted universe multiverse
           deb http://ubuntu.ucr.ac.cr/ubuntu xenial-backports main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ xenial-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ xenial partner
           Active apt sources in file: /etc/apt/sources.list.d/skype-stable.list
           deb [arch=amd64] https://repo.skype.com/deb stable main
           Active apt sources in file: /etc/apt/sources.list.d/smathot-cogscinl-xenial.list
           deb http://ppa.launchpad.net/smathot/cogscinl/ubuntu xenial main
           deb-src http://ppa.launchpad.net/smathot/cogscinl/ubuntu xenial main
           Active apt sources in file: /etc/apt/sources.list.d/spotify.list
           deb http://repository.spotify.com stable non-free
Info:      Processes: 242 Uptime: 2 min Memory: 2504.3/3785.7MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 

Code: Select all

dmesg | grep microcode
[    0.000000] microcode: microcode updated early to revision 0x2c, date = 2017-03-25
[    4.377274] microcode: sig=0x506c9, pf=0x1, revision=0x2c
[    4.377343] microcode: Microcode Update Driver: v2.2.
Muchas gracias por tu tiempo JOPETA, a ver si logramos solucionar esto.

User avatar
JOPETA
Level 13
Level 13
Posts: 4538
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Problemas con el touchpad, a veces no funciona.

Post by JOPETA » Wed Jul 18, 2018 5:27 pm

wichowolf wrote:
Wed Jul 18, 2018 5:09 pm
Incluso ahora ya he tenido que reiniciar el portatil dos veces porque el touchpad ha dejado de funcionar completamente.
¿Hiciste lo de instalar y configurar el dconf editor?
wichowolf wrote:
Wed Jul 18, 2018 5:09 pm
Hay que cambiar "install build-essentials" a "install build-essential" de lo contrario da error.
Ooops, perdón. Corregido.

Sobre el microcode en tu caso la explicación mas sencilla es esta que aunque hayas instalado el paquete, para tu cpu tan reciente Ubuntu aún no lo tiene disponible. Puedes comprobarlo si al ejecutar el siguiente código no obtienes resultados.

Code: Select all

/usr/sbin/iucode_tool -tb -lS /lib/firmware/intel-ucode/*
Manteniendo instalado el iucode-tools llegado el momento se realizará la instalación.

Volviendo al tema del comportamiento general del equipo y dado que lo relativamente reciente del mismo puede ser la causa principal de tus problemas (a falta de que confirmes que lo propuesto no tiene resultados) como norma general si estos porblemas impiden el uso normal del sistema el tema de las vulnerabilidades ocupa un sgundo lugar. Puedes probar a instalar un kernel mas reciente desde la mainline de Ubuntu como se indica en este tutorial. Tienes disponible el 4.16 y el 4.17 y podrías probar con ellos.

Otra opción de tener problemas con la instalación de estos kernels es probar con los de la antesala de los kernels de Ubuntu (la ppa canonical kernel) que estan ahora con el próximo 4.15 0-29?? :roll:
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

wichowolf
Level 1
Level 1
Posts: 11
Joined: Fri Apr 20, 2018 3:35 pm

Re: Problemas con el touchpad, a veces no funciona.

Post by wichowolf » Thu Jul 19, 2018 1:36 pm

Sobre instalar y desinstalar el dconf editor no lo habias mencionado antes. Como hago esto?

User avatar
JOPETA
Level 13
Level 13
Posts: 4538
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Problemas con el touchpad, a veces no funciona.

Post by JOPETA » Thu Jul 19, 2018 1:55 pm

JOPETA wrote:
Wed Jul 18, 2018 4:09 am
Antes comprueba que en la BIOS tienes desactivado el Secure Boot y que lo indicado aquí no soluciona tu problema.
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

wichowolf
Level 1
Level 1
Posts: 11
Joined: Fri Apr 20, 2018 3:35 pm

Re: Problemas con el touchpad, a veces no funciona.

Post by wichowolf » Thu Jul 19, 2018 4:36 pm

Gracias JOPETA. Pues con respecto al Secure boot, el resultado es el siguiente. Que piensas respecto a esto?

Code: Select all

dmesg |grep Secure
[    0.000000] secureboot: Secure boot could not be determined (mode 0)
[    4.386219] Loaded UEFI:db cert 'Hewlett-Packard Company: HP UEFI Secure Boot 2013 DB key: 1d7cf2c2b92673f69c8ee1ec7063967ab9b62bec' linked to secondary sys keyring
[    4.965565] sdhci: Secure Digital Host Controller Interface driver
y con respecto al link que copiaste. La única configuración es activar el touchpad, que de lo contrario no funcionaria.

User avatar
JOPETA
Level 13
Level 13
Posts: 4538
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Problemas con el touchpad, a veces no funciona.

Post by JOPETA » Fri Jul 20, 2018 7:12 am

wichowolf wrote:
Thu Jul 19, 2018 4:36 pm
La única configuración es activar el touchpad, que de lo contrario no funcionaria.
Esta opción previene la pérdida del Touchpad en algunos portátiles y circunstancias ( bloqueo de pantalla,suspensión, hibernación,inicio de sesión gráfica,...) asegurando que queda disponible.

¿Sobre el resultado del código y la carga de los controladores libinput/synaptic/evdev?

Code: Select all

grep -i "Using input driver" /var/log/Xorg.0.log
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

wichowolf
Level 1
Level 1
Posts: 11
Joined: Fri Apr 20, 2018 3:35 pm

Re: Problemas con el touchpad, a veces no funciona.

Post by wichowolf » Tue Jul 31, 2018 1:19 pm

Este es el resultado del codigo:

Code: Select all

grep -i "Using input driver" /var/log/Xorg.0.log
[    20.461] (II) Using input driver 'libinput' for 'Video Bus'
[    20.478] (II) Using input driver 'libinput' for 'Power Button'
[    20.498] (II) Using input driver 'libinput' for 'HP Webcam: HP Webcam'
[    20.534] (II) Using input driver 'libinput' for 'AT Translated Set 2 keyboard'
[    20.549] (II) Using input driver 'libinput' for 'SynPS/2 Synaptics TouchPad'
[    20.586] (II) Using input driver 'libinput' for 'HP Wireless hotkeys'
[    20.629] (II) Using input driver 'libinput' for 'HP WMI hotkeys'
[   725.114] (II) Using input driver 'libinput' for 'PS/2 Generic Mouse'
[  1728.460] (II) Using input driver 'libinput' for 'SynPS/2 Synaptics TouchPad'

User avatar
JOPETA
Level 13
Level 13
Posts: 4538
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Problemas con el touchpad, a veces no funciona.

Post by JOPETA » Tue Jul 31, 2018 5:36 pm

Puede que tu problema se resuelva simplemente con reinstalar xorg-synaptics apt install xserver-xorg-input-synaptics y/o apt install xserver-xorg-input-evdev.

Puedes permanecer con libinput ya que aunque figure en el resutado anterior puede que realmente no sea el controlador en uso (es un aplicación del espacio de usuario para manejar eventos del kernel), si tratas de desinstalar libinput o de resinstalarlo sin máss ademas de problemas de dependencias desinstalarías multitud de paquetes.

Comprueba que realmente lo tienes instalado con el siguiente código

Code: Select all

apt-cache policy xserver-xorg-core xserver-xorg-input-libinput
Existen problemas con libinput y Xorg en Ubuntu xenial. Si te aparece Installed: (none) comprueba el resultado de xinput y devuelve el resultado del siguiente código reemplazando ID por el valor real obtenido en el listado anterior

Code: Select all

xinput list-props ID
Por ejemplo en mi caso sería ↳ SynPS/2 Synaptics TouchPad id=12 [slave pointer (2) y por lo tanto el código deberá ser xinput list-props 12.

Puedes tratar del instalarlo realmente. Podrías instalar el controlador parcheado xserver-xorg-input-libinput-hwe-16.04 pero te puede dar problemas de dependendecias y tendrás que isnstalar el xserver-xorg-core que a se vez te desintalr otros paquetes incluidos los contraladores de la gráfica que tendrías que reinstalar. La forma correcta de hacerlo es esta pero como se dice en el hilo se pierden funcionalidades que luego hay que configurar.
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

Post Reply

Return to “Español (Spanish)”