Problema con angry IP scanner

Spanish Forum

Moderator: JCSenar

Post Reply
sergiolocuelo
Level 1
Level 1
Posts: 26
Joined: Mon May 14, 2018 11:15 am

Problema con angry IP scanner

Post by sergiolocuelo » Sat Sep 08, 2018 12:21 pm

Hola, me descargué el paquete del software angry ip scanner y lo instalé con gdebi, el problema es que cuando intento abrir el programa no se abre, como si no le hubiera ejecutado. ¿Alguien sabe que hacer para que funcione?

User avatar
JOPETA
Level 13
Level 13
Posts: 4710
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Problema con angry IP scanner

Post by JOPETA » Sat Sep 08, 2018 12:53 pm

Los desarrolladores parece que si :D
ipscn.png
¿Has probado desde la terminal conipscan?¿Tienes instalado openjdk-8-jdk? y de ser así ¿tienes predeterminada la apertura de archivos .jar de forma correcta?
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

sergiolocuelo
Level 1
Level 1
Posts: 26
Joined: Mon May 14, 2018 11:15 am

Re: Problema con angry IP scanner

Post by sergiolocuelo » Sun Sep 09, 2018 3:43 pm

JOPETA wrote:
Sat Sep 08, 2018 12:53 pm
Los desarrolladores parece que si :D
ipscn.png ¿Has probado desde la terminal conipscan?¿Tienes instalado openjdk-8-jdk? y de ser así ¿tienes predeterminada la apertura de archivos .jar de forma correcta?
Tengo instalado java, pero ¿Se supone que tengo que hacer un java -jar al archivo deb o descomprimirlo y hacerselo al archivo? No tengo ni idea de lo que hacer.

User avatar
JOPETA
Level 13
Level 13
Posts: 4710
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Problema con angry IP scanner

Post by JOPETA » Sun Sep 09, 2018 3:56 pm

Si es un .deb sólo tendrías que haber hecho doble clic sobre él archivo descargado para instalarlo y observar si te te cumunicaba la falta de alguna dependencia.

Como has instalado sin problemas aparentemente, y el problema si existe aparece al ejecutarlo desde el menú (me ha parecido enterderte), abre una terminal y ejecútalo con ipscan, devuelve el resultado como se indica aquí si se produce algún error.
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

sergiolocuelo
Level 1
Level 1
Posts: 26
Joined: Mon May 14, 2018 11:15 am

Re: Problema con angry IP scanner

Post by sergiolocuelo » Sun Sep 09, 2018 4:07 pm

JOPETA wrote:
Sun Sep 09, 2018 3:56 pm
Si es un .deb sólo tendrías que haber hecho doble clic sobre él archivo descargado para instalarlo y observar si te te cumunicaba la falta de alguna dependencia.

Como has instalado sin problemas aparentemente, y el problema si existe aparece al ejecutarlo desde el menú (me ha parecido enterderte), abre una terminal y ejecútalo con ipscan, devuelve el resultado como se indica aquí si se produce algún error.
Este es el resultado:

Code: Select all

Exception in thread "main" java.awt.AWTError: Assistive Technology not found: org.GNOME.Accessibility.AtkWrapper
	at java.desktop/java.awt.Toolkit.newAWTError(Toolkit.java:472)
	at java.desktop/java.awt.Toolkit.fallbackToLoadClassForAT(Toolkit.java:488)
	at java.base/java.util.stream.ForEachOps$ForEachOp$OfRef.accept(ForEachOps.java:183)
	at java.base/java.util.stream.ReferencePipeline$2$1.accept(ReferencePipeline.java:177)
	at java.base/java.util.HashMap$KeySpliterator.forEachRemaining(HashMap.java:1608)
	at java.base/java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:484)
	at java.base/java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:474)
	at java.base/java.util.stream.ForEachOps$ForEachOp.evaluateSequential(ForEachOps.java:150)
	at java.base/java.util.stream.ForEachOps$ForEachOp$OfRef.evaluateSequential(ForEachOps.java:173)
	at java.base/java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234)
	at java.base/java.util.stream.ReferencePipeline.forEach(ReferencePipeline.java:497)
	at java.desktop/java.awt.Toolkit.loadAssistiveTechnologies(Toolkit.java:532)
	at java.desktop/java.awt.Toolkit.getDefaultToolkit(Toolkit.java:613)
	at java.desktop/sun.swing.SwingUtilities2.getSystemMnemonicKeyMask(SwingUtilities2.java:2143)
	at java.desktop/javax.swing.plaf.basic.BasicLookAndFeel.initComponentDefaults(BasicLookAndFeel.java:1096)
	at java.desktop/javax.swing.plaf.metal.MetalLookAndFeel.initComponentDefaults(MetalLookAndFeel.java:440)
	at java.desktop/javax.swing.plaf.basic.BasicLookAndFeel.getDefaults(BasicLookAndFeel.java:150)
	at java.desktop/javax.swing.plaf.metal.MetalLookAndFeel.getDefaults(MetalLookAndFeel.java:1560)
	at java.desktop/javax.swing.UIManager.setLookAndFeel(UIManager.java:587)
	at java.desktop/javax.swing.UIManager.setLookAndFeel(UIManager.java:628)
	at java.desktop/javax.swing.UIManager.initializeDefaultLAF(UIManager.java:1403)
	at java.desktop/javax.swing.UIManager.initialize(UIManager.java:1516)
	at java.desktop/javax.swing.UIManager.maybeInitialize(UIManager.java:1482)
	at java.desktop/javax.swing.UIManager.getDefaults(UIManager.java:708)
	at java.desktop/javax.swing.UIManager.getString(UIManager.java:854)
	at java.desktop/javax.swing.UIManager.getString(UIManager.java:871)
	at java.desktop/javax.swing.JOptionPane.showMessageDialog(JOptionPane.java:612)
	at net.azib.ipscan.Main.main(Main.java:97)
Caused by: java.lang.ClassNotFoundException: org.GNOME.Accessibility.AtkWrapper
	at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:582)
	at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:190)
	at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:499)
	at java.base/java.lang.Class.forName0(Native Method)
	at java.base/java.lang.Class.forName(Class.java:374)
	at java.desktop/java.awt.Toolkit.fallbackToLoadClassForAT(Toolkit.java:485)
	... 26 more

User avatar
JOPETA
Level 13
Level 13
Posts: 4710
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Problema con angry IP scanner

Post by JOPETA » Sun Sep 09, 2018 4:16 pm

BIen pues como suponía el problema es la imposibilidad de crear la interfaz es decir con java.

Dices tener java instalado pero no confirmas la versión ni si es JDK y no sólo JRE (daría igual si fuera de Oracle o OpenJDK del repositorio).En el github del desarrollador contemplan problemas en caso de usar JDK 9 y JDK 7.

Tampoco confirmas que el sistema sabe con qué tiene que abrir los java según el enlace que te adjunté en el post anterior. También de tener varias versiones de java instaladas debes definir la versión que se va a usar por defecto con

Code: Select all

sudo update-alternatives --config java
deberás seleccionar la versión correcta.
Last edited by JOPETA on Sun Sep 09, 2018 4:31 pm, edited 1 time in total.
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

sergiolocuelo
Level 1
Level 1
Posts: 26
Joined: Mon May 14, 2018 11:15 am

Re: Problema con angry IP scanner

Post by sergiolocuelo » Sun Sep 09, 2018 4:28 pm

JOPETA wrote:
Sun Sep 09, 2018 4:16 pm
BIen pues como suponía el problema es la imposibilidad de crear la interfaz es decir con java.

Dices tener java instalado pero no confirmas la versión ni si es JDK y no sólo JRE (daría igual si fuera de Oracle o OpenJDK del repositorio).En el github del desarrollador contemplan problemas en caso de usar JDK 9 y JDK 7.

Tampoco confirmas que el sistema sabe con qué tiene que abrir los java según el enlace que te adjunté en el post anterior
Tengo Java version 1.8.0_181 y tengo dos jdk: OpenJDKJava 11 Runtime y OpenJDKJava 8 Runtime

sergiolocuelo
Level 1
Level 1
Posts: 26
Joined: Mon May 14, 2018 11:15 am

Re: Problema con angry IP scanner

Post by sergiolocuelo » Sun Sep 09, 2018 4:39 pm

Acabo de identificar el problema, tengo java para linux de 32 bits, pensaba que mi ordenador usaba arquitectura de 32 bits pero es de 64. ¿Como se desinstala todas las versiones de java que tengo?

User avatar
JOPETA
Level 13
Level 13
Posts: 4710
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Problema con angry IP scanner

Post by JOPETA » Mon Sep 10, 2018 3:31 am

En principio no hay probemas de coexistencia entre las maquinas java de 32 y 64, es decir deberías poder instalar la edición de 64 bits de java, si es que no lo has hecho ya, y seleccionarla para ejecutarla por defecto y cambiar a la de 32 cuando fuera necesario (aplicaciones java de 32 bits).

Otra cosa es que hubieras instalado la edición de 32 bits de Lnux Mint...Pero no comunicas errores en la instalación (ejecucion del paquete .deb) de la aplicación luego no debe ser este el problema.

Respecto al problema de ejecución de la aplicación, se han comunicado bugs en Bionic que apuntan a OpenJDK (no ocurren con Oracle JDK) que parecen estar detrás de la no ejecución de la aplicación. Podría ser solucionables simplemente desactivándo, la línea correspondiente en el archivo /etc/java-8-openjdk/accessibility.properties que quedaría así
#assistive_technologies=org.GNOME.Accessibility.AtkWrapper
o instalando Oracle JDK.
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

Post Reply

Return to “Español (Spanish)”