Ubuntu no inicia al tener una partición con Windows

Spanish Forum

Moderator: JCSenar

Post Reply
Charlotte1916
Level 1
Level 1
Posts: 2
Joined: Sat Oct 06, 2018 8:17 am

Ubuntu no inicia al tener una partición con Windows

Post by Charlotte1916 » Sat Oct 06, 2018 8:22 am

Hola, tuve que instalar una maquina virtual donde el primer sistema operativo era Ubuntu, y después instalar Windows 10. Lo instalé los dos sistemas operativos y al apagar la maquina virtual despues de instalar Windows 10, y intentar iniciar Ubuntu accede al modo de recuperación. Y intento encontrar una solución a este problema editando el gestor de arranque GRUB para sistemas con UEFI BIOS. Pero no lo he encontrado, alguna idea para solucionarlo y iniciar Ubuntu?

User avatar
JCSenar
Level 9
Level 9
Posts: 2791
Joined: Sat Sep 06, 2014 6:26 pm
Location: Irun, España
Contact:

Re: Ubuntu no inicia al tener una partición con Windows

Post by JCSenar » Sun Oct 07, 2018 2:48 am

Charlotte1916 wrote:
Sat Oct 06, 2018 8:22 am
Hola, tuve que instalar una maquina virtual donde el primer sistema operativo era Ubuntu, y después instalar Windows 10. Lo instalé los dos sistemas operativos y al apagar la maquina virtual despues de instalar Windows 10, y intentar iniciar Ubuntu accede al modo de recuperación. Y intento encontrar una solución a este problema editando el gestor de arranque GRUB para sistemas con UEFI BIOS. Pero no lo he encontrado, alguna idea para solucionarlo y iniciar Ubuntu?
Hola Charlotte1916: ¡Bienvenido al foro! :D

En cualquier instalación dual Windows-GNU-Linux (tanto en disco duro como en máquina virtual). el orden correcto es primero Windows y segundo GNU/Linux. Repítelo y te saldrá bien.
Image
Si tu consulta ha sido resuelta, por favor, edita tu primer mensaje y añade [SOLUCIONADO] al título. Gracias.

Charlotte1916
Level 1
Level 1
Posts: 2
Joined: Sat Oct 06, 2018 8:17 am

Re: Ubuntu no inicia al tener una partición con Windows

Post by Charlotte1916 » Sun Oct 07, 2018 5:51 am

JCSenar wrote:
Sun Oct 07, 2018 2:48 am
Charlotte1916 wrote:
Sat Oct 06, 2018 8:22 am
Hola, tuve que instalar una maquina virtual donde el primer sistema operativo era Ubuntu, y después instalar Windows 10. Lo instalé los dos sistemas operativos y al apagar la maquina virtual despues de instalar Windows 10, y intentar iniciar Ubuntu accede al modo de recuperación. Y intento encontrar una solución a este problema editando el gestor de arranque GRUB para sistemas con UEFI BIOS. Pero no lo he encontrado, alguna idea para solucionarlo y iniciar Ubuntu?
Hola Charlotte1916: ¡Bienvenido al foro! :D

En cualquier instalación dual Windows-GNU-Linux (tanto en disco duro como en máquina virtual). el orden correcto es primero Windows y segundo GNU/Linux. Repítelo y te saldrá bien.
Hola, entonces de Ubuntu a Windows no se puede? Nos lo han mandado de deberes que lo hicieramos de esta forma y que busquemos una solución.

User avatar
JCSenar
Level 9
Level 9
Posts: 2791
Joined: Sat Sep 06, 2014 6:26 pm
Location: Irun, España
Contact:

Re: Ubuntu no inicia al tener una partición con Windows

Post by JCSenar » Sun Oct 07, 2018 6:01 am

Charlotte1916 wrote:
Sun Oct 07, 2018 5:51 am
Hola, entonces de Ubuntu a Windows no se puede? Nos lo han mandado de deberes que lo hicieramos de esta forma y que busquemos una solución.
Pues si os lo han mandado en deberes, tal vez sí se pueda hacer :shock:

Espera a ver si algún otro tiene la solución...
Image
Si tu consulta ha sido resuelta, por favor, edita tu primer mensaje y añade [SOLUCIONADO] al título. Gracias.

User avatar
JOPETA
Level 13
Level 13
Posts: 4831
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Ubuntu no inicia al tener una partición con Windows

Post by JOPETA » Sun Oct 07, 2018 7:08 am

Mi experiencia con máquinas virtuales es muy escasa, lo cual me alegra en este caso ya que no tengo por costrumbre hacerle los deberes ni a mi hija. :D

Sólo una ayudita.. busca y sigue las indicaciones de cómo iniciar Ubuntu/Mint desde la consola de rescate de GRUB en una instalación normal y adáptalo a tu estructura de disco.

Una vez consigas iniciar, si lo consigues, se consciente de que has iniciado realmente sin cargador de arranque por lo que tendrás que reinstalar el cargador de arranque, pero antes deberás comprobar las modificaciones que la instalación de Windows haya podido realizar en el particionado y en espacial en la partición EFI cruzando los resultados delsblk y blkid con el contenido de /etc/fstab y modificar este último de ser necesario. Por supuesto después de esto y antes de reparar/reinstalar el cargador de arranque deberás montar la partición EFI si no lo estaba (es decir si has tenido que modificar su montaje en el archivo anterior) y asegurarte de que el sistema tienes instalado y ha cargado todo lo necesario. :wink:
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

Post Reply

Return to “Español (Spanish)”