Instalar escaner impresora Epson L395

Spanish Forum

Moderator: JCSenar

Post Reply
alvarojim
Level 1
Level 1
Posts: 3
Joined: Wed Oct 17, 2018 9:32 am

Instalar escaner impresora Epson L395

Post by alvarojim » Wed Oct 17, 2018 9:47 am

Hola amigos del foro. Soy el típico usuario que está abandonando windows, y cada cuanto me encuentro con cosas que intentan desanimarme. Hasta ahora siempre encuentro en la red alguna solución, pero ahora me he quedado entrampado en esto. He logrado instalar una epson L355 y L365 en linux mint, pero ahora no he podido con el escaner de la L395. Bajé los controladores, pero al querer instalar los paquetes me dá un error. Por ejemplo a diferencia de los de las L355 y L365, al descomprimir, no viene una carpeta DATA, sólo una CORE y una PLUGINS. Al ejecutar el .deb de la CORE, me da el error :"No se puede satisfacer la dependencia: libboost-filesystem1.58.0. Y en los .deb de PLUGINS, todos son errores distintos.

Por favor, si me pudiesen orientar, lo agradecería mucho.

Saludos.
Alvaro.

User avatar
JCSenar
Level 9
Level 9
Posts: 2797
Joined: Sat Sep 06, 2014 6:26 pm
Location: Irun, España
Contact:

Re: Instalar escaner impresora Epson L395

Post by JCSenar » Wed Oct 17, 2018 1:25 pm

alvarojim wrote:
Wed Oct 17, 2018 9:47 am
pero ahora no he podido con el escaner de la L395. Bajé los controladores, pero al querer instalar los paquetes me dá un error. Por ejemplo a diferencia de los de las L355 y L365, al descomprimir, no viene una carpeta DATA, sólo una CORE y una PLUGINS. Al ejecutar el .deb de la CORE, me da el error :"No se puede satisfacer la dependencia: libboost-filesystem1.58.0. Y en los .deb de PLUGINS, todos son errores distintos.

Por favor, si me pudiesen orientar, lo agradecería mucho.

Saludos.
Alvaro.
Hola alvarojim: ¡Bienvenido al foro! :D

¿Qué versión y escritorio de Linux MInt estás utilizando?

Además, proporciona de dónde has conseguido los drivers para el escaner porque en la web oficial, aunque aparentemente estén disponibles:

Pantallazo-1.png

Luego no hay nada :shock:

Pantallazo-2.png
Image
Si tu consulta ha sido resuelta, por favor, edita tu primer mensaje y añade [SOLUCIONADO] al título. Gracias.

alvarojim
Level 1
Level 1
Posts: 3
Joined: Wed Oct 17, 2018 9:32 am

Re: Instalar escaner impresora Epson L395

Post by alvarojim » Thu Oct 18, 2018 7:33 am

Hola, y gracias por atender mi solicitud. Bueno, a tus preguntas. Estoy usando Linux Mint 19 64 bits, cinnamon, y los drivers los saqué de este link.
http://download.ebz.epson.net/dsc/searc ... archModule

Otras cosas a mencionar que he realizado.
.- De acuerdo a lo que indica la web, instalé lsb (entiendo que mint es una distro de ubuntu).
.- Instalé los paquetes del escaner (los que me dan error al hacerlo en entorno gráfico uno por uno), con el archivo install.sh con "apt-get ./install.sh"
.- También intenté instalando libusb aunque nunca supe como ejecutarlo, menos hacer una prueba de comunicación con el escáner.
.- Y por último probé con VueScan, pero tampoco reconoció el escaner.

Muchas gracias y estaré atento a tu respuesta.

Salu2.

User avatar
JCSenar
Level 9
Level 9
Posts: 2797
Joined: Sat Sep 06, 2014 6:26 pm
Location: Irun, España
Contact:

Re: Instalar escaner impresora Epson L395

Post by JCSenar » Thu Oct 18, 2018 11:00 am

alvarojim wrote:
Thu Oct 18, 2018 7:33 am
Hola, y gracias por atender mi solicitud. Bueno, a tus preguntas. Estoy usando Linux Mint 19 64 bits, cinnamon, y los drivers los saqué de este link.
http://download.ebz.epson.net/dsc/searc ... archModule
JCSenar wrote:
Wed Oct 17, 2018 1:25 pm
Además, proporciona de dónde has conseguido los drivers para el escaner porque en la web oficial, aunque aparentemente estén disponibles:

Luego no hay nada :shock:
Hoy el enlace funciona bien :D

¿Es posible que descargaras el paquete equivocado? Tienes que tener en cuenta que tu versión (LM19) corresponde a Ubuntu 18.04. En la página de descargas del paquete del escaner no hay opción para Linux Mint 19 pero sí para Ubuntu 18.04, que es el que debes escoger mientras no haya versión para LM 19:

Pantallazo-3.png

Una vez descargado y descomprimido el archivo, tienes una carpeta que contiene el archivo install.sh:

Captura de pantalla -2018-10-18 16-50-51.png

Tal y como se recoge en estas instrucciones, abre un Terminal en la carpeta y ejecuta el archivo con el comando sudo ./install.sh. A mí se me instala correctamente en Linux Mint 19:

Code: Select all

juancar@HP-8200:~/Descargas/imagescan-bundle-ubuntu-18.04-1.3.38.x64.deb$ sudo ./install.sh
[sudo] contraseña para juancar: 
Obj:1 http://security.ubuntu.com/ubuntu bionic-security InRelease
Obj:2 http://archive.canonical.com/ubuntu bionic InRelease                     
Obj:3 http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu bionic InRelease    
Obj:4 http://archive.ubuntu.com/ubuntu bionic InRelease                        
Obj:5 http://archive.ubuntu.com/ubuntu bionic-updates InRelease                
Obj:6 http://archive.ubuntu.com/ubuntu bionic-backports InRelease              
Ign:7 http://packages.linuxmint.com tara InRelease                             
Obj:8 http://packages.linuxmint.com tara Release       
Leyendo lista de paquetes... Hecho                    
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
Paquetes sugeridos:
  graphicsmagick-dbg
Se instalarán los siguientes paquetes NUEVOS:
  graphicsmagick libboost-program-options1.65.1 libgraphicsmagick++-q16-12
  libgraphicsmagick-q16-3
0 actualizados, 4 nuevos se instalarán, 0 para eliminar y 29 no actualizados.
Se necesita descargar 1.985 kB de archivos.
Se utilizarán 9.901 kB de espacio de disco adicional después de esta operación.
Des:1 http://archive.ubuntu.com/ubuntu bionic/universe amd64 libgraphicsmagick-q16-3 amd64 1.3.28-2 [1.112 kB]
Des:2 http://archive.ubuntu.com/ubuntu bionic/universe amd64 graphicsmagick amd64 1.3.28-2 [634 kB]
Des:3 http://archive.ubuntu.com/ubuntu bionic/main amd64 libboost-program-options1.65.1 amd64 1.65.1+dfsg-0ubuntu5 [137 kB]
Des:4 http://archive.ubuntu.com/ubuntu bionic/universe amd64 libgraphicsmagick++-q16-12 amd64 1.3.28-2 [102 kB]
Descargados 1.985 kB en 1s (2.799 kB/s)             
Seleccionando el paquete libgraphicsmagick-q16-3 previamente no seleccionado.
(Leyendo la base de datos ... 268995 ficheros o directorios instalados actualmente.)
Preparando para desempaquetar .../libgraphicsmagick-q16-3_1.3.28-2_amd64.deb ...
Desempaquetando libgraphicsmagick-q16-3 (1.3.28-2) ...
Seleccionando el paquete graphicsmagick previamente no seleccionado.
Preparando para desempaquetar .../graphicsmagick_1.3.28-2_amd64.deb ...
Desempaquetando graphicsmagick (1.3.28-2) ...
Seleccionando el paquete libboost-program-options1.65.1:amd64 previamente no seleccionado.
Preparando para desempaquetar .../libboost-program-options1.65.1_1.65.1+dfsg-0ubuntu5_amd64.deb ...
Desempaquetando libboost-program-options1.65.1:amd64 (1.65.1+dfsg-0ubuntu5) ...
Seleccionando el paquete libgraphicsmagick++-q16-12 previamente no seleccionado.
Preparando para desempaquetar .../libgraphicsmagick++-q16-12_1.3.28-2_amd64.deb ...
Desempaquetando libgraphicsmagick++-q16-12 (1.3.28-2) ...
Procesando disparadores para mime-support (3.60ubuntu1) ...
Configurando libgraphicsmagick-q16-3 (1.3.28-2) ...
Procesando disparadores para libc-bin (2.27-3ubuntu1) ...
Procesando disparadores para man-db (2.8.3-2) ...
Configurando libboost-program-options1.65.1:amd64 (1.65.1+dfsg-0ubuntu5) ...
Configurando graphicsmagick (1.3.28-2) ...
Configurando libgraphicsmagick++-q16-12 (1.3.28-2) ...
Procesando disparadores para libc-bin (2.27-3ubuntu1) ...
Seleccionando el paquete imagescan previamente no seleccionado.
(Leyendo la base de datos ... 269121 ficheros o directorios instalados actualmente.)
Preparando para desempaquetar .../imagescan_3.48.0-1epson4ubuntu18.04_amd64.deb ...
Desempaquetando imagescan (3.48.0-1epson4ubuntu18.04) ...
Seleccionando el paquete imagescan-plugin-ocr-engine previamente no seleccionado.
Preparando para desempaquetar .../imagescan-plugin-ocr-engine_1.0.0-1epson4ubuntu18.04_amd64.deb ...
Desempaquetando imagescan-plugin-ocr-engine (1.0.0-1epson4ubuntu18.04) ...
Seleccionando el paquete imagescan-plugin-networkscan previamente no seleccionado.
Preparando para desempaquetar .../imagescan-plugin-networkscan_1.1.1-1epson4ubuntu18.04_amd64.deb ...
Desempaquetando imagescan-plugin-networkscan (1.1.1-1epson4ubuntu18.04) ...
Seleccionando el paquete imagescan-plugin-gt-s650 previamente no seleccionado.
Preparando para desempaquetar .../imagescan-plugin-gt-s650_1.0.0-1epson4ubuntu18.04_amd64.deb ...
Desempaquetando imagescan-plugin-gt-s650 (1.0.0-1epson4ubuntu18.04) ...
Configurando imagescan (3.48.0-1epson4ubuntu18.04) ...
Procesando disparadores para desktop-file-utils (0.23+linuxmint3) ...
Configurando imagescan-plugin-networkscan (1.1.1-1epson4ubuntu18.04) ...
Configurando imagescan-plugin-gt-s650 (1.0.0-1epson4ubuntu18.04) ...
Configurando imagescan-plugin-ocr-engine (1.0.0-1epson4ubuntu18.04) ...
Procesando disparadores para libc-bin (2.27-3ubuntu1) ...
Procesando disparadores para mime-support (3.60ubuntu1) ...
juancar@HP-8200:~/Descargas/imagescan-bundle-ubuntu-18.04-1.3.38.x64.deb$ 
Image
Si tu consulta ha sido resuelta, por favor, edita tu primer mensaje y añade [SOLUCIONADO] al título. Gracias.

alvarojim
Level 1
Level 1
Posts: 3
Joined: Wed Oct 17, 2018 9:32 am

Re: Instalar escaner impresora Epson L395

Post by alvarojim » Thu Oct 18, 2018 11:12 am

Si, efectivamente bajé ese paquete que era lo más cercano en versión a LM19, y tal como me indicas (y que mencioné en la primera respuesta), ejecuté el install.sh por la terminal y me los ha instalado bien, pero cuando abro SimpleScan o VueScan, ambos me dicen que no se detecta ningún escaner. Reinicié la máquina y todo. Si fuera para mí, monto un win con virtualbox y ya, pero es para mi hija que también está en esa etapa de transición de windows a linux y le tengo los dos SO instalados (dual boot), pero no es la idea estar reiniciando cada vez que quiera escanear, o no?

Bueno, seguiré tratando y esperando a ver si existe otra forma, salu2 y gracias.

Alvaro.

User avatar
JCSenar
Level 9
Level 9
Posts: 2797
Joined: Sat Sep 06, 2014 6:26 pm
Location: Irun, España
Contact:

Re: Instalar escaner impresora Epson L395

Post by JCSenar » Thu Oct 18, 2018 3:10 pm

alvarojim wrote:
Thu Oct 18, 2018 11:12 am
Si, efectivamente bajé ese paquete que era lo más cercano en versión a LM19, y tal como me indicas (y que mencioné en la primera respuesta)
alvarojim wrote:
Thu Oct 18, 2018 11:12 am
Instalé los paquetes del escaner (...), con el archivo install.sh con "apt-get ./install.sh"
Solo por aclararlo: en tu primera respuesta no indicas qué paquete descargaste (había varios) sino de donde. Y la forma que indicas que utilizaste tampoco es válida. Por eso mi anterior respuesta.
alvarojim wrote:
Thu Oct 18, 2018 11:12 am
ejecuté el install.sh por la terminal y me los ha instalado bien
Entonces lo has instalado con el comando correcto.
alvarojim wrote:
Thu Oct 18, 2018 11:12 am
pero cuando abro SimpleScan o VueScan, ambos me dicen que no se detecta ningún escaner.
Por descartar ¿has probado con ImageScan, que es el que se instala con los drivers? No debería tener que ver pero.... :?

Captura de pantalla -2018-10-18 21-07-09.png

Cuando he visto que había versiones separadas para Ubuntu y Linux Mint me ha parecido raro (y preocupante :roll: ). Es posible que el instalador (pensado para Ubuntu 18.04) detecte que el sistema es Linux Mint 19 (o sea, no es Ubuntu 18.04) y por eso no se instale correctamente. Es solo una hipótesis y estaría bien probar los drivers adecuados en LM 18, a ver si cambia algo.

Mientras, en el supuesto de que lo anterior sea correcto, podrías probar a engañar al sistema. Ejecuta en el Terminal el comando:

sudo -H xed /etc/lsb-release

Se te abrirá un archivo con el siguiente contenido:

Code: Select all

DISTRIB_ID=LinuxMint
DISTRIB_RELEASE=19
DISTRIB_CODENAME=tara
DISTRIB_DESCRIPTION="Linux Mint 19 Tara"
Modifícalo de esta forma y guarda los cambios:

Code: Select all

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=18.04
DISTRIB_CODENAME=bionic
DISTRIB_DESCRIPTION="Ubuntu 18.04 Bionic Beaver"
Reinicia, prueba a instalar de nuevo los drivers y a ejecutar el programa de escaneo. A ver si suena la flauta...

En cualquier caso, revierte los cambios en el archivo y dejarlo como estaba originalmente puesto que seguramente el problema esté durante la instalación.
Image
Si tu consulta ha sido resuelta, por favor, edita tu primer mensaje y añade [SOLUCIONADO] al título. Gracias.

Post Reply

Return to “Español (Spanish)”