[Solucionado] Aspire E5-575G no inicia con Nvidia Geforce 940MX

Spanish Forum

Moderator: JCSenar

Post Reply
Jacaro95
Level 1
Level 1
Posts: 5
Joined: Sat Jan 26, 2019 2:45 pm

[Solucionado] Aspire E5-575G no inicia con Nvidia Geforce 940MX

Post by Jacaro95 » Sat Jan 26, 2019 3:16 pm

Buenas a todos,
Hace poco que instalé Linux en este ordenador y tengo un problema con mi tarjeta gráfica.
Resulta que aparentemente instalé los drivers de Nvidia, inicialmente instalé el que recomienda el sistema operativo con el administrador de controladores, si no recuerdo mal instaló el nvidia-driver-390.
Pues una vez hecho, me meto en steam (ya que el ordenador lo estoy utilizando tanto para trabajar como para el ocio) y no me carga juegos que si debería, porque ya hice pruebas en otros ordenadores con menos recursos. Voy a información del sistema en steam y por lo que observo no detecta la tarjeta gráfica, detecta los graficos de intel.
He intentado instalar varias versiones de los drivers, y todo cambio ha sido a peor (ahora inicia la pantalla siempre a 960x540 aunque consigo arreglar este problema temporalmente). Hay alguna manera para hacer que trabaje la tarjeta gráfica Nvidia en vez la de Intel?

detalles de mi pc:
CPU : Intel Core i5-7200U
RAM : 8GB
Grafica: Nvidia Geforce 940MX

gracias de antemano.
Last edited by Jacaro95 on Thu Jan 31, 2019 2:31 pm, edited 1 time in total.

User avatar
JCSenar
Level 9
Level 9
Posts: 2905
Joined: Sat Sep 06, 2014 6:26 pm
Location: Irun, España
Contact:

Re: Tarjeta gráfica "no funciona"

Post by JCSenar » Sun Jan 27, 2019 3:59 am

Jacaro95 wrote:
Sat Jan 26, 2019 3:16 pm
detalles de mi pc:
CPU : Intel Core i5-7200U
RAM : 8GB
Grafica: Nvidia Geforce 940MX

gracias de antemano.
Hola Jacaro95: ¡Bienvenido al foro! :D

Por favor, proporciona más información sobre tu equipo/sistema como se explica aquí.
Image
Si tu consulta ha sido resuelta, por favor, edita tu primer mensaje y añade [SOLUCIONADO] al título. Gracias.

Jacaro95
Level 1
Level 1
Posts: 5
Joined: Sat Jan 26, 2019 2:45 pm

Re: Tarjeta gráfica "no funciona"

Post by Jacaro95 » Sun Jan 27, 2019 7:46 am

JCSenar wrote:
Sun Jan 27, 2019 3:59 am
Hola Jacaro95: ¡Bienvenido al foro! :D

Por favor, proporciona más información sobre tu equipo/sistema como se explica aquí.
Muchas gracias por el recibimiento :D

aquí vuelco toda la información del PC, gracias por decirmelo.

Code: Select all

System:
  Host: JacaroPC Kernel: 4.15.0-43-generic x86_64 bits: 64 compiler: gcc 
  v: 7.3.0 Desktop: MATE 1.20.1 Distro: Linux Mint 19.1 Tessa 
  base: Ubuntu 18.04 bionic 
Machine:
  Type: Laptop System: Acer product: Aspire E5-575G v: V1.47 
  serial: <filter> 
  Mobo: Acer model: Ironman_SK v: V1.47 serial: <filter> UEFI: Insyde 
  v: 1.47 date: 09/06/2018 
Battery:
  ID-1: BAT1 charge: 15.8 Wh condition: 32.8/41.4 Wh (79%) 
  model: PANASONIC AS16A5K status: Discharging 
CPU:
  Topology: Dual Core model: Intel Core i5-7200U bits: 64 type: MT MCP 
  arch: Kaby Lake rev: 9 L2 cache: 3072 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 21696 
  Speed: 3100 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 3102 2: 3100 
  3: 3100 4: 3094 
Graphics:
  Device-1: Intel HD Graphics 620 vendor: Acer Incorporated ALI driver: i915 
  v: kernel bus ID: 00:02.0 
  Device-2: NVIDIA vendor: Acer Incorporated ALI driver: N/A bus ID: 01:00.0 
  Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1280x720_60.00~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2) 
  v: 4.5 Mesa 18.0.5 direct render: Yes 
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Acer Incorporated ALI 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
  Sound Server: ALSA v: k4.15.0-43-generic 
Network:
  Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter 
  vendor: Lite-On driver: ath10k_pci v: kernel port: 4000 bus ID: 03:00.0 
  IF: wlp3s0 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Acer Incorporated ALI driver: r8169 v: 2.3LK-NAPI port: 3000 
  bus ID: 04:00.1 
  IF: enp4s0f1 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 1.14 TiB used: 446.01 GiB (38.3%) 
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO 250GB 
  size: 232.89 GiB 
  ID-2: /dev/sda vendor: Toshiba model: MQ01ABD100 size: 931.51 GiB 
Partition:
  ID-1: / size: 127.30 GiB used: 31.65 GiB (24.9%) fs: ext4 
  dev: /dev/nvme0n1p5 
Sensors:
  System Temperatures: cpu: 52.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Repos:
  No active apt repos in: /etc/apt/sources.list 
  Active apt repos in: /etc/apt/sources.list.d/graphics-drivers-ppa-bionic.list 
  1: deb http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu bionic main
  2: deb-src http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu bionic main
  Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
  1: deb http://mirrors.evowise.com/linuxmint/packages tessa main upstream import backport
  2: deb http://archive.ubuntu.com/ubuntu bionic main restricted universe multiverse
  3: deb http://archive.ubuntu.com/ubuntu bionic-updates main restricted universe multiverse
  4: deb http://archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse
  5: deb http://security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
  6: deb http://archive.canonical.com/ubuntu/ bionic partner
Info:
  Processes: 180 Uptime: 4m Memory: 7.66 GiB used: 509.2 MiB (6.5%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.3.0 Shell: bash v: 4.4.19 
  inxi: 3.0.27 

User avatar
JOPETA
Level 14
Level 14
Posts: 5047
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Tarjeta gráfica "no funciona"

Post by JOPETA » Wed Jan 30, 2019 5:16 am

Jacaro95 wrote:
Sat Jan 26, 2019 3:16 pm
Resulta que aparentemente instalé los drivers de Nvidia, inicialmente instalé el que recomienda el sistema operativo con el administrador de controladores, si no recuerdo mal instaló el nvidia-driver-390.
Puedes ver el controlador instalado con el Administrador de controladores o con el siguiente código en la terminal

Code: Select all

dkms status
Tambien puedes ver desde la terminal los controladores disponibles con ubuntu-drivers devices o añadir la ppa graphics drivers para disponer de otros controladores más actualizados con

Code: Select all

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
Jacaro95 wrote:
Sat Jan 26, 2019 3:16 pm
He intentado instalar varias versiones de los drivers, y todo cambio ha sido a peor (ahora inicia la pantalla siempre a 960x540 aunque consigo arreglar este problema temporalmente). Hay alguna manera para hacer que trabaje la tarjeta gráfica Nvidia en vez la de Intel?
Si nunca iniciaste con la discreta o dedicada Nvidia (con independencia del controlador instalado) es posible que el sistema esté predeterminado a usar la integrada intel. La preselección de la gráfica de Inicio puede realizarse, dependiendo del PC a nivel de BIOS, mediante el Nvidia server Setting (que además permite definir el rendimiento de la gráfica) o el icono de la barra del panel (nvidia-prime). Puedes cambiar de gráfica de inicio de forma gráfica usando esas aplicaciones o desde la terminal con

Code: Select all

sudo prime-select nvidia
Esto último requiere de haber instalado determinado software (nvida-setting, nvidia-prime, nvidia-prime applet). Puedes comprobar el software instalado para el control de la gráfica con el siguiente código en la terminal

Code: Select all

dpkg -l | grep -i nvidia
Una vez comprobado que tienes instalado controlador y resto de software y predeterminada la gráfica de inicio, deberás reiniciar para que la gráfica discreta sea usada. Si el primer reinicio es problemático (si acabas de instalar el controlador es lo normal), reinicia nuevamente si observas un comportamiento extraño, congelamientos, artefactos...

Si no se carga el controlador de la gráfica discreta o sólo inicias con la Intel después de lo anterior, además de la configuración de la BIOS existen otros factores que pueden afectar o impedir la carga del controlador. Por ejemplo puede malograr la carga e instalación de controladores libres, semiprivativos o privativos a nivel de BIOS el Secure boot que debería estar desactivado (lo puedes comprobar con mokutil --sb-state) , en la carga del sistema que el kernel trate de instalar por defecto el controlador libre nouveau , un contenido inadecuado de los archivos de configuración tanto del sistema (como el /etc/defautl/grub), relativos a los gráficos (puedes analizar el contenido de los registros como /var/log/Xorg.0.log o el informe de errores del sistema), del usuario ...

Dependiendo del resultado que obtengas una vez confirmada la existencia o no de problemas al reinicio, se podrán avanzar o sugerir algo más concreto después de analizar el inxi (inxi -Gxx) u otra información además de la comentada como por ejemplo

Code: Select all

dmesg | grep intel-microcode
xrandr --prop
lspci -nnk | egrep -A3 -i "3D|VGA"	              
ls /etc/modprobe.d
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

Jacaro95
Level 1
Level 1
Posts: 5
Joined: Sat Jan 26, 2019 2:45 pm

Re: Tarjeta gráfica "no funciona"

Post by Jacaro95 » Wed Jan 30, 2019 2:26 pm

SOLUCIONADO! :D :D
JOPETA wrote:
Wed Jan 30, 2019 5:16 am
Si no se carga el controlador de la gráfica discreta o sólo inicias con la Intel después de lo anterior, además de la configuración de la BIOS existen otros factores que pueden afectar o impedir la carga del controlador. Por ejemplo puede malograr la carga e instalación de controladores libres, semiprivativos o privativos a nivel de BIOS el Secure boot que debería estar desactivado (lo puedes comprobar con mokutil --sb-state) , en la carga del sistema que el kernel trate de instalar por defecto el controlador libre nouveau , un contenido inadecuado de los archivos de configuración tanto del sistema (como el /etc/defautl/grub), relativos a los gráficos (puedes analizar el contenido de los registros como /var/log/Xorg.0.log o el informe de errores del sistema), del usuario ...
Respuesta corta: efectivamente el secure boot estaba habilitado, una vez cambiado el valor el "Nvidia x server settings" me ha mostrado todas sus opciones y no una ventana gris y vacia. ya puedo seleccionar la grafica que quiero utilizar! :D :D

Respuesta larga: cuando instalé el sistema operativo ponía que para instalar los drivers sin problema tenía que deshabilitar el secure boot, cosa que hice. Pero a pesar de que quiero manejar linux principalmente, quiero tener Windows por si acaso hay algun programa que tenga que utilizar que me de problemas en linux. Resulta que cuando terminé la instalación de linux el ordenador solo cargaba el "Windows boot manager" ignorando por completo el arranque de grub. Después de darle varias vueltas en internete y tras mucho probar, vi una solucion, que era seleccionar en la bios un "archivo UEFI de confianza" y buscar el archivo grub.efi, pero esa opción solo se desbloqueaba habilitando el secure boot, a partir de ahí conseguí iniciar linux, ejecutar "update-grub" y hacer funcionar el menu de selección de grub. Pero se quedó ahí, el secure boot habilitado.

he explicado todo por si puede servir de algo... espero no estar hablando de mas.

Muchísimas gracias por contestar y por haber dado con la solucion :D

User avatar
JOPETA
Level 14
Level 14
Posts: 5047
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Tarjeta gráfica "no funciona"

Post by JOPETA » Thu Jan 31, 2019 4:51 am

Pues gracias por la aclaración tan útil y me alegro que lo solucionaras de la forma más fácil.:D

Por favor edita tu primer post (el que abre el hilo) haciendo clic en el icono de lápiz y modifica el título añadiendo [Solucionado] y si puede ser añade el PC (Acer Aspire E5-575G) que se trata de la gráfica Nvidia y lo que no funcionaba era el inicio (prime) con ella. Algo como Aspire E5-575G no inicia con Nvidia Geforce 940MX [Solucionado] . :wink:
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

Post Reply

Return to “Español (Spanish)”