Ufraw o Nufraw, pero no ambos

Spanish Forum

Moderator: JCSenar

Post Reply
User avatar
hatteras
Level 9
Level 9
Posts: 2880
Joined: Fri Sep 24, 2010 6:43 pm
Location: En el paraiso en la tierra
Contact:

Ufraw o Nufraw, pero no ambos

Post by hatteras » Sat Feb 02, 2019 9:41 am

Puedo instalar el programa Ufraw o el Nufraw, ambos son editor de archivos fotográficos .raw , pero no puedo instalar los dos. Si tengo uno instalado, para instalar el otro tengo primero que desinstalar el que tengo instalado.

Al intentar instalar nUfraw, teniendo ya Unfraw me sale el siguiente mensaje
dpkg: error al procesar el archivo /var/cache/apt/archives/nufraw_0.35-4dhor~trusty_amd64.deb (--unpack):
intentando sobreescribir `/usr/bin/nikon-curve', que está también en el paquete ufraw 0.22-2dhor~trusty
dpkg-deb: error: el subproceso copiado fue terminado por la señal (Tubería rota)
Procesando disparadores para man-db (2.6.7.1-1ubuntu1) ...
Se encontraron errores al procesar:
/var/cache/apt/archives/nufraw_0.35-4dhor~trusty_amd64.deb

Si desinstalo ufraw, si que puedo instalar nufraw, y si vuelvo a tratar de instalar ufraw me sale un mensaje similar. En ambos mensajes, lo común es que hay un problema en sobreescribir `/usr/bin/nikon-curve',

¿ Alguna solución para poder tener ambos Editores de archivos .raw ?
Todos somos muy ignorantes. Pero no todos ignoramos las mismas cosas.
Es un placer ayudar, y ver que a alguien le es útil.
Es un placer pedir ayuda y ver que alguien te la da desinteresadamente.

Image

User avatar
JOPETA
Level 14
Level 14
Posts: 5034
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Ufraw o Nufraw, pero no ambos

Post by JOPETA » Sat Feb 02, 2019 11:20 am

Como dicen aquí, básicamente nufraw parece ser un fork de ufraw con una UI mejorada y hasta ahí es lógico que no puedan coexistir ya que tendrán librerías comunes como el paquete en discordia (el nikon-curve), que estarán incorporadas al paquete de ufraw y al nufraw resultando incompatibles.

La versión de ufraw de la que deriva nufraw es la 0.23 y por elllo la primera versión es la 0.24. En tu caso, además, la versión de ufraw que instalas es la 0.22, anterior el cisma, y la de nufraw es la 0.35 (parece que recurres a esta ppa como repositorio) Los .deb incorporan las librerías del error, como dependencias. Quizas si trataras de compilar el/los paquetes desde su fuentes, por ejemplo recurriendo a los tarball de sourceforge, no se si tambien tendrías estos problemas ya que tienes la opción de usar flags especificos en para estos extras en el configure.

Por otra parte no veo la necesidad de instalar ambas ya que dicen en el primer enlace que la compatibilidad con las versiones anteriores (de ufraw) debería estar asegurada (aunque algunos usuarios tengan simplemente que renombrar las extensiones de los archivos .ufraw a .nufraw), incorpora versiones actualizadas del decodificador (dcraw ), con un mayor numero de cámaras soportadas,...

De hecho para los de GIMP ufraw se considera desfasado (parece detener su desarollo en el 2015 aunuqe se mantiene hasta el 2017 según que fuentes) y recomiendan nufraw no como un fork sino como la versión actualizada del anterior (la última versión de nufraw es la 0.42 compatible con GIMP 2.10).

Si las usas como editor independiente (no como plugin de otra aplicación), siempre puedes recurrir a las versiones portables y otras formas de instalación al menos de uno de ellos para evitar esto. :roll:
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

Post Reply

Return to “Español (Spanish)”