Problemas con audio / HDMI [SOLUCIONADO]

Spanish Forum

Moderator: JCSenar

Post Reply
lautir94
Level 1
Level 1
Posts: 2
Joined: Sun Feb 03, 2019 12:19 am

Problemas con audio / HDMI [SOLUCIONADO]

Post by lautir94 » Sun Feb 03, 2019 12:36 am

Hola aficionados por el software libre. Acudo al foro por la siguiente inquietud, espero puedan ayudarme.

No funciona el sonido en el navegador luego de usar el cable hdmi para conectarme al TV. Funciona mientras esta conectado, pero cuando desonecto el televisor no escucho los sonidos del navegador (youtube, facebook, etc.). Por suerte un usuario llamado JOPETA en este mismo foro dió solución a mi problema (que era problema de otro usuario pero coincidía con el mío) y cada vez que termino de usar el pc con el cable hdmi debo desistalar pulseaudio y Alsa , instalarlos y recargarlos con los siguientes comandos que JOPETA compartió:

Code: Select all

sudo apt-get remove --purge alsa-base pulseaudio linux-sound-base alsa-base alsa-utils
sudo apt-get install alsa-base pulseaudio linux-sound-base alsa-base alsa-utils

pulseaudio -k && sudo alsa force-reload 
El problema es que es muy engorroso tener que hacer esto cada vez que quiero usar la pc luego de conectar el HDMI, y lo uso con frecuencia. Habra una posibilidad de realizar un script en bash para que haga esto cada vez que termine de usar el hdmi? o alguna solución mas efectiva?

Audio:
Device-1: Intel Broadwell-U Audio vendor: Acer Incorporated ALI
driver: snd_hda_intel v: kernel bus ID: 00:03.0 chip ID: 8086:160c
Device-2: Intel Wildcat Point-LP High Definition Audio
vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel
bus ID: 00:1b.0 chip ID: 8086:9ca0
Sound Server: ALSA v: k4.15.0-20-generic

Agradezco su ayuda, soy nuevo posteando en el foro, disculpen si violé alguna regla. Saludos!
Last edited by lautir94 on Sun Feb 03, 2019 6:24 pm, edited 1 time in total.

User avatar
MrEen
Level 9
Level 9
Posts: 2534
Joined: Mon Jun 12, 2017 8:39 pm

Re: Problemas con audio / HDMI

Post by MrEen » Sun Feb 03, 2019 1:38 am

Perdón, pero no hablo español.

Escribe en la terminal:

Code: Select all

apt install pavucontrol
seguido por:

Code: Select all

pavucontrol
en la pestaña Dispositivos de salida asegúrese de que el dispositivo de audio incorporado esté configurado como alternativa (la casilla con la marca de verificación debe estar coloreada)

Espero que ayude.

User avatar
JOPETA
Level 14
Level 14
Posts: 5034
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Problemas con audio / HDMI

Post by JOPETA » Sun Feb 03, 2019 5:00 am

Además de lo indicado por MrEen sobre instalar pavucontrol y activar el dispostivo adecuado, observo que puede que no tengas actualizado el kernel (mira aquí para hacerlo de forma gráfica), lo que lleva a la necesidad de conocer mas detalles de tu sistema. Devuelve el resultado del siguiente código usando la opción </> (code) del editor de foro.

Code: Select all

inxi -Fxznr
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

lautir94
Level 1
Level 1
Posts: 2
Joined: Sun Feb 03, 2019 12:19 am

Re: Problemas con audio / HDMI

Post by lautir94 » Sun Feb 03, 2019 3:16 pm

Hola Gracias por la pronta respuesta! Probe en configurar el pavucontrol como me dijeron.

Por el momento esta funcionando como esperaba! muchas gracias.

Por otro lado, los resultados de inxi -Fxznr .

Code: Select all

System:

  Host: lautaro-Aspire-E5-473 Kernel: 4.15.0-45-generic x86_64 bits: 64 
  compiler: gcc v: 7.3.0 Desktop: Cinnamon 4.0.9 
  Distro: Linux Mint 19.1 Tessa base: Ubuntu 18.04 bionic 
Machine:
  Type: Laptop System: Acer product: Aspire E5-473 v: V1.07 serial: <filter> 
  Mobo: Acer model: Robin_BH v: V1.07 serial: <filter> UEFI [Legacy]: Insyde 
  v: 1.07 date: 07/15/2015 
Battery:
  ID-1: BAT1 charge: 15.1 Wh condition: 32.4/37.0 Wh (88%) 
  model: SANYO 0032334135314C41 status: Discharging 
CPU:
  Topology: Dual Core model: Intel Core i5-5200U bits: 64 type: MT MCP 
  arch: Broadwell rev: 4 L2 cache: 3072 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 17559 
  Speed: 798 MHz min/max: 500/2700 MHz Core speeds (MHz): 1: 798 2: 798 
  3: 798 4: 798 
Graphics:
  Device-1: Intel HD Graphics 5500 vendor: Acer Incorporated ALI 
  driver: i915 v: kernel bus ID: 00:02.0 
  Display: x11 server: X.Org 1.19.6 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1360x768~60Hz, 1360x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2) 
  v: 4.5 Mesa 18.2.2 direct render: Yes 
Audio:
  Device-1: Intel Broadwell-U Audio vendor: Acer Incorporated ALI 
  driver: snd_hda_intel v: kernel bus ID: 00:03.0 
  Device-2: Intel Wildcat Point-LP High Definition Audio 
  vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
  bus ID: 00:1b.0 
  Sound Server: ALSA v: k4.15.0-45-generic 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Acer Incorporated ALI driver: r8169 v: 2.3LK-NAPI port: 3000 
  bus ID: 02:00.1 
  IF: enp2s0f1 state: down mac: <filter> 
  Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter 
  vendor: Lite-On driver: ath10k_pci v: kernel port: 3000 bus ID: 03:00.0 
  IF: wlp3s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 931.51 GiB used: 12.05 GiB (1.3%) 
  ID-1: /dev/sda vendor: Seagate model: ST1000LM024 HN-M101MBB 
  size: 931.51 GiB 
Partition:
  ID-1: / size: 915.89 GiB used: 12.05 GiB (1.3%) fs: ext4 dev: /dev/sda1 
Sensors:
  System Temperatures: cpu: 44.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Repos:
  No active apt repos in: /etc/apt/sources.list 
  Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
  1: deb http://mirrors.evowise.com/linuxmint/packages tessa main upstream import backport
  2: deb http://mirror.uchile.cl/ubuntu bionic main restricted universe multiverse
  3: deb http://mirror.uchile.cl/ubuntu bionic-updates main restricted universe multiverse
  4: deb http://mirror.uchile.cl/ubuntu bionic-backports main restricted universe multiverse
  5: deb http://security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
  6: deb http://archive.canonical.com/ubuntu/ bionic partner
  Active apt repos in: /etc/apt/sources.list.d/spotify.list 
  1: deb http://repository.spotify.com stable non-free
Info:
  Processes: 197 Uptime: 12m Memory: 3.77 GiB used: 1.18 GiB (31.3%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.3.0 Shell: bash v: 4.4.19 
  inxi: 3.0.27 

User avatar
JOPETA
Level 14
Level 14
Posts: 5034
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Problemas con audio / HDMI [SOLUCIONADO]

Post by JOPETA » Mon Feb 04, 2019 7:17 am

El mérito es de MrEen aunque la actualización del kernel tampoco le habrá venido mal. :D
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

Post Reply

Return to “Español (Spanish)”