Nemo - Varios asuntos sobre permisos

Spanish Forum

Moderators: tomeu, JCSenar

Post Reply
User avatar
Helzegri
Level 1
Level 1
Posts: 6
Joined: Thu Feb 07, 2019 7:39 am

Nemo - Varios asuntos sobre permisos

Post by Helzegri » Wed Mar 06, 2019 1:34 pm

Hola, mi equipo tiene instalado LMDE3 Cinnamon y va de lujo, pero con Nemo tengo algunas cuestiones que no sé si solo me pasan a mí o son bug de la versión 19, porque he buscado en el foro y en otros sitios y no he encontrado nada relativo a estos problemas que tengo.

Casi todo es referido a la asignación de permisos dentro de el entorno gráfico (Nemo) porque desde Terminal no tengo problemas. Le voy a distribuir estos sistemas a mis usuarios y si se encuentran los mismos problemas me gustaría tenerlos solucionados antes de poner en explotación sus máquinas.

Sobre todo quiero saber si es que me falta algo por instalar como complemento a Nemo o se me escapa algo en la forma de hacer la operatoria de los permisos desde el entorno gráfico de las fichas "Propiedades-Permisos".

1.- Ni en modo simple, ni con el modo avanzado de permisos activado de Nemo consigo que la modificación de permisos de carpetas y lo que contienen recursivamente (otras carpetas y ficheros) tomen los permisos de escritura o lectura que se están modificando en la carpeta superior desde la que hago el cambio mediante "Propiedades" "Permisos", vamos, que el botón "Aplicar los permisos a los archivos contenidos" no me funciona, no hace nada. Si entro en el contenido y hago la misma aplicación de permisos directamente sobre un archivo o bloque de archivos, sí los modifica perfectamente, lo que parece que no me funciona es la recursividad que se supone que aporta ese botón. Como ya he dicho antes, si lo hago por Terminal con -R, lo hace todo perfectamente.

2.- ¿Existe posibilidad, en modo gráfico de Nemo de cambiar el grupo propietario de un directorio o archivo si estoy en una sesión sftp como usuario remoto de un almacenamiento en red? En el almacenamiento local me aparecen los grupos locales pero los remotos del servidor al que estoy conectado, no. Por Terminal con una sesión ssh sí me permite hacerlo, pero para mis usuarios quiero que ese cambio lo puedan hacer ellos directamente desde Nemo. Se da el caso de que algunos de ellos tienen un grupo principal en el sistema remoto y a veces les interesa que ese directorio que han creado en unidades que "no son las suyas", pertenezcan a su grupo secundario para que otros usuarios de ese grupo puedan manipular el contenido del directorio que ellos han creado una vez que autorice escritura en ese directorio a ese grupo que para ellos es su grupo secundario.

3.- Cuando se modifica y concede, por la ficha de permisos de Nemo, el permiso de escritura a grupo de un directorio que está creado con permisos "drwxr-sr-x" (porque interesa que ese SGID de grupo se mantenga en todos los subdirectorios creados desde el directorio padre) Nemo actúa cambiándo el permiso de ese directorio a "drwxrwxr-x" por lo que el SGID de grupo se pierde en todos esos subdirectorios de nivel inferior y hay que cambiarlos por medio de Terminal aplicando el permiso "s" desde comando. ¿A alguien le ha pasado esto o es que algo falta en mi sistema para que funcione el atributo especial "Establecer el ID de grupo"? Curiosamente cuando el directorio tiene activado el permiso "s" a grupo y se entra en la ficha de permisos, ese atributo permanece activado, pero si se modifica el permiso de escritura se cambia a "x" y ya no deja volver a a marcarlo.


En fin, que a ver si a alguien se le han presentado problemas similares y por lo menos me orienta dónde puedo encontrar documentación sobre el tema o referencia si es que son fallos de Nemo y hay que tener paciencia hasta que los corrijan, la verdad es que me gustaría darles a los usuarios un sistema lo más "pulido" posible porque creo que se van a adaptar bien a este magnífico sistema y alguno se planteará instalarse Mint en sus sistemas personales fuera de la empresa.

Un saludo y gracias.

User avatar
Wibol
Level 4
Level 4
Posts: 366
Joined: Fri Nov 27, 2015 7:00 am
Location: España

Re: Nemo - Varios asuntos sobre permisos

Post by Wibol » Thu Mar 07, 2019 6:11 am

No tengo LMDE3 para probarlo, pero lo que comentas tiene pinta de tratarse de un bug.

Para comprobar si es así, yo instalaría Linux Mint 18.3 (basado en Ubuntu) que está mucho más probado y pulido y averiguar si éste responde como se espera. Es lo malo de instalar las versiones más recientes, y como LMDE es rolling release, debe estar a la última en cuanto a software.

Antes de realizar una consulta, no olvides:

User avatar
Helzegri
Level 1
Level 1
Posts: 6
Joined: Thu Feb 07, 2019 7:39 am

Re: Nemo - Varios asuntos sobre permisos

Post by Helzegri » Thu Mar 07, 2019 8:21 am

Hola Wibol, si tengo oportunidad, me crearé una máquina virtual con la distribución basada en Ubuntu para comprobar si es un bug exclusivo de LMDE3 o no, la verdad es que voy un poco pillado de tiempo y no he tenido ocasión para muchas probaturas.

Con respecto a los 3 puntos que puse, el punto 1 parece que tiene una solución aunque no va fino del todo como sucedía con LMDE2 y es que las operaciones de asignación de permisos en LMDE3 desde Nemo parece que requieren algún "clic de más" de lo que era necesario en LMDE2. Me explico, antes podías hacer varias operaciones simultáneas antes de aplicarlas, unas que afectaban al directorio contenedor y otras a los ficheros contenidos. En LMDE3 parece que esto no va todo lo fino que debiera (supongo que lo corregirán aunque no he encontrado en Github nada reportado sobre esto) y las operaciones deben hacerse por separado, aplicar y salir (sí, suena a latoso pero parece que es lo que hay). Así, lo primero sería limpiar los permisos para el directorio, aplicar, modificar los permisos del directorio, aplicar, limpiar los permisos de los archivos, pulsar el botón de recursividad, aplicar, modificar los permisos de los archivos, pulsar el botón de recursividad y aplicar. Con esta operatoria tan "especial" parece que sí me ha asignado correctamente los permisos a los ficheros contenidos de forma recursiva. Ya os daré más detalles si concreto las "situaciones" en las que se produce el supuesto "bug".

Sobre las otras dos cuestiones, aún no he encontrado solución ni referencias, incluso estoy por colgar el asunto en el foro en inglés, a ver si alguien ha tenido el mismo problema.

Un saludo.

User avatar
JOPETA
Level 15
Level 15
Posts: 5741
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Nemo - Varios asuntos sobre permisos

Post by JOPETA » Sun Mar 10, 2019 6:56 am

No es mala idea recurrir al foro principal (la verdad a mi se me escapan muchas cosas de tu relato), aunque esté en ingles.En el caso de LMDE dada la escasez de usuarios que existen y/o participan en este foro si que deberías recurrir al subforo LMDE3.

Si que podrías, no obstante encontrar algo en el foro principal. Por ejemplo aquí queda claro que la opción de aplicar permisos a los archivos contenidos hace exactamente eso, no lo hace de forma recursiva al contenido de los subdirectorios. Para eso, en Nemo, deberías crear una extensión/script.

Por otra parte existen limitaciones en lo que los usuarios pueden hacer respecto al cambios de propiedades y permisos de acceso, labor que corresponde al root (antes debes otorgares permisos especiales y crear grupos aunuqe de esto sabrás mas que yo), y el uso de herramientas gráficas como root se desaconseja debido a problemas conocidos desde que el gksudo se ha eliminado.

Sobre problemas similares (referidos a bugs) en el el Git Hub de Nemo donde econtraras información relacionada (que los hay a poco que busques) y hacer propuestas de mejora en el apartado correspondiente (pull requests) :wink:
Last edited by JOPETA on Mon Mar 11, 2019 11:50 am, edited 3 times in total.
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.(Javier Krahe)

User avatar
Helzegri
Level 1
Level 1
Posts: 6
Joined: Thu Feb 07, 2019 7:39 am

Re: Nemo - Varios asuntos sobre permisos

Post by Helzegri » Mon Mar 11, 2019 11:33 am

Jopeta, gracias por la respuesta y los enlaces, les echaré un vistazo y a ver si cuelgo algo por ahí por si hay alguien que controle más de estos temas.

Ahora estoy algo liado con distribuir las máquinas en el trabajo y, básicamente, ya tengo el sistema bastante "potable" para los usuarios, así que ya se encargarán ellos de ir sacando problemillas durante la adaptación que van a llevar a cabo.

En cuanto empiecen a trabajar con él me liberaré un poco de tiempo y entraré a ver si en estos casos consigo algún avance, en cuanto tenga algo ya iré actualizando el hilo por si alguien se atasca también con estos temas y así tenga algo del camino andado.

La verdad es que con LMDE3 lo que tengo solo pendiente de "investigar" son casos muy "particulares" y concretos de unos cuantos equipos, cómo enchufar y que reconozca los usb de conexión a Internet de Movistar-Huawei, que parece que no los detecta bien, algunas movidas con los tamaños de salida de alguna impresora en red que las hace a escala y no al 100% y este caso y otros más de permisos en red.

A ver si una vez configurado todo mis usuarios se vuelven totalmente autónomos con el uso de LMDE3 y van chapando sus Windows cuando vean las ventajas que tiene con respecto a los Windows 10 y esos desastres.

Saludos.

Post Reply

Return to “Español (Spanish)”