Problemas con un HUB USB

Spanish Forum

Moderators: tomeu, JCSenar

Post Reply
boloxed
Level 1
Level 1
Posts: 1
Joined: Thu Mar 07, 2019 6:47 am

Problemas con un HUB USB

Post by boloxed » Thu Mar 07, 2019 7:00 am

Buenos días!
Primero que todo, muchas gracias por la ayuda que podáis ofrecerme.
Os cuento un poco mi problema.
Tenía Windows 8 en mi PC. Ayer actualicé a Windows 10 y hice una instalación dual con Linux Mint Cinnamon (la última versión).
Tengo un Hub USB (concretamente este -> Unotec Hub 7x USB 2.0 Negro) donde tenía conectado todos los periféricos, teclado, ratón, altavoces, cámara y demás.
El problema está que el sistema no reconoce este HUB USB, pero este si va (pues Windows 10 me lo reconoce todo).
He conectado el ratón y el teclado a los usbs de mi PC pero el problema está en que no me funciona nada conectado al HUB, ni altavoces, ni cámara ni nada.

A ver si me podéis dar un poco de luz. Si necesitáis más información o cualquier otra cosa, decidme y os intentaré ayudar en lo posible.

Siento si la pregunta es muy tonta, pero acabo de empezar con Mint y no sé muy bien como proceder.
Muchas gracias y un saludo.

User avatar
JOPETA
Level 15
Level 15
Posts: 5542
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Problemas con un HUB USB

Post by JOPETA » Sat Mar 09, 2019 12:13 pm

1)Si que necesitas proporcionar la información relativa a tu sistema que se indica aquí.

2)Otra información necesaria, en tu caso, sería el listado de dispositivos usb (con algún dispositivo conectados para ver si es identificado y cómo) y el de los módulos cargados por el sistema. Devuelve el resultado de los siguientes códigos de la misma forma (usando la opción </> (code) del editor del foro,

Code: Select all

lsusb 
lsmod
3)Proporciona otra información necesaria para saber si existe algún otro problema en la conexión y carga de controladores compartiendo los enlaces que se generan con los siguientes códigos

Code: Select all

dmesg | nc termbin.com 9999
cat /var/log/kern.log | nc termbin.com 9999
4)Por lo demás, a falta de datos, revisa la configuración de la BIOS/UEFI en lo relativo al USB y asegura que el soporte heredado ( legacy USB support) está activado (si MInt está instalado en modo UEFI esto puede ser determinante)
Legacy support.resized.jpg
y de tener diferentes opciones de configuación prueba desactivando el sosporte USB 3.0/xHCI (no siendo un dispositivo USB 3.0 podría dar problemas)
USB 3.0.resized.jpg
nada que ver con relegar el manejo de cambios XHCI al controlodar para SOs sin soporte o con problemas con el XHCI
soporte del manejo de cambios de estado XHCI.resized.jpg
5)Si no fuera un problema de firmware o controladores, en general los hubs que incorporan una conexión de corriente para alimentación adicional como es el caso del tuyo, es que la necesitan en Linux (aunque puede que no sea así en Windows).

Editado: Auque estaba apuntado, parece que no quedaba suficientemente claro, que tu dispositivo aunque no venga provisto de adaptador si posee la conexión para alimientación adicional (punto 5), a la que se refiere el aporte de vaca.
Last edited by JOPETA on Sun Mar 10, 2019 6:20 am, edited 12 times in total.
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

vaca
Level 1
Level 1
Posts: 49
Joined: Thu Jul 12, 2018 1:58 pm
Location: Barcelona Spain

Re: Problemas con un HUB USB

Post by vaca » Sat Mar 09, 2019 9:39 pm

Hola te comento que tu hub primero de todo cuando conectamos varios dispositivos ,cada uno de ellos tiene una cantidad de energia que deben recibir correctamente sobre cuando ponemos por ej discos duros ext pongamos de 2,5 medio son discos que toman su energia del puerto del hub.

Comprueba si tu hub tiene entrada de energia de alimentación ext , repasa el manual deberia de venir a no ser que sea un hub pasivo es decir sin fuente de autoalimentacion .

Yo tengo un hub trust de 10 puertos usb 2.0 con entrada de energia ext en un pequeño transformador que da alimentacion a los 10 puertos , y tengo conectado disco duro de mint , tv usb , raton inhalambrico y ningun problema de acceso y puedo conectar a veces mi movil en mode mtp samsung en caliente y rendimiento perfecto.

Tambien como dice JOPETA mirate la bios , si tu hub es usb 2 o 3 conectalo siempre al puerto adecuado equivalente y en la bios asegurate que el reconocimiento usb 3 sea en mode legacy , es la herencia del antiguo dos a nivel de interrupciones de memoria para su reconocimiento de compatibilidad .

Inmagino que asi el kernel reconoceria correctamente tu hub , y si tu hub no lleva opción de alimentación ext y aun asi persistiera los problemas considera entonces si puedes reemplazarlo con uno que lleva alimentacion ext los hay economicos por 30 euros que es lo que me costo a mi.
Cuanto menos sobrecargardo a nivel de energia mejor el puerto usb del pc , y es esa la funcion del transformador dar energia extra a cada puerto del hub y uniforme a nivel de e/s en la comunicacion con la matriz usb de tu pc con el hub !
Last edited by JCSenar on Sun Mar 10, 2019 3:38 pm, edited 1 time in total.
Reason: Corregido jc senar por JOPETA

Post Reply

Return to “Español (Spanish)”