Error actualizando de LM 19 a 19.1. TERMINADO

Spanish Forum

Moderators: tomeu, JCSenar

josemed1952
Level 3
Level 3
Posts: 105
Joined: Wed Mar 28, 2018 4:08 pm

Re: Error actualizando de LM 19 a 19.1

Post by josemed1952 » Sun May 19, 2019 9:03 am

Y sobre sudo -H pluma /etc/apt/sources.list-d/official-package-repositories.list
Ocurre lo mismo...
He desactivado los repositorios adicionales y ppas, segun tu indicacion.
Attachments
Pantallazo-2019-05-19 15-00-27.png

josemed1952
Level 3
Level 3
Posts: 105
Joined: Wed Mar 28, 2018 4:08 pm

Re: Error actualizando de LM 19 a 19.1

Post by josemed1952 » Sun May 19, 2019 9:09 am

Y sobre
3)Abre una teminal y ejecuta

Code: Select all

sudo apt update
sudo apt upgrade && apt full-upgrade
La pantalla es la que te añado.
Jose
Attachments
Pantallazo-2019-05-19 15-07-30.png
Pantallazo-2019-05-19 15-07-30.png (10.03 KiB) Viewed 249 times

User avatar
JOPETA
Level 14
Level 14
Posts: 5480
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Error actualizando de LM 19 a 19.1

Post by JOPETA » Sun May 19, 2019 12:10 pm

josemed1952 wrote:
Sun May 19, 2019 8:57 am
Sobre la linea de comando en le terminal...sudo nano /etc/apt/sources.list-d/official-package-repositories.list
Entro en una pantalla en la que me dice que la carpeta no existe, por lo que no puedo cambiar, nada... :shock:
Es evidente que la ruta al archivo del repoositorio es errónea- Fallo mío, se coló un guión donde debía haber un punto. oops:

Code: Select all

sudo nano /etc/apt/sources.list.d/official-package-repositories.list
Velve a intentarlo (desde el principio).

Por otra parte el apt update se te atraviesa un poco ( en un post anterior pusiste apdate y ahora lo has omitido...) :D
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

josemed1952
Level 3
Level 3
Posts: 105
Joined: Wed Mar 28, 2018 4:08 pm

Re: Error actualizando de LM 19 a 19.1

Post by josemed1952 » Mon May 20, 2019 2:54 am

Hola Jopeta, buenos días...
Después de varias horas parece que se ha cargado bien la nueva versión 19.1.
Y digo que parece porque ha surgido en principio un problema...
Antes de cargar el esritorio, me sale la pantalla de usuario y contraseña...
Bien si le introduzco la que tenía antes, parece que quiere seguir, pero vuelve a la misma pantalla y vuelve a preguntar la contraseña.
Si le doy al intro sin introducir ninguna, me dice que contraseña incorrecta...
Que puedo hacer.
Saludos cordiales.

User avatar
JOPETA
Level 14
Level 14
Posts: 5480
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Error actualizando de LM 19 a 19.1

Post by JOPETA » Mon May 20, 2019 4:16 am

Al no haber seguido el tutorial del foro para el uppgrade desconozco cuantas cosas mas pueden haber ido mal con el paso de LM 18.3 a LM 19 y ahora ya has actualizado a LM19.1 :shock:

Por ejemplo como paso obligado en la actualización está la instalación de lightdm y la desinstalcion de mdm. Además la imposiblidad de iniciar sesión gráfica, si miras aquí, tambien puede estar causada por el Display Manager, sea cal sea, ya que este debe ser desactivado para que determinadaos cambios asociados a las actualizaciones (sobre todo de gráficos) surtan efecto.

Abre sesión de consola desde la ventana de incinio con Alt+Ctrl+F1 o F2 y logeate. Una vez descartes otras posibilidades según lo indicado en el enlace, en especial descarta los cambios de permsos a los que se refiere el apartado 4 y procede con lo siguiente:
1)Para conocer el gestor de inicio de sesión gráfica (display manager o DM) que tienes instalado con

Code: Select all

cat /etc/X11/default-display-manager
2)Desactiva el gestor de inicio de sesión instalado. De ser /usr/sbin/lightdm el resultado, con

Code: Select all

sudo service lightdm stop
Si el resultado fuera "/usr/sbin/mdm" reemplaza lightdm en el código anterior

Code: Select all

sudo service mdm stop
y luego necesitarás instalar lightdm y desinstalar completamente mdm.
3)Hazlo de todas formas por si acaso.

Code: Select all

sudo apt-get  install --reinstall lightdm lightdm-settings slick-greeter
Cuando seas preguntado para elegir entre MDM y LightDM elige este último. Luego desintala mdm completamente

Code: Select all

apt remove --purge mdm mint-mdm-themes*

4)Escribe

Code: Select all

sudo dpkg-reconfigure lightdm
sudo reboot
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

josemed1952
Level 3
Level 3
Posts: 105
Joined: Wed Mar 28, 2018 4:08 pm

Re: Error actualizando de LM 19 a 19.1

Post by josemed1952 » Mon May 20, 2019 6:48 am

Hola.
Primero agradacerte muy sinceramente tu interés, dedicación y ayuda.
Realmente me siento perdido, sin tu ayuda, sería incapaz de solucionarlo.
Lamento mis errores.
Bueno he hecho lo que me apuntas, es decir desde la pantalla de inicio con Alt+Ctrl+F1 y me he logeado (la verdad es que es la primera vez que veo esa pantalla y forma de acceso, tambíen finalmente he comprendido que era eso de logear :) )
He introducido la línea que me indicas tras el simbolo del dolar, osea asi ( $ cat /etc/x11/default-display-manager)
Y me dice que no existe el archivo o directorio
Buf!
Jose

User avatar
JOPETA
Level 14
Level 14
Posts: 5480
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Error actualizando de LM 19 a 19.1

Post by JOPETA » Mon May 20, 2019 7:20 am

josemed1952 wrote:
Mon May 20, 2019 6:48 am
He introducido la línea que me indicas tras el simbolo del dolar, osea asi ( $ cat /etc/x11/default-display-manager)
Y me dice que no existe el archivo o directorio
Debes tener mas cuidadín al escribir códigos, la X es mayúscula. :roll:

Code: Select all

cat /etc/X11/default-display-manager
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

josemed1952
Level 3
Level 3
Posts: 105
Joined: Wed Mar 28, 2018 4:08 pm

Re: Error actualizando de LM 19 a 19.1

Post by josemed1952 » Mon May 20, 2019 9:21 am

Hola profe...
Bien hasta el paso 3.

3)Hazlo de todas formas por si acaso.
sudo apt-get install --reinstall lightdm lightdm-settings slick-greeter

Cuando seas preguntado para elegir entre MDM y LightDM elige este último. Luego desintala mdm completamente
apt remove --purge mdm mint-mdm-themes*

En primer lugar no me pregunta elegir...
Pero escribo ...apt remove --purge mdm mint-mdm-themes*
y me dice...
No se ha podido abrir el paquete mint-mdm-themes*
No se ha podido encontrar paquete usando * con mint-mdm-themes
No se podido encontrar paquete con la expresion regular mint-mdm-themes
Donde he metido la pata ahora?
Saludos

User avatar
JOPETA
Level 14
Level 14
Posts: 5480
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Error actualizando de LM 19 a 19.1

Post by JOPETA » Mon May 20, 2019 11:08 am

josemed1952 wrote:
Mon May 20, 2019 9:21 am
Donde he metido la pata ahora?
Si no lo tenías instalado en ningún sitio, ya que no existe dicho paquete en el repositorio de LM 19.X. :D

Lo de hacerlo por si acaso era mas que nada por la reinstalación de lightdm ya que la desintalación completa de mdm sólo sería necesaria si partiste de la instalación de LM 18 y LM 18.1 que si llevan el mdm por defecto y podrían quedar restos.

Lo mas importante es el dpkg-reconfigure. :wink:
Last edited by JOPETA on Mon May 20, 2019 11:37 am, edited 1 time in total.
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

josemed1952
Level 3
Level 3
Posts: 105
Joined: Wed Mar 28, 2018 4:08 pm

Re: Error actualizando de LM 19 a 19.1

Post by josemed1952 » Mon May 20, 2019 11:32 am

Pues algo falta..., porque despues del reboot, en la pantalla de inicio sigue sin pasar al escritorio de Linux y me sigue preguntando la contraseña de inicio.
Si le doy otra, que no es, me dice contraseña invalida.

User avatar
JOPETA
Level 14
Level 14
Posts: 5480
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Error actualizando de LM 19 a 19.1

Post by JOPETA » Mon May 20, 2019 11:53 am

Si has hecho el resto de comprobaciones del último enlace (falta de espacio, permisos de archivos,..) quizás sea ya hora de considerar la reinstalación de mint-meta mate desde la consola y de no ser suficiente...la reinstalación desde cero o en límpio. Es lo aconsejable si un upgrade no sale bien ya que tampoco habrás creado una instantánea del sistema con Timeshift si no seguiste los tutoriales del foro. :(
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

josemed1952
Level 3
Level 3
Posts: 105
Joined: Wed Mar 28, 2018 4:08 pm

Re: Error actualizando de LM 19 a 19.1

Post by josemed1952 » Mon May 20, 2019 12:40 pm

Jopeta, estoy perdido..., la verdad no se que hacer...
Te refieres a las comprobaciones del link que me has enviado?.
O a lo que tu me has indicado.
Lo que tu me has dicho, si lo he hecho paso a paso...
Lo del link "Por ejemplo como paso obligado en la actualización está la instalación de lightdm y la desinstalcion de mdm. Además la imposiblidad de iniciar sesión gráfica, si miras aquí, tambien puede estar causada por el Display Manager, sea cual sea, ya que este debe ser desactivado para que determinadaos cambios asociados a las actualizaciones (sobre todo de gráficos) surtan efecto. "
No se por donde meterle mano, porque no encuentro el ejemplo en mi caso.
Enfin, ya ves como ando de perdido

josemed1952
Level 3
Level 3
Posts: 105
Joined: Wed Mar 28, 2018 4:08 pm

Re: Error actualizando de LM 19 a 19.1

Post by josemed1952 » Mon May 20, 2019 1:04 pm

Hare lo que tu me digas... reinstalar desde la consola o desde cero...
Solo dime como
Disculpa mi escaso conocimiento.
Jsoe

User avatar
JOPETA
Level 14
Level 14
Posts: 5480
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Error actualizando de LM 19 a 19.1

Post by JOPETA » Mon May 20, 2019 1:30 pm

josemed1952 wrote:
Mon May 20, 2019 12:40 pm
Te refieres a las comprobaciones del link que me has enviado?.
Si a este, pero ya te contesta tu mismo en el siguiente post.
josemed1952 wrote:
Mon May 20, 2019 1:04 pm
Hare lo que tu me digas... reinstalar desde la consola o desde cero...
Desde la consola (Alt+Ctrl+F1 o F2) es fácil (sudo apt-get install --reinstal mint-meta-mate)pero reinstalas sobre la base de que el problema es la configuración del sistema. Si ya has corregido el problema de los repositorios de post anteriores puedes probar(sólo quedaba pendiente un error de acceso a las cuentas de google quizás por no haber desactivado repositorios adicionales o a la necesidad de reinstalar google chrome...a saber). También podrías crear un usuario nuevo desde la consola y confirmar que el problema es la configuración de tu usuario.(*)

Desde cero sería siempre prefirible y mas en tu caso (no debiste arriesgar con un nuevo upgrade si haber resuelto el problema del corta y pega) y más rápido (ya lo podrías haber hecho unas cuantas veces). Lo unico es que tienes unos 100GB de datos personales en la partición raiz que deberías trasladar a otra partición del disco o medio externo. Lo puedes hacer desde el live de Mint (es solo copiar y pegar con el navegador de archivos del live) que crees siguiendo estos pasos
y, si queres conservar a estructura actual deberás hacer una instalación con particionado manual. Si tuiveras algún problema con esto devuelve el resultado desde el live de los siguientes códigos

Code: Select all

sudo parted -l
sudo blkid


-------------
(*)Si precisas ayuda con esto no hay problema pero creo que es seguir perdiendo el tiempo con un sistema del que ya no estás seguro. Reemplaza nuevo_usuario con el nombre del nuevo usuario en minúsculas y sin espacios.

Code: Select all

sudo adduser nuevo_usuario
y completa la información que se requiere en pantalla a continuación: contraseñas (si usas las misma que tu usuario actual eso que te ahorras), nombre real (esta vez ya con mayúsculas )...
Luego para no tener problemas con el inicio añádelo al grupo nopasswdlogin así solo tendrías que seleccionarlo del menú de la ventana de inicio sin introducir contraseña para acceder a la sesión gráfica.

Code: Select all

sudo adduser nuevo_usuario nopasswdlogin
reincia y prueba con el nuevo usuario. Si no presenta problemas de logueo ya te indico como seguir. Si los presenta no pierdas mas el tiempo y realiza una nueva instalación desde cero.
(Editado)
Last edited by JOPETA on Mon May 20, 2019 3:02 pm, edited 2 times in total.
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

josemed1952
Level 3
Level 3
Posts: 105
Joined: Wed Mar 28, 2018 4:08 pm

Re: Error actualizando de LM 19 a 19.1

Post by josemed1952 » Mon May 20, 2019 2:53 pm

Ok, te dire...

josemed1952
Level 3
Level 3
Posts: 105
Joined: Wed Mar 28, 2018 4:08 pm

Re: Error actualizando de LM 19 a 19.1

Post by josemed1952 » Mon May 20, 2019 3:09 pm

Jopeta... si tuviera pelos, me tiraria hasta quedarme como estoy :( :( :(
He creado el nuevo usuario sin problemas.
En la pantalla de inicio aprecen los 2 usuarios.
El nuevo no pide contraseña, solo acceder pinchando en el sitio.
Bien pues lo hago y hace lo mismo que con el otro, es decir, vuelve a la pantalla de incio y vuelta a empezar.

User avatar
JOPETA
Level 14
Level 14
Posts: 5480
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Error actualizando de LM 19 a 19.1

Post by JOPETA » Mon May 20, 2019 3:15 pm

¿Has comprobado que tampoco no inicias con startx desde la sesión de consola? Supongo que de haberlo hecho podrías haber comentado los errors que lanza a que se refieren. :roll:

Creo que ya toca reinstalar desde cero...como digo en el post anterior ganarás tiempo y seguridad en tu nuevo sistema LM 19.1 :roll:
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

josemed1952
Level 3
Level 3
Posts: 105
Joined: Wed Mar 28, 2018 4:08 pm

Re: Error actualizando de LM 19 a 19.1

Post by josemed1952 » Mon May 20, 2019 3:30 pm

Lo pruebo...startx

josemed1952
Level 3
Level 3
Posts: 105
Joined: Wed Mar 28, 2018 4:08 pm

Re: Error actualizando de LM 19 a 19.1

Post by josemed1952 » Mon May 20, 2019 3:53 pm

Hola, habia probado antes startx, pero no vi nada raro, aunque no reinicio.
Como no puedo hacerlo de otra forma, al resultado le he hecho una foto, pero no me deja subirla porque es muy pesada...

josemed1952
Level 3
Level 3
Posts: 105
Joined: Wed Mar 28, 2018 4:08 pm

Re: Error actualizando de LM 19 a 19.1

Post by josemed1952 » Mon May 20, 2019 4:12 pm

Code: Select all

jose@jose-Aspire-A315-21:~$ inxi -Fxznr
System:
  Host: jose-Aspire-A315-21 Kernel: 4.15.0-50-generic x86_64 bits: 64 
  compiler: gcc v: 7.3.0 Desktop: MATE 1.20.1 Distro: Linux Mint 19.1 Tessa 
  base: Ubuntu 18.04 bionic 
Machine:
  Type: Laptop System: Acer product: Aspire A315-21 v: V1.03 
  serial: <filter> 
  Mobo: SR model: Squirtle_SR v: V1.03 serial: <filter> 
  UEFI [Legacy]: Insyde v: 1.03 date: 11/15/2017 
Battery:
  ID-1: BAT1 charge: 35.0 Wh condition: 35.0/36.7 Wh (95%) 
  model: SANYO AC14B18J status: Full 
CPU:
  Topology: Dual Core model: AMD A9-9420 RADEON R5 5 COMPUTE CORES 2C+3G 
  bits: 64 type: MCP arch: Excavator L2 cache: 1024 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 11978 
  Speed: 1397 MHz min/max: 1400/3000 MHz Core speeds (MHz): 1: 1397 2: 1396 
Graphics:
  Device-1: AMD Stoney [Radeon R2/R3/R4/R5 Graphics] 
  vendor: Acer Incorporated ALI driver: amdgpu v: kernel bus ID: 00:01.0 
  Display: x11 server: X.Org 1.19.6 driver: amdgpu,ati 
  unloaded: fbdev,modesetting,radeon,vesa resolution: 1366x768~60Hz 
  OpenGL: renderer: AMD STONEY (DRM 3.23.0 4.15.0-50-generic LLVM 7.0.0) 
  v: 4.5 Mesa 18.2.8 direct render: Yes 
Audio:
  Device-1: AMD vendor: Acer Incorporated ALI driver: snd_hda_intel 
  v: kernel bus ID: 00:01.1 
  Device-2: AMD Family 15h Audio vendor: Acer Incorporated ALI 
  driver: snd_hda_intel v: kernel bus ID: 00:09.2 
  Sound Server: ALSA v: k4.15.0-50-generic 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Acer Incorporated ALI driver: r8169 v: 2.3LK-NAPI port: 2000 
  bus ID: 02:00.1 
  IF: enp2s0f1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter 
  vendor: Lite-On driver: ath10k_pci v: kernel port: 2000 bus ID: 03:00.0 
  IF: wlp3s0 state: down mac: <filter> 
Drives:
  Local Storage: total: 931.51 GiB used: 10.44 GiB (1.1%) 
  ID-1: /dev/sda vendor: Western Digital model: WD10SPZX-21Z10T0 
  size: 931.51 GiB 
Partition:
  ID-1: / size: 393.67 GiB used: 10.44 GiB (2.7%) fs: ext4 dev: /dev/sda6 
Sensors:
  System Temperatures: cpu: 58.9 C mobo: N/A gpu: amdgpu temp: 58 C 
  Fan Speeds (RPM): N/A 
Repos:
  No active apt repos in: /etc/apt/sources.list 
  Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
  1: deb http://packages.linuxmint.com tessa main upstream import backport #id:linuxmint_main
  2: deb http://archive.ubuntu.com/ubuntu bionic main restricted universe multiverse
  3: deb http://archive.ubuntu.com/ubuntu bionic-updates main restricted universe multiverse
  4: deb http://archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse
  5: deb http://security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
  6: deb http://archive.canonical.com/ubuntu/ bionic partner
Info:
  Processes: 170 Uptime: 23m Memory: 11.26 GiB used: 1.84 GiB (16.3%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 Shell: bash v: 4.4.19 
  inxi: 3.0.27 
jose@jose-Aspire-A315-21:~$
Last edited by JCSenar on Tue May 21, 2019 8:19 am, edited 1 time in total.
Reason: Añadido el formato [code]

Post Reply

Return to “Español (Spanish)”