Error actualizando de LM 19 a 19.1. TERMINADO

Spanish Forum

Moderators: tomeu, JCSenar

User avatar
JOPETA
Level 14
Level 14
Posts: 5468
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Error actualizando de LM 19 a 19.1

Post by JOPETA » Wed May 22, 2019 4:08 am

Me asalta una duda (con la dificultad que entraña) al ver las imágenes remitidas Los errores que se dislumbran no tienen por si mismos que impedir el inicio de la sesión gráfica despues de startx en la sesión de consola lo que si se parece es que se abandona la sesión de consola ¿Has probado si realmente no abres sesión gráfica en otra tty (Ctrl+Alt+F7 o F8)?

No acumules post, sobre todo si quedan cuestiones sin resolver o vuelves sobre ideas que pareces haber superado en el anterior.
josemed1952 wrote:
Wed May 22, 2019 2:55 am
Quieres decir que podriamos copiar todos los datos personales que tengo en 19.1 fallida a 19.1 correcta?.
Porque si es asi, sería perfecto. Los pasamos y luego se elimina la particion sd1.
Si por lo de copiar el contenido (solo los archivos personales, es decir el contenido de las carpetas /home/usuario/Videos...etc de la partición sda1 a la homónima de la partición sda6 (Mint correcto) no las carpetas en si mismas. Es solo navegar por el sistema de archivos y copiar el contenido (no las carpetas) del /home/usuario/videos del Mint cascado al /home/usuario/videos del Mint sano.... [

No por lo de eliminar la sda1. No te quiero liar y las razones son varias (es la única partición primaria definida y dirige el arranque como te he comentado) si la eliminas sin más (cosa que tendrías que hacer dede un Live) no podrás iniciar después y tendrías que reinstalar GRUB.

En este punto, se adminten propuestas de otros usuarios.
josemed1952 wrote:
Wed May 22, 2019 3:47 am
He intentadodesde opciones avanzadas, entrar al modo de pruebas (root) para seleccionar el modo de pruebas graficas, pero no hay esa opcion... :?
Por otra parte he introducido (dpkg --get-selections | grep linux-image) y el resultado es que me aparece...
Pareces estar dispuesto a probar B) cuando no dices haber probado lo del apartado A) del post de referencia. En lo referente a los kernel listados si procedes según lo que dices es normal que estén, además, de los orginales (4.10), uno de la serie 4.13 y una imagen virtual de transito de xenial a bionic (iv-hwe) están todos los de la serie 4.15 menos los 4.15.0-22, 23 y 24. En cualquier caso es precipitarse. Sigue iniciando con el 4.15.0-50 para lo propuesto a continuación y deja el apartado B) para después (con independencia de que puedes desintalar todos los kernels menos ese último y el iv-hwe que a saber para lo que lo necesitas).

Por orden de simplicidad, el orden en una situación normal (te servirá como aprendizaje para problemas de inicio futuros) es:

Proporcionar información aclaratoria del problema se trata, en tu caso, después del fallo del inicio de la sesión gráfica por el procedimiento normal y opción de inicio por defecto) en
-abrir una sesión de consola con (Alt+Ctrl+F1 o F2)
-introducir tu nombre de usuario y contraseña (logearte)
-y de escribir con cuidado

Code: Select all

cat /var/log/xorg.0.log | nc termbin.com 9999
La barra vertical "|" la obtienes en el teclado presionando a la vez AltGr+1 . El resultado es una dirección url que puedes copiar fácilmente en un papel y devolverla en el foro tal cual.
-tambien puedes aclarar de igual forma (devolviendo la url) si has modificado de forma correcta los repositorios

Code: Select all

cat /etc/apt/sources.list.d/official-package-repositories.list 
-De esta forma también puedes obtener el listado de los kernels instalados ls /boot/ | nc termbin.com 9999, o la descripción completa del sistema con inxi -Fxznrc0 | nc termbin.com 9999 (el c0 (ce cero) es para evitar códigos absurdos en el texto de la web de compartición)
La incomodidad de tener que escribir y por la posibilidad de equivocarse al escribir las puedes evitar, como alternativa si incias con el LM 19.1 sano y con el navegador de archivos haces clic en el icono de la partición a la izquierda en Dispositivos (vendrá con el icono de un disco duro volumen de 100GB ) sigues las rutas indicadas de la partición del LM cascado en la ventana de la derecha. Luego haces clic sobre el archivo indicado para abrirlo con el editor de texto. Este contenido lo puedes copiar y pegar en el foro usando la opción </> code que ya conoces.
navegación.png
Preferencias en la pruebas propuestas
Son en orden de complejidad y riesgo, además es normal que debas repetir los primeros apartados para probar la eficacia del siguiente apartado. Sin los datos requeridos es lo más conveniente:
1)Probar primero lo referido en el enlace (inicio de emergencia por problemas de controladores gráficos de Nvidia y AMD). A los parámetros modificadores que se mencionan (nomodeset xforcevesa) puedes añadir los que se indican al final del post anterior es decir añadir a los anteriores nolapic noapic noacpi acpi=0 ( el igual lo tendrás presionando la tecla con la ¿ y ¡)

2)Si el problema persiste hacer lo indicado para la reinstalación de xserver, en la sesión iniciada de la forma anterior (es decir repetir el apartado 1 a cada reinicio si el inicio normal repite el problema) y desde la consola (ALT+Ctrl +F1) si no queda mas remedio y en el orden propuesto Primero en el apartado A) del post al que te remites.
-reconfigurar el xserver desde la consola (esto debería eliminar la configuración del sistema, no la introducida de forma manual)

Code: Select all

sudo dpkg-reconfigure xserver-xorg
y reinicia para comprobar.

-Si no prueba con los modificadores del apartdado 1'y/o el otro usuario .
-Si no tienes resultados reinstalar el Xserver por completo, desde la consola después de purgar la configuración claro.

Code: Select all

sudo dpkg --configure -a
sudo apt-get remove --purge xserver-xorg
sudo apt-get install xserver-xorg
sudo dpkg-reconfigure xserver-xorg

Reinicar y ver que ocurre.

A parte de probar con lo indicado en el punto 1 si el reinicio no soluciona el problema, también puedes probar a iniciar con el usuario nuevo creado en este punto.
Descartado lo anterior sería preferible, iniciar con el 4.15.0-50 (opcion por defecto) desinstalar todos los kernels anteriores si quieres excepto quizas el 4.15 .0-20 por las dudas y proprocionar la información indicada ademas de la url resultante de

Code: Select all

dmesg  | nc termbin.com 9999
y esperar respuesta en este .punto.

EDITADO?
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

josemed1952
Level 3
Level 3
Posts: 105
Joined: Wed Mar 28, 2018 4:08 pm

Re: Error actualizando de LM 19 a 19.1

Post by josemed1952 » Wed May 22, 2019 7:13 am

Vale ire siguiendo tu guión.
Pero primero, puedes decirme que es tty? (Me asalta una duda (con la dificultad que entraña) al ver las imágenes remitidas Los errores que se dislumbran no tienen por si mismos que impedir el inicio de la sesión gráfica despues de startx en la sesión de consola ¿Has probado si realmente no abres sesión gráfica en otra tty (Ctrl+Alt+F7 o F8)?)

User avatar
tomeu
Level 5
Level 5
Posts: 674
Joined: Wed Mar 29, 2017 12:03 pm
Location: España

Re: Error actualizando de LM 19 a 19.1

Post by tomeu » Wed May 22, 2019 7:30 am

josemed1952 wrote:
Wed May 22, 2019 7:13 am
..
Pero primero, puedes decirme que es tty? ....
Hola, eso creo que lo podrías saber con solo teclear "tty linux" en la barra del buscador que uses.
De todas formas:
La tty es la consola que nos permite en GNU/Linux acceder a nuestro sistema operativo fuera de su entorno gráfico (X-Window). En general disponemos de hasta seis terminales.
Para acceder:
Ctrl + Alt + F1 para acceder a la primera, F2 para la segunda y así hasta F6 para la sexta.
Para regresar al entorno gráfico:
Ctrl + Alt + F7
Viendo la extensión de este post y con pocos frutos, habría que plantearse hacer copia de seguridad de datos en disco externo / useb / nube y reinstalar desde cero. A ningún SO le va mal una instalación limpia cada par de años.
Linux Mint Tessa 19.1 64bits Cinnamon 4.0.10

josemed1952
Level 3
Level 3
Posts: 105
Joined: Wed Mar 28, 2018 4:08 pm

Re: Error actualizando de LM 19 a 19.1

Post by josemed1952 » Wed May 22, 2019 9:24 am

Gracias Tomeu por la explicacion.
Bien he probado desde la pantalla de la pantalla de inicio (la que pide contraseña para acceso al escritorio) con Crt+Alt+F7 y no hace nada.
Con Ctrl+Alt+F8, la pantalla pasa a negro con el cursor en la esquina superior izquierda parpadeando, pero no tengo teclado ni raton...
No puedo hacer lo indicado al final para reflejar la información, porque al abrir gestor de archivos en dispositivos, solo me aparece (desde 19.1 bueno), un volumen de 557 Gb y sistema de archivos.
Bien inicio según guión en primer lugar (Proporcionar información aclaratoria del problema)

josemed1952
Level 3
Level 3
Posts: 105
Joined: Wed Mar 28, 2018 4:08 pm

Re: Error actualizando de LM 19 a 19.1

Post by josemed1952 » Wed May 22, 2019 11:08 am

Pasos que he dado...
1. De Preferencia en las pruebas... añadir segun tutorial nomodeset....., sigue igual. Añadiendo segun tu comentario nolapic noapic noacpi..... etc, la pantalla se queda en negro y bloqueada.

2 a la linea.... cat /var/log/Xorg..... resultado https://termbin.com/av0y
3 a la línea ...cat /etc/apt/sources.... ver foto 2.png
4 a la linea ls /boot/ | nc term...., resultado https:// termbin.com/1c5o
5 a la línea inxi -Fxznrco.... resultado https://termbin.com/mkj6

A la recomendacion segun tutorial con inx.... ver foto Captura de pantalla

Antes de seguir con la reconfiguracion de xserver, espero vuestra opinion
Attachments
Captura de pantalla -2019-05-22 16-07-57.png
2.png

User avatar
JOPETA
Level 14
Level 14
Posts: 5468
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Error actualizando de LM 19 a 19.1

Post by JOPETA » Wed May 22, 2019 12:40 pm

josemed1952 wrote:
Wed May 22, 2019 9:24 am
Bien he probado desde la pantalla de la pantalla de inicio (la que pide contraseña para acceso al escritorio) con Crt+Alt+F7 y no hace nada.
No es ahí es una vez abres la sesión de consola (Ctrl+Alt+F1 o F2) y despues de iniciar el xserver con startX cuando debes comprobar que no se abre una sesión gráfica con Ctrl+Alt+F7 o F8. Quizas debas antes de startx introducir lo siguiente en la consola

Code: Select all

sudo service lightdm restart
Otra cosa a descartar que tal vez no haya quedado claro es que si alguna vez probaste con sudo startx cosa que en ningún caso se debe hacer) en la sesión de consola debes restituir los derechos de los permisos de la forma indicada

Code: Select all

sudo chown -R $USER:$USER $HOME
. Luego trtar de inicar sesión grñafica y luego comprobar que no se ha abierto en otro terminal con Ctrl+Alt+F7 o F8). Esta es la primera causa de error en el inicio de la sesiones gráficas. :roll:

Sobre la información proporcionada la verdad tengo que mirarla a fondo pero el Xorg.0.log finaliza de forma abrupta
. AIGLX: Suspending AIGLX clients for VT switch
, no se si no estará incompleto o que se interrumpe al entrar de forma manual en la sessión de consola. Hay muchos informes que contenienen este aviso y no se que pensar. Puedes devolver el resultado de otro inicio y tambien el de xorg.1.log y el resitro de la sesión grafica por si acaso es decir

Code: Select all

cat /var/log/xorg.0.log | nc termbin.com 9999
cat /var/log/xorg.1.log | nc termbin.com 9999
cat ~/.xsession-errors| nc termbin.com 9999
El símbolo ~ lo obtienes mediante AltGr+4.

Las capturas no eran necesarias si se aporta el inxi que parece correcto y el listado de kernels ya lo proprocionaste en un post anterior.

Sobre la finalización con la pantalla negra con los modificadores de la carga del kernel pudiera tener relación con los permisos también o el xserver. ¿Puedes abrir desde ella la consola con Ctrl+Alt+F1? Puedes dejarlo solo en nomodeset. :roll:
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

josemed1952
Level 3
Level 3
Posts: 105
Joined: Wed Mar 28, 2018 4:08 pm

Re: Error actualizando de LM 19 a 19.1

Post by josemed1952 » Wed May 22, 2019 3:49 pm

Bueno...
He vuelto a editar y escribir nomodeset, pero compruebo que no se queda guardado.
1 En primer lugar la linea...sudo chown -R $USER:$USER $HOME, Ok
2 sudo service lightdm restart, Ok
3 startX, ver foto dividida en 3. Creo que ya lo envié antes, no se si es igual.
4 He lanzado con Ctrl+Alt+F7 la pantalla de contraseña pero sigue comportandose igual, con F8, no hace nada.
5 A la línea cat /var/log/xorg.0.log | nc termbin.com 9999, el resultado es: https://termbin.com/8sac
6 A la linea cat /var/log/xorg.1.log | nc termbin.com 9999, el resultado es no existe archivo o directorio
7 A la linea cat ~/.xsession-errors| nc termbin.com 9999, el resultado es: https://termbin.com/g3rt
Attachments
1.png
2.png
3.png

josemed1952
Level 3
Level 3
Posts: 105
Joined: Wed Mar 28, 2018 4:08 pm

Re: Error actualizando de LM 19 a 19.1

Post by josemed1952 » Wed May 22, 2019 3:51 pm

Bueno...
He vuelto a editar y escribir nomodeset, pero compruebo que no se queda guardado.
1 En primer lugar la linea...sudo chown -R $USER:$USER $HOME, Ok
2 sudo service lightdm restart, Ok
3 startX, ver foto dividida en 3. Creo que ya lo envié antes, no se si es igual.
4 He lanzado con Ctrl+Alt+F7 la pantalla de contraseña pero sigue comportandose igual, con F8, no hace nada.
5 A la línea cat /var/log/xorg.0.log | nc termbin.com 9999, el resultado es: https://termbin.com/8sac
6 A la linea cat /var/log/xorg.1.log | nc termbin.com 9999, el resultado es no existe archivo o directorio
7 A la linea cat ~/.xsession-errors| nc termbin.com 9999, el resultado es: https://termbin.com/g3rt
Attachments
1.png
2.png
3.png

User avatar
JOPETA
Level 14
Level 14
Posts: 5468
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Error actualizando de LM 19 a 19.1

Post by JOPETA » Thu May 23, 2019 6:10 am

josemed1952 wrote:
Wed May 22, 2019 3:51 pm
He vuelto a editar y escribir nomodeset, pero compruebo que no se queda guardado.
De eso se trata, es sólo una modificación para ese inicio. Si tuviera éxito ya lo haríamos fijo.
josemed1952 wrote:
Wed May 22, 2019 3:51 pm
3 startX, ver foto dividida en 3. Creo que ya lo envié antes, no se si es igual.
No es igual, al menos se ve más claro el error del xserver. :D
josemed1952 wrote:
Wed May 22, 2019 3:51 pm
5 A la línea cat /var/log/xorg.0.log | nc termbin.com 9999, el resultado es: https://termbin.com/8sac
Sigue estando incompleto ahora aún mas cortado que antes. Puedes intentar enviar el resultado de esto

Code: Select all

cat /home/jose/.local/share/xorg/Xorg.1.log | nc termbin.com 9999
josemed1952 wrote:
Wed May 22, 2019 3:49 pm
7 A la linea cat ~/.xsession-errors| nc termbin.com 9999, el resultado es: https://termbin.com/g3rt
Observo los errores habituales caundo empieza la de la carga del escriorio mate pero el proceso es abortado de forma brusca sin mas.Sól se llagan a emitir dos notificaciones Una referida a pero no creo que niguna de ellas sea la causa del aborting..... Además si el problema lo tienes tambien iniciando con el nuevo usuario quedarían decartados tanto el error del dbus como el del tema vino. :(

A falta del nuevo archivo solicitado creo que debes pasar a reconfigurar/reinstalar el xserver... :roll:
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

josemed1952
Level 3
Level 3
Posts: 105
Joined: Wed Mar 28, 2018 4:08 pm

Re: Error actualizando de LM 19 a 19.1

Post by josemed1952 » Thu May 23, 2019 7:31 am

Hola
El resultado a la linea... cat /home/jose/.local/share/xorg/Xorg.1.log | nc termbin.com 9999, es https://termbin.com/96bb
Además si el problema lo tienes tambien iniciando con el nuevo usuario quedarían decartados tanto el error del dbus como el del tema vino., correcto el problema lo tengo con ambos usuarios.
Saludos

User avatar
JOPETA
Level 14
Level 14
Posts: 5468
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Error actualizando de LM 19 a 19.1

Post by JOPETA » Fri May 24, 2019 6:00 am

Lo dicho prueba a reconfigura/reisntalar xserver.
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

josemed1952
Level 3
Level 3
Posts: 105
Joined: Wed Mar 28, 2018 4:08 pm

Re: Error actualizando de LM 19 a 19.1

Post by josemed1952 » Fri May 24, 2019 9:16 am

Vale.
Pregunta: Al reinstalar xsever, se perderan los archivos, direcciones, y demas temas personales?
Como se hace reinstalar xserver?.

User avatar
JOPETA
Level 14
Level 14
Posts: 5468
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Error actualizando de LM 19 a 19.1

Post by JOPETA » Fri May 24, 2019 11:03 am

josemed1952 wrote:
Fri May 24, 2019 9:16 am
Pregunta: Al reinstalar xsever, se perderan los archivos, direcciones, y demas temas personales?
No
josemed1952 wrote:
Fri May 24, 2019 9:16 am
Como se hace reinstalar xserver?.
Según lo indicado en el post de referencia
-reconfigurar el xserver desde la consola (ALTĆtrl+F1 o F2)esto debería eliminar la configuración del sistema, no la introducida de forma manual)

Code: Select all

sudo dpkg-reconfigure xserver-xorg
y reinicia para comprobar.

Code: Select all

sudo reboot
-Si no inicias en sesión grafica prueba con el otro usuario desde la ventana de inicio ..
-Si tampoco reinicia (Alt+Ctrl+Supr) y prueba con los modificadores del apartadado 1 del enalce (nomodeset) y con el otro usuario desde la ventana de inicio .
Si no tienes resultados reinstalar el Xserver por completo, después de purgar la configuración claro. Desde la consola (Alt+Ctrl+F1 o F2)

Code: Select all

sudo dpkg --configure -a
sudo apt-get remove --purge xserver-xorg
sudo apt-get install xserver-xorg
sudo dpkg-reconfigure xserver-xorg
y reinicia para comprobar.

Code: Select all

sudo reboot
-Si no inicias en sesión grafica prueba con el otro usuario desde la ventana de inicio ..
-Si tampoco reinicia (Alt+Ctrl+Supr) y prueba con los modificadores del apartadado 1 del enlace (nomodeset) y con el otro usuario desde la ventana de inicio .
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

josemed1952
Level 3
Level 3
Posts: 105
Joined: Wed Mar 28, 2018 4:08 pm

Re: Error actualizando de LM 19 a 19.1

Post by josemed1952 » Fri May 24, 2019 2:01 pm

Hola
A la linea sudo dpkg-reconfigure xserver-xorg, con ambos usuarios sigue igual. Tampoco cambia nada con el nomodeset
Y lo mismo para
sudo dpkg --configure -a
sudo apt-get remove --purge xserver-xorg
sudo apt-get install xserver-xorg
sudo dpkg-reconfigure xserver-xorg

Con ambos usuarios y con nomodeset

User avatar
JOPETA
Level 14
Level 14
Posts: 5468
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Error actualizando de LM 19 a 19.1

Post by JOPETA » Fri May 24, 2019 2:48 pm

Prueba desde la consola con

Code: Select all

sudo service lightdm stop
sudo apt-get remove --purge  xserver-xorg-core xserver-xorg-video-*
sudo apt-get install  xserver-xorg-core xserver-xorg-video-amdgpu
sudo dpkg-reconfigure xserver-xorg
sudo update-initramfs -u
sudo reboot
Si esto no funciona haz lo indicado sobre la desintalación de kernels (aparteado B de este post). Desintala todos menos el actual y vuelve a instalar uno por e ejemplo el 4.15.0-48. Cuando lo hagas trata de iniciar con eĺ desde las opciones avanzadas del menú (nada de recovery mode).

Si se producen errores con los códigos, por favor di qué errores.
Last edited by JOPETA on Fri May 24, 2019 3:27 pm, edited 1 time in total.
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

josemed1952
Level 3
Level 3
Posts: 105
Joined: Wed Mar 28, 2018 4:08 pm

Re: Error actualizando de LM 19 a 19.1

Post by josemed1952 » Fri May 24, 2019 3:12 pm

A la linea
sudo update-intramfs -u
, me dice orden no encontrada

User avatar
JOPETA
Level 14
Level 14
Posts: 5468
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Error actualizando de LM 19 a 19.1

Post by JOPETA » Fri May 24, 2019 3:26 pm

Perdón me comí la "i" del init :oops:

Code: Select all

sudo update-initramfs -u
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

josemed1952
Level 3
Level 3
Posts: 105
Joined: Wed Mar 28, 2018 4:08 pm

Re: Error actualizando de LM 19 a 19.1

Post by josemed1952 » Fri May 24, 2019 4:00 pm

No se por donde empezar...
Bueno he vuelto a escribir todas la lineas
sudo service lightdm stop
sudo apt-get remove --purge xserver-xorg-core xserver-xorg-video-*
sudo apt-get install xserver-xorg-core xserver-xorg-video-amdgpu
sudo dpkg-reconfigure xserver-xorg
sudo update-initramfs -u

A la linea , sudo update-initramfs -ume dice quw no soporta para local es_ESutf8
A la línea sudo apt-get install xserver-xorg-core xserver-xorg-video-amdgpu, me dice que no encuentra xserver-xorg-video-amdgpu
Bueno he hecho reboot y ahora no llega a la pantalla de contraseña de usuario. Se para en una pantalla de terminal y me pide nombre de usuario y contraseña.
Vale, lo introduzco y queriendo ver lo de los kernels, escribo dpkg --get-selections | grep linux image y la verdad ya no me acuerdo lo que dice (tengo la cabeza como un melon), pero no lo hace

User avatar
JOPETA
Level 14
Level 14
Posts: 5468
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Error actualizando de LM 19 a 19.1

Post by JOPETA » Sat May 25, 2019 3:19 am

josemed1952 wrote:
Fri May 24, 2019 4:00 pm
A la linea , sudo update-initramfs -ume dice quw no soporta para local es_ESutf8
Eso no tiene la menor importancia
josemed1952 wrote:
Fri May 24, 2019 4:00 pm
A la línea sudo apt-get install xserver-xorg-core xserver-xorg-video-amdgpu, me dice que no encuentra xserver-xorg-video-amdgpu
Comprueba que lo escribes bien (por ejemplo sin acento en vídeo.
josemed1952 wrote:
Fri May 24, 2019 4:00 pm
Bueno he hecho reboot y ahora no llega a la pantalla de contraseña de usuario. Se para en una pantalla de terminal y me pide nombre de usuario y contraseña.
Es posible que se haya desintalado el lightdm con lo anterior. Vuelve a instalarlo de la forma indicada ya

Code: Select all

sudo apt-get  install --reinstall lightdm lightdm-settings slick-greeter
sudo dpkg-reconfigure lightdm
sudo service lightdm start
startx 
o directamente volver a reiniciar.
josemed1952 wrote:
Fri May 24, 2019 4:00 pm
Vale, lo introduzco y queriendo ver lo de los kernels, escribo dpkg --get-selections | grep linux image y la verdad ya no me acuerdo lo que dice (tengo la cabeza como un melon), pero no lo hace
Ya lo habías hecho antes, solo tienes que tener cuidado a la hora de introducir los códigos. Falta un guióndpkg --get-selections | grep linux-image
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.( J. Krahe)

josemed1952
Level 3
Level 3
Posts: 105
Joined: Wed Mar 28, 2018 4:08 pm

Re: Error actualizando de LM 19 a 19.1

Post by josemed1952 » Sat May 25, 2019 7:50 am

Buenos días.
He podido aplicar la línea sudo apt-get install xserver-xorg-core xserver-xorg-video-amdgpu, correcto.
A las líneas indicadas...
sudo apt-get install --reinstall lightdm lightdm-settings slick-greeter
sudo dpkg-reconfigure lightdm
sudo service lightdm start
startx

Cuando he introducido la sudo service lightdm start, sin hacer nada me ha llevado directamente a la pantalla previa al escritorio, donde aparecen los 2 usuarios para introducir contraseña. Pero no tengo teclado, no tengo raton, no puedo abrir terminal, osea estoy bloqueado. Solo he podido reiniciar el ordenador con el boton de apagado.
Al ponerlo en marcha nuevamente el pc, me ha llevado hasta la misma pantalla, pero sin teclado, raton... etc, osea atascado. Solo puedo apagar el ordenador.
Claro no he podido terminar las operaciones con el startx ni hacer lo de los kernels.

Post Reply

Return to “Español (Spanish)”