Page 1 of 6

Error actualizando de LM 19 a 19.1. TERMINADO

Posted: Wed May 15, 2019 1:40 pm
by josemed1952
Hola.
Alguien puede ayudarme?.
Desde la version Sylvia 18.3, actrualize a la versión 19 Tara. He querido actualizar a la version 19.1 y me dice que antes debo instalar un archivo.
Pero al hacerlo me dice que no puedo porque tengo previamente que reparar algun paquete que tengo roto.
El mensaje que me da el sistema es...

Code: Select all

Traceback (most recent call last):
  File "/usr/lib/linuxmint/mintUpdate/mintUpdate.py", line 1807, in open_preferences
    builder.add_from_file(gladefile)
GLib.GError: gtk-builder-error-quark: /usr/share/linuxmint/mintupdate/preferences.ui:266:51 Invalid property: GtkScrolledWindow.propagate_natural_width (11)
Por favor alguien puede ayudarme?.
Que tengo que hacer?.
Gracias
Jose

Re: Linux Mint 19 Tara, ayuda!

Posted: Wed May 15, 2019 4:11 pm
by tomeu
Si tienes un paquete roto, puedes abrir synaptic, irte a paquetes rotos, y desinstalar/instalarlo o reinstalarlo.
Ojo con las dependencias, es decir, si al eliminarlo te va a borrar otros paquetes fíjate cuáles o mejor pruebas con reinstalarlo, desde el mismo synaptic por supuesto.

Re: Linux Mint 19 Tara, ayuda!

Posted: Wed May 15, 2019 4:37 pm
by Wibol
En Symaptic también existe la opción "Reparar paquetes rotos" en el menú "Editar".

Re: Linux Mint 19 Tara, ayuda!

Posted: Thu May 16, 2019 3:08 am
by josemed1952
Bueno vereis.
Cuando intento pasar a la actualizacion 19.1 Tessa desde la 19 Tara, me dice que, previamente tengo que instalar el paquete que falta mint-meta-mate.
Vale, le doy a instalar y me dice, que no se pudieron aplicar los cambios. Arregle los paquetes rotos primero (no dice que paquetes).
Ahora desde el centro de control, le pido informe del sistema...

Y me dice...
Traceback (most recent call last):
File "/usr/lib/linuxmint/mintUpdate/mintUpdate.py", line 1807, in open_preferences
builder.add_from_file(gladefile)
GLib.GError: gtk-builder-error-quark: /usr/share/linuxmint/mintupdate/preferences.ui:266:51 Invalid property: GtkScrolledWindow.propagate_natural_width (11)

Vale y hasta ahi llego. No se que hacer ni como.
Gracias por vuestro interes y ayuda.
Jose

Re: Linux Mint 19 Tara, ayuda!

Posted: Thu May 16, 2019 4:27 am
by tomeu
Pues veo que ya entendí la pregunta o situación desde el inicio 8)

Un "upgrade" entre versiones de la misma rama, como es de 19 a 19.1, no extraña casi ninguna dificultad, y sobre todo comparado con un upgrade de 18.3 a 19 que, por lo visto realizaste con éxito (1)

La existencia de "paquetes rotos" no solo impide un upgrade, sino que muchas veces también la mera actualización de paquetes (update).

¿Has abierto la aplicación Synaptic? Me temo que no porque si no sabes qué paquetes están rotos... Abre synaptic y en "filtros" verás "paquetes rotos" o algo así.

Como dice Wibol y yo me había olvidado existe la opción de arreglarlo.

Doy por sentado que tienes en cuenta que para actualizar, p.ej. de 19 a 19.1, se recomienda desmarcar fuentes PPA o externas, así como tener actualizados los desklets, applets, extensiones...

(1) Salvo que ese paquete roto lo estés arrastrando desde el upgrade de 18.3 a 19 :?:

Editado: Quizás te interese echarle un vistazo a está página: Cómo arreglar paquetes rotos en Linux Mint

Suerte.

Re: Linux Mint 19 Tara, ayuda!

Posted: Thu May 16, 2019 5:38 am
by josemed1952
Hola y gracias por tu interes en ayudarme.
He leido lo que se indica en como arreglar paquetes rotos...
Seguido paso a paso las indicaciones y cuando llego a instalar el programa y-ppa-manager, me dice que no se ha podido instalar algunos paquetes porque, tienen dependencias incumplidas y que tengo retenidos los paquetes rotos... :shock:
En Synaptic, me indica que no tengo paquetes rotos y por lo tanto no me da opcion seleccionar "estado" ni que paquete seleccionar.
Osea estoy mas perdido que un pulpo en el garaje.
Saludos cordiales

Re: Linux Mint 19 Tara, ayuda!

Posted: Thu May 16, 2019 5:39 am
by JOPETA
tomeu wrote:
Thu May 16, 2019 4:27 am
Doy por sentado que tienes en cuenta que para actualizar, p.ej. de 19 a 19.1, se recomienda desmarcar fuentes PPA o externas, así como tener actualizados los desklets, applets, extensiones...
Tener actualizado el sistema por lo menos instalando todas la actualizaciones de nivel 3 y desactivados extensiones, applets y desklets, usar temas por defecto...

1)Que actualizando de Cinnamon 19 a Cinnamon 19.1 te pida paquetes de Mate (todo el escritorio mate si es el mint-meta-mate) es cuando menos indicativo como mínimo de haber instalado herramientas nativas de este escritorio.

2)En cualquier caso en los errores mostrados no se muestran la referencia a paquetes rotos sino fallos en la carga de herramientas del escritorio como el gestor de actualizaciones (mintupdate) y sus correspondientes ejecutables de python, como si usaras diferentes versiones de python o GTK que pueden ser o no importantes si realmente tienes presente en el panel el escudito del Gestor de actualizaciones o si no funciona pese a aparecer al hacer clic sobre él.

3)Antes de hacer nada más, cierra Synaptic, el administrador de controladores y cualquier otro gestor de software que tengas abierto- Abre una terminal (Ctrl+Alt+T) y devuelve el resultado completo de los siguientes códigos en la terminal de la forma indicada aquí (copia y pega una línea cada vez seguido de Intro)

Code: Select all

inxi -Fxnzr
sudo apt update
sudo apt-get install --resintall mintupdate
Respecto a las paquetes rotos que se mencionan y luego no aparecen- Cuidado que no es lo mismo parece que ha tenido paquetes retenidos, pidió una situación imposible, puede que tenga paquetes rotos con que realmente los tengas. Synaptic es lentorro de reflejos. Si intentas una instalación que fracasa por lo que sea (dependencias, paquetes rotos) o si la cancelas cuando te avisa que instalará o desinstalará lo que sea, debes refrescarlo para que no se quede con el recuerdo de lo ocurrido una vez solucionado el problema o cancelar la instalación. Mejor aún cerrarlo, volver a abrirlo y refrescarlo. :wink:

Re: Linux Mint 19 Tara, ayuda!

Posted: Thu May 16, 2019 6:07 am
by josemed1952
Hola Jopeta.
Gracias, te cuento...
No he actualizado desde Cinnamon, lo hice desde Mint Mate.

He introducido en el terminal las líneas que me indicas y el resultado es...
En sudo inxi -Fxnzr, me hace una descripción del pc muy extensa
En sudo apt update, despues de leer la lista de paquetes, crear el arbol de dependenciasm me indica que se pueden actualizar 15 paquetes y que omite un fichero configurado porque mo admite la arquitectura i386.
En sudo apt-get install --reinstall mintupdate, aparentemente ha configurado mintupdate (5.4.7)
Pero no ha cambiado nada, los mensajes siguen siendo los mismos que antes y sin poder actualizar.
Jose

Re: Linux Mint 19 Tara, ayuda!

Posted: Thu May 16, 2019 6:09 am
by josemed1952
Por cierto, no tengo opción de copiar y pegar los codigos que me indica la terminal.
Los selecciono, y no abre menu contextual con el boton derecho.

Re: Linux Mint 19 Tara, ayuda!

Posted: Thu May 16, 2019 7:11 am
by JOPETA
1)El problema (por lo que dices del clic derecho del ratón y no poder adjuntar los resultado de los códigos) parece ser la interacion con el escritorio. Puede que l problea sea del tema instalado (instala uno de los temas proporcionados por defecto por Mint Menú>Centro de control>Apariencia) o los controladores gráficos (si tuvieras gráficas nvidia/amd), los elementos gráficos del escritorio y panel personalizados (por aquello de los gtk) deberías desintalarlos para instalarlos de nuevo...

2)Podrías usar las opciones de la barra de menu de la teminal (Editar>Seleccionar todo, Editat>copiar) y tratar de pegar los resultados de la forma indicada en foro. Tal vez debas abrir una terminal y escribir ( si no puedes acceder ni siquiera a la barra de menú de la terminal) con marco --replace o metacity --replace para tener unas ventanas mínimamente practicables.Otra opción es que proporciones el enlaces a una página de compartición que se generan con los siguinetes códigos

Code: Select all

inxi -Fxznrc0 |nc termbin.com 9999
.

3)Lamento la confusión respecto a Mate/Cinnamon. Se me han debido cruzar dos hilos diferentes. :oops:

4)Los fallos con los paquetes que indican la archiquetectura (386 o amd64) son normales ya que esto ha quedado superado salvo excepciones. La nueva edición es por defecto multiarch. Lo cual no sólo ocasiona fallos a la hora de conectar con repositorios externos como los de Chrome, sino que determinadas libreriás 386 no van a terner actualizaciones ya que quedan incoporadas o otros paquetes o un paquete genéricos- Un sudo apt autoclean y sudo apt autoremove no vendrían mal-,....

Re: Linux Mint 19 Tara, ayuda!

Posted: Thu May 16, 2019 7:28 am
by josemed1952
Socorroo...
Al introducir marco --replace en la terminal he perdido la posibilidad de cerrar pantallas, minimizar... incluso copiar, pegar en pantallas normales!.
Como hago para volver por lo menos a como estaba....
Me empiezo a agoviar...
Saluos

Re: Linux Mint 19 Tara, ayuda!

Posted: Thu May 16, 2019 7:45 am
by JOPETA
Si usabas compiz abre la linea de ordenes( Alt+F2) o una terminal y usa compiz --replace o como indicaba en el post anterior (que por cierto estaba reeditando) metacity --replace . No te pongas nervioso por eso. :D

Basta con que cierres y vuelvas a abrir sesión o reinicies para acceder a la Configuración del escriorio (Menú>Centro de Control>Configuración del escriorio> Ventanas) y usar el gestor de ventanas+compositor que usabas antes.

Re: Linux Mint 19 Tara, ayuda!

Posted: Thu May 16, 2019 9:10 am
by josemed1952
Uf!, que susto!!!
Bien he reiniciado el pc y parece que esta igual que antes...
Bueno, el problema inicial sigue igual...
Se os ocurre algo?.

Re: Error actualizando de LM 19 a 19.1

Posted: Thu May 16, 2019 12:02 pm
by JOPETA
A parte de lo dicho en el penultimo post y en espera de los resultado, no me atrevo a que reinstales mint-meta-mate con sudo apt-get-install mint-meta-mate -f.... :roll:

Re: Error actualizando de LM 19 a 19.1

Posted: Thu May 16, 2019 12:38 pm
by josemed1952
Pues ya lo habia intentado antes, pero lo he vuelto a hacer
y el resultado es...
No se han podido instalar algunos paquetes.
Hay paquetes con dependencias incumplidas
No se han podido corregir los problemas, usted ha retenido paquetes rotos...
Te adjunto un pantallazo del resultado, porque no puedo copiar y pegar...
Pantallazo-2019-05-16 18-35-54.png
Pantallazo-2019-05-16 18-35-54.png (6.64 KiB) Viewed 364 times

Re: Error actualizando de LM 19 a 19.1

Posted: Thu May 16, 2019 12:44 pm
by josemed1952
JOPETA wrote:
Thu May 16, 2019 12:02 pm
A parte de lo dicho en el penultimo post y en espera de los resultado, no me atrevo a que reinstales mint-meta-mate con sudo apt-get-install mint-meta-mate -f.... :roll:
Puedo intentar enviarlos con un pantallazo también...
Dime por favor a que resultados te refieres que esperas, puedes repetirme las instrucciones?.

Re: Error actualizando de LM 19 a 19.1

Posted: Fri May 17, 2019 1:51 pm
by josemed1952
Hola de nuevo, los resultados del terminal a lo propuesto son los que te indico abajo
1 y 2 son a inxi -Fxnzr
3 es a sudo apt update
4 es a sudo apt-get install --resintall mintupdate

Re: Error actualizando de LM 19 a 19.1

Posted: Fri May 17, 2019 1:52 pm
by josemed1952
Y el 4

Re: Error actualizando de LM 19 a 19.1

Posted: Sun May 19, 2019 6:18 am
by JOPETA
No te he contestado antes ya que es más que evidente que tienes un cisco considerable de repositorios y esprab una acalaración por tu pate. Aunque los repositorios de MInt apuntan a tara es decir LM 19 los de Ubuntu todavía apuntan a xenial que es la base de LM 18 , no a bionic como debieran.

Quiere esto decir que si no seguiste otro tutorial para actualizar a LM 19 (mediante mintupgrade), posteriormente has editado manualmente el archivo /etc/apt/sources.list.d/official-package-repositories.list, cambiando bionic por xenial. :roll:

Comprenderás que si normalmente lo recomendable es instalar desde cero, en esta ocasión con más razón dependiendo de los cambios que hayas realizado a manubrio. En cualquier caso si quieres seguir probando haz lo sugerido a continuación:
1) Deshaz los cambios

Code: Select all

sudo nano /etc/apt/sources.list.d/official-package-repositories.list
y reemplaza xenial por bionic. Digo nano porque en estas condiciones no se si pluma te funcionaría (quizás con sudo -H pluma /etc/apt/sources.list.d/official-package-repositories.list) .
Guarda los cambios y cierra el editor.

2)Desactiva los repositorios adicionales y ppas en Menú >Centro de Control>Fuentes del Software También parece ( aunque sólo parece) que tengas mezcla ta que la mayoría apunta a bionic pero alguno con el de Megasync apunta al xUbuntu 16.04). Desactivar es lo más adecuado por los códigos que vas a ejecutar y las aplicaciones que dejen de funcionar sin duda deberás reinstalarlas después de hacer lo siguiente.

3)Abre una teminal y ejecuta

Code: Select all

sudo apt update 
sudo apt upgrade && apt full-upgrade


4)Cruza los dedos.... :wink:

Re: Error actualizando de LM 19 a 19.1

Posted: Sun May 19, 2019 8:57 am
by josemed1952
Hola Jopeta y muchas gracias por seguir ayudandome, ya lo daba por perdido.
Disculpa que sea un poco torpe..., la instalación de Tara la hice siguiendo un tutorial de intrnet (yo no sabria hacerlo).
Y de ahi, a la situación actual.
Bien sigo tus pasos y te digo...
Sobre la linea de comando en le terminal...sudo nano /etc/apt/sources.list-d/official-package-repositories.list
Entro en una pantalla en la que me dice que la carpeta no existe, por lo que no puedo cambiar, nada... :shock:
Gracias por tu ayuda y paciencia...
>Jose