Mint 19 - Toshiba Satellite L50 c201 - WIFI no funciona [solucionado]

Spanish Forum

Moderators: tomeu, JCSenar

Post Reply
rinfante
Level 1
Level 1
Posts: 3
Joined: Sun Jun 09, 2019 4:36 pm

Mint 19 - Toshiba Satellite L50 c201 - WIFI no funciona [solucionado]

Post by rinfante »

Hola

Recurro a vosostros después de intentar varias cosas sin éxito, os cuento el problema:

He instalado el Linux Mint 19 en una Toshiba Satellite L50 c 201, indicándole que borrara windows 10 y ocupara todo el disco. La instalación ha ido perfecta, pero sólo puedo conectare por ethernet, el wifi no se activa. de ninguna manera

He intentado lo que indican en este post:
viewtopic.php?t=283728
sin avances.

Dejo detalles del sistema:

Code: Select all

System:
  Host: alice Kernel: 4.15.0-20-generic x86_64 bits: 64 compiler: gcc 
  v: 7.3.0 Desktop: Xfce 4.12.3 Distro: Linux Mint 19.1 Tessa 
  base: Ubuntu 18.04 bionic 
Machine:
  Type: Laptop System: TOSHIBA product: SATELLITE L50-C v: PSKW2E-00H00XCE 
  serial: <filter> 
  Mobo: FF50 model: 06F3 v: Type2 - Board Version serial: <filter> 
  UEFI: INSYDE v: 1.20 date: 09/11/2015 
Battery:
  ID-1: BAT1 charge: 12.3 Wh condition: 12.3/45.0 Wh (27%) 
  model: LGC PA5185U-1BRS status: Full 
CPU:
  Topology: Dual Core model: Intel Core i7-6500U bits: 64 type: MT MCP 
  arch: Skylake rev: 3 L2 cache: 4096 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20736 
  Speed: 500 MHz min/max: 400/3100 MHz Core speeds (MHz): 1: 500 2: 500 
  3: 500 4: 500 
Graphics:
  Device-1: Intel HD Graphics 520 
  vendor: Toshiba America Info Systems Skylake GT2 driver: i915 v: kernel 
  bus ID: 00:02.0 
  Device-2: NVIDIA GM108M [GeForce 930M] 
  vendor: Toshiba America Info Systems driver: nouveau v: kernel 
  bus ID: 01:00.0 
  Display: server: X.Org 1.19.6 driver: modesetting,nouveau 
  unloaded: fbdev,vesa resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2) 
  v: 4.5 Mesa 18.2.8 direct render: Yes 
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio 
  vendor: Toshiba America Info Systems driver: snd_hda_intel v: kernel 
  bus ID: 00:1f.3 
  Sound Server: ALSA v: k4.15.0-20-generic 
Network:
  Device-1: Intel Wireless 3165 driver: iwlwifi v: kernel port: 4000 
  bus ID: 02:00.0 
  IF: wlp2s0 state: down mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Toshiba America Info Systems driver: r8169 v: 2.3LK-NAPI 
  port: 3000 bus ID: 03:00.0 
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 931.51 GiB used: 13.44 GiB (1.4%) 
  ID-1: /dev/sda vendor: Toshiba model: MQ01ABD100 size: 931.51 GiB 
  temp: 41 C 
Partition:
  ID-1: / size: 915.40 GiB used: 13.44 GiB (1.5%) fs: ext4 dev: /dev/sda2 
Sensors:
  System Temperatures: cpu: 41.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Repos:
  No active apt repos in: /etc/apt/sources.list 
  Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
  1: deb http://packages.linuxmint.com tessa main upstream import backport #id:linuxmint_main
  2: deb http://archive.ubuntu.com/ubuntu bionic main restricted universe multiverse
  3: deb http://archive.ubuntu.com/ubuntu bionic-updates main restricted universe multiverse
  4: deb http://archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse
  5: deb http://security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
  6: deb http://archive.canonical.com/ubuntu/ bionic partner
Info:
  Processes: 188 Uptime: 14m Memory: 7.63 GiB used: 1.18 GiB (15.5%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.4.0 Shell: bash v: 4.4.19 
  inxi: 3.0.27 
Gracias de antemano.
Last edited by rinfante on Sat Jun 15, 2019 6:17 am, edited 1 time in total.
JeremyB
Level 20
Level 20
Posts: 11659
Joined: Fri Feb 21, 2014 8:17 am

Re: Mint 19 - Toshiba Satellite L50 c201 - WIFI no funciona

Post by JeremyB »

Code: Select all

rfkill list
Por favor
rinfante
Level 1
Level 1
Posts: 3
Joined: Sun Jun 09, 2019 4:36 pm

Re: Mint 19 - Toshiba Satellite L50 c201 - WIFI no funciona

Post by rinfante »

Hola, pone:

Code: Select all

0: Toshiba Bluetooth: Bluetooth
	Soft blocked: no
	Hard blocked: no
1: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no
2: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: yes
User avatar
JOPETA
Level 16
Level 16
Posts: 6916
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Mint 19 - Toshiba Satellite L50 c201 - WIFI no funciona

Post by JOPETA »

El resultado de rfkill muestra que la wifi está desactivada/bloqueada por hardware y, el inxi que no es una tarjeta que debiera tener problemas de controladores, a no ser que JeremyB opine lo contrario. :wink:

Quizás deberías actualizar el kernel de la forma gráfica indicada para instalar el último disponible de la serie 4.15 .

Decir sólo que hiciste lo del enlace obliga a pedirte que confirmes cada una de las sugerencias y que devuelvas, como te ha solicitado JeremyB, el resultado de los códigos que se proponen. Debes confirmar lo que has probado y el resultado obtenido:
a)Has Iniciado con el cable de red desconectado y, en estas condiciones,

b)Has entrado en la BIOS y confirmado que exisiste un apartado destinado a la configuraciones de las conexiones y la conexión de la tarjeta WIFI (WLAN ; WIFI PCI,..) está activada

c)Una vez en la BIOS/UEFI aclara también el modo de inicio y si es UEFI asegura que el Secure Boot/inicio seguro y el CSM/compatilidad están desactivados y, en cualquier caso, el Fast Boot/inicio rápido tambien.

d)Tu Toshiba debería tener
-un botón (en un lateral o en el panel del teclado) para conmutar la WIFI/Bluetooth (¿lo tienes? y si es así ¿cuales son la opciones y cual es su posición? y/o

- un acceso de teclado (Fn+F8??? o Fn+F12??). ¿Funciona este y otros accesos de teclado? (presiónalas aisladamente, sin la tecla de Fn, y con ella para probar).
e)Tras efectuar estas operaciones y ejecutado sudo systemctl restart networkmanager, trascurridos unos segundos, ¿tienes el mismo resultado de rfkill list all?

f)Desactiva/elimina la conexión por cable desde el acceso del panel (clic, no se si derecho o izquierdo en XFCE, en el icono o en Menú>Configuración>Conexiones de Red) y reinicia para asegurar que la red inalámbrica está activada. Si no es así, vuelve a probar que lo dicho en los apartados anteriores no tiene efecto transcurrido unos segundos.
Last edited by JOPETA on Tue Jun 11, 2019 3:49 pm, edited 2 times in total.
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.(Javier Krahe)
JeremyB
Level 20
Level 20
Posts: 11659
Joined: Fri Feb 21, 2014 8:17 am

Re: Mint 19 - Toshiba Satellite L50 c201 - WIFI no funciona

Post by JeremyB »

If it has no switch, you may need to power down, remove battery and power cord, then press the power button for 20 seconds

Traducción:
Si no tiene interruptor, es posible que deba apagar, quitar la batería y el cable de alimentación, luego presionar el botón de encendido durante 20 segundos
Last edited by JCSenar on Mon Jun 10, 2019 11:29 am, edited 1 time in total.
Reason: Añadida traducción
rinfante
Level 1
Level 1
Posts: 3
Joined: Sun Jun 09, 2019 4:36 pm

Re: Mint 19 - Toshiba Satellite L50 c201 - WIFI no funciona

Post by rinfante »

Hola, les escribo conectado a mi red WIFI.

He seguido todos los pasos de JOPETA y por último he sacado la batería y presionado el botón de encender por 30 segundos como mencionaba JeremiB, luego de reiniciar, ya funcionaba.

Muchisima gracias a los dos =)
Post Reply

Return to “Español (Spanish)”