Oracle VirtualBox no responde - Solucionado

Spanish Forum

Moderators: tomeu, JCSenar

Post Reply
santopitar
Level 1
Level 1
Posts: 10
Joined: Sun Aug 25, 2019 6:15 am

Oracle VirtualBox no responde - Solucionado

Post by santopitar » Sun Aug 25, 2019 6:34 am

Hola.
A continuación explico mi problema.
Por lo general, mantengo el host (Linux Mint) actualizado a la última versión, incluido el kernel, y durante algunos meses tengo problemas con las últimas versiones de VirtualBox, que actualizo desde el repositorio oficial.
Lo que sucede es que la máquina virtual de Windows 7 está congelada, y luego VirtualBox también está congelada, aparece una ventana en la que el host (Linux Mint) indica que "Oracle VirtualBox no responde", por lo que me da las opciones de esperar o forzar el cierre.
Cuando fuerzo el cierre y vuelvo a abrir VirtualBox, la máquina virtual de Windows 7 aparece como abortada. Si lo vuelvo a iniciar, lo hace sin problemas, después de indicar que el último cierre no fue adecuado, pero se congela nuevamente después de unos minutos.
Hay momentos en que la congelación está al principio, cuando intento ingresar la contraseña y otras cuando uso una aplicación (Word, Excel ... etc.).
Lo que hago es arreglarlo usando una versión anterior de VirtualBox (generalmente tengo que volver a "5.2.30-130521 ~ Ubuntu ~ bionic"), y el núcleo del host (Linux Mint) lo dejó en la última versión. Pero cuando intenté actualizar a la última versión de VirtualBox, me dieron el mismo error nuevamente, con diferentes versiones.
Copio a continuación la información sobre el contexto y adjunto el archivo con el registro de VirtualBox:
Gracias de antemano.

VirtualBox version: 6.0.10 r132072 (Qt5.9.5) - 6.0.10-132072~Ubuntu~bionic
Host: Linux Mint 19 (Tara) - 16GB - 64b
Guest: Windows 7 - 4GB - 64b

Command "VBoxManage list extpacks":

Code: Select all

Extension Packs: 1
Pack no. 0:   Oracle VM VirtualBox Extension Pack
Version:      6.0.10
Revision:     132072
Edition:      
Description:  USB 2.0 and USB 3.0 Host Controller, Host Webcam, VirtualBox RDP, PXE ROM, Disk Encryption, NVMe.
VRDE Module:  VBoxVRDP
Usable:       true 
Why unusable: 
Command "VBoxManage showvminfo "MV_W7-64b (NoBorrar)" --details":

Code: Select all

Name:                        MV_W7-64b (NoBorrar)
Groups:                      /
Guest OS:                    Windows 7 (64-bit)
UUID:                        8683ce38-98ce-47b3-99c7-da035052d814
Config file:                 /home/josemari/00_VirtualBox VMs/MV_W7-64b (NoBorrar)/MV_W7-64b (NoBorrar).vbox
Snapshot folder:             /home/josemari/00_VirtualBox VMs/MV_W7-64b (NoBorrar)/Snapshots
Log folder:                  /home/josemari/00_VirtualBox VMs/MV_W7-64b (NoBorrar)/Logs
Hardware UUID:               8683ce38-98ce-47b3-99c7-da035052d814
Memory size                  4096MB
Page Fusion:                 disabled
VRAM size:                   128MB
CPU exec cap:                100%
HPET:                        disabled
CPUProfile:                  host
Chipset:                     piix3
Firmware:                    BIOS
Number of CPUs:              2
PAE:                         enabled
Long Mode:                   enabled
Triple Fault Reset:          disabled
APIC:                        enabled
X2APIC:                      disabled
Nested VT-x/AMD-V:           disabled
CPUID Portability Level:     0
CPUID overrides:             None
Boot menu mode:              message and menu
Boot Device 1:               DVD
Boot Device 2:               HardDisk
Boot Device 3:               Not Assigned
Boot Device 4:               Not Assigned
ACPI:                        enabled
IOAPIC:                      enabled
BIOS APIC mode:              APIC
Time offset:                 0ms
RTC:                         local time
Hardw. virt.ext:             enabled
Nested Paging:               enabled
Large Pages:                 disabled
VT-x VPID:                   enabled
VT-x unr. exec.:             enabled
Paravirt. Provider:          Default
Effective Paravirt. Prov.:   HyperV
State:                       aborted (since 2019-08-21T11:18:08.656000000)
Monitor count:               1
3D Acceleration:             enabled
2D Video Acceleration:       enabled
Teleporter Enabled:          disabled
Teleporter Port:             0
Teleporter Address:          
Teleporter Password:         
Tracing Enabled:             disabled
Allow Tracing to Access VM:  disabled
Tracing Configuration:       
Autostart Enabled:           disabled
Autostart Delay:             0
Default Frontend:            
Storage Controller Name (0):            SATA
Storage Controller Type (0):            IntelAhci
Storage Controller Instance Number (0): 0
Storage Controller Max Port Count (0):  30
Storage Controller Port Count (0):      2
Storage Controller Bootable (0):        on
SATA (0, 0): /home/josemari/00_VirtualBox VMs/MV_W7-64b (NoBorrar)/MV_W7-64b.vdi (UUID: cfb6dec6-e42b-447b-ae7f-8f729dc1d791)
SATA (1, 0): Empty
NIC 1:                       MAC: 080027CCF460, Attachment: NAT, Cable connected: on, Trace: off (file: none), Type: 82540EM, Reported speed: 0 Mbps, Boot priority: 0, Promisc Policy: deny, Bandwidth group: none
NIC 1 Settings:  MTU: 0, Socket (send: 64, receive: 64), TCP Window (send:64, receive: 64)
NIC 2:                       disabled
NIC 3:                       disabled
NIC 4:                       disabled
NIC 5:                       disabled
NIC 6:                       disabled
NIC 7:                       disabled
NIC 8:                       disabled
Pointing Device:             USB Tablet
Keyboard Device:             PS/2 Keyboard
UART 1:                      disabled
UART 2:                      disabled
UART 3:                      disabled
UART 4:                      disabled
LPT 1:                       disabled
LPT 2:                       disabled
Audio:                       enabled (Driver: PulseAudio, Controller: HDA, Codec: STAC9221)
Audio playback:              enabled
Audio capture:               enabled
Clipboard Mode:              Bidirectional
Drag and drop Mode:          Bidirectional
VRDE:                        enabled (Address 0.0.0.0, Ports 3389, MultiConn: off, ReuseSingleConn: off, Authentication type: null)
Video redirection:           disabled
VRDE property               : TCP/Ports  = "3389"
VRDE property               : TCP/Address = <not set>
VRDE property               : VideoChannel/Enabled = <not set>
VRDE property               : VideoChannel/Quality = <not set>
VRDE property               : VideoChannel/DownscaleProtection = <not set>
VRDE property               : Client/DisableDisplay = <not set>
VRDE property               : Client/DisableInput = <not set>
VRDE property               : Client/DisableAudio = <not set>
VRDE property               : Client/DisableUSB = <not set>
VRDE property               : Client/DisableClipboard = <not set>
VRDE property               : Client/DisableUpstreamAudio = <not set>
VRDE property               : Client/DisableRDPDR = <not set>
VRDE property               : H3DRedirect/Enabled = <not set>
VRDE property               : Security/Method = <not set>
VRDE property               : Security/ServerCertificate = <not set>
VRDE property               : Security/ServerPrivateKey = <not set>
VRDE property               : Security/CACertificate = <not set>
VRDE property               : Audio/RateCorrectionMode = <not set>
VRDE property               : Audio/LogPath = <not set>
OHCI USB:                    disabled
EHCI USB:                    disabled
xHCI USB:                    enabled

USB Device Filters:

<none>

Bandwidth groups:  <none>

Shared folders:

Name: 'DATOS_EXT4', Host path: '/media/josemari/DATOS_EXT4' (machine mapping), writable
Name: 'RESPALDO_EXT4', Host path: '/media/josemari/RESPALDO_EXT4' (machine mapping), writable
Name: 'VARIOS1_EXT4', Host path: '/media/josemari/VARIOS1_EXT4' (machine mapping), writable
Name: 'VARIOS2_EXT4', Host path: '/media/josemari/VARIOS2_EXT4' (machine mapping), writable
Name: 'josemari', Host path: '/home/josemari' (machine mapping), writable

Capturing:                   active
Capture audio:               active
Capture screens:             0
Capture file:                /home/josemari/00_VirtualBox VMs/MV_W7-64b (NoBorrar)/MV_W7-64b (NoBorrar).webm
Capture dimensions:          1024x768
Capture rate:                512kbps
Capture FPS:                 25kbps
Capture options:             ac_enabled=true,vc_enabled=true,ac_profile=med

Description:

Guest:

Configured memory balloon size: 0MB
Last edited by santopitar on Fri Sep 13, 2019 3:01 am, edited 1 time in total.

User avatar
tomeu
Level 5
Level 5
Posts: 812
Joined: Wed Mar 29, 2017 12:03 pm
Location: España

Re: Oracle VirtualBox no responde

Post by tomeu » Sun Aug 25, 2019 7:35 am

Bienvenido al foro.
Por favor un poco más de información.
Si abres un hilo con tu problema, no te olvides proporciona información completa sobre tu sistema. Abre una terminal (clic en el icono de la terminal del escritorio o presiona Ctrl+Alt+T), copia y pega los siguientes códigos en ella y devuelve el resultado usando la opción </> (Code) del editor de textos del foro que aparece encima del cuadro donde escribes.
inxi -Fxnzr
Gracias
Linux Mint Tina 19.2 64bits Cinnamon 4.2.4
Por favor, recuerda añadir al título el 'palabro' "[SOLUCIONADO]" si el problema o cuestión ha quedado resuelto. Gracias

santopitar
Level 1
Level 1
Posts: 10
Joined: Sun Aug 25, 2019 6:15 am

Re: Oracle VirtualBox no responde

Post by santopitar » Sun Aug 25, 2019 9:12 am

Gracias.

Esta es la salida del comando "inxi -Fxnzr":

Code: Select all

System:    Host: PC-CASA Kernel: 4.15.0-58-generic x86_64 bits: 64 gcc: 7.4.0
           Desktop: Cinnamon 3.8.9 (Gtk 3.22.30-1ubuntu4)
           Distro: Linux Mint 19 Tara
Machine:   Device: desktop System: ASUS product: All Series serial: N/A
           Mobo: ASUSTeK model: H97-PLUS v: Rev X.0x serial: N/A
           UEFI [Legacy]: American Megatrends v: 2603 date: 02/26/2016
CPU:       Quad core Intel Core i5-4590 (-MCP-) 
           arch: Haswell rev.3 cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 26339
           clock speeds: max: 3700 MHz 1: 1948 MHz 2: 1810 MHz 3: 1579 MHz
           4: 1494 MHz
Graphics:  Card: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1680x1050@59.88hz
           OpenGL: renderer: Mesa DRI Intel Haswell Desktop
           version: 4.5 Mesa 19.0.8 Direct Render: Yes
Audio:     Card-1 Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:03.0
           Card-2 Intel 9 Series Family HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-58-generic
Network:   Card-1: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 03:00.0
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
           Card-2: Qualcomm Atheros AR9287 Wireless Network Adapter (PCI-Express)
           driver: ath9k bus-ID: 06:00.0
           IF: wlp6s0 state: down mac: <filter>
Drives:    HDD Total Size: 3750.8GB (26.2% used)
           ID-1: /dev/sda model: Samsung_SSD_850 size: 250.1GB
           ID-2: /dev/sdb model: ST500DM002 size: 500.1GB
           ID-3: /dev/sdc model: ST1000DM003 size: 1000.2GB
           ID-4: /dev/sdd model: ST1000DM003 size: 1000.2GB
           ID-5: /dev/sde model: WDC_WD1003FZEX size: 1000.2GB
Partition: ID-1: / size: 79G used: 11G (15%) fs: ext4 dev: /dev/sda6
           ID-2: /boot size: 945M used: 429M (49%) fs: ext4 dev: /dev/sda1
           ID-3: /home size: 148G used: 58G (42%) fs: ext4 dev: /dev/sda7
           ID-4: swap-1 size: 2.15GB used: 0.00GB (0%)
           fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C
           Fan Speeds (in rpm): cpu: 0
Repos:     Active apt sources in file: /etc/apt/sources.list.d/additional-repositories.list
           deb [arch=amd64] https://download.virtualbox.org/virtualbox/debian bionic contrib
           Active apt sources in file: /etc/apt/sources.list.d/alex-p-aegisub-bionic.list
           deb http://ppa.launchpad.net/alex-p/aegisub/ubuntu bionic main
           deb-src http://ppa.launchpad.net/alex-p/aegisub/ubuntu bionic main
           Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://mintlinux.mirror.wearetriple.com/packages tara main upstream import backport
           deb http://es-mirrors.evowise.com/ubuntu bionic main restricted universe multiverse
           deb http://es-mirrors.evowise.com/ubuntu bionic-updates main restricted universe multiverse
           deb http://es-mirrors.evowise.com/ubuntu bionic-backports main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ bionic partner
           Active apt sources in file: /etc/apt/sources.list.d/spotify.list
           deb http://repository.spotify.com stable non-free
Info:      Processes: 227 Uptime: 3:10 Memory: 6355.5/15918.7MB
           Init: systemd runlevel: 5 Gcc sys: 7.4.0
           Client: Shell (bash 4.4.201) inxi: 2.3.56 

User avatar
tomeu
Level 5
Level 5
Posts: 812
Joined: Wed Mar 29, 2017 12:03 pm
Location: España

Re: Oracle VirtualBox no responde

Post by tomeu » Mon Aug 26, 2019 4:14 am

Lo siento, yo no veo por dónde puede venir el problema, espero que alguien más pueda darte mejor ayuda.

Con todo, veo que tienes en la máquina virtual windows 7 activado tanto la aceleración 3D como la de video 2D. Yo la/s activé en su día y me fue peor que desactivada/s.

Con tanta instalación/desinstalación de VBox desde el repositorio (5.2.x) y de la última versión de la web (6.0.x) doy por sentado que se han hecho las desinstalaciones a fondo sin dejar rastros (excepto máquinas virtuales). Pues si es la versión del repositorio dices que funciona verdad?

A mi las actualizaciones de kernel en la misma rama o actualizaciones punto nunca han afectado a mi máquina virtual, un salto de kernel sí, pero no es tu caso.

Lo que me confunde algo es esto:
VirtualBox version: 6.0.10 r132072 (Qt5.9.5) - 6.0.10-132072~Ubuntu~bionic
Host: Linux Mint 19 (Tara) - 16GB - 64b
Guest: Windows 7 - 4GB - 64b
En rojo. ¿de qué son esos Gigas?
Linux Mint Tina 19.2 64bits Cinnamon 4.2.4
Por favor, recuerda añadir al título el 'palabro' "[SOLUCIONADO]" si el problema o cuestión ha quedado resuelto. Gracias

santopitar
Level 1
Level 1
Posts: 10
Joined: Sun Aug 25, 2019 6:15 am

Re: Oracle VirtualBox no responde

Post by santopitar » Mon Aug 26, 2019 8:16 am

Lo que está en rojo es la memoria RAM de las máquinas, tanto el anfitrión como el huesped.
Desactivaré las aceleraciones, pero no creo que influya porque antes iba bien.
Creo que es un conflicto con los nuevos kernels de Linux Mint y las nuevas versiones de VirtualBox, a partir de la 6.
Pero debe ser algo respecto a mi máquina, porque no encuentro nada por ahí al respecto, y es algo que alguien habría notado ya.
El caso es que con la versión 5.2.32, que es la anterior a la 6 que viene en el repositorio, de momento va bien. Pero no me hace gracia no poder tener la última versión de VirtualBox, porque uso bastante la máquina de W7.
Gracias por tu ayuda.

User avatar
JCSenar
Level 10
Level 10
Posts: 3147
Joined: Sat Sep 06, 2014 6:26 pm
Location: Irun, España
Contact:

Re: Oracle VirtualBox no responde

Post by JCSenar » Mon Aug 26, 2019 8:33 am

santopitar wrote:
Mon Aug 26, 2019 8:16 am
Creo que es un conflicto con los nuevos kernels de Linux Mint y las nuevas versiones de VirtualBox, a partir de la 6.
La versión 6.0.x de VirtualBox dio algunos problemas al principio pero pensaba que ya se habrían corregido :(

Yo sigo con la v. 5.2.32 (kernel 4.15.0-58) sin problemas.
santopitar wrote:
Mon Aug 26, 2019 8:16 am
Pero no me hace gracia no poder tener la última versión de VirtualBox, porque uso bastante la máquina de W7.
Habrá que esperar, a ver si la versión 6.1.x soluciona los problemas....

De todas formas y por curiosidad, aparte del nuevo diseño del programa, ¿qué características tiene la versión 6.0.x que no puedas hacer con la actual 5.2.x?
Image
Si tu consulta ha sido resuelta, por favor, edita tu primer mensaje y añade [SOLUCIONADO] al título. Gracias.

mintxavi
Level 1
Level 1
Posts: 18
Joined: Mon Jul 02, 2018 6:50 am

Re: Oracle VirtualBox no responde

Post by mintxavi » Mon Aug 26, 2019 9:48 am

hola a todos

Misma version de virtualbox aqui, mi pc muy viejo ya pero todavia mueve algunos linux nuevos, ignoro con win7 si se produce algun problema, pero a mi me van bien las maquinas con la aceleracion habilitada pero ahora estoy en el kernel 5.0.0.25.

Por si acaso si observe esto:
vbox.png

mejor asi en :vboxvga o svga

saludos a todos y buen dia

User avatar
tomeu
Level 5
Level 5
Posts: 812
Joined: Wed Mar 29, 2017 12:03 pm
Location: España

Re: Oracle VirtualBox no responde

Post by tomeu » Mon Aug 26, 2019 11:55 am

JCSenar wrote:
Mon Aug 26, 2019 8:33 am
Yo sigo con la v. 5.2.32 (kernel 4.15.0-58) sin problemas.
Yo también seguiría con esa versión (del repositorio), pero en mi caso fue al revés. Al probar un kernel superior se me fastidió VBox y, tras regresar al anterior kernel, solo encontré la solución instalando la última versión descargada desde VB. :? Por eso estoy con la 6.0.10
JCSenar wrote:
Mon Aug 26, 2019 8:33 am
De todas formas y por curiosidad, aparte del nuevo diseño del programa, ¿qué características tiene la versión 6.0.x que no puedas hacer con la actual 5.2.x?
Solo a efectos didácticos (tampoco se me había ocurrido pensar en ello hasta ahora):
Sobre las comentadas "mejoras" en la última versión
Parece que la mejora se debe notar, sobre todo, en la virtualización de SS.OO. superiores a win 7, como win 10 ó Mac OSX.
Yo solo le doy uso con muy poco: programas institucionales anclados en el viejo guendolin y en poder escanear usando el alimentador automático (que en linux no funciona bien, y para que el escaneo sea decente hay que hacerlo hoja a hoja).
Por cierto ¿qué pasará con win 7 virtualizado cuando llegue enero de 2020 y lo descontinúen?
Mi copia de win 7 es como la recomendada por Pjtor :shock:
Linux Mint Tina 19.2 64bits Cinnamon 4.2.4
Por favor, recuerda añadir al título el 'palabro' "[SOLUCIONADO]" si el problema o cuestión ha quedado resuelto. Gracias

santopitar
Level 1
Level 1
Posts: 10
Joined: Sun Aug 25, 2019 6:15 am

Re: Oracle VirtualBox no responde

Post by santopitar » Fri Sep 06, 2019 4:02 am

Bueno, parece que se ha arreglado. Quería explicar cuál fue el error que creo que cometí, porque es bastante tonto.
Al instalar la nueva versión de Guest Additions en la máquina virtual, antes de hacerlo, desinstalé la versión anterior. También lo hice con una aplicación, que generalmente uso en Windows, que desinstala las aplicaciones en profundidad: "Revo Uninstaller".
Creo que ese fue el error, porque se puede instalar la nueva versión de Guest Additions sin desinstalar la versión anterior, y cuando finaliza solo aparece la nueva versión en la lista de programas instalados.
Gracias por todo y cierro el tema.

santopitar
Level 1
Level 1
Posts: 10
Joined: Sun Aug 25, 2019 6:15 am

Re: Oracle VirtualBox no responde

Post by santopitar » Fri Sep 06, 2019 4:02 am

Disculpad, pero no encuentro como se cierra un tema, o como se da por cerrado.

User avatar
Wibol
Level 4
Level 4
Posts: 359
Joined: Fri Nov 27, 2015 7:00 am
Location: España

Re: Oracle VirtualBox no responde

Post by Wibol » Fri Sep 06, 2019 4:15 am

Debes hacer clic en el icono del lápiz que aparece en la parte superior de tu primer post y añadir al título "(Solucionado)".

Antes de realizar una consulta, no olvides:

santopitar
Level 1
Level 1
Posts: 10
Joined: Sun Aug 25, 2019 6:15 am

Re: Oracle VirtualBox no responde - Solucionado

Post by santopitar » Fri Sep 13, 2019 3:01 am

Hecho. Gracias

User avatar
tomeu
Level 5
Level 5
Posts: 812
Joined: Wed Mar 29, 2017 12:03 pm
Location: España

Re: Oracle VirtualBox no responde

Post by tomeu » Mon Sep 16, 2019 8:25 am

santopitar wrote:
Fri Sep 06, 2019 4:02 am
Bueno, parece que se ha arreglado. Quería explicar cuál fue el error que creo que cometí, porque es bastante tonto.
Al instalar la nueva versión de Guest Additions en la máquina virtual, antes de hacerlo, desinstalé la versión anterior. También lo hice con una aplicación, que generalmente uso en Windows, que desinstala las aplicaciones en profundidad: "Revo Uninstaller".
Creo que ese fue el error, porque se puede instalar la nueva versión de Guest Additions sin desinstalar la versión anterior, y cuando finaliza solo aparece la nueva versión en la lista de programas instalados.
Gracias por todo y cierro el tema.
Imagino que el uso de "Revo Uninstaller" lo habías hecho en la máquina virtualizada "Windows 7", pero siendo así, más que borrar VBox en Windows (que no estaba instalado) lo que eliminaste fueron las "guest aditions" y sus referencias en el famoso "Registro" de Windows con una "limpieza a fondo".
Como referencia El capítulo V de VirtualBox en los tutoriales: No hace falta ni desinstalar la versión anterior en Linux. :wink:
Finalmente, queda la duda de saber si lograste instalar la versión 6.0.10 en la fecha de tu mensaje o ya habías instalado la 6.0.12, que casi sale al mismo tiempo :D :D
Linux Mint Tina 19.2 64bits Cinnamon 4.2.4
Por favor, recuerda añadir al título el 'palabro' "[SOLUCIONADO]" si el problema o cuestión ha quedado resuelto. Gracias

Post Reply

Return to “Español (Spanish)”