Error instalador actualizaciones en LM 19.1 [SOLUCIONADO]

Spanish Forum

Moderators: tomeu, JCSenar

Post Reply
eldruida_mint
Level 1
Level 1
Posts: 8
Joined: Fri Aug 16, 2019 5:13 pm

Error instalador actualizaciones en LM 19.1 [SOLUCIONADO]

Post by eldruida_mint » Thu Sep 05, 2019 3:17 pm

Hola he comprobado de un par de meses atras que cada vez que Linux Mint 19.2 me informa hay actualizaciones al terminar de instalarlas me muestra siempre el siguiente mensaje:

Code: Select all

E: amavisd-new: instalado amavisd-new paquete post-installation guión el subproceso devolvió un error con estado de salida 1
E: amavisd-milter: problemas de dependencias - se deja sin configurar
E: amavisd-new-postfix: problemas de dependencias - se deja sin configurar
Muestro los detalles:

Code: Select all

(Leyendo la base de datos ... 437802 ficheros o directorios instalados actualmente.)
Preparando para desempaquetar .../libsnmp-base_5.7.3+dfsg-1.8ubuntu3.2_all.deb ...
Desempaquetando libsnmp-base (5.7.3+dfsg-1.8ubuntu3.2) sobre (5.7.3+dfsg-1.8ubuntu3.1) ...
Preparando para desempaquetar .../libsnmp30_5.7.3+dfsg-1.8ubuntu3.2_amd64.deb ...
Desempaquetando libsnmp30:amd64 (5.7.3+dfsg-1.8ubuntu3.2) sobre (5.7.3+dfsg-1.8ubuntu3.1) ...
Configurando amavisd-new (1:2.11.0-1ubuntu1.1) ...
Creating/updating amavis user account...
Job for amavis.service failed because the control process exited with error code.
See "systemctl status amavis.service" and "journalctl -xe" for details.
invoke-rc.d: initscript amavis, action "start" failed.
● amavis.service - LSB: Starts amavisd-new mailfilter
   Loaded: loaded (/etc/init.d/amavis; generated)
   Active: failed (Result: exit-code) since Thu 2019-09-05 21:14:06 CEST; 4ms ago
     Docs: man:systemd-sysv-generator(8)
  Process: 23265 ExecStart=/etc/init.d/amavis start (code=exited, status=1/FAILURE)

sep 05 21:14:06 eldruida-700-110es amavis[23265]: Starting amavisd: head: cannot open '/etc/mailname' for reading: No such file or directory
sep 05 21:14:06 eldruida-700-110es amavis[23265]:   The value of variable $myhostname is "eldruida-700-110es", but should have been
sep 05 21:14:06 eldruida-700-110es amavis[23265]:   a fully qualified domain name; perhaps uname(3) did not provide such.
sep 05 21:14:06 eldruida-700-110es amavis[23265]:   You must explicitly assign a FQDN of this host to variable $myhostname
sep 05 21:14:06 eldruida-700-110es amavis[23265]:   in /etc/amavis/conf.d/05-node_id, or fix what uname(3) provides as a host's
sep 05 21:14:06 eldruida-700-110es amavis[23265]:   network name!
sep 05 21:14:06 eldruida-700-110es amavis[23265]: (failed).
sep 05 21:14:06 eldruida-700-110es systemd[1]: amavis.service: Control process exited, code=exited status=1
sep 05 21:14:06 eldruida-700-110es systemd[1]: amavis.service: Failed with result 'exit-code'.
sep 05 21:14:06 eldruida-700-110es systemd[1]: Failed to start LSB: Starts amavisd-new mailfilter.
dpkg: error al procesar el paquete amavisd-new (--configure):
 instalado amavisd-new paquete post-installation guión el subproceso devolvió un error con estado de salida 1
dpkg: problemas de dependencias impiden la configuración de amavisd-milter:
 amavisd-milter depende de amavisd-new; sin embargo:
 El paquete `amavisd-new' no está configurado todavía.

dpkg: error al procesar el paquete amavisd-milter (--configure):
 problemas de dependencias - se deja sin configurar
Configurando libsnmp-base (5.7.3+dfsg-1.8ubuntu3.2) ...
No se escribió un informe «apport» porque el mensaje de error indica que es un mensaje de error asociado a un fallo previo.
                                           dpkg: problemas de dependencias impiden la configuración de amavisd-new-postfix:
 amavisd-new-postfix depende de amavisd-new (= 1:2.11.0-1ubuntu1.1); sin embargo:
 El paquete `amavisd-new' no está configurado todavía.

dpkg: error al procesar el paquete amavisd-new-postfix (--configure):
 problemas de dependencias - se deja sin configurar
Configurando libsnmp30:amd64 (5.7.3+dfsg-1.8ubuntu3.2) ...
No se escribió un informe «apport» porque el mensaje de error indica que es un mensaje de error asociado a un fallo previo.
                                           Procesando disparadores para man-db (2.8.3-2ubuntu0.1) ...
Procesando disparadores para libc-bin (2.27-3ubuntu1) ...
Se encontraron errores al procesar:
 amavisd-new
 amavisd-milter
 amavisd-new-postfix
E: Sub-process /usr/bin/dpkg returned an error code (1)
Un paquete no se pudo instalar. Tratando de recuperarlo:
Configurando amavisd-new (1:2.11.0-1ubuntu1.1) ...
Creating/updating amavis user account...
Job for amavis.service failed because the control process exited with error code.
See "systemctl status amavis.service" and "journalctl -xe" for details.
invoke-rc.d: initscript amavis, action "start" failed.
● amavis.service - LSB: Starts amavisd-new mailfilter
   Loaded: loaded (/etc/init.d/amavis; generated)
   Active: failed (Result: exit-code) since Thu 2019-09-05 21:14:08 CEST; 5ms ago
     Docs: man:systemd-sysv-generator(8)
  Process: 23554 ExecStart=/etc/init.d/amavis start (code=exited, status=1/FAILURE)

sep 05 21:14:08 eldruida-700-110es amavis[23554]: Starting amavisd: head: cannot open '/etc/mailname' for reading: No such file or directory
sep 05 21:14:08 eldruida-700-110es amavis[23554]:   The value of variable $myhostname is "eldruida-700-110es", but should have been
sep 05 21:14:08 eldruida-700-110es amavis[23554]:   a fully qualified domain name; perhaps uname(3) did not provide such.
sep 05 21:14:08 eldruida-700-110es amavis[23554]:   You must explicitly assign a FQDN of this host to variable $myhostname
sep 05 21:14:08 eldruida-700-110es amavis[23554]:   in /etc/amavis/conf.d/05-node_id, or fix what uname(3) provides as a host's
sep 05 21:14:08 eldruida-700-110es amavis[23554]:   network name!
sep 05 21:14:08 eldruida-700-110es amavis[23554]: (failed).
sep 05 21:14:08 eldruida-700-110es systemd[1]: amavis.service: Control process exited, code=exited status=1
sep 05 21:14:08 eldruida-700-110es systemd[1]: amavis.service: Failed with result 'exit-code'.
sep 05 21:14:08 eldruida-700-110es systemd[1]: Failed to start LSB: Starts amavisd-new mailfilter.
dpkg: error al procesar el paquete amavisd-new (--configure):
 instalado amavisd-new paquete post-installation guión el subproceso devolvió un error con estado de salida 1
dpkg: problemas de dependencias impiden la configuración de amavisd-milter:
 amavisd-milter depende de amavisd-new; sin embargo:
 El paquete `amavisd-new' no está configurado todavía.

dpkg: error al procesar el paquete amavisd-milter (--configure):
 problemas de dependencias - se deja sin configurar
dpkg: problemas de dependencias impiden la configuración de amavisd-new-postfix:
 amavisd-new-postfix depende de amavisd-new (= 1:2.11.0-1ubuntu1.1); sin embargo:
 El paquete `amavisd-new' no está configurado todavía.

dpkg: error al procesar el paquete amavisd-new-postfix (--configure):
 problemas de dependencias - se deja sin configurar
Se encontraron errores al procesar:
 amavisd-new
 amavisd-milter
 amavisd-new-postfix

¿Porqué me sale este mensaje? Mi sistema no va bien? Como evitar salga ese mensaje. GRACIAS
Last edited by JCSenar on Sat Sep 07, 2019 3:44 pm, edited 2 times in total.
Reason: Añadido [SOLUCIONADO]

herra
Level 1
Level 1
Posts: 25
Joined: Fri Oct 14, 2016 12:55 pm

Re: error instalador actualizaciones

Post by herra » Thu Sep 05, 2019 3:57 pm

Hola.
Prueba correr desde una consola para arreglar los paquetes rotos:
$ sudo dpkg --configure -a

Luego elimina los paquetes que dan error y reinstalalos nuevamente:
$sudo dpkg --purge "paquete"
$sudo apt-get install "paquete"

Saludos
Last edited by JCSenar on Fri Sep 06, 2019 7:44 am, edited 1 time in total.
Reason: Cambiado "puege" por "purge"

User avatar
tomeu
Level 5
Level 5
Posts: 884
Joined: Wed Mar 29, 2017 12:03 pm
Location: España

Re: Error instalador actualizaciones en LM 19.1

Post by tomeu » Sat Sep 07, 2019 1:24 am

eldruida_mint wrote:
Thu Sep 05, 2019 3:17 pm
¿Porqué me sale este mensaje? Mi sistema no va bien? Como evitar salga ese mensaje. GRACIAS
Parece que has instalado un paquete "amavisd-new" y o bien le no están cubiertas las dependencias o bien no está bien configurado (o ambas), y te dan esos avisos.

Veo que ese paquete es un gestor o filtro de correo para usar antivirus o antispam. No se instala por defecto en LMint 19.2 (ni en ninguna versión anterior que yo sepa)

Da la impresión que tu sistema va bien, y que para eliminar esos mensajes o bien "purgas" ese paquete o lo configuras correctamente. :D
Image
Linux Mint Tina 19.2 64bits Cinnamon 4.2.4
Por favor, recuerda añadir al título el 'palabro' "[SOLUCIONADO]" si el problema o cuestión ha quedado resuelto. Gracias

eldruida_mint
Level 1
Level 1
Posts: 8
Joined: Fri Aug 16, 2019 5:13 pm

Re: Error instalador actualizaciones en LM 19.1

Post by eldruida_mint » Sat Sep 07, 2019 5:10 am

SOLUCIONADO. Gracias por el comentario. Una vez me has comentado no es un archivo original del sistema lo he buscado en la paqueteria lo he desinstalado ( eran cuatro archivos) y todo vuelve a estar OK

Post Reply

Return to “Español (Spanish)”