No se instalar Java en Linux Mint ni en Firefox [SOLUCIONADO]

Spanish Forum

Moderators: tomeu, JCSenar

Post Reply
Ignorante55
Level 1
Level 1
Posts: 4
Joined: Sat Sep 07, 2019 3:48 am

No se instalar Java en Linux Mint ni en Firefox [SOLUCIONADO]

Post by Ignorante55 » Sat Sep 07, 2019 3:53 am

Al pasarme de windows a linux mint, me he encontrado con un problema.
No sé cómo instalar Java ni en Linux MInt ni en Firefox 69.0 (ultima actualizacion)
A pesar de ir buscando por internet, no lo consigo.
Agradeceria explicación paso a paso, porque soy novato.
Gracias
Last edited by JCSenar on Thu Sep 12, 2019 7:30 am, edited 1 time in total.
Reason: Añadido [SOLUCIONADO]

User avatar
tomeu
Level 5
Level 5
Posts: 884
Joined: Wed Mar 29, 2017 12:03 pm
Location: España

Re: No se instalar Java en Linux Mint ni en Firefox

Post by tomeu » Sat Sep 07, 2019 5:18 am

En este post almacen certificados... verás varias formas de instalar JAVA: openJDK-8, openJDEK-11 (si no lo tuvieses instalado ya) y Oracle-Java.

No podrás instalar el plugin de Java en FF 69. Firefox no admite desde hace mucho ese plugin: la última versión que lo admite es 52.x ESR ó si quieres la release la ver 51.x

Ni en Linux, ni en Windows, ni Mac (lo mismo ocurre con Chrome)
Image
Linux Mint Tina 19.2 64bits Cinnamon 4.2.4
Por favor, recuerda añadir al título el 'palabro' "[SOLUCIONADO]" si el problema o cuestión ha quedado resuelto. Gracias

Ignorante55
Level 1
Level 1
Posts: 4
Joined: Sat Sep 07, 2019 3:48 am

Re: No se instalar Java en Linux Mint ni en Firefox

Post by Ignorante55 » Wed Sep 11, 2019 8:47 am

gracias por la respuesta, pero entonces, cómo puedo acceder a lugares públicos, como la Seguridad Social, Hacienda, o registradoresonline, que aun usan la tecnologia Java?
Que explorador en Linux MInt podria servirme para hacer eso?
Gracias de nuevo

User avatar
JCSenar
Level 10
Level 10
Posts: 3193
Joined: Sat Sep 06, 2014 6:26 pm
Location: Irun, España
Contact:

Re: No se instalar Java en Linux Mint ni en Firefox

Post by JCSenar » Wed Sep 11, 2019 9:46 am

Ignorante55 wrote:
Wed Sep 11, 2019 8:47 am
gracias por la respuesta, pero entonces, cómo puedo acceder a lugares públicos, como la Seguridad Social, Hacienda, o registradoresonline, que aun usan la tecnologia Java?
Que explorador en Linux MInt podria servirme para hacer eso?
Yo entro en todas partes con el DNIe:

DNI ELECTRÓNICO (I): Instalación en Linux Mint
DNI ELECTRÓNICO (II): Configuración en Chrome/Chromium
Image
Si tu consulta ha sido resuelta, por favor, edita tu primer mensaje y añade [SOLUCIONADO] al título. Gracias.

User avatar
tomeu
Level 5
Level 5
Posts: 884
Joined: Wed Mar 29, 2017 12:03 pm
Location: España

Re: No se instalar Java en Linux Mint ni en Firefox

Post by tomeu » Wed Sep 11, 2019 11:27 am

Yo (en Linux) uso 4 navegadores: Firefox (última versión release, hoy 69), Firefox 60 ESR, Chrome 77 y Brave 76. Antes para páginas muy, muy, anticuadas que necesitan Oracle-Java (y versión anterior a la actual) usaba Firefox 52 ESR en lugar de 60 ESR. Hoy en día solo me queda 1 página tan estúpida que sigue en esas, y es más sencillo tener un windows virtualizado con su I.Explorer solo por esa página.

Sigo manteniendo la versión 60 ESR de firefox, porque es también cierto que algunas páginas no se ponen mucho al día y funcionan mejor con versiones más conservadoras.

Todos los navegadores citados en la actualidad me permiten trabajar con todas las páginas que has dicho en linux, y sin Oracle-Java. Si alguna necesita java, usa el entorno java openjdk, y supongo que eso es para acceder a la aplicación autofirm@.

No sabía que la web del Registro de la Propiedad usara java. Es más, lo dudo.

No recuerdo si las últimas versiones de Palemoon permiten el plugin java. Aun así Palemoon ha sido un navegador que a mi siempre me ha ado muchos problemas para que funcione en lugares que requieren el uso del Dnie u otra tarjeta con otro tipo de certificado.

Pero, es más, lo dicho ya no es solo en Linux. Con Windows y Mac pasa lo mismo. Edge no admite el plugin de java, lo que te obliga usar I.Explorer. Y, salvo error, las nuevas versiones de Safari tampoco lo permiten en Mac. Es más, creo que safari nunca ha congeniado muy bien con java y páginas seguras de instituciones u organismos.

Si necesitas usar el plugin java, sea en Linux, Mac o Windows (salvo I.Explorer) no queda otra que recurrir a una versión antigua de Firefox: De la rama ESR la versión 52; de la rama release, la versión 51 o anterior.

Desde el lanzamiento de Firefox 69 va a ser bastante complejo instalar versiones antiguas si no se ha creado un perfil distinto para esa versión antigua.
Image
Linux Mint Tina 19.2 64bits Cinnamon 4.2.4
Por favor, recuerda añadir al título el 'palabro' "[SOLUCIONADO]" si el problema o cuestión ha quedado resuelto. Gracias

Ignorante55
Level 1
Level 1
Posts: 4
Joined: Sat Sep 07, 2019 3:48 am

SOLUCIONADO No se instalar Java en Linux Mint ni en Firefox

Post by Ignorante55 » Thu Sep 12, 2019 3:19 am

Muchisimas gracias por la explicación exhaustiva, que me ha abierto un mundo que estaba lleno de dudas.

Ahora SI lo tengo claro. (La web a la que me referia por error no era la del registro de la propiedad , si no la del Registro Mercantil)

Bueno, tema zanjado, voy a por ello.

Gracias de nuevo.

Post Reply

Return to “Español (Spanish)”