Error al usar administrador de actualizaciones

Spanish Forum

Moderators: tomeu, JCSenar

User avatar
desmolinux
Level 3
Level 3
Posts: 143
Joined: Mon Oct 02, 2017 7:05 am

Error al usar administrador de actualizaciones

Post by desmolinux »

Image

Hola de nuevo, hoy he ido a actualizar las aplicaciones y al darle a refrescar al administrador de actualizaciones , ha dado este fallo, lo he intentado un par de veces, pero sigue dando el fallo.
Que puedo hacer para que actualice bien?

Muchas gracias.
Last edited by desmolinux on Thu Jun 11, 2020 6:57 am, edited 3 times in total.
User avatar
JOPETA
Level 17
Level 17
Posts: 7228
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Error al usar administrador de actualizaciones

Post by JOPETA »

¿Qué fallo?
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.(Javier Krahe)
User avatar
JCSenar
Level 11
Level 11
Posts: 3602
Joined: Sat Sep 06, 2014 6:26 pm
Location: Irun, España
Contact:

Re: Error al usar administrador de actualizaciones

Post by JCSenar »

JOPETA wrote:
Wed Feb 26, 2020 1:58 pm
¿Qué fallo?
Corregido aunque no se aprecia bien... :?
Image
Si tu consulta ha sido resuelta, por favor, edita tu primer mensaje y añade [SOLUCIONADO] al título. Gracias.
User avatar
JOPETA
Level 17
Level 17
Posts: 7228
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Error al usar administrador de actualizaciones

Post by JOPETA »

Lo que se adivina son numerosas claves expiradas de dos reposositorios music manager de google y brave-browser. Lo más probable es que al tratarse de productos de Goolge este haya cambiado las firmas digitales y debas esperar a que lo resuelvan. Tu no tendrías que hacer nada ya que es lo que han recomendado en otros episodios de este tipo de descoordinación cmo por ejemplo este.
No action is needed (and recommended) from users side, just waiting for the repos in use to be signed with renewed key
Aunque esto no debe afectar al resto de las actualizaciones, si quieres no tener este tipo de resultados al actualizar mientras podrías desactivar esos respositorios en las Fuentes/origenes de software si es que están allí los Respositorios Adicionales o PPAs. Dudo que las opciones de mantenimiento (como arreglar problemas de mergelist o encontrar claves perdidas) sirva en este caso aunque puedes intentarlo antes de desactivarlos.
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.(Javier Krahe)
User avatar
desmolinux
Level 3
Level 3
Posts: 143
Joined: Mon Oct 02, 2017 7:05 am

Re: Error al usar administrador de actualizaciones

Post by desmolinux »

Image

No se si la foto se ve?

Sobre los errores del google music manager, no se porque sale ahi, por que ese programa lo instalé yo descargando el archivo de instalacion, ya que no estaba en el gestor de software.Y el Brave browser igual, lo instale descargandolo.

Entonces que debo hacer? darle a actualizar aunque de ese error?
Last edited by JCSenar on Wed Feb 26, 2020 4:12 pm, edited 1 time in total.
Reason: Corregido el formato [rimg]
User avatar
JOPETA
Level 17
Level 17
Posts: 7228
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Error al usar administrador de actualizaciones

Post by JOPETA »

No se ve. :(

Da igual de donde lo descargaras si al instalar se crea el repositorio (como es normal con los productos de Google).

El gestor de actualizaciones sigue su curso con el resto de los repositorios, de haber otras actualizaciones de otro software estarán disponible para instalar. No debes dejar de instalar esas otras actualizaciones por esto.

Sobre que hacer creo que lo ha quedado claro. Esperar a que lo solucionen los de Google/brave o hacer lo indicado en Orígenes/Fuentes del Software en el post anterior. Tu decides. :wink:
Last edited by JOPETA on Thu Feb 27, 2020 3:10 am, edited 1 time in total.
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.(Javier Krahe)
User avatar
JCSenar
Level 11
Level 11
Posts: 3602
Joined: Sat Sep 06, 2014 6:26 pm
Location: Irun, España
Contact:

Re: Error al usar administrador de actualizaciones

Post by JCSenar »

desmolinux wrote:
Wed Feb 26, 2020 3:13 pm
No se si la foto se ve?
Has de utilizar el formato [rimg].

Y no [url] o [img].
Image
Si tu consulta ha sido resuelta, por favor, edita tu primer mensaje y añade [SOLUCIONADO] al título. Gracias.
User avatar
tomeu
Level 6
Level 6
Posts: 1370
Joined: Wed Mar 29, 2017 12:03 pm
Location: España

Re: Error al usar administrador de actualizaciones

Post by tomeu »

JOPETA wrote:
Wed Feb 26, 2020 3:37 pm

Da igual de donde lo descargaras si al instalar se crea el repositorio (como es normal con los productos de Google).
Aunque esté basado en ello y sea casi hijo de... Brave no es exactamente de Google
brave-info.png
https://brave.com/about/

En fuentes de software → mantenimiento se puede intentar lo de "agregar claves faltantes", hacer clic ahí hace que trabaje un buen rato, pero suele ir bien con ese problema de claves. :wink:
claves faltantes.png

Aunque no se me daba ese problema, y no hacía mucho que lo había usado, el reciente resultado ha dado esto:
claves anadidas.png
claves anadidas.png (29.46 KiB) Viewed 1644 times
Osea, que hay claves nuevas en google, brave, y otros más.
Image
Linux Mint Ulyana 20 Cinnamon
Por favor, recuerda añadir al título el 'palabro' "[SOLUCIONADO]" si el problema o cuestión ha quedado resuelto. Gracias
User avatar
JOPETA
Level 17
Level 17
Posts: 7228
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Error al usar administrador de actualizaciones

Post by JOPETA »

tomeu wrote:
Thu Feb 27, 2020 1:56 am
[Aunque esté basado en ello y sea casi hijo de... Brave no es exactamente de Google
Gracias por las precisiones quizás debí añadir y otras aplicaciones procedentes de repositorios externos. Tenía en mente la consulta de un usario que no entendía que instalar un .deb en estas ocasiones conllevara la intalación automática del respositorio. :D
tomeu wrote:
Thu Feb 27, 2020 1:56 am
En fuentes de software → mantenimiento se puede intentar lo de "agregar claves faltantes", hacer clic ahí hace que trabaje un buen rato, pero suele ir bien con ese problema de claves. :wink:
De nuevo gracias por la precisión, no recordaba exactamente el nombre de esa entrada del menú de Mantenimiento (no tengo instalado LM 19.2 ni LM 19.3).
Last edited by JOPETA on Sat Feb 29, 2020 12:42 pm, edited 5 times in total.
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.(Javier Krahe)
User avatar
tomeu
Level 6
Level 6
Posts: 1370
Joined: Wed Mar 29, 2017 12:03 pm
Location: España

Re: Error al usar administrador de actualizaciones

Post by tomeu »

JOPETA wrote:
Thu Feb 27, 2020 4:07 am
De nuevo gracias por la precisión, no recordaba exactamente el nombre de esa entrada del menú de Mantenimiento (no tengo instalado LM 19.2 ni LM 19.3)
No se merecen.
Y cierto, esa es una de las novedades de Mint 19.2 y .3 y bastante efectiva.
Lo de "Repositorios Adicionales", es decir, no PPAs de ubuntu, es bastante frecuente.
Image
Linux Mint Ulyana 20 Cinnamon
Por favor, recuerda añadir al título el 'palabro' "[SOLUCIONADO]" si el problema o cuestión ha quedado resuelto. Gracias
User avatar
JOPETA
Level 17
Level 17
Posts: 7228
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Error al usar administrador de actualizaciones

Post by JOPETA »

Falta que Desmolinux nos diga si se ha solucionado el problema. :roll:
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.(Javier Krahe)
User avatar
desmolinux
Level 3
Level 3
Posts: 143
Joined: Mon Oct 02, 2017 7:05 am

Re: Error al usar administrador de actualizaciones

Post by desmolinux »

JOPETA wrote:
Thu Feb 27, 2020 4:24 am
Falta que Desmolinux nos diga si se ha solucionado el problema. :roll:
Esta tarde lo pruebo que estoy en el tajo, de todas formas yo tengo LM 18 :? no se si tengo la posibilidad de hacer lo indicado por Tomeu.
User avatar
JOPETA
Level 17
Level 17
Posts: 7228
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Error al usar administrador de actualizaciones

Post by JOPETA »

No y tampoco creo que sea necesario, luego lo comentas.
tomeu wrote:
Thu Feb 27, 2020 4:17 am
JOPETA wrote:
Thu Feb 27, 2020 4:07 am
no recordaba exactamente el nombre de esa entrada del menú de Mantenimiento (no tengo instalado LM 19.2 ni LM 19.3)
cierto, esa es una de las novedades de Mint 19.2 y .3 y bastante efectiva.
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.(Javier Krahe)
User avatar
desmolinux
Level 3
Level 3
Posts: 143
Joined: Mon Oct 02, 2017 7:05 am

Re: Error al usar administrador de actualizaciones

Post by desmolinux »

He ido a mirar lo de fuentes de software, pero no tengo eso de agregar claves faltantes, he pinchado en repositorios adicionales y he visto los que me han dado el problema.

Como debo actuar ahora para actualizar?

Image
Last edited by JCSenar on Thu Feb 27, 2020 3:12 pm, edited 1 time in total.
Reason: Añadido formato [rimg]
User avatar
tomeu
Level 6
Level 6
Posts: 1370
Joined: Wed Mar 29, 2017 12:03 pm
Location: España

Re: Error al usar administrador de actualizaciones

Post by tomeu »

Como tienes LM 18.2 y lo de "Añadir claves faltantes" arranca con LM 19.2... pues eso explica que no lo tengas.

Como también los tengo puedo decirte que los repositorios de Google (chrome) y brave funcionan, por lo que puede ser que tuvieses un problema que haya sido pasajero. Los otros 2 no los conozco; veo que el último es de whatsapp ¿lo necesitas? digo el repositorio.

Puedes empezar desmarcando todos, refrescas las fuentes; luego lo dejas a sí o vas marcando los que te interesan (entiendo que lo de los navegadores es necesario por las actualizaciones de seguridad) y compruebas si se sigue dando el fallo.

Si se da el fallo, hay que volver a instalar las claves. Un método sencillo es quitar el respositorio, quitar también su clave vieja, en la imagen "claves de actualización", desinstalar el programa (no se desinstala el perfil y preferencias) y luego volverlo a instalar con su nuevo deb descargado de google/brave; se debe crear entonces un nuevo repositorio adicional con su nueva clave.
Image
Linux Mint Ulyana 20 Cinnamon
Por favor, recuerda añadir al título el 'palabro' "[SOLUCIONADO]" si el problema o cuestión ha quedado resuelto. Gracias
User avatar
desmolinux
Level 3
Level 3
Posts: 143
Joined: Mon Oct 02, 2017 7:05 am

Re: Error al usar administrador de actualizaciones

Post by desmolinux »

Ok, he probado a ir quitando los repositorios que dan problemas, y curiosamente el unico que no da error al refrescar es el que tiene que ver con whatsapp (que me pregunto yo que es y de donde ha salido) Los otros 3 van dando fallos al refrescar.
Entiendo entonces que si quiero actualizar esas programas, tengo que hacer lo que me has comentado de desinstalar y descargar de nuevo del archivo deb.
He empezado por brave y en la web me sale lo siguiente:
https://brave-browser.readthedocs.io/en ... html#linux

Entiendo que tengo que seguir los pasos descritos
sudo apt install apt-transport-https curl

curl -s https://brave-browser-apt-release.s3.br ... e-core.asc | sudo apt-key --keyring /etc/apt/trusted.gpg.d/brave-browser-release.gpg add -

echo "deb [arch=amd64] https://brave-browser-apt-release.s3.brave.com/ stable main" | sudo tee /etc/apt/sources.list.d/brave-browser-release.list

sudo apt update

sudo apt install brave-browser
O esto es solo si da error? Por cierto, no veo que haya donde descargar ningún archivo deb.

Gracias.
User avatar
tomeu
Level 6
Level 6
Posts: 1370
Joined: Wed Mar 29, 2017 12:03 pm
Location: España

Re: Error al usar administrador de actualizaciones

Post by tomeu »

http://ubuntuhandbook.org/index.php/201 ... inux-mint/

No te olvides lo del final de la línea: sudo apt install brave-browser brave-keyring

Creo que antes había un *.deb (acabo de verlo en sourceforge pero es bastante antiguo)
Image
Linux Mint Ulyana 20 Cinnamon
Por favor, recuerda añadir al título el 'palabro' "[SOLUCIONADO]" si el problema o cuestión ha quedado resuelto. Gracias
User avatar
desmolinux
Level 3
Level 3
Posts: 143
Joined: Mon Oct 02, 2017 7:05 am

Re: Error al usar administrador de actualizaciones

Post by desmolinux »

Perdón, por el retraso en contestar, he estado unos días fuera, y perdón por no enterarme mucho,
He desmarcado el Brave y el Chrome en "repositorios adicionales" de Fuentes de software y he actualizado el resto del sistema sin problema.
Ahora he vuelto a marcar solo el Brave, he refrescado en administ de actualizaciones y ha vuelto a dar el error, como en la lista a actualizar se ha puesto el Brave, le he dado a actualizar y ha salido esta nueva ventana,
Si le digo que siga para delante y actualice, que problemas puedo tener?
Es mejor lo primero que me dijisteis de desinstalarlo y volver a instalarlo?

Image


Gracias.
Last edited by JCSenar on Sat Mar 07, 2020 11:33 am, edited 1 time in total.
Reason: Añadido formato [rimg]
User avatar
tomeu
Level 6
Level 6
Posts: 1370
Joined: Wed Mar 29, 2017 12:03 pm
Location: España

Re: Error al usar administrador de actualizaciones

Post by tomeu »

desmolinux wrote:
Sat Mar 07, 2020 5:45 am
Es mejor lo primero que me dijisteis de desinstalarlo y volver a instalarlo?
sactamente
Image
Linux Mint Ulyana 20 Cinnamon
Por favor, recuerda añadir al título el 'palabro' "[SOLUCIONADO]" si el problema o cuestión ha quedado resuelto. Gracias
User avatar
desmolinux
Level 3
Level 3
Posts: 143
Joined: Mon Oct 02, 2017 7:05 am

Re: Error al usar administrador de actualizaciones

Post by desmolinux »

tomeu wrote:
Fri Feb 28, 2020 2:03 am
Como tienes LM 18.2 y lo de "Añadir claves faltantes" arranca con LM 19.2... pues eso explica que no lo tengas.

Como también los tengo puedo decirte que los repositorios de Google (chrome) y brave funcionan, por lo que puede ser que tuvieses un problema que haya sido pasajero. Los otros 2 no los conozco; veo que el último es de whatsapp ¿lo necesitas? digo el repositorio.

Puedes empezar desmarcando todos, refrescas las fuentes; luego lo dejas a sí o vas marcando los que te interesan (entiendo que lo de los navegadores es necesario por las actualizaciones de seguridad) y compruebas si se sigue dando el fallo.

Si se da el fallo, hay que volver a instalar las claves. Un método sencillo es quitar el respositorio, quitar también su clave vieja, en la imagen "claves de actualización", desinstalar el programa (no se desinstala el perfil y preferencias) y luego volverlo a instalar con su nuevo deb descargado de google/brave; se debe crear entonces un nuevo repositorio adicional con su nueva clave.
Entonces a ver si he entendido los pasos, con el chrome por ejemplo:
Primero como en la imagen 1 , asi marcado le doy a eliminar.
Image
Segundo como en la imagen2 , tambien eliminar.
Image
Tercero, en el gestor de software, le doy a desinstalar y luego otra vez a instalar
Es asi, o me falta algo?
Gracias.
Post Reply

Return to “Español (Spanish)”