Error al usar administrador de actualizaciones

Spanish Forum

Moderators: tomeu, JCSenar

User avatar
tomeu
Level 6
Level 6
Posts: 1370
Joined: Wed Mar 29, 2017 12:03 pm
Location: España

Re: Error al usar administrador de actualizaciones

Post by tomeu »

Creo que lo has entendido.

Más simple:

1.- Te vas a Gestor de Actualizaciones → Fuentes de Software → Repositorios adicionales y desmarcas "Brave"
repo_adic.png
Actualizas la cache cuando te pide.

2.- Te vas a Mantenimiento → Paquetes Externos. Tras haber desactivado el repositorio "Brave" y actualizado la caché, este programa y su clave saldrán como "Paquete Externo" a desinstalar. Lo marcas y desinstalas.
paq_externos.png
Tras desinstalar el paquete Brave:

3.- Vuelves a "Repositorios Adicionales". Marcas "Brave" y le das eliminar. Cierras el gestor de software. Puedes comprobar en /opt si está Brave-browser o no. Si quieres eliminar configuraciones de usuario (y hacer un perfil limpio) puedes revisar en /home/usuario/.config/BraveBrowser/Brave-Browser y borrar la carpeta "BraveBrowser, al arrancar de nuevo será como la primera vez; si quieres guardar marcadores, extensiones, etc.. no borres la carpeta de usuario.

4.- Para reinstalar. Abres terminal y vas introduciendo lo siguiente:
sudo apt update
sudo apt install apt-transport-https curl
curl -s https://brave-browser-apt-release.s3.brave.com/brave-core.asc | sudo apt-key --keyring /etc/apt/trusted.gpg.d/brave-browser-release.gpg add -
echo "deb [arch=amd64] https://brave-browser-apt-release.s3.brave.com/ stable main" | sudo tee /etc/apt/sources.list.d/brave-browser-release.list
sudo apt update
sudo apt install brave-browser
Image
Linux Mint Ulyana 20 Cinnamon
Por favor, recuerda añadir al título el 'palabro' "[SOLUCIONADO]" si el problema o cuestión ha quedado resuelto. Gracias
User avatar
desmolinux
Level 3
Level 3
Posts: 143
Joined: Mon Oct 02, 2017 7:05 am

Re: Error al usar administrador de actualizaciones

Post by desmolinux »

Hola , he seguido todos los pasos, y iba yendo bien hasta el ultimo paso

Code: Select all

flako@flako-System-Product-Name ~ $ sudo apt update
[sudo] password for flako: 
Ign:1 http://dl.google.com/linux/chrome/deb stable InRelease
Obj:2 http://ppa.launchpad.net/flacon/ppa/ubuntu xenial InRelease              
Obj:3 http://ftp.caliu.cat/pub/distribucions/ubuntu/archive xenial InRelease   
Ign:4 http://mirrors.evowise.com/linuxmint/packages sonya InRelease            
Obj:5 http://archive.canonical.com/ubuntu xenial InRelease                     
Obj:6 http://dl.google.com/linux/chrome/deb stable Release                     
Obj:7 http://ftp.caliu.cat/pub/distribucions/ubuntu/archive xenial-updates InRelease
Obj:8 http://mirrors.evowise.com/linuxmint/packages sonya Release              
Des:9 http://security.ubuntu.com/ubuntu xenial-security InRelease [109 kB]     
Obj:10 http://ftp.caliu.cat/pub/distribucions/ubuntu/archive xenial-backports InRelease
Obj:11 http://ppa.launchpad.net/team-xbmc/ppa/ubuntu xenial InRelease          
Obj:12 http://ppa.launchpad.net/webupd8team/indicator-kdeconnect/ubuntu xenial InRelease
Descargados 109 kB en 1s (95,2 kB/s)                                           
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
Se pueden actualizar 52 paquetes. Ejecute «apt list --upgradable» para verlos.
flako@flako-System-Product-Name ~ $ sudo apt install apt-transport-https curl
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
apt-transport-https ya está en su versión más reciente (1.2.32).
curl ya está en su versión más reciente (7.47.0-1ubuntu2.14).
Los paquetes indicados a continuación se instalaron de forma automática y ya no son necesarios.
  glib-networking:i386 libaio1:i386 libasound2:i386 libasound2-plugins:i386
  libasyncns0:i386 libatk-bridge2.0-0:i386 libatspi2.0-0:i386
  libboost-filesystem1.58.0:i386 libboost-system1.58.0:i386 libbsd0:i386
  libcairo-gobject2:i386 libcapnp-0.5.3:i386 libcolord2:i386
  libdrm-amdgpu1:i386 libdrm-intel1:i386 libdrm-nouveau2:i386
  libdrm-radeon1:i386 libdrm2:i386 libedit2:i386 libegl1-mesa:i386
  libelf1:i386 libepoxy0:i386 libflac8:i386 libgbm1:i386 libgl1-mesa-dri:i386
  libgl1-mesa-glx:i386 libglapi-mesa:i386 libgtk-3-0:i386 libice6:i386
  libjack-jackd2-0:i386 libjson-c2:i386 libjson-glib-1.0-0:i386
  liblcms2-2:i386 libllvm6.0:i386 libmirclient9:i386 libmircommon7:i386
  libmircore1:i386 libmirprotobuf3:i386 libnotify4:i386 libogg0:i386
  libpciaccess0:i386 libportaudio2:i386 libprotobuf-lite9v5:i386
  libproxy1v5:i386 libpulse0:i386 librest-0.7-0:i386 libsamplerate0:i386
  libsdl2-2.0-0:i386 libsensors4:i386 libsm6:i386 libsndfile1:i386
  libsndio6.1:i386 libsoundtouch1:i386 libsoup-gnome2.4-1:i386
  libsoup2.4-1:i386 libspeexdsp1:i386 libsqlite3-0:i386 libtxc-dxtn-s2tc0:i386
  libvorbis0a:i386 libvorbisenc2:i386 libwayland-client0:i386
  libwayland-cursor0:i386 libwayland-egl1-mesa:i386 libwayland-server0:i386
  libwrap0:i386 libwxbase3.0-0v5:i386 libwxgtk3.0-0v5:i386 libx11-xcb1:i386
  libxcb-dri2-0:i386 libxcb-dri3-0:i386 libxcb-glx0:i386 libxcb-present0:i386
  libxcb-sync1:i386 libxcb-xfixes0:i386 libxkbcommon0:i386 libxshmfence1:i386
  libxss1:i386 libxxf86vm1:i386 notification-daemon:i386
Utilice «sudo apt autoremove» para eliminarlos.
0 actualizados, 0 nuevos se instalarán, 0 para eliminar y 52 no actualizados.
flako@flako-System-Product-Name ~ $ curl -s https://brave-browser-apt-release.s3.brave.com/brave-core.asc | sudo apt-key --keyring /etc/apt/trusted.gpg.d/brave-browser-release.gpg add -
OK
flako@flako-System-Product-Name ~ $ echo "deb [arch=amd64] https://brave-browser-apt-release.s3.brave.com/ stable main" | sudo tee /etc/apt/sources.list.d/brave-browser-release.list
deb [arch=amd64] https://brave-browser-apt-release.s3.brave.com/ stable main
flako@flako-System-Product-Name ~ $ sudo apt update
Ign:1 http://mirrors.evowise.com/linuxmint/packages sonya InRelease
Obj:2 http://mirrors.evowise.com/linuxmint/packages sonya Release              
Obj:3 http://ftp.caliu.cat/pub/distribucions/ubuntu/archive xenial InRelease   
Des:4 http://security.ubuntu.com/ubuntu xenial-security InRelease [109 kB]     
Ign:5 http://dl.google.com/linux/chrome/deb stable InRelease                   
Obj:6 http://archive.canonical.com/ubuntu xenial InRelease                     
Obj:7 http://ftp.caliu.cat/pub/distribucions/ubuntu/archive xenial-updates InRelease
Obj:9 http://ppa.launchpad.net/flacon/ppa/ubuntu xenial InRelease              
Obj:10 http://dl.google.com/linux/chrome/deb stable Release                    
Obj:11 http://ftp.caliu.cat/pub/distribucions/ubuntu/archive xenial-backports InRelease
Des:12 https://brave-browser-apt-release.s3.brave.com stable InRelease [3.180 B]
Obj:13 http://ppa.launchpad.net/team-xbmc/ppa/ubuntu xenial InRelease          
Obj:14 http://ppa.launchpad.net/webupd8team/indicator-kdeconnect/ubuntu xenial InRelease
Des:16 https://brave-browser-apt-release.s3.brave.com stable/main amd64 Packages [3.741 B]
Descargados 116 kB en 1s (101 kB/s)                             
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
Se pueden actualizar 52 paquetes. Ejecute «apt list --upgradable» para verlos.
flako@flako-System-Product-Name ~ $ sudo apt install brave-brower
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias       
Leyendo la información de estado... Hecho
E: No se ha podido localizar el paquete brave-brower
flako@flako-System-Product-Name ~ $ 
Que puede haber salido mal?
User avatar
JCSenar
Level 11
Level 11
Posts: 3601
Joined: Sat Sep 06, 2014 6:26 pm
Location: Irun, España
Contact:

Re: Error al usar administrador de actualizaciones

Post by JCSenar »

desmolinux wrote:
Tue Mar 10, 2020 3:44 pm

Code: Select all

sudo apt install brave-brower
E: No se ha podido localizar el paquete brave-brower
Que puede haber salido mal?
brave-browser
Image
Si tu consulta ha sido resuelta, por favor, edita tu primer mensaje y añade [SOLUCIONADO] al título. Gracias.
User avatar
tomeu
Level 6
Level 6
Posts: 1370
Joined: Wed Mar 29, 2017 12:03 pm
Location: España

Re: Error al usar administrador de actualizaciones

Post by tomeu »

Esas eses son muy sibilinas y sinuosas, hay que ir con cuidado con ellas :D

Una manera de evitar errores de tecleo es escribir el principio de la palabra y teclear tab; si escribo brav y hago "tab", el programa apt me escribe el resto que está en su cache; si hay solo una opción la completa automáticamente, si hay más, no hace nada, le das otro tab, y "apt" te lista las opciones :wink:
Image
Linux Mint Ulyana 20 Cinnamon
Por favor, recuerda añadir al título el 'palabro' "[SOLUCIONADO]" si el problema o cuestión ha quedado resuelto. Gracias
User avatar
desmolinux
Level 3
Level 3
Posts: 143
Joined: Mon Oct 02, 2017 7:05 am

Re: Error al usar administrador de actualizaciones

Post by desmolinux »

Hostias, que me faltó una S , perdón estoy zumbado.

Esta tarde pruebo de nuevo.

Ya está, instalado y funcionando. Ahora voy a por el chrome,
User avatar
desmolinux
Level 3
Level 3
Posts: 143
Joined: Mon Oct 02, 2017 7:05 am

Re: Error al usar administrador de actualizaciones

Post by desmolinux »

Chrome instalado, solo una duda, cuando estaba en Repositorios adicionales y fui a desinstalar el chrome, veo que no está el brave, no se si lo ha borrado al ir a quitar el chrome, :shock:
El brave funciona bien, lo dejo asi o mejor volver a instalarlo?
User avatar
tomeu
Level 6
Level 6
Posts: 1370
Joined: Wed Mar 29, 2017 12:03 pm
Location: España

Re: Error al usar administrador de actualizaciones

Post by tomeu »

desmolinux wrote:
Wed Mar 11, 2020 2:09 pm
Chrome instalado, solo una duda, cuando estaba en Repositorios adicionales y fui a desinstalar el chrome, veo que no está el brave, no se si lo ha borrado al ir a quitar el chrome, :shock:
El brave funciona bien, lo dejo asi o mejor volver a instalarlo?
Por lo que dices Brave ya está instalado, lo que habrás borrado es el repositorio. Conviene volver a poner el repositorio si quieres que se actualice.
Image
Linux Mint Ulyana 20 Cinnamon
Por favor, recuerda añadir al título el 'palabro' "[SOLUCIONADO]" si el problema o cuestión ha quedado resuelto. Gracias
User avatar
desmolinux
Level 3
Level 3
Posts: 143
Joined: Mon Oct 02, 2017 7:05 am

Re: Error al usar administrador de actualizaciones

Post by desmolinux »

tomeu wrote:
Thu Mar 12, 2020 1:55 am
desmolinux wrote:
Wed Mar 11, 2020 2:09 pm
Chrome instalado, solo una duda, cuando estaba en Repositorios adicionales y fui a desinstalar el chrome, veo que no está el brave, no se si lo ha borrado al ir a quitar el chrome, :shock:
El brave funciona bien, lo dejo asi o mejor volver a instalarlo?
Por lo que dices Brave ya está instalado, lo que habrás borrado es el repositorio. Conviene volver a poner el repositorio si quieres que se actualice.
Y para eso, hago todo el proceso de instalacion desde cero, verdad? Sin tener que volver a desinstalarlo?

De esta salgo hecho un crack en instalaciones y desinstalaciones :D
User avatar
tomeu
Level 6
Level 6
Posts: 1370
Joined: Wed Mar 29, 2017 12:03 pm
Location: España

Re: Error al usar administrador de actualizaciones

Post by tomeu »

No desde cero, bastará esto:
tomeu wrote:
Tue Mar 10, 2020 2:29 am
curl -s https://brave-browser-apt-release.s3.brave.com/brave-core.asc | sudo apt-key --keyring /etc/apt/trusted.gpg.d/brave-browser-release.gpg add -
echo "deb [arch=amd64] https://brave-browser-apt-release.s3.brave.com/ stable main" | sudo tee /etc/apt/sources.list.d/brave-browser-release.list
Los paquetes curl y apt-trasport-https ya los tienes instalados y no hay necesidad de volverlo a hacer. Si lo haces es inicuo, porque apt te dirá simplemente que ya están instalados.
Un sudo apt update no está de más tras añadir el repositorio.
Image
Linux Mint Ulyana 20 Cinnamon
Por favor, recuerda añadir al título el 'palabro' "[SOLUCIONADO]" si el problema o cuestión ha quedado resuelto. Gracias
User avatar
desmolinux
Level 3
Level 3
Posts: 143
Joined: Mon Oct 02, 2017 7:05 am

Re: Error al usar administrador de actualizaciones

Post by desmolinux »

Perfecto, ahora si está es repositorio.

Muchas gracias a todos. Cada día aprendo mas.
User avatar
desmolinux
Level 3
Level 3
Posts: 143
Joined: Mon Oct 02, 2017 7:05 am

Re: Error al usar administrador de actualizaciones (solucionado)

Post by desmolinux »

Hola de nuevo, hoy he ido a actualizar y me ha vuelto a dar problemas el Brave, exactamente me sale lo que adjunto, debo ignorarlo e instalar o mejor vuelvo al método comentado ya aquí y desinstalo y vuelvo a instalar?

Gracias.

Image
Last edited by JCSenar on Wed Jun 10, 2020 3:16 pm, edited 1 time in total.
Reason: Añadido formato [rimg]
User avatar
desmolinux
Level 3
Level 3
Posts: 143
Joined: Mon Oct 02, 2017 7:05 am

Re: Error al usar administrador de actualizaciones

Post by desmolinux »

Subo el tema, a ver si consigo solucionarlo.

Gracias.
User avatar
JOPETA
Level 17
Level 17
Posts: 7221
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Error al usar administrador de actualizaciones

Post by JOPETA »

Tomado de un hilo de hace cinco años donde se trata el problema (y un ciento mas de cuestiones que nada tienen que ver) extraigo esto
JOPETA wrote:
Tue Nov 17, 2015 3:09 pm
Investigando la razón de la advertencia en un post del foro principal he recibido esta respuesta. Parece ser debida a que la base de datos de los paquetes locales es más antigua que la que existe en el repositorio con lo que pierde la conexión y no puede realizar la comprobación de la firma digital ni el checksum desde el repositorio. El problema se soluciona (o eso dicen) si antes de instalar la actualización haces clic en el botón de refrescar o de forma manual con

Code: Select all

sudo apt-get update
Lo mejor es no actualizar y esperar si es necesario unas cuantas horas a que la conexión con el servidor se restablezca.
Osea, esperar o cambiar de servidor local (mirror) en las fuentes/orígenes del software y actualizas la caché. :wink:
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.(Javier Krahe)
Post Reply

Return to “Español (Spanish)”