Problemas inicio LMDE y grub

Spanish Forum

Moderators: tomeu, JCSenar

Post Reply
User avatar
Rayeta76
Level 3
Level 3
Posts: 163
Joined: Thu Oct 25, 2012 8:02 pm

Problemas inicio LMDE y grub

Post by Rayeta76 »

Hola a todos tras instalar LMDE 4 en grub me aparecen varias opciones de inicio de Windows 10 y Windows 7.
El LMDE esta en el disco sda, y el resto de discos son de datos.
De grub se borra las lineas pero lo que me gustaría es eliminar los sectores que hacen referencia a esos arranques en los discos sdb y sde.
Dichos discos nunca fueron para disco de sistema uno es siempre el disco de datos y el otro lo solía utilizar para varias cámaras que tengo en el piso que ahora controlo por el qnap.
adjunto el pastebin de boot- repair para si me podéis ayudar.
http://paste.ubuntu.com/p/HFHY4xWvJs/
User avatar
JOPETA
Level 17
Level 17
Posts: 7367
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Problemas inicio LMDE y grub

Post by JOPETA »

Entiendo que te refieres a que grub localiza con os-prober los siguientes sistemas

Code: Select all

menuentry 'Windows 7 (on /dev/sdb1)' --class windows --class os $menuentry_id_option 'osprober-chain-01CC5314D497C7F0' {
	insmod part_msdos
	insmod ntfs
	set root='hd1,msdos1'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd1,msdos1 --hint-efi=hd1,msdos1 --hint-baremetal=ahci1,msdos1  01CC5314D497C7F0
	else
	  search --no-floppy --fs-uuid --set=root 01CC5314D497C7F0
	fi
	parttool ${root} hidden-
	chainloader +1
}
menuentry 'Windows 10 (on /dev/sde1)' --class windows --class os $menuentry_id_option 'osprober-chain-40A255FAA255F4BE' {
	insmod part_msdos
	insmod ntfs
	set root='hd4,msdos1'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-bios=hd4,msdos1 --hint-efi=hd4,msdos1 --hint-baremetal=ahci4,msdos1  40A255FAA255F4BE
	else
	  search --no-floppy --fs-uuid --set=root 40A255FAA255F4BE
	fi
	parttool ${root} hidden-
	drivemap -s (hd0) ${root}
	chainloader +1
}
El caso es que Boot info dice que tienes instalado GRUB en los sectores de inicio de esos discos...

Code: Select all

 => Windows 7/8/2012 is installed in the MBR of /dev/sdb.
 => Grub2 (v2.00) is installed in the MBR of /dev/sdc and looks at sector 1 of 
    the same hard drive for core.img. core.img is at this location and looks 
    for 
    (lvmid/a2fPZM-Dv5h-qhKd-DnJa-jRiV-kqeG-rLkKwn/uO828e-YFPc-PGvz-Bajo-rMcD-Gs
    ic-KgMuTy)/boot/grub. It also embeds following components:
    
    modules
    ---------------------------------------------------------------------------
    fshelp ext2 part_msdos diskfilter lvm biosdisk
    ---------------------------------------------------------------------------
 => Grub2 (v2.00) is installed in the MBR of /dev/sdd and looks at sector 1 of 
    the same hard drive for core.img. core.img is at this location and looks 
    for 
    (lvmid/a2fPZM-Dv5h-qhKd-DnJa-jRiV-kqeG-rLkKwn/uO828e-YFPc-PGvz-Bajo-rMcD-Gs
    ic-KgMuTy)/boot/grub. It also embeds following components:
    
    modules
    ---------------------------------------------------------------------------
    fshelp ext2 part_msdos diskfilter lvm biosdisk
    ---------------------------------------------------------------------------
 => Windows 7/8/2012 is installed in the MBR of /dev/sde.
 => Grub2 (v2.00) is installed in the MBR of /dev/sdf and looks at sector 1 of 
    the same hard drive for core.img. core.img is at this location and looks 
    for 
    (lvmid/a2fPZM-Dv5h-qhKd-DnJa-jRiV-kqeG-rLkKwn/uO828e-YFPc-PGvz-Bajo-rMcD-Gs
    ic-KgMuTy)/boot/grub. It also embeds following components:
    
    modules
    ---------------------------------------------------------------------------
    fshelp ext2 part_msdos diskfilter lvm biosdisk
    ---------------------------------------------------------------------------
y sdb1 y sde1 está marcadas como particiones de inicio (flag boot o *) en el fdisk...

Code: Select all

Disk /dev/sdb: 931.5 GiB, 1000204886016 bytes, 1953525168 sectors
Disk model: WDC WD10EADS-00P
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x0003d554

Device     Boot Start        End    Sectors   Size Id Type
/dev/sdb1  *       63 1953523711 1953523649 931.5G  7 HPFS/NTFS/exFAT

...
Disk /dev/sde: 111.8 GiB, 120034123776 bytes, 234441648 sectors
Disk model: KINGSTON SV300S3
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x4ef10eb0

Device     Boot   Start       End   Sectors   Size Id Type
/dev/sde1  *       2048   1187839   1185792   579M  7 HPFS/NTFS/exFAT
/dev/sde2       1187840 234438655 233250816 111.2G  7 HPFS/NTFS/exFAT


Pueden ser el resultado de un intento de reparación anterior con Boot Repair??

Si son disco MBR (dos), como dice el fdisk, puede ser que hayas reparticionado cn alguna ocasión con herrmientas de Windows (por ejmplo si instalaste en ellos Windows en modo BIOS) y antes eran GPT Windows deja la copia de la tabla de la GPT pero Linux puede resctarla en esta ocasiones o con gparted. MIra este hilo explicativo del problema y de la solución.

En cualquier caso podrías tratar de sobrescribir el MBR por ejemplo con fixparts.

SIgue las instrucciones del enlace (mas resumido tienes un pequeño manual en la teminal con man fixparts :D ) y si tienes problemas devuelve el resultado de lo que muestra la lanzar la aplicación por ejemplo para sdb sudo fixparts /dev/sdb) y tras escribr p. Luego sal sin hacer nada con q. Lo mismo para sde (sudo fixpart /dev/sde .

Como ves tienes la opción de eliminar el flag de inicio con a y si el partionado es correcto puedes escribir el nuevo MBR con w

Una vez hecha la reparación sugerida y/o la elimianción del flag boot y sobreescrito el MBR esto sudo os-prober no debería indentificar ningún sistema instalado en ellas, espero.
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.(Javier Krahe)
Post Reply

Return to “Español (Spanish)”