(SOLUCIONADO) Microfono interno no funciona

Spanish Forum

Moderators: tomeu, JCSenar

Post Reply
Sangheili
Level 1
Level 1
Posts: 31
Joined: Thu Jun 11, 2020 11:23 am

(SOLUCIONADO) Microfono interno no funciona

Post by Sangheili »

Buenos días, soy nuevo en Linux Mint, decidi cambiarme de W10 a Mint ya que aunque he sabido que existe, desde el 2008, no pude realizar el cambio ya que es computadora compartida, me pasé el sabado a LInux Mint 19.3 Xfce debido a que la Pc no es de muy buenos requisitos.
Todo en orden, no habia tenido problemas, hasta que tuve que utilizar ZOOM o Skype para mis clases o dar tutorías.
No me reconoce el microfono integrado de la computadora que es una HP Todo en Uno 20-c001la. Procesador Intel Celeron a 1.60 Ghz y 4 de Ram.
También he probado con un auricular bluetooth que tiene microfono incorporado y tampoco me lo reconoce, en Windows 10 no tenia este problema; llevo 2 días intentando arreglarlo pero no logro conseguirlo y me frustra ya que no he podido realizar mis clases de manera normal.

Alguien conoce una solución?
gfgh.png
Captura de pantalla del Pavucontrol
ESTA CAPTURA FUE SIN TENER CONECTADO EL DISPOSITIVO BLUETOOTH
Last edited by Sangheili on Fri Jun 12, 2020 6:20 pm, edited 3 times in total.

Sangheili
Level 1
Level 1
Posts: 31
Joined: Thu Jun 11, 2020 11:23 am

Re: Microfono interno no funciona

Post by Sangheili »

Adjuntaré algunas cosas extra que pueden ser de ayuda. Como ser el libro de registros (no sé si sea relevante) Y el comando pacmd list-card

Mensaje de registro

Code: Select all

11:06:34 pulseaudio: [pulseaudio] backend-ofono.c: Failed to register as a handsfree audio agent with ofono: org.freedesktop.DBus.Error.ServiceUnknown: The name org.ofono was not provided by any .service files
11:06:30 ntpd: unable to create socket on wlp3s0 (5) for fe80::af45:3d37:36cf:643%3#123
11:06:30 kernel: the NTP socket is in use, exiting
11:06:29 wpa_supplicant: bgscan simple: Failed to enable signal strength monitoring
11:06:28 ntpd: error resolving pool 2.ubuntu.pool.ntp.org: Name or service not known (-2)
11:06:28 ntpd: error resolving pool 2.ubuntu.pool.ntp.org: Name or service not known (-2)
11:06:27 ntpd: error resolving pool 1.ubuntu.pool.ntp.org: Name or service not known (-2)
11:06:27 wpa_supplicant: dbus: Failed to construct signal
11:06:27 wpa_supplicant: dbus: Failed to construct signal
11:06:27 wpa_supplicant: dbus: wpa_dbus_get_object_properties: failed to get object properties: (none) none
11:06:26 ntpd: error resolving pool 0.ubuntu.pool.ntp.org: Name or service not known (-2)
Comando pacmd list-card

Code: Select all

oscar@oscar-20-c001la:~$ pacmd list-cards
2 card(s) available.
    index: 0
	name: <alsa_card.pci-0000_00_1b.0>
	driver: <module-alsa-card.c>
	owner module: 7
	properties:
		alsa.card = "0"
		alsa.card_name = "HDA Intel PCH"
		alsa.long_card_name = "HDA Intel PCH at 0x81410000 irq 124"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1b.0"
		sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card0"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "2284"
		device.product.name = "Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series High Definition Audio Controller"
		device.form_factor = "internal"
		device.string = "0"
		device.description = "Audio Interno"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	profiles:
		input:analog-stereo: Estéreo analógico Entrada (priority 60, available: unknown)
		output:analog-stereo: Estéreo analógico Salida (priority 6000, available: unknown)
		output:analog-stereo+input:analog-stereo: Estéreo Analógico Dúplex (priority 6060, available: unknown)
		output:hdmi-stereo: Digital Stereo (HDMI) Salida (priority 5400, available: no)
		output:hdmi-stereo+input:analog-stereo: Digital Stereo (HDMI) Salida + Estéreo analógico Entrada (priority 5460, available: unknown)
		output:hdmi-surround: Digital Surround 5.1 (HDMI) Salida (priority 300, available: no)
		output:hdmi-surround+input:analog-stereo: Digital Surround 5.1 (HDMI) Salida + Estéreo analógico Entrada (priority 360, available: unknown)
		output:hdmi-surround71: Digital Surround 7.1 (HDMI) Salida (priority 300, available: no)
		output:hdmi-surround71+input:analog-stereo: Digital Surround 7.1 (HDMI) Salida + Estéreo analógico Entrada (priority 360, available: unknown)
		off: Apagado (priority 0, available: unknown)
	active profile: <output:analog-stereo+input:analog-stereo>
	sinks:
		alsa_output.pci-0000_00_1b.0.analog-stereo/#0: Audio Interno Estéreo analógico
	sources:
		alsa_output.pci-0000_00_1b.0.analog-stereo.monitor/#0: Monitor of Audio Interno Estéreo analógico
		alsa_input.pci-0000_00_1b.0.analog-stereo/#1: Audio Interno Estéreo analógico
	ports:
		analog-input-internal-mic: Micrófono interno (priority 8900, latency offset 0 usec, available: unknown)
			properties:
				device.icon_name = "audio-input-microphone"
		analog-input-mic: Micrófono (priority 8700, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-input-microphone"
		analog-output-speaker: Altavoces (priority 10000, latency offset 0 usec, available: unknown)
			properties:
				device.icon_name = "audio-speakers"
		analog-output-headphones: Auriculares analógicos (priority 9000, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-headphones"
		hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"
    index: 1
	name: <bluez_card.9D_6E_8E_76_3A_DD>
	driver: <module-bluez5-device.c>
	owner module: 27
	properties:
		device.description = "Platinet PM1060"
		device.string = "9D:6E:8E:76:3A:DD"
		device.api = "bluez"
		device.class = "sound"
		device.bus = "bluetooth"
		device.form_factor = "headset"
		bluez.path = "/org/bluez/hci0/dev_9D_6E_8E_76_3A_DD"
		bluez.class = "0x240404"
		bluez.alias = "Platinet PM1060"
		device.icon_name = "audio-headset-bluetooth"
		device.intended_roles = "phone"
	profiles:
		a2dp_sink: Reproducción de alta fidelidad (A2DP Sink) (priority 40, available: unknown)
		headset_head_unit: Unidad de auriculares (HSP/HFP) (priority 30, available: no)
		off: Apagado (priority 0, available: yes)
	active profile: <a2dp_sink>
	sinks:
		bluez_sink.9D_6E_8E_76_3A_DD.a2dp_sink/#1: Platinet PM1060
	sources:
		bluez_sink.9D_6E_8E_76_3A_DD.a2dp_sink.monitor/#2: Monitor of Platinet PM1060
	ports:
		headset-output: Auriculares (priority 0, latency offset 0 usec, available: unknown)
			properties:
				
		headset-input: Auriculares (priority 0, latency offset 0 usec, available: no)
			properties:

User avatar
MrEen
Level 20
Level 20
Posts: 11602
Joined: Mon Jun 12, 2017 8:39 pm

Re: Microfono interno no funciona

Post by MrEen »

Hola Sangheili, y bienvenidos al foro.

Para Bluetooth, deberá cambiar al perfil HSP / HFP para que el micrófono funcione. Esto degradará el sonido que escucha, pero es la única forma en que su voz puede transmitir.

Para el micrófono interno, vea si este comando lo hace funcionar:

Code: Select all

amixer set Capture 100,0
Si eso no ayuda, veamos el resultado de aplay -l

Sangheili
Level 1
Level 1
Posts: 31
Joined: Thu Jun 11, 2020 11:23 am

Re: Microfono interno no funciona

Post by Sangheili »

Buenas noches, gracias por responder.

Adjuntaré la captura de como me fue con los comandos amixer set capture 100,0 y aplay -l , después verificaré con el bluetooth. Ya que , por andar moviendo algunas configuraciones, ahora no me quiere conectar, pero eso lo resolveré después (tiendo a ser muy curioso )
Attachments
fsd.png

Sangheili
Level 1
Level 1
Posts: 31
Joined: Thu Jun 11, 2020 11:23 am

Re: Microfono interno no funciona

Post by Sangheili »

Buenos dias,

Despues de haber estado jugando un poco con la configuracion, logre que el microfono funcionara y tambien le retire el ruido de fondo que me hacia. Solamente estuve cambiando los canales probando en todos y cada uno, utilize Skype de preferencia ya que ahi son mis conferencias para verificar el microfono hasta que alfin me capto el microfono, con interferencia, pero lo hizo, y despues me ocupe del ruido de fondo o echo.

Ahora el siguiente problema, esque el teclado no me quiere reconocer las tildes (perdonando los errores ortograficas y de acentuacion). Me ocupare de eso luego.

Gracias por su ayuda.

turqueza
Level 1
Level 1
Posts: 1
Joined: Fri Jun 12, 2020 11:24 am

Re: (SOLUCIONADO) Microfono interno no funciona

Post by turqueza »

Hola, y como lo solucionaste el problema del microfono? Yo estoy en ese problema ahora!!!

saludos

Sangheili
Level 1
Level 1
Posts: 31
Joined: Thu Jun 11, 2020 11:23 am

Re: (SOLUCIONADO) Microfono interno no funciona

Post by Sangheili »

Hola turqueza,

Pues,el problema con el microfono integrado lo resolvi cambiando un poco los ajustes del pavucontrol , en la opcion de configuracion- audio interno- estereo analogico duplex. Despues de eso, te sugiero para probar el microfono integrado intentes con Skype para hacer la llamada de prueba de configuracion de audio y video, y lo intentes.

SI lo detecta correctamente, escucharas un sonido de fondo molesto, como si estuvieras al lado de un auto o motor. Te aconsejo seguir estos pasos: https://marcosmarti.org/como-eliminar-e ... -en-linux/
Y despues de eso no tendras problemas con el incorporado de tu Pc.

Por el momento, ahora mi problema es, con el bluetooth , como dijo MrEren coloque el dispositivo Bluetooth (lo reconoce) como HSP/HFP , pero siempre vuelve a la configuracion de A2DP Link una vez cierro el pavu control. Alguna ayuda

User avatar
JCSenar
Level 11
Level 11
Posts: 3539
Joined: Sat Sep 06, 2014 6:26 pm
Location: Irun, España
Contact:

Re: (SOLUCIONADO) Microfono interno no funciona

Post by JCSenar »

Sangheili wrote:
Fri Jun 12, 2020 12:02 pm
Por el momento, ahora mi problema es, con el bluetooth , como dijo MrEren coloque el dispositivo Bluetooth (lo reconoce) como HSP/HFP , pero siempre vuelve a la configuracion de A2DP Link una vez cierro el pavu control. Alguna ayuda
Abre un tema nuevo para el problema del bluetooth. Gracias.
Image
Si tu consulta ha sido resuelta, por favor, edita tu primer mensaje y añade [SOLUCIONADO] al título. Gracias.

Post Reply

Return to “Español (Spanish)”