Problemas tras actualizar a LM 20 (VLC no funciona)

Spanish Forum

Moderators: tomeu, JCSenar

Post Reply
yellowhale
Level 1
Level 1
Posts: 5
Joined: Sun Jun 28, 2020 10:59 am

Problemas tras actualizar a LM 20 (VLC no funciona)

Post by yellowhale »

Buenos días (al menos en latinoamérica)
El día de ayer tras ver en Facebook que ya estaban las imágenes estables de LM 20 me decidí a instalarlo en mi computadora portatil. Yo no suelo hacer una actualización, sino que yo hago una instalación limpia del SO.

Instalé LM y el primer "error" que encontré fue con el GRUB, o boot menu, como se le denomine aquí. Donde el que tenía para LM 19.3 se fue, ese con diseño aceptable, no el aburrido negro. Y justamente el negro volvió, el cual ya no me agrada. ¿Habrá forma de volver al otro diseño? ¿Se solventará instalando el paquete "grub2-theme-mint"?

Por otro lado, el problema más importante, el que ni reinstalando el SO se puede solucionar de ninguna manera.
VLC Media Player está dando problemas que jamás había tenido.
1. Inicio la sesión, abro un video en VLC, lo reproduce bien pero tras cerrar el programa y querer abrir el mismo video (u otro) VLC NO se ejecuta, sin importar cuántas veces lo abra. El gestor de tareas sigue mostrando un proceso de VLC corriendo, el cual no se cierra por más veces que intente cerrarlo con la app.
2. Cuando abro un video y me meto a las opciones tales como rotar el video o girar, no hace absolutamente nada. Incluso me ha llegado a fallar la parte donde puedo manipular la temperatura del color, brillo, contraste y demás.
¿Es un problema de LM 20 o es mi computadora exclusivamente? Porque por más de 10 años he usado VLC y nunca había tenido ese problema.

Gracias de antemano.

User avatar
tomeu
Level 6
Level 6
Posts: 1343
Joined: Wed Mar 29, 2017 12:03 pm
Location: España

Re: Problemas tras actualizar a LM 20 (VLC no funciona)

Post by tomeu »

yellowhale wrote:
Sun Jun 28, 2020 11:17 am
¿Se solventará instalando el paquete "grub2-theme-mint"?
En teoría así debería ser, ese es el paquete con el tema del grub.
Si usas un portátil y según la resolución de tu monitor tal vez te interese el paquete "grub2-theme-mint-2k"
Si usas Mate (no vi si decías qué entorno usas) el paquete también tienes la opcióna "grub2-themes-ubuntu-mate"

Del segundo problema, no puedo decir nada.
Image
Linux Mint Ulyana 20 Cinnamon
Por favor, recuerda añadir al título el 'palabro' "[SOLUCIONADO]" si el problema o cuestión ha quedado resuelto. Gracias

User avatar
JCSenar
Level 11
Level 11
Posts: 3538
Joined: Sat Sep 06, 2014 6:26 pm
Location: Irun, España
Contact:

Re: Problemas tras actualizar a LM 20 (VLC no funciona)

Post by JCSenar »

yellowhale wrote:
Sun Jun 28, 2020 11:17 am
Por otro lado, el problema más importante, el que ni reinstalando el SO se puede solucionar de ninguna manera.
VLC Media Player está dando problemas que jamás había tenido.
1. Inicio la sesión, abro un video en VLC, lo reproduce bien pero tras cerrar el programa y querer abrir el mismo video (u otro) VLC NO se ejecuta, sin importar cuántas veces lo abra. El gestor de tareas sigue mostrando un proceso de VLC corriendo, el cual no se cierra por más veces que intente cerrarlo con la app.
2. Cuando abro un video y me meto a las opciones tales como rotar el video o girar, no hace absolutamente nada. Incluso me ha llegado a fallar la parte donde puedo manipular la temperatura del color, brillo, contraste y demás.
¿Es un problema de LM 20 o es mi computadora exclusivamente? Porque por más de 10 años he usado VLC y nunca había tenido ese problema.
Pues no se por qué te pasa :?:

Estoy probando un vídeo en una instalación limpia de LM 20 Mate y VLC funciona bien. Abro y cierro el archivo tantas veces como quiero y también puedo rotarlo sin problema: :shock: :shock:

Pantallazo-2020-06-29 13-44-37.jpg
Image
Si tu consulta ha sido resuelta, por favor, edita tu primer mensaje y añade [SOLUCIONADO] al título. Gracias.

User avatar
tomeu
Level 6
Level 6
Posts: 1343
Joined: Wed Mar 29, 2017 12:03 pm
Location: España

Re: Problemas tras actualizar a LM 20 (VLC no funciona)

Post by tomeu »

sobre VLC en LM 20...
Además… después de la gran controversia por la imposición de snap por parte de Ubuntu; los desarrolladores de Linux Mint tomaron una decisión drástica para algunos, feliz para otros. Los paquetes que instalan herramientas y que disimuladamente insertan snapd, son bloqueados. Por tanto Linux Mint viene sin VLC y sin Gimp de manera predeterminada.
[soloLinux]
Image
Linux Mint Ulyana 20 Cinnamon
Por favor, recuerda añadir al título el 'palabro' "[SOLUCIONADO]" si el problema o cuestión ha quedado resuelto. Gracias

User avatar
JCSenar
Level 11
Level 11
Posts: 3538
Joined: Sat Sep 06, 2014 6:26 pm
Location: Irun, España
Contact:

Re: Problemas tras actualizar a LM 20 (VLC no funciona)

Post by JCSenar »

tomeu wrote:
Mon Jun 29, 2020 2:50 pm
sobre VLC en LM 20...
Además… después de la gran controversia por la imposición de snap por parte de Ubuntu; los desarrolladores de Linux Mint tomaron una decisión drástica para algunos, feliz para otros. Los paquetes que instalan herramientas y que disimuladamente insertan snapd, son bloqueados. Por tanto Linux Mint viene sin VLC y sin Gimp de manera predeterminada.
[soloLinux]
Sí. Pero con sudo apt-get install vlc se instala (sin snap) :!:
Image
Si tu consulta ha sido resuelta, por favor, edita tu primer mensaje y añade [SOLUCIONADO] al título. Gracias.

User avatar
tomeu
Level 6
Level 6
Posts: 1343
Joined: Wed Mar 29, 2017 12:03 pm
Location: España

Re: Problemas tras actualizar a LM 20 (VLC no funciona)

Post by tomeu »

Sí, se instala. Solo quería hacer el apunte de que ya, con LM 20, no viene de serie. (castigado por usar snap o instalar herramientas)
Image
Linux Mint Ulyana 20 Cinnamon
Por favor, recuerda añadir al título el 'palabro' "[SOLUCIONADO]" si el problema o cuestión ha quedado resuelto. Gracias

yellowhale
Level 1
Level 1
Posts: 5
Joined: Sun Jun 28, 2020 10:59 am

Re: Problemas tras actualizar a LM 20 (VLC no funciona)

Post by yellowhale »

tomeu wrote:
Mon Jun 29, 2020 6:22 am
yellowhale wrote:
Sun Jun 28, 2020 11:17 am
¿Se solventará instalando el paquete "grub2-theme-mint"?
En teoría así debería ser, ese es el paquete con el tema del grub.
Si usas un portátil y según la resolución de tu monitor tal vez te interese el paquete "grub2-theme-mint-2k"
Si usas Mate (no vi si decías qué entorno usas) el paquete también tienes la opcióna "grub2-themes-ubuntu-mate"

Del segundo problema, no puedo decir nada.
El primero asunto sí se soluciona así de fácil. Y uso Cinnamon.
Lástima que el que más me interesa es lo relativo a VLC.

yellowhale
Level 1
Level 1
Posts: 5
Joined: Sun Jun 28, 2020 10:59 am

Re: Problemas tras actualizar a LM 20 (VLC no funciona)

Post by yellowhale »

JCSenar wrote:
Mon Jun 29, 2020 7:50 am
yellowhale wrote:
Sun Jun 28, 2020 11:17 am
Por otro lado, el problema más importante, el que ni reinstalando el SO se puede solucionar de ninguna manera.
VLC Media Player está dando problemas que jamás había tenido.
1. Inicio la sesión, abro un video en VLC, lo reproduce bien pero tras cerrar el programa y querer abrir el mismo video (u otro) VLC NO se ejecuta, sin importar cuántas veces lo abra. El gestor de tareas sigue mostrando un proceso de VLC corriendo, el cual no se cierra por más veces que intente cerrarlo con la app.
2. Cuando abro un video y me meto a las opciones tales como rotar el video o girar, no hace absolutamente nada. Incluso me ha llegado a fallar la parte donde puedo manipular la temperatura del color, brillo, contraste y demás.
¿Es un problema de LM 20 o es mi computadora exclusivamente? Porque por más de 10 años he usado VLC y nunca había tenido ese problema.
Pues no se por qué te pasa :?:

Estoy probando un vídeo en una instalación limpia de LM 20 Mate y VLC funciona bien. Abro y cierro el archivo tantas veces como quiero y también puedo rotarlo sin problema: :shock: :shock:


Pantallazo-2020-06-29 13-44-37.jpg
Casi que eso me hace pensar es cosa de Cinnamon, pero no he leído a nadie más diciendo nada al respecto.
¿Será que la falla es exclusiva de mi lap top?, jamás había tenido semejante falla tan ilógica.

yellowhale
Level 1
Level 1
Posts: 5
Joined: Sun Jun 28, 2020 10:59 am

Re: Problemas tras actualizar a LM 20 (VLC no funciona)

Post by yellowhale »

tomeu wrote:
Mon Jun 29, 2020 2:50 pm
sobre VLC en LM 20...
Además… después de la gran controversia por la imposición de snap por parte de Ubuntu; los desarrolladores de Linux Mint tomaron una decisión drástica para algunos, feliz para otros. Los paquetes que instalan herramientas y que disimuladamente insertan snapd, son bloqueados. Por tanto Linux Mint viene sin VLC y sin Gimp de manera predeterminada.
[soloLinux]
Sé lo del bloqueo a Snap, pero no creo tenga que ver, ya que VLC está en los repositorios de todas maneras.

User avatar
mintxavi
Level 3
Level 3
Posts: 136
Joined: Mon Jul 02, 2018 6:50 am

Re: Problemas tras actualizar a LM 20 (VLC no funciona)

Post by mintxavi »

lanzalo sin configuracion previa... desde terminal ejecuta:

vlc --ignore-config

tambien para ver que ocurre(modo verbose)
vlc -v


si no es debido a configuraciones previas en mal estado pues mira tambien ese proceso que se queda encendido del vlc (o solo es una instancia de el?)

yellowhale
Level 1
Level 1
Posts: 5
Joined: Sun Jun 28, 2020 10:59 am

Re: Problemas tras actualizar a LM 20 (VLC no funciona)

Post by yellowhale »

No es práctico estar lanzando VLC desde consola cada vez que quiero abrir un audio o video.
Lo segundo no lo puedo poner en práctica, porque no he vuelto a instalar VLC.
Lo tercero, ¿Acaso no mencioné que el proceso me es imposible cerrar (o matar) desde el gestor de tareas) Sino lo hice, ahora lo hago, porque eso pasa.
Por cierto que comenté mi problema, pero en inglés, ante personas de la comunidad LM pero en FB y descubrí no sólo a mí me pasa lo de VLC, no al 100% idéntico, pero igual da problemas.

User avatar
mintxavi
Level 3
Level 3
Posts: 136
Joined: Mon Jul 02, 2018 6:50 am

Re: Problemas tras actualizar a LM 20 (VLC no funciona)

Post by mintxavi »

Entiendo si...lo de la terminal era para ver si mostraba algun fallo no para lanzarlo...parece que lo solucionaste no?

Yo lo arranco (cierto que con algun problema al principio) desde el LIVE de mint. adjunto imagen para que te guies a ver si eso mismo te vale en caso de que no lo solucionaras ya...
Screenshot_2020-07-10_09-56-55.jpeg

buen dia y suerte con ello...

alfema
Level 4
Level 4
Posts: 229
Joined: Tue Mar 24, 2015 2:26 pm

Re: Problemas tras actualizar a LM 20 (VLC no funciona)

Post by alfema »

Vengo a ratificar el problema, he actualizado de Mint 19.3 a Mint 20 según el proceso indicado, lanzo desde Nemo un vídeo, se abre VLC y lo reproduce correctamente, cierro VLC, hago doble pulsación sobre otro vídeo o con botón derecho selecciono "Reproducir ..." y tampoco lanza el vídeo, VLC se queda en ejecución sin cerrarlo, hay que matarlo.
--
Saludos / Greetings
Mi sistema desde agosto 2016 / My system since august 2016
Linux Mint 20 - Cinnamon (64 bit)
Intel i7-6700K + Kingston HyperX Savage 2x8 GiB + SSD Crucial MX 550 512 MB + AMD RX 580

User avatar
KevinDeveloper
Level 2
Level 2
Posts: 84
Joined: Wed Jan 09, 2019 3:47 pm
Location: Guatemala.
Contact:

Re: Problemas tras actualizar a LM 20 (VLC no funciona)

Post by KevinDeveloper »

alfema wrote:
Sat Jul 11, 2020 1:22 pm
Vengo a ratificar el problema, he actualizado de Mint 19.3 a Mint 20 según el proceso indicado, lanzo desde Nemo un vídeo, se abre VLC y lo reproduce correctamente, cierro VLC, hago doble pulsación sobre otro vídeo o con botón derecho selecciono "Reproducir ..." y tampoco lanza el vídeo, VLC se queda en ejecución sin cerrarlo, hay que matarlo.
Bueno, exactamente tenía ese problema con VLC cuando me instalé Ubuntu Budgie 20.04 hace unos meses. Como LM 20 se basa en él (Ubuntu 20.04), quizás esa sea la raíz del problema. Voy a probar a ejecutar VLC en mi instalación de LM 20 Cinnamon y reportaré resultados.
No importa cuántas veces caigas, lo que realmente importa es cuántas veces haces el esfuerzo por levantarte y lograr lo que te propones.

User avatar
KevinDeveloper
Level 2
Level 2
Posts: 84
Joined: Wed Jan 09, 2019 3:47 pm
Location: Guatemala.
Contact:

Re: Problemas tras actualizar a LM 20 (VLC no funciona)

Post by KevinDeveloper »

yellowhale wrote:
Sun Jun 28, 2020 11:17 am
Instalé LM y el primer "error" que encontré fue con el GRUB, o boot menu, como se le denomine aquí. Donde el que tenía para LM 19.3 se fue, ese con diseño aceptable, no el aburrido negro. Y justamente el negro volvió, el cual ya no me agrada.
En mi caso, cuando inicié por primera vez el USB Live de LM 20 Cinnamon, me di cuenta de esto, así que hice un respaldo del tema de GRUB para colocarlo de nuevo tras la instalación. Ahora funciona de maravilla.
No importa cuántas veces caigas, lo que realmente importa es cuántas veces haces el esfuerzo por levantarte y lograr lo que te propones.

User avatar
KevinDeveloper
Level 2
Level 2
Posts: 84
Joined: Wed Jan 09, 2019 3:47 pm
Location: Guatemala.
Contact:

Re: Problemas tras actualizar a LM 20 (VLC no funciona)

Post by KevinDeveloper »

Acabo de probar VLC en mi instalación de LM 20 Cinnamon y tampoco pasa lo que mencionas. Puedo cerrar y abrir correctamente el programa sin que se congele en la bandeja del sistema. ¿Has probado los comandos que te dio mintxavi? Son necesarios para delimitar cuál es la causa del problema y tener una idea general de por qué está pasando ello. Si con eso logras hacerlo funcionar, entonces puedes crear un lanzador con el comando o purgar el programa y reinstalarlo.
No importa cuántas veces caigas, lo que realmente importa es cuántas veces haces el esfuerzo por levantarte y lograr lo que te propones.

alfema
Level 4
Level 4
Posts: 229
Joined: Tue Mar 24, 2015 2:26 pm

Re: Problemas tras actualizar a LM 20 (VLC no funciona)

Post by alfema »

Resultado de vlc --ignore-config, mismo problema, si pulso Control + C sí se cierra el proceso y me permite lanzar otro vídeo desde Nemo.

Code: Select all

alfema@pc-i6700k:~$ vlc --ignore-config
VLC media player 3.0.9.2 Vetinari (revision 3.0.9.2-0-gd4c1aefe4d)
[000055f18c8d15b0] main libvlc: Ejecutar vlc con la interfaz predeterminada. Use «cvlc» para usar vlc sin interfaz.
[000055f18c961270] main playlist: playlist is empty
[000055f18c989030] main audio output error: too low audio sample frequency (0)
[00007f9ce8d36700] main decoder error: failed to create audio output
[000055f18c989030] vlcpulse audio output error: digital pass-through stream connection failure: No permitido
[000055f18c989030] main audio output error: module not functional
[00007f9ce8d36700] main decoder error: failed to create audio output
libva info: VA-API version 1.7.0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/radeonsi_drv_video.so
libva info: Found init function __vaDriverInit_1_7
libva info: va_openDriver() returns 0
mesa: for the --simplifycfg-sink-common option: may only occur zero or one times!
mesa: for the --global-isel-abort option: may only occur zero or one times!
mesa: for the --amdgpu-atomic-optimizations option: may only occur zero or one times!
[00007f9cd0002de0] glconv_vaapi_x11 gl error: vaDeriveImage: operation failed
[00007f9cf0005700] main video output error: video output creation failed
[00007f9ce8c14e60] main decoder error: failed to create video output
mesa: for the --simplifycfg-sink-common option: may only occur zero or one times!
mesa: for the --global-isel-abort option: may only occur zero or one times!
mesa: for the --amdgpu-atomic-optimizations option: may only occur zero or one times!
[00007f9ce8c14e60] avcodec decoder: Using G3DVL VDPAU Driver Shared Library version 1.0 for hardware decoding
[h264 @ 0x7f9ce8c1f180] Failed setup for format vdpau: hwaccel initialisation returned error.
[00007f9ce8c14e60] avcodec decoder error: existing hardware acceleration cannot be reused
libva info: VA-API version 1.7.0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/radeonsi_drv_video.so
libva info: Found init function __vaDriverInit_1_7
libva info: va_openDriver() returns 0
[00007f9c8c0451d0] glconv_vaapi_x11 gl error: vaDeriveImage: operation failed
libva info: VA-API version 1.7.0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/radeonsi_drv_video.so
libva info: Found init function __vaDriverInit_1_7
libva info: va_openDriver() returns 0
[00007f9cd0138880] glconv_vaapi_x11 gl error: vaDeriveImage: operation failed
[00007f9cf013bc00] main video output error: video output creation failed
[00007f9ce8c14e60] main decoder error: failed to create video output
^C
alfema@pc-i6700k:~$
Resultado de vlc -v, funciona correctamente, lanzo un vídeo desde Nemo, se cierra, lanzo otro y ahora sí funciona, no se si el comando anterior ha influído, reiniciaré y probaré más tarde.

Code: Select all

alfema@pc-i6700k:~$ vlc -v
VLC media player 3.0.9.2 Vetinari (revision 3.0.9.2-0-gd4c1aefe4d)
[00005610d307c5b0] main libvlc: Ejecutar vlc con la interfaz predeterminada. Use «cvlc» para usar vlc sin interfaz.
[00005610d310c210] main playlist: playlist is empty
[00005610d3134100] main audio output error: too low audio sample frequency (0)
[00007f0a68d36060] main decoder error: failed to create audio output
[00005610d3134100] vlcpulse audio output error: digital pass-through stream connection failure: No permitido
[00005610d3134100] main audio output error: module not functional
[00007f0a68d36060] main decoder error: failed to create audio output
libva info: VA-API version 1.7.0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/radeonsi_drv_video.so
libva info: Found init function __vaDriverInit_1_7
libva info: va_openDriver() returns 0
mesa: for the --simplifycfg-sink-common option: may only occur zero or one times!
mesa: for the --global-isel-abort option: may only occur zero or one times!
mesa: for the --amdgpu-atomic-optimizations option: may only occur zero or one times!
[00007f0a4c002de0] glconv_vaapi_x11 gl error: vaDeriveImage: operation failed
[00007f0a740054f0] main video output error: video output creation failed
[00007f0a68c1b680] main decoder error: failed to create video output
mesa: for the --simplifycfg-sink-common option: may only occur zero or one times!
mesa: for the --global-isel-abort option: may only occur zero or one times!
mesa: for the --amdgpu-atomic-optimizations option: may only occur zero or one times!
[00007f0a68c1b680] avcodec decoder: Using G3DVL VDPAU Driver Shared Library version 1.0 for hardware decoding
[h264 @ 0x7f0a68c3b940] Failed setup for format vdpau: hwaccel initialisation returned error.
[00007f0a68c1b680] avcodec decoder error: existing hardware acceleration cannot be reused
libva info: VA-API version 1.7.0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/radeonsi_drv_video.so
libva info: Found init function __vaDriverInit_1_7
libva info: va_openDriver() returns 0
[00007f09f40450e0] glconv_vaapi_x11 gl error: vaDeriveImage: operation failed
[00005610d310c210] main playlist warning: cannot reuse provided vout
libva info: VA-API version 1.7.0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/radeonsi_drv_video.so
libva info: Found init function __vaDriverInit_1_7
libva info: va_openDriver() returns 0
[00007f0a4c138840] glconv_vaapi_x11 gl error: vaDeriveImage: operation failed
[00007f0a740d09b0] main video output error: video output creation failed
[00007f0a68c1b680] main decoder error: failed to create video output
[00005610d3134100] pulse audio output warning: starting late (-22556 us)
QObject::~QObject: Timers cannot be stopped from another thread
alfema@pc-i6700k:~$ 
--
Saludos / Greetings
Mi sistema desde agosto 2016 / My system since august 2016
Linux Mint 20 - Cinnamon (64 bit)
Intel i7-6700K + Kingston HyperX Savage 2x8 GiB + SSD Crucial MX 550 512 MB + AMD RX 580

User avatar
mintxavi
Level 3
Level 3
Posts: 136
Joined: Mon Jul 02, 2018 6:50 am

Re: Problemas tras actualizar a LM 20 (VLC no funciona)

Post by mintxavi »

Pero si ya os di la razon...leer atras,dije que lo probe en un live mint xfce20 y fallaba el vlc, en efecto aunque cambies del celluloid a vlc como predeterminado, al hacer clic en un video en efecto no lo abria(aparte de un parpadeo extraño)...asi que para probar cambie la orden de inicio asi:(editar lanzadores, del menu u otros que tengas)


vlc_orig.png
cambiar simplemente a :
vlc_2.png

y en el live simplemente hacia que funcionara siempre esto...debe ser algo eventual creo...es posible que no siempre falle y a algunas personas les funcione a la 1º y a otras no... espero haber sido claro ahora en la explicacion

Post Reply

Return to “Español (Spanish)”