Sin sonido en salidas de audio y micro frontales

Spanish Forum

Moderators: tomeu, JCSenar

Post Reply
javiwinner
Level 1
Level 1
Posts: 3
Joined: Mon Jul 13, 2020 12:53 pm

Sin sonido en salidas de audio y micro frontales

Post by javiwinner »

Hola a todos. Soy nuevo en el foro, aunque llevo tiempo probando ésta distribución, primero en un portátil, concretamente la 19.3 y al estar muy satisfecho, he decido instalarla en un Pc de sobre mesa, concretamente la distro 20, que aunque tiene su tiempo, lo tengo bastante fino. El único problema que he encontrado, es que aunque tengo sonido en la parte trasera, tanto salida, como micro, no es así en el panel delantero. Para mí sería interesante ya que muchas veces conecto auriculares. Decir que tengo en otro disco, windows 10 y también tuve que ingeniármelas para poder encontrar unos driver para la tarjeta de sonido, y poder activar el panel delantero. Her estado leyendo algunas cosas e incluso he instalado el pulseaudio, pero no me activa el panel.

Cualquier ayuda para un novato, se agradecería. Muchas gracias.


Os pongo los datos de la placa: ASUSTeK model: P5KPL-AM EPU

inxi-Fxznr:

Code: Select all

System:
  Kernel: 5.4.0-40-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 
  Desktop: Cinnamon 4.6.6 Distro: Linux Mint 20 Ulyana 
  base: Ubuntu 20.04 focal 
Machine:
  Type: Desktop Mobo: ASUSTeK model: P5KPL-AM EPU v: x.0x serial: <filter> 
  BIOS: American Megatrends v: 0501 date: 08/20/2010 
Battery:
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M215 2nd Gen 
  charge: 100% (should be ignored) status: Discharging 
  Device-2: hidpp_battery_1 model: Logitech Wireless Keyboard K330 
  charge: 100% (should be ignored) status: Discharging 
CPU:
  Topology: Quad Core model: Intel Core2 Quad bits: 64 type: MCP 
  arch: Core Merom rev: 7 L2 cache: 4096 KiB 
  flags: lm nx pae sse sse2 sse3 ssse3 vmx bogomips: 19201 
  Speed: 1600 MHz min/max: 1596/2394 MHz Core speeds (MHz): 1: 1600 2: 1600 
  3: 1600 4: 1600 
Graphics:
  Device-1: AMD Barts PRO [Radeon HD 6850] vendor: Gigabyte driver: radeon 
  v: kernel bus ID: 01:00.0 
  Display: x11 server: X.Org 1.20.8 driver: ati,radeon 
  unloaded: fbdev,modesetting,vesa resolution: 1920x1080~60Hz 
  OpenGL: renderer: AMD BARTS (DRM 2.50.0 / 5.4.0-40-generic LLVM 10.0.0) 
  v: 3.3 Mesa 20.0.8 direct render: Yes 
Audio:
  Device-1: Intel NM10/ICH7 Family High Definition Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Device-2: AMD Barts HDMI Audio [Radeon HD 6790/6850/6870 / 7720 OEM] 
  vendor: Gigabyte driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  Device-3: Logitech HD Webcam C510 type: USB driver: snd-usb-audio,uvcvideo 
  bus ID: 2-3:2 
  Sound Server: ALSA v: k5.4.0-40-generic 
Network:
  Device-1: Qualcomm Atheros AR8121/AR8113/AR8114 Gigabit or Fast Ethernet 
  vendor: ASUSTeK driver: ATL1E v: N/A port: ec00 bus ID: 02:00.0 
  IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 801.12 GiB used: 17.76 GiB (2.2%) 
  ID-1: /dev/sda vendor: Kingston model: SA400S37240G size: 223.57 GiB 
  ID-2: /dev/sdb vendor: Kingston model: SA400S37120G size: 111.79 GiB 
  ID-3: /dev/sdc vendor: Western Digital model: WD5000AAKX-001CA0 
  size: 465.76 GiB 
Partition:
  ID-1: / size: 18.24 GiB used: 10.25 GiB (56.2%) fs: ext4 dev: /dev/sdb1 
  ID-2: /home size: 83.83 GiB used: 7.51 GiB (9.0%) fs: ext4 dev: /dev/sdb6 
  ID-3: swap-1 size: 7.45 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sdb5 
Sensors:
  System Temperatures: cpu: 59.0 C mobo: N/A gpu: radeon temp: 43 C 
  Fan Speeds (RPM): N/A 
Repos:
  No active apt repos in: /etc/apt/sources.list 
  Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
  1: deb http://mirrors.evowise.com/linuxmint/packages ulyana main upstream import backport
  2: deb http://mirror.tedra.es/ubuntu focal main restricted universe multiverse
  3: deb http://mirror.tedra.es/ubuntu focal-updates main restricted universe multiverse
  4: deb http://mirror.tedra.es/ubuntu focal-backports main restricted universe multiverse
  5: deb http://security.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse
  6: deb http://archive.canonical.com/ubuntu/ focal partner
Info:
  Processes: 203 Uptime: 20m Memory: 3.84 GiB used: 1.68 GiB (43.8%) 
  Init: systemd runlevel: 5 Compilers: gcc: 9.3.0 Shell: bash v: 5.0.16 
  inxi: 3.0.38
amixer:

Code: Select all

Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 42
  Mono: Playback 41 [98%] [-1.50dB] [on]
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 42
  Mono:
  Front Left: Playback 42 [100%] [0.00dB] [on]
  Front Right: Playback 42 [100%] [0.00dB] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 254 [100%] [-0.20dB]
  Front Right: Playback 254 [100%] [-0.20dB]
Simple mixer control 'Front',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 42
  Mono:
  Front Left: Playback 42 [100%] [0.00dB] [on]
  Front Right: Playback 42 [100%] [0.00dB] [on]
Simple mixer control 'Front Mic',0
  Capabilities: pvolume pswitch cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Mono
  Limits: Playback 0 - 31
  Mono: Capture [off]
  Front Left: Playback 0 [0%] [-34.50dB] [off]
  Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control 'Front Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%] [0.00dB]
  Front Right: 0 [0%] [0.00dB]
Simple mixer control 'Surround',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 42
  Mono:
  Front Left: Playback 0 [0%] [-63.00dB] [off]
  Front Right: Playback 0 [0%] [-63.00dB] [off]
Simple mixer control 'Center',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 42
  Mono: Playback 0 [0%] [-63.00dB] [off]
Simple mixer control 'LFE',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 42
  Mono: Playback 0 [0%] [-63.00dB] [off]
Simple mixer control 'Line',0
  Capabilities: pvolume pswitch cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Mono
  Limits: Playback 0 - 31
  Mono: Capture [on]
  Front Left: Playback 0 [0%] [-34.50dB] [off]
  Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control 'CD',0
  Capabilities: pvolume pswitch cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Mono
  Limits: Playback 0 - 31
  Mono: Capture [off]
  Front Left: Playback 0 [0%] [-34.50dB] [off]
  Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'IEC958 Default PCM',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 31
  Front Left: Capture 24 [77%] [19.50dB] [on]
  Front Right: Capture 24 [77%] [19.50dB] [on]
Simple mixer control 'Auto-Mute Mode',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Disabled'
Simple mixer control 'Channel Mode',0
  Capabilities: enum
  Items: '2ch' '4ch' '6ch'
  Item0: '2ch'
Simple mixer control 'Dynamic Power-Control',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Disabled'
Simple mixer control 'Independent HP',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Disabled'
Simple mixer control 'Loopback Mixing',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Disabled'
Simple mixer control 'Rear Mic',0
  Capabilities: pvolume pswitch cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Playback channels: Front Left - Front Right
  Capture channels: Mono
  Limits: Playback 0 - 31
  Mono: Capture [off]
  Front Left: Playback 0 [0%] [-34.50dB] [off]
  Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control 'Rear Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%] [0.00dB]
  Front Right: 0 [0%] [0.00dB]
Simple mixer control 'Stereo Mix',0
  Capabilities: cswitch cswitch-joined cswitch-exclusive
  Capture exclusive group: 0
  Capture channels: Mono
  Mono: Capture [off]
pacmd list-cards:

Code: Select all

 card(s) available.
    index: 0
	name: <alsa_card.pci-0000_01_00.1>
	driver: <module-alsa-card.c>
	owner module: 7
	properties:
		alsa.card = "2"
		alsa.card_name = "HDA ATI HDMI"
		alsa.long_card_name = "HDA ATI HDMI at 0xfe9fc000 irq 29"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:01:00.1"
		sysfs.path = "/devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card2"
		device.bus = "pci"
		device.vendor.id = "1002"
		device.vendor.name = "Advanced Micro Devices, Inc. [AMD/ATI]"
		device.product.id = "aa88"
		device.product.name = "Barts HDMI Audio [Radeon HD 6790/6850/6870 / 7720 OEM]"
		device.string = "2"
		device.description = "Barts HDMI Audio [Radeon HD 6790/6850/6870 / 7720 OEM]"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	profiles:
		output:hdmi-stereo: Digital Stereo (HDMI) Salida (priority 5900, available: no)
		output:hdmi-surround: Digital Surround 5.1 (HDMI) Salida (priority 800, available: no)
		output:hdmi-surround71: Digital Surround 7.1 (HDMI) Salida (priority 800, available: no)
		off: Apagado (priority 0, available: unknown)
	active profile: <off>
	ports:
		hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "video-display"
    index: 1
	name: <alsa_card.pci-0000_00_1b.0>
	driver: <module-alsa-card.c>
	owner module: 8
	properties:
		alsa.card = "0"
		alsa.card_name = "HDA Intel"
		alsa.long_card_name = "HDA Intel at 0xfe8fc000 irq 28"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:00:1b.0"
		sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card0"
		device.bus = "pci"
		device.vendor.id = "8086"
		device.vendor.name = "Intel Corporation"
		device.product.id = "27d8"
		device.product.name = "NM10/ICH7 Family High Definition Audio Controller"
		device.form_factor = "internal"
		device.string = "0"
		device.description = "Audio Interno"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	profiles:
		input:analog-stereo: Estéreo analógico Entrada (priority 65, available: no)
		output:analog-stereo: Estéreo analógico Salida (priority 6500, available: unknown)
		output:analog-stereo+input:analog-stereo: Estéreo Analógico Dúplex (priority 6565, available: no)
		output:iec958-stereo: Estéreo Digital (IEC958) Salida (priority 5500, available: unknown)
		output:iec958-stereo+input:analog-stereo: Estéreo Digital (IEC958) Salida + Estéreo analógico Entrada (priority 5565, available: no)
		off: Apagado (priority 0, available: unknown)
	active profile: <output:analog-stereo+input:analog-stereo>
	sinks:
		alsa_output.pci-0000_00_1b.0.analog-stereo/#4: Audio Interno Estéreo analógico
	sources:
		alsa_output.pci-0000_00_1b.0.analog-stereo.monitor/#5: Monitor of Audio Interno Estéreo analógico
		alsa_input.pci-0000_00_1b.0.analog-stereo/#6: Audio Interno Estéreo analógico
	ports:
		analog-input-front-mic: Micrófono frontal (priority 8500, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-input-microphone"
		analog-input-rear-mic: Micrófono trasero (priority 8200, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-input-microphone"
		analog-input-linein: En línea (priority 8100, latency offset 0 usec, available: no)
			properties:
				
		analog-output-lineout: Línea de salida (priority 9000, latency offset 0 usec, available: yes)
			properties:
				
		analog-output-headphones: Auriculares analógicos (priority 9900, latency offset 0 usec, available: no)
			properties:
				device.icon_name = "audio-headphones"
		iec958-stereo-output: Salida digital (S/PDIF) (priority 0, latency offset 0 usec, available: unknown)
			properties:
				
    index: 2
	name: <alsa_card.usb-046d_081d_41B940A0-00>
	driver: <module-alsa-card.c>
	owner module: 9
	properties:
		alsa.card = "1"
		alsa.card_name = "USB Device 0x46d:0x81d"
		alsa.long_card_name = "USB Device 0x46d:0x81d at usb-0000:04:01.2-3, high speed"
		alsa.driver_name = "snd_usb_audio"
		device.bus_path = "pci-0000:04:01.2-usb-0:3:1.0"
		sysfs.path = "/devices/pci0000:00/0000:00:1e.0/0000:04:01.2/usb2/2-3/2-3:1.0/sound/card1"
		udev.id = "usb-046d_081d_41B940A0-00"
		device.bus = "usb"
		device.vendor.id = "046d"
		device.vendor.name = "Logitech, Inc."
		device.product.id = "081d"
		device.product.name = "HD Webcam C510"
		device.serial = "046d_081d_41B940A0"
		device.form_factor = "webcam"
		device.string = "1"
		device.description = "HD Webcam C510"
		module-udev-detect.discovered = "1"
		device.icon_name = "camera-web-usb"
	profiles:
		input:mono-fallback: Mono Entrada (priority 1, available: unknown)
		input:multichannel-input: Multicanal Entrada (priority 1, available: unknown)
		off: Apagado (priority 0, available: unknown)
	active profile: <input:multichannel-input>
	sources:
		alsa_input.usb-046d_081d_41B940A0-00.multichannel-input/#1: HD Webcam C510 Multicanal
	ports:
		analog-input-mic: Micrófono (priority 8700, latency offset 0 usec, available: unknown)
			properties:
				device.icon_name = "audio-input-microphone"
		multichannel-input: Entrada multicanal (priority 0, latency offset 0 usec, available: unknown)

javiwinner
Level 1
Level 1
Posts: 3
Joined: Mon Jul 13, 2020 12:53 pm

Re: Sin sonido en salidas de audio y micro frontales

Post by javiwinner »

Hola de nuevo, después de investigar, he conseguido tener sonido en la salida de auriculares panel delantero. Aunque no consigo, que al enchufar se mute los altavoces traseros, Con Pulseaudio, selecciono auriculares pero se oyen a la vez, y tengo que entrar en Alsamixer para hacerlo manual, pero no me guarda los cambios.
Esto es como me queda, para que se oiga
<Image

También he estado leyendo para forzar el guardado en alsamixer modificando el Pulseaudio, pero no he obtenido resultado, y siempre cuando conecto los auriculares o doy salida al panel delantero, se oye los traseros, y tengo que entrar en Alsamixer, para hacerlo manual.

User avatar
MrEen
Level 20
Level 20
Posts: 11581
Joined: Mon Jun 12, 2017 8:39 pm

Re: Sin sonido en salidas de audio y micro frontales

Post by MrEen »

Hola javiwinner, y bienvenido al foro.

En alsamixer, desactive el modo de silenciamiento automático, luego enchufar los auriculares debe silenciar la salida posterior. <--Auto-Mute Mode

javiwinner
Level 1
Level 1
Posts: 3
Joined: Mon Jul 13, 2020 12:53 pm

Re: Sin sonido en salidas de audio y micro frontales

Post by javiwinner »

MrEen wrote:
Mon Jul 13, 2020 4:03 pm
Hola javiwinner, y bienvenido al foro.

En alsamixer, desactive el modo de silenciamiento automático, luego enchufar los auriculares debe silenciar la salida posterior. <--Auto-Mute Mode
Gracias por la ayuda. He hecho lo que me ha dicho, pero sigue sin funcionar. Cada vez que reinicio para poder activar la salida de auriculares frontales, tengo que abrir el Control de volumen de Pulseaudio, y seleccionarlo manualmente, además tengo que ejecutar el Alsamixer, y bajar el volumen de sonido frontal, Sólo así logro hacerlo, pero de ninguna de las manera se desactiva los frontales al insertar los auriculares.

User avatar
MrEen
Level 20
Level 20
Posts: 11581
Joined: Mon Jun 12, 2017 8:39 pm

Re: Sin sonido en salidas de audio y micro frontales

Post by MrEen »

Ahh, creo que te afecta la versión más nueva de PulseAudio como muchas otras, según esta parte de tu salida:

Code: Select all

	profiles:
		input:analog-stereo: Estéreo analógico Entrada (priority 65, available: no)
		output:analog-stereo: Estéreo analógico Salida (priority 6500, available: unknown)
		output:analog-stereo+input:analog-stereo: Estéreo Analógico Dúplex (priority 6565, available: no)
		output:iec958-stereo: Estéreo Digital (IEC958) Salida (priority 5500, available: unknown)
		output:iec958-stereo+input:analog-stereo: Estéreo Digital (IEC958) Salida + Estéreo analógico Entrada (priority 5565, available: no)
		off: Apagado (priority 0, available: unknown)
	active profile: <output:analog-stereo+input:analog-stereo>
Intente volver a la versión anterior de PulseAudio, luego reinicie con este comando:

Code: Select all

apt update && apt install libpulse-mainloop-glib0=1:13.99.1-1ubuntu3.2 libpulse0=1:13.99.1-1ubuntu3.2 libpulsedsp=1:13.99.1-1ubuntu3.2 pulseaudio=1:13.99.1-1ubuntu3.2 pulseaudio-module-bluetooth=1:13.99.1-1ubuntu3.2 pulseaudio-utils=1:13.99.1-1ubuntu3.2

Post Reply

Return to “Español (Spanish)”