Linux Mint 20 Ulyana tarda en arrancar

Spanish Forum

Moderators: tomeu, JCSenar

Post Reply
drmike
Level 1
Level 1
Posts: 2
Joined: Sun Sep 13, 2020 12:01 pm

Linux Mint 20 Ulyana tarda en arrancar

Post by drmike »

Buenos días, soy nuevo en linux y me decidí instalar linux mint cinamon 20, tengo una laptop HP de 4 gb en ram, 500 gb de disco duro, procesador celeron de 1.6 doble núcleo, tenia windows 10 y me iba relativamente bien, primero intente particionar el disco y tener ambos sistemas, pero iniciaba directo a windows, asi que para no quenrarme la cabeza termine instalando linux completo, pero e notado que tarda mucho al arrancar como 2:00 min, para el apagado vuela, y el sistema me corre fluido, les dejo información, gracias por el apoyo.
saludos.

Code: Select all

System:
  Kernel: 5.4.0-47-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 
  Desktop: Cinnamon 4.6.7 Distro: Linux Mint 20 Ulyana 
  base: Ubuntu 20.04 focal 
Machine:
  Type: Laptop System: Hewlett-Packard product: HP Notebook v: N/A 
  serial: <filter> 
  Mobo: Hewlett-Packard model: 81E1 v: KBC Version 71.17 serial: <filter> 
  UEFI: Insyde v: F.22 date: 11/04/2016 
Battery:
  ID-1: BAT0 charge: 19.1 Wh condition: 19.1/19.1 Wh (100%) 
  model: Hewlett-Packard Primary status: Full 
CPU:
  Topology: Dual Core model: Intel Celeron N3060 bits: 64 type: MCP 
  arch: Airmont rev: 4 L2 cache: 1024 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 6400 
  Speed: 1446 MHz min/max: 480/2480 MHz Core speeds (MHz): 1: 1670 2: 574 
Graphics:
  Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx 
  Integrated Graphics 
  vendor: Hewlett-Packard driver: i915 v: kernel bus ID: 00:02.0 
  Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 400 (BSW) v: 4.6 Mesa 20.0.8 
  direct render: Yes 
Audio:
  Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series 
  High Definition Audio 
  vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Sound Server: ALSA v: k5.4.0-47-generic 
Network:
  Device-1: Realtek RTL8723BE PCIe Wireless Network Adapter 
  vendor: Hewlett-Packard driver: rtl8723be v: kernel port: 2000 
  bus ID: 02:00.0 
  IF: wlp2s0 state: up mac: <filter> 
  Device-2: Realtek RTL810xE PCI Express Fast Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: kernel port: 1000 bus ID: 03:00.0 
  IF: enp3s0 state: down mac: <filter> 
Drives:
  Local Storage: total: 465.76 GiB used: 16.35 GiB (3.5%) 
  ID-1: /dev/sda vendor: Seagate model: ST500LT012-1DG142 size: 465.76 GiB 
Partition:
  ID-1: / size: 456.96 GiB used: 16.34 GiB (3.6%) fs: ext4 dev: /dev/sda2 
Sensors:
  System Temperatures: cpu: 41.0 C mobo: 0.0 C 
  Fan Speeds (RPM): N/A 
Repos:
  No active apt repos in: /etc/apt/sources.list 
  Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
  1: deb http://packages.linuxmint.com ulyana main upstream import backport #id:linuxmint_main
  2: deb http://archive.ubuntu.com/ubuntu focal main restricted universe multiverse
  3: deb http://archive.ubuntu.com/ubuntu focal-updates main restricted universe multiverse
  4: deb http://archive.ubuntu.com/ubuntu focal-backports main restricted universe multiverse
  5: deb http://security.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse
  6: deb http://archive.canonical.com/ubuntu/ focal partner
  Active apt repos in: /etc/apt/sources.list.d/spotify.list 
  1: deb http://repository.spotify.com stable non-free
Info:
  Processes: 182 Uptime: 16m Memory: 3.69 GiB used: 1.30 GiB (35.2%) 
  Init: systemd runlevel: 5 Compilers: gcc: 9.3.0 Shell: bash v: 5.0.17 
  inxi: 3.0.38
Last edited by JCSenar on Sun Sep 13, 2020 12:14 pm, edited 1 time in total.
Reason: Añadido el formato [code]
User avatar
JOPETA
Level 17
Level 17
Posts: 7374
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Linux Mint 20 Ulyana tarda en arrancar

Post by JOPETA »

Proporciona el resultado de los siguiente códigos. Abre una terminal (Alt+Ctrl+T), copia y pega una linea o cada vez seguido de intro y devuelve el resultado usando la opción </> code del editor del foro como se indica aquí.

Code: Select all

systemd-analyze
systemd-analyze critical-chain
systemd-analyze blame
dmesg | grep -i "error\|warn\|fail\|microcode\|firmware" 
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.(Javier Krahe)
drmike
Level 1
Level 1
Posts: 2
Joined: Sun Sep 13, 2020 12:01 pm

Re: Linux Mint 20 Ulyana tarda en arrancar

Post by drmike »

Gracias jopeta, sigo necesitando tu ayuda, por cuestiones de trabajo, desgraciadamente necesito utilizar office, asi que reintale windows 10, pero obvio quiero seguir con la experiencia lunux mint, me gusto mucho el sistema, asi que lo reinstale, ahora la version linux mint 19.3 triana escritorio xfce, todo bien con la creacion del disco mediante etcher y la instalacion, el problema ahora es que no puedo accesar a windows 10, intente con boot repair y en ese reinicio si pude entrar a windows pero en los demas ya no, te anexo las imagenes de la pantalla del grub tanto de la ves que pude accesar a windows como de la que normalmente sale, escribo el post desde chromium (una de las razones por las que ya no use ulyana), y vuela, tmb te dejo la liga que me genero el programa boot repair. gracias!!!

=http://paste.ubuntu.com/p/8sKzyX9VT8/

Te dejo lo que me arroja el comando sudo update-grub

Code: Select all

drmontor@drmontor-HP-Notebook:~$ sudo update-grub
[sudo] contraseña para drmontor:       
Obteniendo el archivo «/etc/default/grub»
Obteniendo el archivo «/etc/default/grub.d/50_linuxmint.cfg»
Obteniendo el archivo «/etc/default/grub.d/60_mint-theme.cfg»
Generando un fichero de configuración de grub...
Encontrado tema: /boot/grub/themes/linuxmint/theme.txt
Encontrada imagen de linux: /boot/vmlinuz-5.0.0-32-generic
Encontrada imagen de memoria inicial: /boot/initrd.img-5.0.0-32-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
Encontrado Windows 10 en /dev/sda1
Encontrado Windows 10 en /dev/sda2
hecho
este es el reporte de boot repair

Code: Select all

boot-repair-4ppa125                                              [20200916_1620]

============================== Boot Info Summary ===============================

 => Grub2 (v2.00) is installed in the MBR of /dev/sda and looks at sector 1 of 
    the same hard drive for core.img. core.img is at this location and looks 
    for (,msdos6)/boot/grub. It also embeds following components:
    
    modules
    ---------------------------------------------------------------------------
    fshelp ext2 part_msdos biosdisk
    ---------------------------------------------------------------------------

sda1: __________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows 8/2012: NTFS
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        /bootmgr /Boot/BCD[attachment=1]grub4.jpg[/attachment]

sda2: __________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows 8/2012: NTFS
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  Windows 7
    Boot files:        /bootmgr /Boot/BCD /Windows/System32/winload.exe

sda3: __________________________________________________________________________

    File system:       Extended Partition
    Boot sector type:  -
    Boot sector info: 

sda5: __________________________________________________________________________

    File system:       swap
    Boot sector type:  -
    Boot sector info: 

sda6: __________________________________________________________________________

    File system:       ext4
    Boot sector type:  -
    Boot sector info: 
    Operating System:  Linux Mint 19.3
    Boot files:        /boot/grub/grub.cfg /etc/fstab /etc/default/grub 
                       /boot/grub/i386-pc/core.img


================================ 3 OS detected =================================

OS#1:   El sistema operativo que se está usando - Linux Mint 19.3 Tricia CurrentSession on sda6
OS#2:   Windows 10 (boot) on sda1
OS#3:   Windows 10 on sda2

============================ Architecture/Host Info ============================

CPU architecture: 64-bit
BOOT_IMAGE of the installed session in use:
/boot/vmlinuz-5.0.0-32-generic root=UUID=7551dc75-d313-420a-aedf-69c6c09e2ada ro quiet splash vt.handoff=1


===================================== UEFI =====================================

This installed-session is not in EFI-mode.
EFI in dmesg.
[    0.014293] ACPI: UEFI 0x0000000077FFC000 000236 (v01 HPQOEM INSYDE   00000001 HP   00040000)
[    0.014308] ACPI: UEFI 0x0000000077FFA000 000042 (v01 HPQOEM INSYDE   00000000 HP   00040000)
[    2.725309] fb0: EFI VGA frame buffer device
[    5.446724] fb0: switching to inteldrmfb from EFI VGA



============================= Drive/Partition Info =============================

Disks info: ____________________________________________________________________

sda	: notGPT,	no-BIOSboot,	has-noESP, 	not-usb,	not-mmc, has-os,	2048 sectors * 512 bytes

Partitions info (1/3): _________________________________________________________

sda6	: is-os,	64, apt-get,	grub-pc ,	grub2,	grub-install,	grubenv-ok,	update-grub,	farbios
sda1	: is-os,	32, nopakmgr,	no-docgrub,	nogrub,	nogrubinstall,	no-grubenv,	noupdategrub,	not-far
sda2	: is-os,	32, nopakmgr,	no-docgrub,	nogrub,	nogrubinstall,	no-grubenv,	noupdategrub,	farbios

Partitions info (2/3): _________________________________________________________

sda6	: isnotESP,	fstab-without-efi,	no-nt,	no-winload,	no-recov-nor-hid,	no-bmgr,	notwinboot
sda1	: isnotESP,	part-has-no-fstab,	no-nt,	no-winload,	no-recov-nor-hid,	bootmgr,	is-winboot
sda2	: isnotESP,	part-has-no-fstab,	no-nt,	haswinload,	no-recov-nor-hid,	bootmgr,	is-winboot

Partitions info (3/3): _________________________________________________________

sda6	: not-sepboot,	with-boot,	fstab-without-boot,	not-sep-usr,	with--usr,	fstab-without-usr,	std-grub.d,	sda
sda1	: not-sepboot,	no-boot,	part-has-no-fstab,	not-sep-usr,	no---usr,	part-has-no-fstab,	std-grub.d,	sda
sda2	: not-sepboot,	no-boot,	part-has-no-fstab,	not-sep-usr,	no---usr,	part-has-no-fstab,	std-grub.d,	sda

fdisk -l (filtered): ___________________________________________________________

Disk sda: 465.8 GiB, 500107862016 bytes, 976773168 sectors
Disk identifier: 0x2053d0b1
      Boot     Start       End   Sectors   Size Id Type
sda1  *         2048   1026047   1024000   500M  7 HPFS/NTFS/exFAT
sda2         1026048 669571071 668545024 318.8G  7 HPFS/NTFS/exFAT
sda3       669573118 976771071 307197954 146.5G  5 Extended
sda5       669573120 671524863   1951744   953M 82 Linux swap / Solaris
sda6       671526912 976771071 305244160 145.6G 83 Linux

parted -lm (filtered): _________________________________________________________

sda:500GB:scsi:512:4096:msdos:ATA ST500LT012-1DG14:;
1:1049kB:525MB:524MB:ntfs::boot;
2:525MB:343GB:342GB:ntfs::;
3:343GB:500GB:157GB:::;
5:343GB:344GB:999MB:linux-swap(v1)::;
6:344GB:500GB:156GB:ext4::;

blkid (filtered): ______________________________________________________________

NAME   FSTYPE UUID                                 PARTUUID                             LABEL                     PARTLABEL
sda                                                                                                               
├─sda1 ntfs   A8B4B1ADB4B17DFE                     2053d0b1-01                          Reservado para el sistema 
├─sda2 ntfs   B2EEB691EEB64CFB                     2053d0b1-02                                                    
├─sda3                                             2053d0b1-03                                                    
├─sda5 swap   f094f53b-3183-45d2-8401-b9ed2edfb12a 2053d0b1-05                                                    
└─sda6 ext4   7551dc75-d313-420a-aedf-69c6c09e2ada 2053d0b1-06                                                    

df (filtered): _________________________________________________________________

       Avail Use% Mounted on
sda1   469.6M   6% /mnt/boot-sav/sda1
sda2   296.3G   7% /mnt/boot-sav/sda2
sda6   125.9G   6% /

Mount options: __________________________________________________________________

sda1   rw,relatime,user_id=0,group_id=0,allow_other,blksize=4096
sda2   rw,relatime,user_id=0,group_id=0,allow_other,blksize=4096
sda6   rw,relatime,errors=remount-ro

====================== sda6/boot/grub/grub.cfg (filtered) ======================

Linux Mint 19.3 Xfce   7551dc75-d313-420a-aedf-69c6c09e2ada
Linux Mint 19.3 Xfce, with Linux 5.0.0-32-generic   7551dc75-d313-420a-aedf-69c6c09e2ada
Windows 10 (on sda1)   A8B4B1ADB4B17DFE
Windows 10 (on sda2)   B2EEB691EEB64CFB
### END /etc/grub.d/30_os-prober ###
### END /etc/grub.d/30_uefi-firmware ###

========================== sda6/etc/fstab (filtered) ===========================

# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda6 during installation
UUID=7551dc75-d313-420a-aedf-69c6c09e2ada /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=f094f53b-3183-45d2-8401-b9ed2edfb12a none            swap    sw              0       0

======================= sda6/etc/default/grub (filtered) =======================

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

==================== sda6: Location of files loaded by Grub ====================

           GiB - GB             File                                 Fragment(s)
 348.453750610 = 374.149365760  boot/grub/grub.cfg                             1
 348.453174591 = 374.148747264  boot/grub/i386-pc/core.img                     1
 322.076168060 = 345.826652160  boot/vmlinuz-5.0.0-32-generic                  2
 322.076168060 = 345.826652160  vmlinuz                                        2
 322.838787079 = 346.645508096  boot/initrd.img-5.0.0-32-generic               1
 322.838787079 = 346.645508096  initrd.img                                     1
 322.838787079 = 346.645508096  initrd.img.old                                 1

===================== sda6: ls -l /etc/grub.d/ (filtered) ======================

-rwxr-xr-x 1 root root 12693 mar 18  2019 10_linux
-rwxr-xr-x 1 root root 11298 mar 18  2019 20_linux_xen
-rwxr-xr-x 1 root root 12059 mar 18  2019 30_os-prober
-rwxr-xr-x 1 root root  1418 mar 18  2019 30_uefi-firmware
-rwxr-xr-x 1 root root   214 mar 18  2019 40_custom
-rwxr-xr-x 1 root root   216 mar 18  2019 41_custom


=============================== StdErr Messages ================================

File descriptor 63 (pipe:[49397]) leaked on lvs invocation. Parent PID 3850: /bin/bash

Suggested repair: ______________________________________________________________

The default repair of the Boot-Repair utility would reinstall the grub2 of
sda6 into the MBR of sda.
Additional repair would be performed: unhide-bootmenu-10s      
Attachments
la unica ocasion que pude iniciar windows
la unica ocasion que pude iniciar windows
iniwin3.jpg (96 KiB) Viewed 246 times
asi se ve el grub no me deja dezplazarme con las felchas del cursr
asi se ve el grub no me deja dezplazarme con las felchas del cursr
User avatar
JOPETA
Level 17
Level 17
Posts: 7374
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Linux Mint 20 Ulyana tarda en arrancar

Post by JOPETA »

Siento haber descuidado este hilo (aunque te escribí un PM que no llegaste a leer y es una pena). No debes dirigir la pregunta a un usuario en particular ya que corres el riego de que ocurra esto, que los demás usuarios no te presten ayuda. :(

Tampoco sabía si encaja responder ya que el hilo lo inicias con un problema que quedas sin tratar y en el siguiente post en vez de devolver los códigos solcitados evoluciona (como los pokemons) a otros dferentes ya sin LM 20.

Sobre el problema que presentabas aquí en segunda instancias, la primera partición de Windows (sda1) es decir la primera opción de Windows no es correcta .Esa partición debe ser la de recuperación de Windows y por tanto debe estar marcada como oculta ya que debe ser accesible sólo desde el entorno de recuperación de Windows.

No entiendo que haya desaparecido la segunda opción (la correcta) del menú de GRUB y tampoco que no puedas desplazarte por el menú de GRUB. Si seguistes las indicaciones correctas para instalar Linux Mint junto a Windows en modo BIOS descartar en primir lugar que tengas activado el inicio rápido de Windows como responsabe de esto ( Boot info no dice nada al respecto de todas formas).

Si tampoco has ralizado una edición manual del archivo /boot/grub/grub.cfg (en cuyo caso se restituiría con un simple sudo update-grub). debes tener habilitado el CSM en la BIOS (modo UEFI compatible con BIOS legacy) que deberáis desactivar si es así, aunque no descarto que tengas algún problema de hardware (disco duro...). No es conveneinete en calquier caso correr boot Repair desde el sitema instalado, mejor hacerlo desde un Live si es que fuera necesrio que no parece. :roll:

Dado que puedes inciar desde Linux pese a todo, si no has modificado manualmente el archivo mencionado y el código anterior no devuelve la entrada correcta al menú, tal vez debas crear una entrada personalizada para esa opción de Windows.
Lo pirmero sería cononcer la UUID de la partición de Windows (sda2) con sudo blkid. Eso es en caso de que la imagen y el resultado de Boot Repair sean anteriores a alguna de las modificaciones que comoentas haber realizado o si has realizado cambios posteriores. En caso contrario, tomando por buenos esos resultados la UUID es B2EEB691EEB64CFB (compruebalo de todas formas antes).

Luego habría que editar el siguiente archivo con

Code: Select all

xed admin:///etc/grub.d/40_custom

Añadir a continuación del texto existente (sin borrarlo) las opciones que en su día fueron correctas (en la imagen) aunque puedes probar con las siguientes líneas (copiar y pegar).

Code: Select all

menuentry "Microsoft Windows BIOS" --clas windows {
		insmod part_msdos
		insmod ntfs
		insmod ntldr     
		search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos2 --hint-efi=hd0,msdos2 --hint-baremetal=ahci0,msdos2 B2EEB691EEb64CFB
		ntldr /bootmgr
	}
Guarda y cierra el editor.

En la terminal ejecuta

Code: Select all

sudo update-grub
Y reinicia.
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.(Javier Krahe)
Post Reply

Return to “Español (Spanish)”