No puedo iniciar Linux Mint despues de actualizar Windows 10

Spanish Forum

Moderators: tomeu, JCSenar

Post Reply
Xoco
Level 2
Level 2
Posts: 54
Joined: Wed Jan 23, 2019 3:56 pm

No puedo iniciar Linux Mint despues de actualizar Windows 10

Post by Xoco »

Hola,

Tengo un portatil con una instalacion dual boot en un SSD (con particion GPT), con Windows 10 y Linux Mint 19.3 (en modo UEFI), y despues de actualizar Windows 10 a su version 2004 y tambien el firmware de la placa ASUS (ambos desde Windows Update), algo ha fallado y no arrancaba ni Windows ni Linux Mint. Para solucionar el arranque de Windows, tuve que hacer una reparacion del sistema para devolverlo a su estado original, pero no he podido iniciar Linux Mint.

El portatil tiene ademas un HDD de 1TB que se refleja en los informes que dejo mas abajo.

Al encender el portatil, detecta el grub de inicio, y al elegir iniciar desde Linux Mint, se queda en estas pantallas en las que no se como continuar.
Screenshot at 2020-09-22 18-40-37.png
Screenshot at 2020-09-22 18-40-37.png (196 KiB) Viewed 194 times
He iniciado el portatil desde Live USB con Linux Mint 19.3 y no detecta el SSD, ni desde GParted ni desde Discos.
Gparted.png
Discos Duros.png

Por si sirve de ayuda, dejo los informes de los siguientes comandos.

Code: Select all

mint@mint:~$ inxi -Fxznr
System:    Host: mint Kernel: 5.0.0-32-generic x86_64 bits: 64 compiler: gcc v: 7.4.0 Desktop: MATE 1.22.2 
           Distro: Linux Mint 19.3 Tricia base: Ubuntu 18.04 bionic 
Machine:   Type: Laptop System: ASUSTeK product: TUF Gaming FX505GT_FX505GT v: 1.0 serial: <filter> 
           Mobo: ASUSTeK model: FX505GT v: 1.0 serial: <filter> UEFI: American Megatrends v: FX505GT.307 date: 06/24/2020 
Battery:   ID-1: BAT0 charge: 43.3 Wh condition: 43.3/48.1 Wh (90%) model: Simplo SDI ICR18650 status: Full 
CPU:       Topology: 6-Core model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Kaby Lake rev: A L2 cache: 12.0 MiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 62208 
           Speed: 800 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
           9: 800 10: 800 11: 800 12: 800 
Graphics:  Device-1: Intel vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0 
           Device-2: NVIDIA vendor: ASUSTeK driver: N/A bus ID: 01:00.0 
           Display: x11 server: X.Org 1.20.4 driver: modesetting unloaded: fbdev,vesa resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel UHD Graphics 630 (Coffeelake 3x8 GT2) v: 4.5 Mesa 19.0.8 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           Device-2: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           Sound Server: ALSA v: k5.0.0-32-generic 
Network:   Device-1: Intel Wireless-AC 9560 [Jefferson Peak] driver: iwlwifi v: kernel port: 5000 bus ID: 00:14.3 
           IF: wlo1 state: up mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169 v: kernel port: 3000 
           bus ID: 02:00.0 
           IF: enp2s0 state: down mac: <filter> 
Drives:    Local Storage: total: 939.04 GiB used: 144.45 GiB (15.4%) 
           ID-1: /dev/sda vendor: Toshiba model: MQ04ABF100 size: 931.51 GiB temp: 35 C 
           ID-2: /dev/sdb type: USB vendor: Corsair model: Flash Voyager size: 7.53 GiB 
RAID:      Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci v: 3.0 bus ID: 00:17.0 
Partition: ID-1: / size: 7.76 GiB used: 1.99 GiB (25.7%) fs: overlay source: ERR-102 
Sensors:   System Temperatures: cpu: 50.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 0 
Repos:     Active apt repos in: /etc/apt/sources.list 
           1: deb cdrom:[Linux Mint 19.3 _Tricia_ - Release amd64 20191216]/ bionic contrib main non-free
           Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
           1: deb http://packages.linuxmint.com tricia main upstream import backport #id:linuxmint_main
           2: deb http://archive.ubuntu.com/ubuntu bionic main restricted universe multiverse
           3: deb http://archive.ubuntu.com/ubuntu bionic-updates main restricted universe multiverse
           4: deb http://archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse
           5: deb http://security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
           6: deb http://archive.canonical.com/ubuntu/ bionic partner
Info:      Processes: 295 Uptime: 2h 43m Memory: 15.52 GiB used: 2.60 GiB (16.8%) Init: systemd runlevel: 5 Compilers: 
           gcc: 7.4.0 Shell: bash v: 4.4.20 inxi: 3.0.32 

Code: Select all

mint@mint:~$ sudo fdisk -l
Disk /dev/loop0: 1.9 GiB, 2014482432 bytes, 3934536 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/sda: 931.5 GiB, 1000204886016 bytes, 1953525168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: E11AB49F-C343-4F76-A618-C9B9EF46B547

Device     Start        End    Sectors   Size Type
/dev/sda1     34      32767      32734    16M Microsoft reserved
/dev/sda2  32768 1953521663 1953488896 931.5G Microsoft basic data

Partition 1 does not start on physical sector boundary.


Disk /dev/sdb: 7.5 GiB, 8086618112 bytes, 15794176 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x032844cf

Device     Boot Start      End  Sectors  Size Id Type
/dev/sdb1  *     2048 15794175 15792128  7.5G  c W95 FAT32 (LBA)

Code: Select all

mint@mint:~$ sudo parted -l
Model: ATA TOSHIBA MQ04ABF1 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                          Flags
 1      17.4kB  16.8MB  16.8MB               Microsoft reserved partition  msftres
 2      16.8MB  1000GB  1000GB               Basic data partition          msftdata


Model: Corsair Flash Voyager (scsi)
Disk /dev/sdb: 8087MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  8087MB  8086MB  primary  fat32        boot, lba

Code: Select all

mint@mint:~$ sudo blkid
/dev/sda2: LABEL="DATOS" UUID="764A-0183" TYPE="exfat" PARTLABEL="Basic data partition" PARTUUID="4ab345ee-e2a4-4f74-9072-f608a922d899"
/dev/sdb1: LABEL="LINUX MINT" UUID="3026-62F3" TYPE="vfat" PARTUUID="032844cf-01"
/dev/loop0: TYPE="squashfs"
/dev/sda1: PARTLABEL="Microsoft reserved partition" PARTUUID="93e51fc2-a6fc-4722-9fb2-97cd97e15e03"
Puede alguien echarme una mano para restablecer el arranque de Linux Mint???.

Gracias.

Un saludo a todos.

*Me fui de Windows para no volver y lo tengo instalado por motivos de trabajo, pero no hace mas que dar problemas en cada actualizacion.
Y disculpad que no ponga los acentos, pero desde el Live USB, el teclado esta en ingles y ni flowers* :shock:
User avatar
JOPETA
Level 17
Level 17
Posts: 7374
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: No puedo iniciar Linux Mint despues de actualizar Windows 10

Post by JOPETA »

Xoco wrote:
Tue Sep 22, 2020 2:54 pm
después de actualizar Windows 10 a su versión 2004 y también el firmware de la placa ASUS (ambos desde Windows Update), algo ha fallado y no arrancaba ni Windows ni Linux Mint. Para solucionar el arranque de Windows, tuve que hacer una reparación del sistema para devolverlo a su estado original, pero no he podido iniciar Linux Mint.
Que puedas ver el inicio GRUB de Mint sugiere que el directorio EFI/Ubuntu de la partición EFI aún existe pero el problema está mas o menos claro según lo que se adivina en los errores del initramfs. Te pide que descartes la configuración de GRUB con cat /proc/cmdline o que requiera de algún módulo no cargado en GRUB con cat /proc/modules para concluir que no existe la partición raíz de Linux al menos dada por esa UUID. Desde luego si existe no es accesible... :roll:

1)No creo que por lo de hacer una reparación del sistema para devolverlo a su estado originall fuera restaurar el sistema al estado de fábrica, ya que esto también afectaría a la partición EFI....Si restauraste sólo Windows debes hacer memoria según la fecha de la restauración de Windows elegida si fué anterior a la instalación de MInt y/o si tuviste que hacer cambios en Windows para instalar/iniciar con Mint...
Dependerá del punto de restauración que usaras para Windows y de cómo estaba el particionado en ese momento que no haya/n sido fulminada/s la/s particion/es de Linux...

Tal vez sólo sea a que en ese punto tuvieras activado el RST(RAID) y que después lo cambiaste para acceder con el modo SATA AHCI para instalar Mint ya que aparecen varios errores referentes a un RAID en los intentos por localizar/acceder a la partición de Mint.
2)Deberás confirmar, en cualquier caso, que las particiones de Linux están presentes en ese disco cosa que puedes hacer desde el Administrador de discos del propio Windows. También asegura que en Windows permanece desactivado el inicio rápido.

3)Todo tiene su origen en la actualización del Firmware lo que sugiere que el primer problema quizás sólamente requería que revisaras la configuración de la UEFI/BIOS tras la actualización para corregir posibles cambios. Si existen las particiones de Linux o si debes reinstalarlo aún debes hacerlo.
Además de las condiciones normales para el inicio UEFI (Modo de inicio UEFI, CSM desactivado, fast boot desactivado... asegúrate que en las opciones Avanzadas(Advanced)>Configuración SATA está en AHCI y/o desactiva el modo RST /Raid si no tenías definido un verdadero RAID en el SSD (tal vez en la configuración de la tarjeta PCI/PCH Configuration si no está ahí).

De poder iniciar Mint cambiando esto quizás no podrás iniciar Windows sin activarlo de nuevo y repetir las modificaciones que hiciste en Windows en su día.
4)De no aparecer la partición de Linux, pese a los cambios en la BIOS/UEFI y en Windows (ten en cuenta que la restauración de instantáneas de Timeshift que tuvieras guardadas en otro disco/partición no sería posible sin una instalación preexistente de Linux Mint aunque esté chafada) sería un trabajo para Testdisk que está instalado por defecto en el live ... o pensar en reinstalar :(
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.(Javier Krahe)
Post Reply

Return to “Español (Spanish)”