Cómo activar el inicio de sesion automática

Spanish Forum

Moderators: tomeu, JCSenar

Post Reply
apokrell
Level 1
Level 1
Posts: 2
Joined: Mon Jan 27, 2020 12:13 pm

Cómo activar el inicio de sesion automática

Post by apokrell »

i have similar problem here
cant disable the login at the starup point , dont know what to do
Last edited by JCSenar on Thu Sep 24, 2020 8:07 am, edited 1 time in total.
Reason: Tema separado, título corregido y enlace añadido
User avatar
JOPETA
Level 17
Level 17
Posts: 7412
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Inicio de sesion automática

Post by JOPETA »

apokrell wrote:
Wed Sep 23, 2020 8:22 am
i have similar problem here
cant disable the login at the starup point , dont know what to do
That's an old thread, when mdm was been replaced by ligtdm as default dm in LM 18.2, and you have installed LM 19 as per this other post in January. Any way, first you will need to be sure lightdm is installed an it is set as default dm (cat /etc/X11/default-display-manager).

If you don't want to see the login window (i.e. automatic login or auto-login) you will need to change Login Window settings. Click on Menu>Control center>Login Window>Users>Automatic login . Write your user name in there (w/o capital letters) and set Delay (timeout) to 0 seconds . Click on next image to enlarge.
Captura de pantalla_2020-09-23_17-42-22.png


or from a terminal (Alt+Ctrl+T) editing /etc/lightdm/lightdm.conf file.
Just copy and paste following code

Code: Select all

xed admin:////etc/lightdm/lightdm.conf
Change the lines in [Seat:*]. Uncomment the lines by removing the “#” in front of each line if any.
[Seat:*]
autologin-guest=false
autologin-user-timeout=0
allow-guest=false
autologin-user=your_user
Save changes and close editor.
Then reboot. :wink:

If login window still appears at start-up, be sure there is no other dm (apt list --installed *dm) installed and your user belong to nopasswdlogin group as per id (if he doesn't, you can add him with sudo adduser your_user nopasswdlogin).

Similar problems are also reported after certain software updates/upgrades and most of then had been solved after reinstalling and reconfiguring lightdm:

Code: Select all

apt reinstall lightdm lightdm-settings slick-greeter && sudo dpkg-reconfigure lightdm
Any way, provide some details about your system (look here, point 5 in particular), and do not forget to mention if theres is anoter desktop installed (multidesktop environment), single user/multiuser installation, if guest account/kiosk mode is enabled,...

______________________________________________

Por coherencia con el foro la traducción al español de mi respuesta por si sirve a alguien.
apokrell wrote:
Wed Sep 23, 2020 8:22 am
Tengo un problema similar aquí.
No puedo desactivar el inicio (ventana) al inicio de la sesison. No se qué puedo hacer.
Ese es un hilo antiguo, cuando mdm fue reemplazado por lightdm como ventana de inicio (en adelante dm de Display Manager que significa algo parecido) predeterminado en LM 18.2, y tu has instalado LM 19 según este post de enero. De cualquier forma, primero deberás asegurarte de que lightdm esté instalado y configurado como dm predeterminado (cat /etc/X11/default-display-manager).

Si no deseas ver la ventana de inicio de sesión (es decir, inicio de sesión automático o autologin), deberás cambiar la configuración de la ventana de inicio de sesión .
Haz clic en Menú>Centro de control>Ventana de inicio>Usuarios>Inicio de sesión automático . Escribe tu nombre de usuario ahí (sin letras mayúsculas) y configura un retraso (tiempo de espera) de 0 segundos. Haz clic en la siguiente imagen para ampliar.
Ventana de inicio LM19.3 .png
o desde la terminal (Alt+Ctrl+T) editando el achivo /etc/lightdm/lightdm.conf:
Simplemente copie y pegue el siguiente código

Code: Select all

xed admin:////etc/lightdm/lightdm.conf
Cambia las líneas en [Seat:*]. Quita el comentario de las líneas eliminando el "#" delante de cada línea, si corresponde.
[Seat: *]
autologin-guest=false
autologin-user-timeout= 0
allow-guest=false
autologin-user=
your_user
Guarda los cambios y cierre el editor.
Luego reincia. :wink

Si la ventana de logueo aún aparece al inicio, asegúrate de que no tienes instalado otro dm (apt list --installed *dm) y que tu usuario pertenece al grupo nopasswdlogin con id (si no pertenece puedes añadirlo con sudo adduser your_user nopasswdlogin).

Problemas similares tambien han sido informados después de la actualización/upgrade de cierto software y la mayoría de la veces se resolvió tras reinstalar y reconfigurar lightdm:

Code: Select all

apt reinstall lightdm lightdm-settings slick-greeter && sudo dpkg-reconfigure lightdm
De todas formas, proporciona algunos detalles sobre tu sistema (mira aquí), y no olvides mencionar si tienes instalado otro escritorio (entorno multi-escritorio), si tu instalación es mono/multiusuario, si tienes activada la sesión de invitados/modo kiosco,...

(edited) Gracias JCSenar. :wink:
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.(Javier Krahe)
Post Reply

Return to “Español (Spanish)”