Mint 20 tarda en arrancar

Spanish Forum

Moderators: tomeu, JCSenar

Post Reply
marhcos
Level 1
Level 1
Posts: 2
Joined: Tue Oct 13, 2020 12:09 pm

Mint 20 tarda en arrancar

Post by marhcos »

Hola a todos, instalé linux Mint 20 y el arranque es lento, una vez que entra al sistema todo funciona bien. Les paso los resultados para ver si alguien me puede ayudar La notebook es una lenovo g480 y no tengo grandes conocimientos en linux. Muchas gracias.

Code: Select all

marcos@marcos-Lenovo-G480:~$ systemd-analyze
Startup finished in 9.637s (kernel) + 37.910s (userspace) = 47.548s 
graphical.target reached after 37.892s in userspace

Code: Select all

systemd-analyze critical-chain
The time when unit became active or started is printed after the "@" character.
The time the unit took to start is printed after the "+" character.

graphical.target @37.892s
└─udisks2.service @22.550s +15.340s
  └─basic.target @21.899s
    └─sockets.target @21.899s
      └─uuidd.socket @21.899s
        └─sysinit.target @21.764s
          └─apparmor.service @18.724s +3.040s
            └─local-fs.target @18.722s
              └─boot-efi.mount @18.616s +106ms
                └─systemd-fsck@dev-disk-by\x2duuid-AEDA\x2dF9DB.service @17.408s +1.170s
                  └─dev-disk-by\x2duuid-AEDA\x2dF9DB.device @17.407s

Code: Select all

systemd-analyze blame
15.517s networkd-dispatcher.service                          
15.340s udisks2.service                                      
11.586s dev-sda5.device                                      
10.778s accounts-daemon.service                              
 8.230s polkit.service                                       
 7.976s avahi-daemon.service                                 
 7.955s NetworkManager.service                               
 7.916s ubuntu-system-adjustments.service                    
 7.390s thermald.service                                     
 7.385s systemd-logind.service                               
 7.380s wpa_supplicant.service                               
 6.274s lightdm.service                                      
 6.265s plymouth-quit-wait.service                           
 5.742s systemd-journal-flush.service                        
 4.697s gpu-manager.service                                  
 4.392s networking.service                                   
 3.775s ModemManager.service                                 
 3.765s rsyslog.service                                      
 3.526s systemd-udevd.service                                
 3.369s systemd-resolved.service                             
 3.342s grub-common.service                                  
 3.040s apparmor.service                                     
 3.028s hddtemp.service                                      
 2.837s e2scrub_reap.service                                 
 2.829s grub-initrd-fallback.service                         
 1.514s systemd-modules-load.service                         
 1.489s alsa-restore.service                                 
 1.349s lm-sensors.service                                   
 1.289s systemd-tmpfiles-setup-dev.service                   
 1.170s systemd-fsck@dev-disk-by\x2duuid-AEDA\x2dF9DB.service
 1.161s systemd-sysusers.service                             
 1.151s systemd-tmpfiles-setup.service                       
 1.142s systemd-sysctl.service                               
 1.005s keyboard-setup.service                               
  993ms user@1000.service                                    
  931ms colord.service                                       
  921ms dns-clean.service                                    
  816ms systemd-random-seed.service                          
  813ms pppd-dns.service                                     
  671ms ifupdown-pre.service                                 
  651ms systemd-udev-trigger.service                         
  650ms upower.service                                       
  639ms systemd-backlight@backlight:intel_backlight.service  
  630ms systemd-rfkill.service                               
  549ms ufw.service                                          
  507ms kerneloops.service                                   
  377ms swapfile.swap                                        
  351ms rtkit-daemon.service                                 
  311ms systemd-timesyncd.service                            
  291ms dev-hugepages.mount                                  
  290ms dev-mqueue.mount                                     
  289ms sys-kernel-debug.mount                               
  287ms sys-kernel-tracing.mount                             
  284ms blk-availability.service                             
  283ms systemd-journald.service                             
  281ms kmod-static-nodes.service                            
  281ms lvm2-monitor.service                                 
  250ms setvtrgb.service                                     
  172ms systemd-remount-fs.service                           
  137ms systemd-tmpfiles-clean.service                       
  134ms console-setup.service                                
  106ms boot-efi.mount                                       
   99ms systemd-update-utmp.service                          
   95ms plymouth-read-write.service                          
   28ms systemd-user-sessions.service                        
   21ms user-runtime-dir@1000.service                        
   17ms plymouth-start.service                               
   14ms systemd-update-utmp-runlevel.service                 
    7ms finalrd.service                                      
    5ms sys-fs-fuse-connections.mount                        
    5ms openvpn.service                                      
    4ms sys-kernel-config.mount 

Code: Select all

$ dmesg | grep -i "error\|warn\|fail\|microcode\|firmware" 
[    0.000000] microcode: microcode updated early to revision 0x21, date = 2019-02-13
[    0.101657] Spectre V2 : Enabling Restricted Speculation for firmware calls
[    0.133378] ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
[    0.142766] acpi PNP0A08:00: _OSC failed (AE_ERROR); disabling ASPM
[    2.305225] pci 0000:00:1a.0: EHCI: BIOS handoff failed (BIOS bug?) 01010001
[    4.305225] pci 0000:00:1d.0: EHCI: BIOS handoff failed (BIOS bug?) 01010001
[    4.606442] RAS: Correctable Errors collector initialized.
[    4.606475] microcode: sig=0x306a9, pf=0x10, revision=0x21
[    4.606543] microcode: Microcode Update Driver: v2.2.
[    4.781325] ACPI Warning: SystemIO range 0x0000000000000428-0x000000000000042F conflicts with OpRegion 0x0000000000000400-0x000000000000047F (\PMIO) (20190816/utaddress-204)
[    4.781337] ACPI Warning: SystemIO range 0x0000000000000540-0x000000000000054F conflicts with OpRegion 0x0000000000000500-0x0000000000000563 (\GPIO) (20190816/utaddress-204)
[    4.781344] ACPI Warning: SystemIO range 0x0000000000000530-0x000000000000053F conflicts with OpRegion 0x0000000000000500-0x0000000000000563 (\GPIO) (20190816/utaddress-204)
[    4.781350] ACPI Warning: SystemIO range 0x0000000000000500-0x000000000000052F conflicts with OpRegion 0x0000000000000500-0x0000000000000563 (\GPIO) (20190816/utaddress-204)
[    9.051219] random: 7 urandom warning(s) missed due to ratelimiting
[   15.537259] EXT4-fs (sda5): re-mounted. Opts: errors=remount-ro
User avatar
Wibol
Level 5
Level 5
Posts: 552
Joined: Fri Nov 27, 2015 7:00 am
Location: España

Re: Mint 20 tarda en arrancar

Post by Wibol »

15.340s udisks2.service
11.586s dev-sda5.device
Comparando esos tiempos con los míos, tu sistema está invirtiendo unos 25 segundos extra iniciando servicios relacionados con el disco o controladora. Yo probaría algún otro kernel más antiguo o moderno del que estás usando.

De todos modos y para ser más concretos, proporciona la salida del comando:

Code: Select all

inxi -Fxznr

Antes de realizar una consulta, no olvides:
marhcos
Level 1
Level 1
Posts: 2
Joined: Tue Oct 13, 2020 12:09 pm

Re: Mint 20 tarda en arrancar

Post by marhcos »

Gracias por la respuesta, te cuento, hoy se me actualizó el kernel pero no hubo cambios. Te paso lo que me pediste.

Code: Select all

$ inxi -Fxznr
System:
  Kernel: 5.4.0-51-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 
  Desktop: Cinnamon 4.6.7 Distro: Linux Mint 20 Ulyana 
  base: Ubuntu 20.04 focal 
Machine:
  Type: Laptop System: LENOVO product: 20150 v: Lenovo G480 serial: <filter> 
  Mobo: LENOVO model: INVALID v: 31900004WIN8 STD SGL serial: <filter> 
  UEFI [Legacy]: LENOVO v: 5ECN95WW(V9.00) date: 12/19/2012 
CPU:
  Topology: Dual Core model: Intel Core i3-3120M bits: 64 type: MT MCP 
  arch: Ivy Bridge rev: 9 L2 cache: 3072 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19953 
  Speed: 1197 MHz min/max: 1200/2500 MHz Core speeds (MHz): 1: 1308 2: 1270 
  3: 1356 4: 1260 
Graphics:
  Device-1: Intel 3rd Gen Core processor Graphics vendor: Lenovo 
  driver: i915 v: kernel bus ID: 00:02.0 
  Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2) 
  v: 4.2 Mesa 20.0.8 direct render: Yes 
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Sound Server: ALSA v: k5.4.0-51-generic 
Network:
  Device-1: Qualcomm Atheros AR8162 Fast Ethernet vendor: Lenovo driver: alx 
  v: kernel port: 2000 bus ID: 01:00.0 
  IF: enp1s0 state: down mac: <filter> 
  Device-2: Qualcomm Atheros AR9485 Wireless Network Adapter vendor: Lenovo 
  driver: ath9k v: kernel port: 2000 bus ID: 02:00.0 
  IF: wlp2s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 149.05 GiB used: 20.54 GiB (13.8%) 
  ID-1: /dev/sda vendor: Western Digital model: WD1600BEVT-75A23T0 
  size: 149.05 GiB 
Partition:
  ID-1: / size: 145.21 GiB used: 20.54 GiB (14.1%) fs: ext4 dev: /dev/sda5 
Sensors:
  System Temperatures: cpu: 50.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
Repos:
  No active apt repos in: /etc/apt/sources.list 
  Active apt repos in: /etc/apt/sources.list.d/additional-repositories.list 
  1: deb https://cloud.r-project.org/bin/linux/ubuntu focal-cran40/
  Active apt repos in: /etc/apt/sources.list.d/brave-browser-release.list 
  1: deb [arch=amd64] https://brave-browser-apt-release.s3.brave.com/ stable main
  Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list 
  1: deb http://packages.linuxmint.com ulyana main upstream import backport #id:linuxmint_main
  2: deb http://archive.ubuntu.com/ubuntu focal main restricted universe multiverse
  3: deb http://archive.ubuntu.com/ubuntu focal-updates main restricted universe multiverse
  4: deb http://archive.ubuntu.com/ubuntu focal-backports main restricted universe multiverse
  5: deb http://security.ubuntu.com/ubuntu/ focal-security main restricted universe multiverse
  6: deb http://archive.canonical.com/ubuntu/ focal partner
Info:
  Processes: 202 Uptime: 2h 17m Memory: 5.68 GiB used: 1.34 GiB (23.7%) 
  Init: systemd runlevel: 5 Compilers: gcc: 9.3.0 Shell: bash v: 5.0.17 
  inxi: 3.0.38 
User avatar
Wibol
Level 5
Level 5
Posts: 552
Joined: Fri Nov 27, 2015 7:00 am
Location: España

Re: Mint 20 tarda en arrancar

Post by Wibol »

La actualización recibida del kernel sería dentro de la rama 5.4 que es la que estás usando. Lo que quería decir es que instales manualmente una rama diferente del kernel como puede ser la 4.15 (si es que está disponible en Linux Mint 20, ya que aún no lo he probado y desconozco las ramas suministradas) e iniciar el sistema usando ese nuevo kernel según se indica en el tutorial para comparar los tiempos.

Si todo continúa igual, habría que buscar otras causas.

Antes de realizar una consulta, no olvides:
User avatar
JOPETA
Level 17
Level 17
Posts: 7232
Joined: Thu Nov 20, 2014 6:10 am
Location: En un lugar de cuyo nombre no quiero acordarme

Re: Mint 20 tarda en arrancar

Post by JOPETA »

Proprociona tambien el resultado de cat /proc/cmdline para estar seguros, pero parece que ese kernel no casa muy bien con tu BIOS ( varios bugs) como indica Wibol.

Aparecen errores relacionado con el soporte EHCI de los dispositivos USB. Asegura que no tienes ningún dispositivo USB conectado cuando inicies ( son conocidos causantes de retraso en el inicio) y/o desactiva el EHCI handoff en la configuración del USB, normalmente en las opciones Avanzadas (advanced) de la BIOS.

Además parece que tiene problemas con el disco duro y/o acceso a la partición raiz. Asegura en la BIOS que la confguración SATA es AHCI y comprueba la aparición de sectores defectusoso o avisos de fallo inminente en Menú>Accesorios>Discos. Proprociona tambien el resultado de sudo fsdisk -l; sudo bkid.

La BIOS está muy desfasada (2012 cuando existen actualizaciones hasta del 2017 para determinados modelos) y entiendo que es una operación no exenta de reiesgos actualizarla.

Dado que en LM 20 no estan disponibles los kernels anteriores al 5.4 (solo el 5.8 ), siguiendo con la recomendación de Wibol tal vez sea interesante, descartado todo lo anterior, considerar la instalación de una edición con ese kernel 4.15 mas adecuado (Linux Mint 19 o 19.1). :roll:
Ni cola de león ni cabeza de ratón, prefiero ser diente de ajo.(Javier Krahe)
Post Reply

Return to “Español (Spanish)”