Page 1 of 1

Erro instalar VLC

Posted: Mon Nov 10, 2014 8:45 pm
by Avolta
Boas, ontem a fazer as actualizações do Linux Mint 17, reparei que o VLC deixou de funcionar.

Ao fazer o comando:

Code: Select all

sudo apt-get install vlc 
apareceu o seguinte
Os pacotes a seguir têm dependências não satisfeitas:
vlc : Depende: vlc-nox (= 3.0.0~~git20141110+r58561+31~ubuntu14.04.1) mas não vai ser instalado
Depende: libavcodec55 (>= 6:9.1-1) mas não é instalável ou
libavcodec-extra-55 (>= 6:10~~git20131218.b3189af~ubuntu14.04.1) mas não é instalável
Depende: libavutil53 (>= 6:9.1-1) mas não é instalável
E: Não foi possível corrigir problemas, você tem pacotes mantidos (hold) estragados.
Quando tentei instalar pelo site da VLC apareceu o erro:
Não foi possível efectuar alterações!
Precisa de resolver os pacotes quebrados.
Já utilizei codigo como

Code: Select all

sudo apt-get autoremove
E o erro mantem-se

Já estive a pesquisar na net e não consigo resolver este problema

Alguem me dá alguma dica do que devo fazer?
Desde já o meu obrigado

Re: Erro instalar VLC

Posted: Thu Dec 04, 2014 6:49 pm
by harouca
Acontece comigo o mesmo.

Os pacotes a seguir têm dependências desencontradas:
vlc : Depende: vlc-nox (= 3.0.0~~git20141204+r58837+31~ubuntu14.04.1) mas não será instalado
Depende: libavcodec55 (>= 6:9.1-1) mas não é instalável ou
libavcodec-extra-55 (>= 6:10~~git20131218.b3189af~ubuntu14.04.1) mas não é instalável
Depende: libavutil53 (>= 6:9.1-1) mas não é instalável
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.


Tentei voltar para a versão anterior mas nada feito. Por favor, alguém com uma solução.

Re: Erro instalar VLC

Posted: Sun Apr 19, 2015 8:11 am
by Tonnux
harouca wrote:Acontece comigo o mesmo.

Os pacotes a seguir têm dependências desencontradas:
vlc : Depende: vlc-nox (= 3.0.0~~git20141204+r58837+31~ubuntu14.04.1) mas não será instalado
Depende: libavcodec55 (>= 6:9.1-1) mas não é instalável ou
libavcodec-extra-55 (>= 6:10~~git20131218.b3189af~ubuntu14.04.1) mas não é instalável
Depende: libavutil53 (>= 6:9.1-1) mas não é instalável
E: Impossível corrigir problemas, você manteve (hold) pacotes quebrados.


Tentei voltar para a versão anterior mas nada feito. Por favor, alguém com uma solução.
Sou do princípio que devemos fazer os possíveis para reparar um sistema. Com isto adquirimos mais conhecimentos acerca desse mesmo sistema.

Contudo, há algumas respostas que só podem ser dadas pelos gurus do linux. Já tenho apanhado casos de fazer todo o procedimento certo para a reparação, mas eis que surgem mais erros e/ou aparecem mais dependências não satisfeitas. Acaba por se entrar num ciclo vicioso. Quanto ao VLC não fazia diferente do fizeram.

Se me permitem dou uma sugestão: aquando da instalação do SO criem sempre uma partição separada /home (a pasta pessoal é instalada aqui automaticamente). Ajuda a manter os dados pessoais mais protegidos. Se tiver que haver uma reinstalação do sistema, os dados ficam protegidos e, depois, acessíveis. Já me sucedeu noutras distros ter que reinstalar o sistema várias vezes e a experiência mostrou-me que é melhor criar a tal partição separada /home.

Edit: Em relação ao software extra instalado, é melhor fazer uma lista, à medida que se instala, para, aquando de uma possível reinstalação do sistema, ser mais rápida a sua instalação, sem esquecimentos.

Re: Erro instalar VLC

Posted: Fri May 29, 2015 10:12 am
by legloas
Vá no gerenciador de pacotes, busque por vlc e marque para remover completamente, após feito, instale novamente para ver se resolve.

Re: Erro instalar VLC

Posted: Sat Jun 16, 2018 12:13 pm
by Tonho
Espero que resolvas. Normalmente basta remover o aplicativo e instalá-lo novamente.
Vale lembrar que o mpv Player está no repositório e é um tanto melhor.