Обновил ядро, система перестала загружаться[РЕШЕНО]

Здесь русские пользователи могут говорить на своем родном языке
Post Reply
warbear
Level 1
Level 1
Posts: 30
Joined: Fri Jan 01, 2021 9:49 am

Обновил ядро, система перестала загружаться[РЕШЕНО]

Post by warbear »

Установил LM 19.3 на ноут HP Pavilion 15-ec1046ur, обновил ядро до 5.0 - не ловит wi-fi; нашёл дрова, но дрова проверены на ядре 5.4 - ладно, обновляем ядро ещё раз. После перезагрузки получаю на старте вот это:

5.409235] cgroup1: Unknown subsys name '__DEVEL__sane_behaivior'
5.520141] nvidia-gpu 0000:01:00.3: i2c timeout error e0000000
5.530181] ucsi_ccg 1-0008: i2c transfer failed -110
5.530209] ucsi_ccg 1-0008: ucsi_ccg_init failed - -110
5.557097] cgroup1: Unknown subsys name '__DEVEL__sane_behaivior'
15.099008] rtw_pci 0000:03:00.0: failed to wait firmware completion

последняя строчка много раз повторена.
Вопрос: что делать?
P.S. Нет, я не могу сейчас вывести inxi -Fxz.
Last edited by warbear on Sat Jan 02, 2021 6:18 pm, edited 1 time in total.
sleeper12
Level 16
Level 16
Posts: 6546
Joined: Thu May 25, 2017 3:22 pm

Re: Обновил ядро, система перестала загружаться

Post by sleeper12 »

Какое ядро ​​вы сейчас используете?

Code: Select all

 uname -r 
Можете ли вы удалить старые ядра, которые больше не используются?
warbear
Level 1
Level 1
Posts: 30
Joined: Fri Jan 01, 2021 9:49 am

Re: Обновил ядро, система перестала загружаться

Post by warbear »

Всё как-то само наладилось. Не знаю, как. Система работает, сетку ловит.
warbear
Level 1
Level 1
Posts: 30
Joined: Fri Jan 01, 2021 9:49 am

Re: Обновил ядро, система перестала загружаться

Post by warbear »

UPD.
Система висла, и ничего с ней сделать нельзя было. Она не давала набрать никакие команды - только выключить ноут. Попытался выйти в меню загрузки ESC+ВКЛ > F9 и загрузиться через файл EFI. Там у меня была директория, оставшаяся ещё от FreeDos, пустая, и три новых, появившихся после установки Linux Mint; debian, BOOT и linux. Попробовал все три. В debian и linux лежат файлы grub.efi, один из них - не помню, какой, - даёт всё то же самое, другой выводит в меню grub resque. Там мне тоже ничего не удалось. В директории BOOT не помню, как файл называется, тоже .efi - вот он дал возможность загрузить Linux или загрузить её с дополнительными опциями; я выбрал второе - попал в меню выбора ядер. Выбрал 5.0.0-32-generic, стоявшее перед 5.4. УРА, ЗАРРАБОТАЛА! И даже вай-фай подхватила. Ну лады. Перезагружаю компьютер. Пытаюсь загрузиться, как и в прошлый раз. Ну, т. е., прямо иду EFI/BOOT/что-там-лежит.efi -
- а хрен там плавал! Опять ошибка, ноут виснет.
Раза с пятного, сначала зайдя в grub resque, смог загрузить нужное мне ядро.

Теперь такой вопрос: вот если я сейчас ядро 5.4 удалю, у меня опять сетка отвалится? Она же появилась после того, как я его поставил. И дрова для видеокарты менеджер дров стал видеть - правда, всё ещё не готов их устанавливать, но раньше-то он вообще считал, что мне никаких дров не надо и никакой видеокарты у меня нет. Ноут выключать боюсь: часа два его перезапустить пытался.

Такие дела.
Всё ещё нужна помощь, короче.
sleeper12
Level 16
Level 16
Posts: 6546
Joined: Thu May 25, 2017 3:22 pm

Re: Обновил ядро, система перестала загружаться

Post by sleeper12 »

Итак, вы сейчас используете ядро ​​5.4?

Ядро 5.0 устарело и больше не поддерживается. Вы должны использовать 5.4 или даже 4.15, если ваша машина старая.
warbear
Level 1
Level 1
Posts: 30
Joined: Fri Jan 01, 2021 9:49 am

Re: Обновил ядро, система перестала загружаться

Post by warbear »

Я сейчас на ядре 5.0; машина у меня не такая уж старая - HP Pavilion 15-ec1046ur, я написал о ней выше, в первом сообщении. Работаю на том, что работает. 5.0 работает, 5.4 - нет.
warbear
Level 1
Level 1
Posts: 30
Joined: Fri Jan 01, 2021 9:49 am

Re: Обновил ядро, система перестала загружаться

Post by warbear »

$ inxi -Fxxxzr
System:
Host: nameLaptop Kernel: 5.0.0-32-generic x86_64 bits: 64 compiler: gcc
v: 7.4.0 Desktop: Xfce 4.14.1 tk: Gtk 3.22.30 info: xfce4-panel wm: xfwm4
dm: LightDM 1.26.0 Distro: Linux Mint 19.3 Tricia
base: Ubuntu 18.04 bionic
Machine:
Type: Laptop System: HP product: HP Pavilion Gaming Laptop 15-ec1xxx
v: N/A serial: <filter> Chassis: type: 10 serial: <filter>
Mobo: HP model: 87B3 v: 31.20 serial: <filter> UEFI: AMI v: F.11
date: 07/22/2020
Battery:
ID-1: BAT0 charge: 50.3 Wh condition: 50.3/50.3 Wh (100%) volts: 13.1/11.6
model: Hewlett-Packard Primary type: Li-ion serial: <filter> status: Full
cycles: 452
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M315/235/317
serial: <filter> charge: 100% rechargeable: yes status: Discharging
CPU:
Topology: 8-Core model: AMD Ryzen 7 4800H with Radeon Graphics bits: 64
type: MT MCP arch: Zen rev: 1 L2 cache: 4096 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
bogomips: 92628
Speed: 1398 MHz min/max: 1400/2900 MHz boost: enabled Core speeds (MHz):
1: 1397 2: 1397 3: 1384 4: 1366 5: 1437 6: 1541 7: 1292 8: 1361 9: 1397
10: 1397 11: 1397 12: 1396 13: 1396 14: 1397 15: 1313 16: 1212
Graphics:
Device-1: NVIDIA vendor: Hewlett-Packard driver: N/A bus ID: 01:00.0
chip ID: 10de:2191
Device-2: AMD vendor: Hewlett-Packard driver: N/A bus ID: 05:00.0
chip ID: 1002:1636
Display: x11 server: X.Org 1.19.6 driver: ati,fbdev
unloaded: modesetting,radeon,vesa resolution: 1024x768~76Hz
OpenGL: renderer: llvmpipe (LLVM 10.0.0 128 bits) v: 3.3 Mesa 20.0.8
compat-v: 3.1 direct render: Yes
Audio:
Device-1: NVIDIA vendor: Hewlett-Packard driver: snd_hda_intel v: kernel
bus ID: 01:00.1 chip ID: 10de:1aeb
Device-2: AMD vendor: Hewlett-Packard driver: N/A bus ID: 05:00.5
chip ID: 1022:15e2
Device-3: AMD vendor: Hewlett-Packard driver: snd_hda_intel v: kernel
bus ID: 05:00.6 chip ID: 1022:15e3
Sound Server: ALSA v: k5.0.0-32-generic
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Hewlett-Packard driver: r8169 v: kernel port: e000 bus ID: 02:00.0
chip ID: 10ec:8168
IF: eno1 state: down mac: <filter>
Device-2: Realtek vendor: Hewlett-Packard driver: rtw_pci v: N/A
port: d000 bus ID: 03:00.0 chip ID: 10ec:c822
IF: wlo1 state: up mac: <filter>
Drives:
Local Storage: total: 476.94 GiB used: 32.09 GiB (6.7%)
ID-1: /dev/nvme0n1 vendor: Western Digital
model: PC SN530 SDBPNPZ-512G-1006 size: 476.94 GiB speed: 31.6 Gb/s
lanes: 4 serial: <filter> rev: HPS2 scheme: GPT
Partition:
ID-1: / size: 453.72 GiB used: 32.07 GiB (7.1%) fs: ext4
dev: /dev/nvme0n1p2
ID-2: swap-1 size: 15.36 GiB used: 0 KiB (0.0%) fs: swap
dev: /dev/nvme0n1p3
Sensors:
Message: No sensors data was found. Is sensors configured?
Repos:
No active apt repos in: /etc/apt/sources.list
Active apt repos in: /etc/apt/sources.list.d/official-package-repositories.list
1: deb http://packages.linuxmint.com tricia main upstream import backport #id:linuxmint_main
2: deb http://archive.ubuntu.com/ubuntu bionic main restricted universe multiverse
3: deb http://archive.ubuntu.com/ubuntu bionic-updates main restricted universe multiverse
4: deb http://archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse
5: deb http://security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
6: deb http://archive.canonical.com/ubuntu/ bionic partner
Info:
Processes: 289 Uptime: 1h 33m Memory: 15.09 GiB used: 1.86 GiB (12.3%)
Init: systemd v: 237 runlevel: 5 default: 2 Compilers: gcc: 7.5.0 alt: 5/7
Shell: bash v: 4.4.20 running in: xfce4-terminal inxi: 3.0.32
sleeper12
Level 16
Level 16
Posts: 6546
Joined: Thu May 25, 2017 3:22 pm

Re: Обновил ядро, система перестала загружаться

Post by sleeper12 »

У вас новый компьютер, почему бы не попробовать Mint 20.
warbear
Level 1
Level 1
Posts: 30
Joined: Fri Jan 01, 2021 9:49 am

Re: Обновил ядро, система перестала загружаться

Post by warbear »

Я думал об этом, но после того, как это обновление ядра принесло мне столько ярких впечатлений, переходить на более новую версию LM я побаиваюсь. Не говоря уже о том, что в инструкции по установке LM 20 пишут, что там надо хорошо знать apt и уметь читать, что он там пишет, а я в линуксе новичок и в apt не смыслю ровным счётом ничего.
sleeper12
Level 16
Level 16
Posts: 6546
Joined: Thu May 25, 2017 3:22 pm

Re: Обновил ядро, система перестала загружаться

Post by sleeper12 »

Вы можете попробовать Mint 20 вживую, прежде чем устанавливать его, чтобы узнать, работает ли он для вас. Просто мысль.
warbear
Level 1
Level 1
Posts: 30
Joined: Fri Jan 01, 2021 9:49 am

Re: Обновил ядро, система перестала загружаться

Post by warbear »

Мысль хорошая, но прямо сейчас у меня нет флешки, чтоб записать на неё дистрибутив LM 20.
sleeper12
Level 16
Level 16
Posts: 6546
Joined: Thu May 25, 2017 3:22 pm

Re: Обновил ядро, система перестала загружаться

Post by sleeper12 »

Хорошо, если вы останетесь с 19.3, попробуйте ядро ​​4.15. Если это работает для вас, по крайней мере, он все еще поддерживается.
warbear
Level 1
Level 1
Posts: 30
Joined: Fri Jan 01, 2021 9:49 am

Re: Обновил ядро, система перестала загружаться

Post by warbear »

А на 4.15 у меня не работал Wi-Fi. Для чего всё затевалось-то: чтобы Wi-Fi заработал.
sleeper12
Level 16
Level 16
Posts: 6546
Joined: Thu May 25, 2017 3:22 pm

Re: Обновил ядро, система перестала загружаться

Post by sleeper12 »

Это странно. Я не знаю, почему вам не подходят 5,4 или 4,15. Оставайтесь с 5.0, пока не сможете протестировать Mint 20.
User avatar
Labuzhskiy
Level 3
Level 3
Posts: 167
Joined: Fri Aug 23, 2013 12:38 am
Location: RU:ru

Re: Обновил ядро, система перестала загружаться

Post by Labuzhskiy »

warbear wrote:
Fri Jan 01, 2021 4:25 pm
UPD.
Система висла, и ничего с ней сделать нельзя было. Она не давала набрать никакие команды - только выключить ноут. Попытался выйти в меню загрузки ESC+ВКЛ > F9 и загрузиться через файл EFI. Там у меня была директория, оставшаяся ещё от FreeDos, пустая, и три новых, появившихся после установки Linux Mint; debian, BOOT и linux. Попробовал все три. В debian и linux лежат файлы grub.efi, один из них - не помню, какой, - даёт всё то же самое, другой выводит в меню grub resque. Там мне тоже ничего не удалось. В директории BOOT не помню, как файл называется, тоже .efi - вот он дал возможность загрузить Linux или загрузить её с дополнительными опциями; я выбрал второе - попал в меню выбора ядер. Выбрал 5.0.0-32-generic, стоявшее перед 5.4. УРА, ЗАРРАБОТАЛА! И даже вай-фай подхватила. Ну лады. Перезагружаю компьютер. Пытаюсь загрузиться, как и в прошлый раз. Ну, т. е., прямо иду EFI/BOOT/что-там-лежит.efi -
- а хрен там плавал! Опять ошибка, ноут виснет.
Раза с пятного, сначала зайдя в grub resque, смог загрузить нужное мне ядро.

Теперь такой вопрос: вот если я сейчас ядро 5.4 удалю, у меня опять сетка отвалится? Она же появилась после того, как я его поставил. И дрова для видеокарты менеджер дров стал видеть - правда, всё ещё не готов их устанавливать, но раньше-то он вообще считал, что мне никаких дров не надо и никакой видеокарты у меня нет. Ноут выключать боюсь: часа два его перезапустить пытался.

Такие дела.
Всё ещё нужна помощь, короче.
warbear wrote:
Fri Jan 01, 2021 10:18 am
...
5.520141] nvidia-gpu 0000:01:00.3: i2c timeout error e0000000
...
Решил тоже мыслями своими поделиться на эту тему: Думаю что причина такого поведения системы в ошибке вызванной свободной версией драйвера nvidia. Надо бы попробовать создать снимок текущей системы в TimeShift и перейти на рекомендованную версию проприетарного NVidia драйвера.
Пару дней назад во время копирования данных через mc в Linux Mint 20 Cinnamon 64-bit тоже потерял контроль управления над ОС. И не мог переключаться между сеансами tty с клавиатуры чтобы поправить. Видеодрайвер стал крашиться, экран поделился на 4 фрагмента. Система перешла в "слепой режим управления". Решилось холодной перезагрузкой с последующей заменой xserver-xorg-video-nouveau (свободный) на nvidia-driver-455 (рекомендованный) через встроенный менеджер драйверов для NVIDIA Corporation GP107GL [Quadro P400].
warbear
Level 1
Level 1
Posts: 30
Joined: Fri Jan 01, 2021 9:49 am

Re: Обновил ядро, система перестала загружаться

Post by warbear »

Labuzhskiy wrote:
Sat Jan 02, 2021 1:13 am
Думаю что причина такого поведения системы в ошибке вызванной свободной версией драйвера nvidia.
Вполне возможно, так оно и было, но дрова не обновлялись. Видеть их менеджер дров видел, а обновлять не хотел, выдавал ошибку. Мне действительно пришлось перейти на Linux Mint 20 и обновить ядро до 5.8 с чем-то, и только тогда всё заработало.
sip
Level 1
Level 1
Posts: 3
Joined: Mon Mar 29, 2021 6:43 am

Re: Обновил ядро, система перестала загружаться[РЕШЕНО]

Post by sip »

Good evening.
The core of the system was updated in a day, updates arrived on the intel processor. The system began to work better in the field, the load on the processor dropped. No temporary hang-ups! .. Everything is OK so far !.
- LinuxMint 20.1 x64 cinamone
Post Reply