Проблема с обновлением util-linux

Russian Forum
volp
Level 1
Level 1
Posts: 5
Joined: Thu Jun 29, 2017 9:24 am

Проблема с обновлением util-linux

Postby volp » Thu Jun 29, 2017 9:28 am

Не обновляется пакет util-linux .
На попытку

Code: Select all

sudo apt-get install --reinstall util-linux

пишет

Code: Select all

E: Internal Error, No file name for util-linux:amd64
.
В /dpkg/status

Code: Select all

Package: util-linux
Essential: yes
Status: install ok half-configured

Грешу на то, что вчера установил wine.
Система Mint 18 Cinamon 64
На

Code: Select all

sudo apt-get install -f

Code: Select all

sudo apt-get -f install
[sudo] пароль для volp:
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 33 пакетов не обновлено.
не установлено до конца или удалено 2 пакетов.
После данной операции, объём занятого дискового пространства возрастёт на 0 B.
Настраивается пакет util-linux (2.27.1-6ubuntu3.3) …
insserv: warning: script 'K01smfpd' missing LSB tags and overrides
insserv: warning: script 'smfpd' missing LSB tags and overrides
insserv: Starting smfpd depends on rc.local and therefore on system facility `$all' which can not be true!
insserv: Starting smfpd depends on rc.local and therefore on system facility `$all' which can not be true!
insserv: Starting smfpd depends on rc.local and therefore on system facility `$all' which can not be true!
insserv: Starting smfpd depends on rc.local and therefore on system facility `$all' which can not be true!
insserv: There is a loop between service smfpd and rc.local if started
insserv:  loop involving service rc.local at depth 8
insserv:  loop involving service smfpd at depth 1
insserv: Starting smfpd depends on rc.local and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: ошибка при обработке пакета util-linux (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 1
Настраивается пакет openvpn (2.3.10-1ubuntu2.1) …
 * Restarting virtual private network daemon(s)...                               *   No VPN is running.
insserv: warning: script 'K01smfpd' missing LSB tags and overrides
insserv: warning: script 'smfpd' missing LSB tags and overrides
insserv: Starting smfpd depends on rc.local and therefore on system facility `$all' which can not be true!
insserv: Starting smfpd depends on rc.local and therefore on system facility `$all' which can not be true!
insserv: Starting smfpd depends on rc.local and therefore on system facility `$all' which can not be true!
insserv: Starting smfpd depends on rc.local and therefore on system facility `$all' which can not be true!
insserv: There is a loop between service smfpd and rc.local if started
insserv:  loop involving service rc.local at depth 8
insserv:  loop involving service smfpd at depth 1
insserv: Starting smfpd depends on rc.local and therefore on system facility `$all' which can not be true!
insserv: exiting now without changing boot order!
update-rc.d: error: insserv rejected the script header
dpkg: ошибка при обработке пакета openvpn (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 1
Обрабатываются триггеры для libc-bin (2.23-0ubuntu9) …
При обработке следующих пакетов произошли ошибки:
 util-linux
 openvpn
E: Sub-process /usr/bin/dpkg returned an error code (1)

volp
Level 1
Level 1
Posts: 5
Joined: Thu Jun 29, 2017 9:24 am

Re: Проблема с обновлением util-linux

Postby volp » Thu Jun 29, 2017 2:06 pm

проблема решена, вот решение с соседнего форума
в файл /etc/init.d/smfpd после #!/bin/bash добавьте

Code: Select all

### BEGIN INIT INFO
# Provides:          skeleton
# Required-Start:     $syslog
# Required-Stop:     $syslog
# Default-Start:     2 3 4 5
# Default-Stop:      0 1 6
# Short-Description: Example initscript
# Description:       This file should be used to construct scripts to be
#     
#     
#     
#     
#     
### END INIT INFO

и повторите

Code: Select all

sudo apt-get install -f


Return to “Русский (Russian)”

Who is online

Users browsing this forum: No registered users and 1 guest