Не устанавливается davfs2

Russian Forum
Post Reply
maxsmeller
Level 1
Level 1
Posts: 8
Joined: Wed May 01, 2019 12:08 am

Не устанавливается davfs2

Post by maxsmeller » Wed May 01, 2019 12:10 am

Следующие пакеты имеют неудовлетворённые зависимости:
davfs2 : Зависит: libneon27 но он не будет установлен
E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.

Mint 19.1 cinnamon чистоустановлена, sudo apt update, sudo apt upgrade, следом такая печаль при попытке установить davfs2

Labuzhskiy
Level 3
Level 3
Posts: 117
Joined: Fri Aug 23, 2013 12:38 am

Re: Не устанавливается davfs2

Post by Labuzhskiy » Wed May 01, 2019 4:25 am

maxsmeller wrote:
Wed May 01, 2019 12:10 am
Следующие пакеты имеют неудовлетворённые зависимости:
davfs2 : Зависит: libneon27 но он не будет установлен
E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.

Mint 19.1 cinnamon чистоустановлена, sudo apt update, sudo apt upgrade, следом такая печаль при попытке установить davfs2
0. Судя по тексту, команда sudo apt upgrade Вам была не нужна.

1. Не забывайте пользоваться TimeShift.

2. Исправьте битые(сломанные) пакеты через Менеджер пакетов Synaptic и примените выбранные изменения; либо командой:
sudo apt-get -f install

:!: 3. Смотрите на Архитектуру установленной Вами ОС и на архитектуру пакетов, которые пытаетесь устанавливать. Если они совпадают, решайте проблему зависимостей; если нет, а заменить ПО аналогичным Вы не можете, ищите возможность установки из альтернативных репозиториев.

maxsmeller
Level 1
Level 1
Posts: 8
Joined: Wed May 01, 2019 12:08 am

Re: Не устанавливается davfs2

Post by maxsmeller » Wed May 01, 2019 4:45 am

Labuzhskiy wrote:
Wed May 01, 2019 4:25 am
maxsmeller wrote:
Wed May 01, 2019 12:10 am
Следующие пакеты имеют неудовлетворённые зависимости:
davfs2 : Зависит: libneon27 но он не будет установлен
E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.

Mint 19.1 cinnamon чистоустановлена, sudo apt update, sudo apt upgrade, следом такая печаль при попытке установить davfs2
0. Судя по тексту, команда sudo apt upgrade Вам была не нужна.

1. Не забывайте пользоваться TimeShift.

2. Исправьте битые(сломанные) пакеты через Менеджер пакетов Synaptic и примените выбранные изменения; либо командой:
sudo apt-get -f install

:!: 3. Смотрите на Архитектуру установленной Вами ОС и на архитектуру пакетов, которые пытаетесь устанавливать. Если они совпадают, решайте проблему зависимостей; если нет, а заменить ПО аналогичным Вы не можете, ищите возможность установки из альтернативных репозиториев.
Можно более для нубов? Почему раньше ставилось, а теперь что-то обновилось, и ставиться перестало, это нормальное поведение для ваших линуксов?

Labuzhskiy
Level 3
Level 3
Posts: 117
Joined: Fri Aug 23, 2013 12:38 am

Re: Не устанавливается davfs2

Post by Labuzhskiy » Wed May 01, 2019 6:18 am

maxsmeller wrote:
Wed May 01, 2019 4:45 am
...
Можно более для нубов? Почему раньше ставилось, а теперь что-то обновилось, и ставиться перестало, это нормальное поведение для ваших линуксов?
:idea: И больше, и подробнее и в картинках можно прочитать по ссылке.

maxsmeller
Level 1
Level 1
Posts: 8
Joined: Wed May 01, 2019 12:08 am

Re: Не устанавливается davfs2

Post by maxsmeller » Wed May 01, 2019 7:18 am

Пробовал через синаптик, не помогло

Так тоже: $ sudo apt-get -f install
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.

Вопрос сейчас такой, почему после простого обновления системы что-то ломается в зависимостях, и я не могу установить пакет из штатных репозиториев? Это нормальное поведение? Или это какой то косяк? Разве apt не должен сам решать проблемы зависимостей, если я все ставлю только со штатных репозиториев?

maxsmeller
Level 1
Level 1
Posts: 8
Joined: Wed May 01, 2019 12:08 am

Re: Не устанавливается davfs2

Post by maxsmeller » Wed May 01, 2019 7:31 am

ovod@X406UA:~$ sudo apt install -y davfs2
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите,
неосуществимо, или же вы используете нестабильную версию дистрибутива, где
запрошенные вами пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости:
davfs2 : Зависит: libneon27 но он не будет установлен
E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.
ovod@X406UA:~$ sudo apt install -y libneon27
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите,
неосуществимо, или же вы используете нестабильную версию дистрибутива, где
запрошенные вами пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости:
libneon27 : Зависит: libssl1.1 (>= 1.1.1) но 1.1.0g-2ubuntu4.3 должен быть установлен
E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.
ovod@X406UA:~$ sudo apt install -y libssl
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
E: Невозможно найти пакет libssl
ovod@X406UA:~$ sudo apt install -y libssl1.1
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Уже установлен пакет libssl1.1 самой новой версии (1.1.0g-2ubuntu4.3).
Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
ovod@X406UA:~$ ^C
ovod@X406UA:~$

Labuzhskiy
Level 3
Level 3
Posts: 117
Joined: Fri Aug 23, 2013 12:38 am

Re: Не устанавливается davfs2

Post by Labuzhskiy » Wed May 01, 2019 8:15 am

maxsmeller wrote:
Wed May 01, 2019 7:18 am
...
Вопрос сейчас такой, почему после простого обновления системы что-то ломается в зависимостях, и я не могу установить пакет из штатных репозиториев? Это нормальное поведение? Или это какой то косяк? Разве apt не должен сам решать проблемы зависимостей, если я все ставлю только со штатных репозиториев?
С похожим вопросом мне тоже пришлось столкнуться однажды, когда на NanoPC-T4, работающем работающем под управлением Ubintu-Bionic,
архитекетуры arm64 решил установить XnViewMP, причём разработчик данного ПО версию под arm64 не выложил, а отправил меня по ссылке, качать версию для архитектуры armhf В итоге, его пакет сломал мне систему, так как имел в зависимостях либы, разработанные для операционных систем симейства Debian libs, не рекомендованных (не пригодных) к установке на Ubuntu-Bionic:arm64. :bug: Чтобы не перестараться, и не получить такой же результат, как был у меня тогда, я бы советовал читать описание библиотек, заявленных в зависимостях Вашего пакета: под ОС какой Архитектуры они были разработаны и какое назначение имеют.
При работе со штатными репозиториями APT сам решает проблемы зависимостей или выдаёт предупреждение о том, что запрошенные Вами пакеты возможно были удалены или более не доступны, так как счисаются устаревшими, но о них сохранилось упоминание в зависимостях другого пакета, поэтому пакет может быть установлен из других "альтернативных" репозиториев.
И, судя по всему, он уже посёк те либы, которые могли бы привести к краху системы.

:?: Вопрос вот в чём: А сам Менеджер пакетов Synaptic Вы пробовали использовать для поиска и установки Вашего davfs2 он там нашёлся на установленной чистой системе до прочих манипуляций? Можете откатить систему через TimeShift в исходное состояние и проверить доступность установки в Synaptic, кто знает, может это и будет решением. :wink:

maxsmeller
Level 1
Level 1
Posts: 8
Joined: Wed May 01, 2019 12:08 am

Re: Не устанавливается davfs2

Post by maxsmeller » Wed May 01, 2019 8:25 am

Labuzhskiy wrote:
Wed May 01, 2019 8:15 am
maxsmeller wrote:
Wed May 01, 2019 7:18 am
...
Вопрос сейчас такой, почему после простого обновления системы что-то ломается в зависимостях, и я не могу установить пакет из штатных репозиториев? Это нормальное поведение? Или это какой то косяк? Разве apt не должен сам решать проблемы зависимостей, если я все ставлю только со штатных репозиториев?
С похожим вопросом мне тоже пришлось столкнуться однажды, когда на NanoPC-T4, работающем работающем под управлением Ubintu-Bionic,
архитекетуры arm64 решил установить XnViewMP, причём разработчик данного ПО версию под arm64 не выложил, а отправил меня по ссылке, качать версию для архитектуры armhf В итоге, его пакет сломал мне систему, так как имел в зависимостях либы, разработанные для операционных систем симейства Debian libs, не рекомендованных (не пригодных) к установке на Ubuntu-Bionic:arm64. :bug: Чтобы не перестараться, и не получить такой же результат, как был у меня тогда, я бы советовал читать описание библиотек, заявленных в зависимостях Вашего пакета: под ОС какой Архитектуры они были разработаны и какое назначение имеют.
При работе со штатными репозиториями APT сам решает проблемы зависимостей или выдаёт предупреждение о том, что запрошенные Вами пакеты возможно были удалены или более не доступны, так как счисаются устаревшими, но о них сохранилось упоминание в зависимостях другого пакета, поэтому пакет может быть установлен из других "альтернативных" репозиториев.
И, судя по всему, он уже посёк те либы, которые могли бы привести к краху системы.

:?: Вопрос вот в чём: А сам Менеджер пакетов Synaptic Вы пробовали использовать для поиска и установки Вашего davfs2 он там нашёлся на установленной чистой системе до прочих манипуляций? Можете откатить систему через TimeShift в исходное состояние и проверить доступность установки в Synaptic, кто знает, может это и будет решением. :wink:
Я не настроил ТаймШифт, ибо уже до этого играл с Минт неделю назад, так же обновлялся, и так же ставил эту утилиту, все проходило штатно. Синаптик так же не пожет ничего поставить, но на чистой системе все ставится. Я запутался с вашими линуксами) Не стоит обновлять? На сервере под центос мне обнорвление еще не разу ВПНку не навернуло или прокси, а тут на тебе, и как потом с венды то переходить? Ничего не ясно

Labuzhskiy
Level 3
Level 3
Posts: 117
Joined: Fri Aug 23, 2013 12:38 am

Re: Не устанавливается davfs2

Post by Labuzhskiy » Wed May 01, 2019 10:09 am

maxsmeller wrote:
Wed May 01, 2019 8:25 am
...
Я не настроил ТаймШифт, ибо уже до этого играл с Минт неделю назад, так же обновлялся, и так же ставил эту утилиту, все проходило штатно. Синаптик так же не пожет ничего поставить, но на чистой системе все ставится. Я запутался с вашими линуксами) Не стоит обновлять? На сервере под центос мне обнорвление еще не разу ВПНку не навернуло или прокси, а тут на тебе, и как потом с венды то переходить? Ничего не ясно
Что у меня не так, никак в толк не возьму, уже ради эксперимента с флешки загрузился,
и эта Ваша davfs2 без проблем установилась:

https://yadi.sk/i/rnwV5Sp63USREg
https://yadi.sk/i/mIBWA33VyEJG5Q
https://yadi.sk/i/3DjrfxxD4FPSzQ
https://yadi.sk/i/jaEyiE1pN0WNRw
https://yadi.sk/i/b45XgSGwQRKT5w
https://yadi.sk/i/fUow-hTBjyhkfQ
https://yadi.sk/i/nnKJUkKXpJKrvg
https://yadi.sk/i/445g1fpHDf7a2A
https://yadi.sk/i/VU1De_A222DELg
https://yadi.sk/i/F5lSsgZ54vjOEQ
https://yadi.sk/i/XSM7Akk_IwviHw
https://yadi.sk/i/U0fodWkRNstfZg
https://yadi.sk/i/94HHtCTzk_WQCg

Но будем надеяться, что кто-то ещё с Вашей проблемой сталкивался и обязательно поможет. :|

maxsmeller
Level 1
Level 1
Posts: 8
Joined: Wed May 01, 2019 12:08 am

Re: Не устанавливается davfs2

Post by maxsmeller » Wed May 01, 2019 11:13 am

Labuzhskiy wrote:
Wed May 01, 2019 10:09 am
maxsmeller wrote:
Wed May 01, 2019 8:25 am
...
Я не настроил ТаймШифт, ибо уже до этого играл с Минт неделю назад, так же обновлялся, и так же ставил эту утилиту, все проходило штатно. Синаптик так же не пожет ничего поставить, но на чистой системе все ставится. Я запутался с вашими линуксами) Не стоит обновлять? На сервере под центос мне обнорвление еще не разу ВПНку не навернуло или прокси, а тут на тебе, и как потом с венды то переходить? Ничего не ясно
Что у меня не так, никак в толк не возьму, уже ради эксперимента с флешки загрузился,
и эта Ваша davfs2 без проблем установилась:

https://yadi.sk/i/rnwV5Sp63USREg
https://yadi.sk/i/mIBWA33VyEJG5Q
https://yadi.sk/i/3DjrfxxD4FPSzQ
https://yadi.sk/i/jaEyiE1pN0WNRw
https://yadi.sk/i/b45XgSGwQRKT5w
https://yadi.sk/i/fUow-hTBjyhkfQ
https://yadi.sk/i/nnKJUkKXpJKrvg
https://yadi.sk/i/445g1fpHDf7a2A
https://yadi.sk/i/VU1De_A222DELg
https://yadi.sk/i/F5lSsgZ54vjOEQ
https://yadi.sk/i/XSM7Akk_IwviHw
https://yadi.sk/i/U0fodWkRNstfZg
https://yadi.sk/i/94HHtCTzk_WQCg

Но будем надеяться, что кто-то ещё с Вашей проблемой сталкивался и обязательно поможет. :|
На стоковом 19.1 ставится, но после установки всех обновлений в дистрибутиве перестает устанавливается... как то так, суть вопроса была, это вообще нормлаьно? По мне так херня, что-то лечим, другое ломаем. Не зря наверное везде пишут не юзать минта, он ломает свои репозитории и совместимость с убунтой постоянно

maxsmeller
Level 1
Level 1
Posts: 8
Joined: Wed May 01, 2019 12:08 am

Re: Не устанавливается davfs2

Post by maxsmeller » Wed May 01, 2019 9:52 pm

Решено установкой без интернета и галочки "устанавливать всю шляпу для МП3 и т.д.". Сначала поставил davfs2, а потом уже все остальное, таймшифт настроил, спасибо.

027
Level 1
Level 1
Posts: 1
Joined: Wed May 15, 2019 11:06 pm

Re: Не устанавливается davfs2

Post by 027 » Wed May 15, 2019 11:17 pm

Тоже столкнулся на рабочей обновленной системе.

Code: Select all

apt install davfs2 
...
Следующие пакеты имеют неудовлетворённые зависимости:
 davfs2 : Зависит: libneon27 но он не будет установлен
E: Невозможно исправить ошибки: у вас зафиксированы сломанные пакеты.
Смотрим все доступные версии:

Code: Select all

apt show libneon27 -a
...
Version: 0.30.2-3~ubuntu18.04.1
...
Version: 0.30.2-2build1
(ну или так, чтобы портянку не прокручивать: $ apt show libneon27 -a | grep -E 'Version')

При стандартной установке apt пытается установить более новую версию 0.30.2-3~ubuntu18.04.1, но не может, с ней какие-то проблемы. В результате не может установить davfs2.
Решается принудительной установкой более старой версии libneon27:

Code: Select all

apt install libneon27=0.30.2-2build1
apt install davfs2

Post Reply

Return to “Русский (Russian)”