Не работает переключение раскладки клавиатуры

Russian Forum
Post Reply
promoute
Level 1
Level 1
Posts: 3
Joined: Sat Feb 19, 2011 10:14 am

Не работает переключение раскладки клавиатуры

Post by promoute » Sat Feb 19, 2011 10:35 am

Добрый день, участникам форума!

В Linux я новичек и мне нужна помощь по следующей проблеме. Впервые установил Linux Mint 10 на свой компьютер. Не работает переключение раскладки клавиатуры с русского на английский и обратно с помощью клавиш. Опробовал различные сочетания клавиш, в том числе и Alt-shift. Переключается только с помощью мышки. В меню "Центр управления - комбинации клавиш клавиатуры" нужных комбинаций не нашел. В меню "Параметры - Input Method Switsher" не понятно, какой пункт выбирать. Пробовал переключать разные варианты - ничего не получилось.

Ilya
Level 1
Level 1
Posts: 6
Joined: Sun Feb 20, 2011 6:03 pm
Location: Russian Federation, Kislovodsk (acidic water =)) )

Re: Не работает переключение раскладки клавиатуры

Post by Ilya » Sun Feb 20, 2011 6:21 pm

тут все просто (пишу как в русской локализации). под гномом - другие версии не пробовал.
menu - > все приложения -> параметры -> клавиатура
(в английской по-моему будет: menu -> all applications -> properties -> keyboard

далее идем в расскладки (layot) и жмем добавить (add).
В появившемся диалог выбираем страну Россия (country Russia), язык - русский (language - русский).
Жмем добавить.

Теперь у нас две раскладки. В текущем окне жмем параметры (по английски не знаю как кнопка будет называться, думаю, что properties).
Появляется дерево, в котором ищем Клавиши для смены раскладки (по английски не знаю как будет, может Keys for change layot). появятся чекбоксы с подписями сочетаний. Там ставим нужное. Жмем закрыть, пробуем переключаемся, внизу есть поле для проверки как все работает и, если все устраивает, жмем для всей системы (по-английски не уверен как будет, скорее всего for all sistem). вводим пароли рута, и птом жмем закрыть.
Всё, должно работать.

однако у меня через несколько часов работы gnome-settings-daemon начинал тупить и есть ресурсы, одновременно переключая в цикле раскладки с русской на английскую и обратно, в итоге при наборе текста получался аццкий треш из кириллицы и латиницы. Если такое будет наблюдаться, то нужно обновить gnome-settings-daemon. А еще лучше обновить всё, что требует обновлений (опять же "хотя бы": я обновляю только те пакеты, которые проверены mint).

хотя есть и другие косяки в сборке, но с расскладкой после обновления будет всё оК :wink:

promoute
Level 1
Level 1
Posts: 3
Joined: Sat Feb 19, 2011 10:14 am

Re: Не работает переключение раскладки клавиатуры

Post by promoute » Mon Feb 21, 2011 11:44 am

Спасибо за помощь. Сделал все как написали - переключение раскладки работает.

gileon
Level 1
Level 1
Posts: 1
Joined: Fri Feb 18, 2011 10:10 am
Location: Munich, Germany

Re: Не работает переключение раскладки клавиатуры

Post by gileon » Mon Feb 21, 2011 11:57 am

А может кто подсказать, как поменять расположение букв в русской раскладке :?:

menangen
Level 1
Level 1
Posts: 3
Joined: Sun Apr 03, 2011 2:38 am

Re: Не работает переключение раскладки клавиатуры

Post by menangen » Sun Apr 03, 2011 2:42 am

Привет! А у меня, вот, тоже прикольная проблема.
Поставил Mint Debian x64 последнюю, на гноме. Вобщем, русская локаль. При остановке Xorg сервера, вываливаемся в терминал, а в терминале только русский язык!

Как быть? Залогинитсья не могу =)
все логины у меня латиницей.

P.S. В самом Gnome USA раскладку добавил, "поднял" её по списку выше, толку ноль. Везде по умолчанию идёт РУ.

alex150578
Level 1
Level 1
Posts: 3
Joined: Sun Apr 10, 2011 12:26 am

Re: Не работает переключение раскладки клавиатуры

Post by alex150578 » Sun Apr 10, 2011 12:32 am

Ilya wrote:тут все просто (пишу как в русской локализации). под гномом - другие версии не пробовал.
menu - > все приложения -> параметры -> клавиатура
(в английской по-моему будет: menu -> all applications -> properties -> keyboard

далее идем в расскладки (layot) и жмем добавить (add).
В появившемся диалог выбираем страну Россия (country Russia), язык - русский (language - русский).
Жмем добавить.

Теперь у нас две раскладки. В текущем окне жмем параметры (по английски не знаю как кнопка будет называться, думаю, что properties).
Появляется дерево, в котором ищем Клавиши для смены раскладки (по английски не знаю как будет, может Keys for change layot). появятся чекбоксы с подписями сочетаний. Там ставим нужное. Жмем закрыть, пробуем переключаемся, внизу есть поле для проверки как все работает и, если все устраивает, жмем для всей системы (по-английски не уверен как будет, скорее всего for all sistem). вводим пароли рута, и птом жмем закрыть.
Всё, должно работать.

однако у меня через несколько часов работы gnome-settings-daemon начинал тупить и есть ресурсы, одновременно переключая в цикле раскладки с русской на английскую и обратно, в итоге при наборе текста получался аццкий треш из кириллицы и латиницы. Если такое будет наблюдаться, то нужно обновить gnome-settings-daemon. А еще лучше обновить всё, что требует обновлений (опять же "хотя бы": я обновляю только те пакеты, которые проверены mint).

хотя есть и другие косяки в сборке, но с расскладкой после обновления будет всё оК :wink:
Привет, сам начинающий пользователь линукса, в общем стоит пока минт а там посмотрим, мож на мандриву перейду.

Значит так. после установки минта раскладка не работала.
Обновил систему с репы и все заработало.

Cmndr_AlexGreen
Level 1
Level 1
Posts: 15
Joined: Thu Mar 31, 2011 4:32 pm

Re: Не работает переключение раскладки клавиатуры

Post by Cmndr_AlexGreen » Thu Jun 30, 2011 5:16 pm

Linux Mint 9 > Fluxbox

Раскладка работает, все в порядке с момента установки но: Где её управление у Флюка, я хочу сменить а инструментов найти не могу)). Куда делся /etc/X11/xorg.conf ? И где вносить изменения?

?Вопрос к знатокам: каким образом в минте 9 под управлением fluxbox осуществляется контроль раскладки Хсами или через hal, и где вообще лежат какие нибудь конфигурационные файлы с параметрами раскладки?

blitz
Level 1
Level 1
Posts: 1
Joined: Mon Jul 20, 2015 8:24 am

Re: Не работает переключение раскладки клавиатуры

Post by blitz » Mon Jul 20, 2015 9:03 am

Ilya корректно изложил суть метода переключения раскладок.

Стоит дополнить, на сегодня - 2015, последовательность в Linux Mint 17 изменилась в некоторых деталях и теперь:

i. Select in taskbar Menu -> Preferences -> Keyboard
ii. Click tab Layouts in the opened window and click button Add...
iii.From Country in pull-down menu select Russian Federation and from Variants - для вашего русского, и подтвердить Add
iv. В окне Layouts по кнопке Options... переход в окно выбора переключения раскладок: Switching to another layout
v. Проверить в текстовом окне Type to test settings, perklyuchaya и набирая.

На каждой странице есть Help,
Page Not Found
The page ‘goscustperiph-2’ was not found in the document ‘help:mate-user-guide’.

Post Reply

Return to “Русский (Russian)”