[SOLVED]Taking so long to boot

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
User avatar
Ricardo Vieira
Level 1
Level 1
Posts: 23
Joined: Sat Oct 28, 2017 6:26 am

Re: Taking so long to boot

Post by Ricardo Vieira » Sun Feb 11, 2018 4:50 pm

Termy wrote:
Sun Feb 11, 2018 4:14 pm
Is that normal for you; in other words, is it better than you previously experienced with that laptop? Your specs seem very nice and I would expect it to boot much faster, unless you're on a HDD, in which case it's probably normal. You can also get BIOS settings which add wait time, intentionally.

Ah, I see you are on a HDD, so yeah, I'd say that's pretty much expected. If you want lightning boot speeds, you might want to tweak the system further, but especially, get an SSD. I have one myself, and bootup is incredibly fast!
Thank you for the tip,Termy. And yes, previously my laptop was running Windows 10 and its boot was slow too. Now I have only Mint on it. :wink:
Sorry for my bad English. I'm using Linux Mint 18.2 Cinnamon 3.4.6 - 64-bit. My PC is a Samsung Laptop NP670ZSE, Intel Core i5-3230 CPU @ 2.60GHz x2, 8 GB RAM, HDD 1TB.

User avatar
Termy
Level 5
Level 5
Posts: 746
Joined: Mon Sep 04, 2017 8:49 pm
Location: UK
Contact:

Re: Taking so long to boot

Post by Termy » Sun Feb 11, 2018 6:40 pm

It looks like that went normally. I expect that problem is solved, and that it's definitely not that which was causing slow boot times. You could check your BIOS for any settings which are slowing down boot time; be careful there though, as the wrong setting can cause problems. I think you'll have to stick with 47 seconds; it's not too bad for a HDD, to be honest, especially what I imagine is a 2.5" drive.

If you absolutely must have the fastest possible boot times, without buying an SSD, you'll probably want to reinstall Linux, with /boot being the first partition on the HDD; this supposedly improves boot time a little. You should get an improved performance by ensuring write caching is enabled for your drive. This does give a risk of data loss if the laptop has an unexpected power loss. To check if you have it enabled: sudo hdparm -W /dev/sda, if /dev/sda is your HDD. That is an upper-case W, by the way; the lower-case one is dangerous, so I recommend you copy-paste!
Here to help.

I'm LearnLinux (LL) on YouTube: https://www.youtube.com/channel/UCfp-lN ... naEE6NtDSg
I'm also terminalforlife (TFL) on GitHub: https://github.com/terminalforlife

User avatar
Ricardo Vieira
Level 1
Level 1
Posts: 23
Joined: Sat Oct 28, 2017 6:26 am

Re: Taking so long to boot

Post by Ricardo Vieira » Sun Feb 11, 2018 7:25 pm

Done. It is 1 (on). The slowness is just in the boot; after the welcome screen, it works perfectly. When 19.0 will come, I will set /boot as the first partition.

Thanks again!

Sorry, I had tried to insert the image, but it seems to small.
Attachments
cache.png
cache.png (260.48 KiB) Viewed 221 times
Sorry for my bad English. I'm using Linux Mint 18.2 Cinnamon 3.4.6 - 64-bit. My PC is a Samsung Laptop NP670ZSE, Intel Core i5-3230 CPU @ 2.60GHz x2, 8 GB RAM, HDD 1TB.

User avatar
Ricardo Vieira
Level 1
Level 1
Posts: 23
Joined: Sat Oct 28, 2017 6:26 am

Re: Taking so long to boot

Post by Ricardo Vieira » Sun Feb 11, 2018 8:02 pm

Trying to post image from Google photos. I hope that works.

https://photos.google.com/photo/AF1QipN ... LdSXZE0nAm
Sorry for my bad English. I'm using Linux Mint 18.2 Cinnamon 3.4.6 - 64-bit. My PC is a Samsung Laptop NP670ZSE, Intel Core i5-3230 CPU @ 2.60GHz x2, 8 GB RAM, HDD 1TB.

User avatar
Termy
Level 5
Level 5
Posts: 746
Joined: Mon Sep 04, 2017 8:49 pm
Location: UK
Contact:

Re: Taking so long to boot

Post by Termy » Mon Feb 12, 2018 11:39 am

I'm afraid that got a 404 error on that link. What did it say? If it's regarding the hdparm command, here's what I, for example, see when I run it on my SSD which does have write-cacheing enabled:

.lmscrot.jpg
.lmscrot.jpg (15.36 KiB) Viewed 211 times

I expect for you it'll show "off" instead of "on", in which case you may want to enable it with: sudo hdparm -W1 /dev/sda

Aaaactually, I think I can just about make out that you have the same result, so sadly you won't benefit from that, as it's already on. I think you'll just have to make do with what you have, at this point.
Here to help.

I'm LearnLinux (LL) on YouTube: https://www.youtube.com/channel/UCfp-lN ... naEE6NtDSg
I'm also terminalforlife (TFL) on GitHub: https://github.com/terminalforlife

User avatar
viteK
Level 1
Level 1
Posts: 19
Joined: Sun Jan 07, 2018 2:39 pm

Re: Taking so long to boot

Post by viteK » Mon Feb 12, 2018 11:46 am

alright, someone have a clue that what is making my boot last forever??

User avatar
Termy
Level 5
Level 5
Posts: 746
Joined: Mon Sep 04, 2017 8:49 pm
Location: UK
Contact:

Re: Taking so long to boot

Post by Termy » Mon Feb 12, 2018 11:58 am

Have you ever considered using hibernation so you can boot in very, very quickly? It's incredibly quick, and, unlike suspend, shouldn't use any power. Did you look through the BIOS at all? I'm quite serious about the wait time thing; it's usually there to give you enough time to enter any keys at boot-up; this can be as much as 10 seconds.
Here to help.

I'm LearnLinux (LL) on YouTube: https://www.youtube.com/channel/UCfp-lN ... naEE6NtDSg
I'm also terminalforlife (TFL) on GitHub: https://github.com/terminalforlife

User avatar
viteK
Level 1
Level 1
Posts: 19
Joined: Sun Jan 07, 2018 2:39 pm

Re: Taking so long to boot

Post by viteK » Mon Feb 12, 2018 12:15 pm

I don't like using hibernation, also because I'm using dual boot. Looked the BIOS and the option "fast boot" was disabled (Windows 10 issues) I enabled it and nothing changed
I'm starting to thinking on reinstall the system

greerd
Level 5
Level 5
Posts: 915
Joined: Sat Jul 31, 2010 10:58 am
Location: Nova Scotia, Canada

Re: Taking so long to boot

Post by greerd » Mon Feb 12, 2018 12:49 pm

Maybe we can go back to the start and try again?

Can you post the outputs for the following commands?

Code: Select all

systemd-analyse time
systemd-analyze critical-chain
lsblk -f
cat /etc/fstab
Image

User avatar
Ricardo Vieira
Level 1
Level 1
Posts: 23
Joined: Sat Oct 28, 2017 6:26 am

Re: Taking so long to boot

Post by Ricardo Vieira » Tue Feb 13, 2018 7:00 am

Termy wrote:
Mon Feb 12, 2018 11:39 am
I'm afraid that got a 404 error on that link. What did it say? If it's regarding the hdparm command, here's what I, for example, see when I run it on my SSD which does have write-cacheing enabled:


.lmscrot.jpg


I expect for you it'll show "off" instead of "on", in which case you may want to enable it with: sudo hdparm -W1 /dev/sda

Aaaactually, I think I can just about make out that you have the same result, so sadly you won't benefit from that, as it's already on. I think you'll just have to make do with what you have, at this point.
Hi Termy, now I got it. It is on. It is not bad the 47 seconds once it runs well after the welcome screen.
Attachments
cache3.jpg
Sorry for my bad English. I'm using Linux Mint 18.2 Cinnamon 3.4.6 - 64-bit. My PC is a Samsung Laptop NP670ZSE, Intel Core i5-3230 CPU @ 2.60GHz x2, 8 GB RAM, HDD 1TB.

User avatar
viteK
Level 1
Level 1
Posts: 19
Joined: Sun Jan 07, 2018 2:39 pm

Re: Taking so long to boot

Post by viteK » Tue Feb 13, 2018 8:00 pm

Ricardo Oliveira, please, create another topic for your problem
greerd wrote:
Mon Feb 12, 2018 12:49 pm
Maybe we can go back to the start and try again?

Can you post the outputs for the following commands?

Code: Select all

systemd-analyse time
systemd-analyze critical-chain
lsblk -f
cat /etc/fstab

Code: Select all

vitek@ghosT ~ $ systemd-analyze time
Startup finished in 8.830s (kernel) + 3min 506ms (userspace) = 3min 9.337s
vitek@ghosT ~ $ systemd-analyze critical-chain
The time after the unit is active or started is printed after the "@" character.
The time the unit takes to start is printed after the "+" character.

graphical.target @1min 43.819s
└─multi-user.target @1min 43.819s
  └─ntp.service @1min 37.175s +6.643s
    └─network-online.target @1min 37.174s
      └─NetworkManager-wait-online.service @1min 30.350s +6.823s
        └─NetworkManager.service @1min 30.270s +74ms
          └─dbus.service @1min 30.260s
            └─basic.target @1min 30.258s
              └─sockets.target @1min 30.258s
                └─cups.socket @1min 30.258s
                  └─sysinit.target @1min 30.256s
                    └─apparmor.service @673ms +121ms
                      └─local-fs.target @673ms
                        └─run-user-1000-gvfs.mount @1min 49.531s
                          └─run-user-1000.mount @1min 47.570s
                            └─local-fs-pre.target @673ms
                              └─lvm2-monitor.service @142ms +530ms
                                └─lvm2-lvmetad.service @189ms
                                  └─systemd-journald.socket @133ms
                                    └─-.slice @123ms
vitek@ghosT ~ $ lsblk -f
NAME   FSTYPE LABEL       UUID                                 MOUNTPOINT
sdb                                                            
├─sdb4 vfat               80E6-5736                            
├─sdb2 ntfs   BarraCuda   E2906F14906EEF0B                     /home/vitek/ArquivosNTFS1
├─sdb5 ntfs               D02CF1E82CF1CA0C                     /home/vitek/Windows
├─sdb3 ntfs   Recuperação 38AEE07BAEE03354                     
└─sdb1                                                         
sr0                                                            
sda                                                            
└─sda1 ext4               1dd04c8a-0888-42c9-934e-34049a306418 /
vitek@ghosT ~ $ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=1dd04c8a-0888-42c9-934e-34049a306418 /               ext4    errors=remount-ro 0       1
# swap was on /dev/sdc5 during installation
UUID=fd48f6c1-9eca-4863-8afd-ec163acc1218 none            swap    sw              0       0
/dev/disk/by-uuid/E2906F14906EEF0B /home/vitek/ArquivosNTFS1/ auto nosuid,nodev,nofail,x-gvfs-show 0 0
/dev/disk/by-uuid/D02CF1E82CF1CA0C /home/vitek/Windows/ auto nosuid,nodev,nofail,x-gvfs-show 0 0

User avatar
Termy
Level 5
Level 5
Posts: 746
Joined: Mon Sep 04, 2017 8:49 pm
Location: UK
Contact:

Re: Taking so long to boot

Post by Termy » Tue Feb 13, 2018 8:13 pm

Okay, I'm seeing several minutes. That's quite painful. I definitely understand your frustration with this now! It looks like the BIOS is definitely not the cause. It gets really slow here: └─run-user-1000.mount @1min 47.570s I can only assume that means there's an entry in fdisk which is taking forever to mount. Perhaps it's a slow drive taking ages to spin up? I'm not familiar with the output of that systemd-analyze command, so I could be misinterpreting it, but it looks simple enough.
Here to help.

I'm LearnLinux (LL) on YouTube: https://www.youtube.com/channel/UCfp-lN ... naEE6NtDSg
I'm also terminalforlife (TFL) on GitHub: https://github.com/terminalforlife

User avatar
viteK
Level 1
Level 1
Posts: 19
Joined: Sun Jan 07, 2018 2:39 pm

Re: Taking so long to boot

Post by viteK » Tue Feb 13, 2018 8:26 pm

This is my first time using linux as primary system, so this command is new for me too...
I only have a 7200 RPM HD monting on boot (since before the problem start)

User avatar
trytip
Level 6
Level 6
Posts: 1278
Joined: Tue Jul 05, 2016 1:20 pm

Re: Taking so long to boot

Post by trytip » Tue Feb 13, 2018 8:53 pm

refresh grub sudo update-grub
Image

greerd
Level 5
Level 5
Posts: 915
Joined: Sat Jul 31, 2010 10:58 am
Location: Nova Scotia, Canada

Re: Taking so long to boot

Post by greerd » Tue Feb 13, 2018 9:14 pm

I see a couple of problems with your boot, the main one being that your /etc/fstab lists a swap partition while your lsblk command doesn't see one. Something has happened to your swap partition, actually sdc isn't mentioned in lsblk (did you remove the drive?) you can comment out the UUID=fd48f6c1-9eca-4863-8afd-ec163acc1218 none swap sw 0 0 in fstab to speed up boot by probably 1.5 minutes. A swap partition isn't necessary to run but you might want to look into what happened to it and if you don't have a lot of memory you might want to get it back in there.

Next is the NetworkManager-wait-online.service, it can be disabled by the command

Code: Select all

sudo systemctl disable NetworkManager-wait-online.service
.

Also sdb3 ntfs Recuperação 38AEE07BAEE03354 isn't mentioned in fstab.
Image

MrEen
Level 5
Level 5
Posts: 599
Joined: Mon Jun 12, 2017 8:39 pm

Re: Taking so long to boot

Post by MrEen » Tue Feb 13, 2018 9:18 pm

Couple of thoughts. Many people disable NetworkManager-wait-online.service with no ill effects with systemctl disable NetworkManager-wait-online.service Followed by a reboot.

Also, fstab reports swap was on sdc5 during installation, but lsblk didn't show a sdc.

Fixing those two could drastically reduce your boot time.

Edit: greerd beat me to it!

User avatar
Ricardo Vieira
Level 1
Level 1
Posts: 23
Joined: Sat Oct 28, 2017 6:26 am

Re: Taking so long to boot

Post by Ricardo Vieira » Wed Feb 14, 2018 6:56 am

viteK wrote:
Tue Feb 13, 2018 8:00 pm
Ricardo Oliveira, please, create another topic for your problem
Sorry for disturb your focus. it was not my intention.

PS: My name is Ricardo Vieira, not Ricardo Oliveira.
Sorry for my bad English. I'm using Linux Mint 18.2 Cinnamon 3.4.6 - 64-bit. My PC is a Samsung Laptop NP670ZSE, Intel Core i5-3230 CPU @ 2.60GHz x2, 8 GB RAM, HDD 1TB.

User avatar
viteK
Level 1
Level 1
Posts: 19
Joined: Sun Jan 07, 2018 2:39 pm

Re: Taking so long to boot

Post by viteK » Wed Feb 14, 2018 5:05 pm

Nice!
I commented the

Code: Select all

 UUID=fd48f6c1-9eca-4863-8afd-ec163acc1218 none swap sw 0 0
on /etc/fstab and disabled the NetworkManager-wait-online.service. Now, from grub to desktop is takes almost 15secs. The only drive I removed is that 500GiB that now is a paperweight.
A swap partition isn't necessary to run but you might want to look into what happened to it and if you don't have a lot of memory you might want to get it back in there.
How much is a lot of memory? I'm running with 8GiB and I think is pretty ok to don't have a swap.
Also sdb3 ntfs Recuperação 38AEE07BAEE03354 isn't mentioned in fstab.
I think this is the recovery partition from Windows. I can ignore it, right?
Sorry for disturb your focus. it was not my intention.

PS: My name is Ricardo Vieira, not Ricardo Oliveira.
Sorry if I was a litte harsh, but is a forum rule. Sorry for get your name wrong

Thanks for all the help, guys!

So 15secs is a nice time for boot on a SSD? Can I improve it more?

greerd
Level 5
Level 5
Posts: 915
Joined: Sat Jul 31, 2010 10:58 am
Location: Nova Scotia, Canada

Re: Taking so long to boot

Post by greerd » Wed Feb 14, 2018 5:37 pm

viteK wrote:
Wed Feb 14, 2018 5:05 pm
How much is a lot of memory? I'm running with 8GiB and I think is pretty ok to don't have a swap.
Probably ok, depending on what you're doing of course.
I think this is the recovery partition from Windows. I can ignore it, right?
Right.
So 15secs is a nice time for boot on a SSD? Can I improve it more?
Might be able to, you can disable services you're not using like perhaps ModemManager.service, just be careful not to disable something needed.
To list all enabled services:

Code: Select all

systemctl list-unit-files --state enabled --no-page
I'd be curious to see the outputs of the 4 commands again:

Code: Select all

systemd-analyse time
systemd-analyze critical-chain
lsblk -f
cat /etc/fstab
Image

User avatar
viteK
Level 1
Level 1
Posts: 19
Joined: Sun Jan 07, 2018 2:39 pm

Re: Taking so long to boot

Post by viteK » Wed Feb 14, 2018 7:01 pm

Might be able to, you can disable services you're not using like perhaps ModemManager.service, just be careful not to disable something needed.
To list all enabled services:
CODE: SELECT ALL

systemctl list-unit-files --state enabled --no-page
58 units files listed
I'll make a search of every one to see if I can disable.
the command is systemctl disable <name of service> right?
I'd be curious to see the outputs of the 4 commands again:
CODE: SELECT ALL

systemd-analyse time
systemd-analyze critical-chain
lsblk -f
cat /etc/fstab

Code: Select all

vitek@ghosT ~ $ systemd-analyze time
Startup finished in 8.834s (kernel) + 1.441s (userspace) = 10.276s
vitek@ghosT ~ $ systemd-analyze critical-chain
The time after the unit is active or started is printed after the "@" character.
The time the unit takes to start is printed after the "+" character.

graphical.target @1.399s
└─lightdm.service @1.211s +186ms
  └─systemd-user-sessions.service @811ms +92ms
    └─basic.target @811ms
      └─paths.target @811ms
        └─acpid.path @811ms
          └─sysinit.target @808ms
            └─apparmor.service @698ms +110ms
              └─local-fs.target @698ms
                └─run-cgmanager-fs.mount @907ms
                  └─local-fs-pre.target @694ms
                    └─lvm2-monitor.service @136ms +556ms
                      └─lvm2-lvmetad.service @187ms
                        └─systemd-journald.socket @131ms
                          └─-.slice @122ms
vitek@ghosT ~ $ lsblk -f
NAME   FSTYPE LABEL       UUID                                 MOUNTPOINT
sdb                                                            
├─sdb4 vfat               80E6-5736                            
├─sdb2 ntfs   BarraCuda   E2906F14906EEF0B                     /home/vitek/ArquivosNTFS1
├─sdb5 ntfs               D02CF1E82CF1CA0C                     /home/vitek/Windows
├─sdb3 ntfs   Recuperação 38AEE07BAEE03354                     
└─sdb1                                                         
sr0                                                            
sda                                                            
└─sda1 ext4               1dd04c8a-0888-42c9-934e-34049a306418 /
vitek@ghosT ~ $ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices                                                                                                    
# that works even if disks are added and removed. See fstab(5).                                                                                                               
#                                                                                                                                                                             
# <file system> <mount point>   <type>  <options>       <dump>  <pass>                                                                                                        
# / was on /dev/sda1 during installation                                                                                                                                      
UUID=1dd04c8a-0888-42c9-934e-34049a306418 /               ext4    errors=remount-ro 0       1                                                                                 
# swap was on /dev/sdc5 during installation                                                                                                                                   
#UUID=fd48f6c1-9eca-4863-8afd-ec163acc1218 none            swap    sw              0       0                                                                                  
/dev/disk/by-uuid/E2906F14906EEF0B /home/vitek/ArquivosNTFS1/ auto nosuid,nodev,nofail,x-gvfs-show 0 0                                                                        
/dev/disk/by-uuid/D02CF1E82CF1CA0C /home/vitek/Windows/ auto nosuid,nodev,nofail,x-gvfs-show 0 0

Post Reply

Return to “Newbie Questions”