Error installing mono because of libc6 dependancy [SOLVED]

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
BigAngry
Level 1
Level 1
Posts: 20
Joined: Thu May 11, 2017 6:10 pm

Error installing mono because of libc6 dependancy [SOLVED]

Post by BigAngry » Wed Nov 14, 2018 3:46 am

I'm trying to install mono but am getting an error. I've tracked it down to libc6 being an older version (2.23) instead of 2.24 per the error below.

Code: Select all

The following packages have unmet dependencies:
 mono-4.0-gac : Depends: libc6 (>= 2.24) but 2.23-0ubuntu10 is to be installed or
                         libc6.1 (>= 2.24) but it is not installable or
                         libc0.1 (>= 2.24) but it is not installable
                Depends: libmono-security4.0-cil (>= 3.0.6) but it is not going to be installed
                Depends: libmono-system-security4.0-cil (>= 1.0) but it is not going to be installed
                Depends: libmono-system4.0-cil (>= 4.0.0~alpha1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
I tried updating libc6, but cannot figure out why its not allowing me to. From what I gathered there is no 'ubuntu' package past the one I have installed, and it wont let me install a debian package. It is also all tied up with dependencies so I cant just remove libc6 without breaking stuff from the looks of it.
I'm guessing there is something very simple that I'm missing here?
Last edited by BigAngry on Wed Nov 14, 2018 10:43 pm, edited 1 time in total.

gm10
Level 13
Level 13
Posts: 4688
Joined: Thu Jun 21, 2018 5:11 pm

Re: Error installing mono because of libc6 dependancy

Post by gm10 » Wed Nov 14, 2018 6:03 am

1. mono is pre-installed on Mint
2. Looks like you're trying to install a third-party mono package that's not meant for your Mint version. Use the one from the official repositories (i.e. disable your external source) and you'll be fine.

Hoser Rob
Level 12
Level 12
Posts: 4462
Joined: Sat Dec 15, 2012 8:57 am

Re: Error installing mono because of libc6 dependancy

Post by Hoser Rob » Wed Nov 14, 2018 9:34 am

BigAngry wrote:
Wed Nov 14, 2018 3:46 am
I'm guessing there is something very simple that I'm missing here?
Yes, as mentioned you're using a 3rd party source, I suspect a .tar file, and using 3rd party sources is something Linux beginners are usuallly advised not to do. For good reason. Those dependency libraries, if you did manage to install them, would probably break other programs that need the previous version.

There are exceptions ... I installl Chrome from a .deb file and have a couple of ppa sources. The last time I installed from a tar file was about 5 years ago, and that was a backported wireless driver, which is kind of necessary.

BigAngry
Level 1
Level 1
Posts: 20
Joined: Thu May 11, 2017 6:10 pm

Re: Error installing mono because of libc6 dependancy

Post by BigAngry » Wed Nov 14, 2018 10:38 pm

I was trying to update mono to a newer version as I need 5.4.

I was following the instructions here https://www.mono-project.com/download/s ... lin-ubuntu and added their repo. I've fixed my previous issue with mono being broken by doing what you guys said above and removing it.

Is there a way for me to get the updated version of mono?

BigAngry
Level 1
Level 1
Posts: 20
Joined: Thu May 11, 2017 6:10 pm

Re: Error installing mono because of libc6 dependancy

Post by BigAngry » Wed Nov 14, 2018 10:43 pm

Ok I've figured it out shortly after posting.

I had to follow the instructions for an older version of Ubuntu as stated here viewtopic.php?t=271579

Now mono -V reads
Mono JIT compiler version 5.16.0.179 (tarball Thu Oct 4 10:27:11 UTC 2018)

Thanks guys!

Post Reply

Return to “Newbie Questions”