headphone and mic jack not working

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
otlichnik73
Level 2
Level 2
Posts: 84
Joined: Tue Mar 20, 2018 6:20 pm

SOLVED Re: headphone and mic jack not working

Post by otlichnik73 » Wed Sep 11, 2019 2:08 am

MrEen wrote:
Tue Sep 10, 2019 7:14 pm
I know this will sound wrong, but it works for some non Dell users. Change model=headset-mode to model=dell-headset-multi, save then reboot and test.
And lets see amixer and dmesg | grep snd when done.
That did not help, sorry With that edit, now when I plug in the headset it does not register in Pulse input that headset microphne is plugged in. The volume indcator of the Input devices is jumping slightly on a very low level randomly.
as requested:

Code: Select all

bekor@Linux1:~$ amixer
Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 87
  Mono: Playback 63 [72%] [-18.00dB] [on]
Simple mixer control 'Headphone',0
  Capabilities: pswitch
  Playback channels: Front Left - Front Right
  Mono:
  Front Left: Playback [off]
  Front Right: Playback [off]
Simple mixer control 'Headphone Mic',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 0 [0%] [-34.50dB] [off]
  Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control 'Headphone Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%] [0.00dB]
  Front Right: 0 [0%] [0.00dB]
Simple mixer control 'Headphone+LO',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Mono:
  Front Left: Playback 0 [0%] [-65.25dB]
  Front Right: Playback 0 [0%] [-65.25dB]
Simple mixer control 'Speaker',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Mono:
  Front Left: Playback 87 [100%] [0.00dB] [on]
  Front Right: Playback 87 [100%] [0.00dB] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 255 [100%] [0.00dB]
  Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control 'Line',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 9 [29%] [-21.00dB] [on]
  Front Right: Playback 9 [29%] [-21.00dB] [on]
Simple mixer control 'Line Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%] [0.00dB]
  Front Right: 0 [0%] [0.00dB]
Simple mixer control 'Line Out',0
  Capabilities: pswitch
  Playback channels: Front Left - Front Right
  Mono:
  Front Left: Playback [on]
  Front Right: Playback [on]
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'Beep',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 0 [0%] [-34.50dB] [on]
  Front Right: Playback 0 [0%] [-34.50dB] [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 31
  Front Left: Capture 31 [100%] [30.00dB] [on]
  Front Right: Capture 31 [100%] [30.00dB] [on]
Simple mixer control 'Capture',1
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 31
  Front Left: Capture 0 [0%] [-16.50dB] [off]
  Front Right: Capture 0 [0%] [-16.50dB] [off]
Simple mixer control 'Auto-Mute Mode',0
  Capabilities: enum
  Items: 'Disabled' 'Speaker Only' 'Line Out+Speaker'
  Item0: 'Line Out+Speaker'
Simple mixer control 'Headset Mic',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 0 [0%] [-34.50dB] [on]
  Front Right: Playback 0 [0%] [-34.50dB] [on]
Simple mixer control 'Headset Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 3 [100%] [36.00dB]
  Front Right: 3 [100%] [36.00dB]
Simple mixer control 'Input Source',0
  Capabilities: cenum
  Items: 'Headphone Mic' 'Headset Mic' 'Line'
  Item0: 'Headset Mic'
Simple mixer control 'Input Source',1
  Capabilities: cenum
  Items: 'Headphone Mic' 'Headset Mic' 'Line'
  Item0: 'Headset Mic'
Simple mixer control 'Loopback Mixing',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Disabled'
bekor@Linux1:~$ dmesg | grep snd
[   17.848978] snd_hda_intel 0000:00:1b.0: enabling device (0100 -> 0102)
[   17.849175] snd_hda_intel 0000:00:1b.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[   17.882658] snd_hda_codec_realtek hdaudioC0D0: ALC221: SKU not ready 0x411111f0
[   17.883071] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC221: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:line
[   17.883072] snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=1 (0x17/0x0/0x0/0x0/0x0)
[   17.883073] snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[   17.883073] snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
[   17.883074] snd_hda_codec_realtek hdaudioC0D0:    inputs:
[   17.883075] snd_hda_codec_realtek hdaudioC0D0:      Headphone Mic=0x1a
[   17.883075] snd_hda_codec_realtek hdaudioC0D0:      Headset Mic=0x19
[   17.883076] snd_hda_codec_realtek hdaudioC0D0:      Line=0x1b
[   18.056244] snd_hda_codec_realtek hdaudioC0D0: Failed to find dell wmi symbol dell_micmute_led_set
bekor@Linux1:~$ 
Last edited by otlichnik73 on Sun Sep 15, 2019 6:24 am, edited 1 time in total.
First Port of Call for Windows Refugees: https://switchtolinuxdesktop.wordpress.com/

otlichnik73
Level 2
Level 2
Posts: 84
Joined: Tue Mar 20, 2018 6:20 pm

Re: headphone and mic jack not working

Post by otlichnik73 » Wed Sep 11, 2019 6:28 am

MrEen wrote:
Tue Sep 10, 2019 7:14 pm
I know this will sound wrong, but it works for some non Dell users. Change model=headset-mode to model=dell-headset-multi, save then reboot and test.
And lets see amixer and dmesg | grep snd when done.
it did not help, sorry... the result is as before - when I plug headset, the Input tab of pulse still shows "headset Microphone" as unplugged
the volume bar shows of that tab very low random signal

Code: Select all

bekor@Linux1:~$ amixer
Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 87
  Mono: Playback 63 [72%] [-18.00dB] [on]
Simple mixer control 'Headphone',0
  Capabilities: pswitch
  Playback channels: Front Left - Front Right
  Mono:
  Front Left: Playback [off]
  Front Right: Playback [off]
Simple mixer control 'Headphone Mic',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 0 [0%] [-34.50dB] [off]
  Front Right: Playback 0 [0%] [-34.50dB] [off]
Simple mixer control 'Headphone Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%] [0.00dB]
  Front Right: 0 [0%] [0.00dB]
Simple mixer control 'Headphone+LO',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Mono:
  Front Left: Playback 0 [0%] [-65.25dB]
  Front Right: Playback 0 [0%] [-65.25dB]
Simple mixer control 'Speaker',0
  Capabilities: pvolume pswitch pswitch-joined
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 87
  Mono:
  Front Left: Playback 87 [100%] [0.00dB] [on]
  Front Right: Playback 87 [100%] [0.00dB] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 255 [100%] [0.00dB]
  Front Right: Playback 255 [100%] [0.00dB]
Simple mixer control 'Line',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 9 [29%] [-21.00dB] [on]
  Front Right: Playback 9 [29%] [-21.00dB] [on]
Simple mixer control 'Line Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 0 [0%] [0.00dB]
  Front Right: 0 [0%] [0.00dB]
Simple mixer control 'Line Out',0
  Capabilities: pswitch
  Playback channels: Front Left - Front Right
  Mono:
  Front Left: Playback [on]
  Front Right: Playback [on]
Simple mixer control 'IEC958',0
  Capabilities: pswitch pswitch-joined
  Playback channels: Mono
  Mono: Playback [off]
Simple mixer control 'Beep',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 0 [0%] [-34.50dB] [on]
  Front Right: Playback 0 [0%] [-34.50dB] [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 31
  Front Left: Capture 31 [100%] [30.00dB] [on]
  Front Right: Capture 31 [100%] [30.00dB] [on]
Simple mixer control 'Capture',1
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 31
  Front Left: Capture 0 [0%] [-16.50dB] [off]
  Front Right: Capture 0 [0%] [-16.50dB] [off]
Simple mixer control 'Auto-Mute Mode',0
  Capabilities: enum
  Items: 'Disabled' 'Speaker Only' 'Line Out+Speaker'
  Item0: 'Line Out+Speaker'
Simple mixer control 'Headset Mic',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 31
  Mono:
  Front Left: Playback 0 [0%] [-34.50dB] [on]
  Front Right: Playback 0 [0%] [-34.50dB] [on]
Simple mixer control 'Headset Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 3 [100%] [36.00dB]
  Front Right: 3 [100%] [36.00dB]
Simple mixer control 'Input Source',0
  Capabilities: cenum
  Items: 'Headphone Mic' 'Headset Mic' 'Line'
  Item0: 'Headset Mic'
Simple mixer control 'Input Source',1
  Capabilities: cenum
  Items: 'Headphone Mic' 'Headset Mic' 'Line'
  Item0: 'Headset Mic'
Simple mixer control 'Loopback Mixing',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Disabled'
bekor@Linux1:~$ dmesg | grep snd
[   17.848978] snd_hda_intel 0000:00:1b.0: enabling device (0100 -> 0102)
[   17.849175] snd_hda_intel 0000:00:1b.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[   17.882658] snd_hda_codec_realtek hdaudioC0D0: ALC221: SKU not ready 0x411111f0
[   17.883071] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC221: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:line
[   17.883072] snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=1 (0x17/0x0/0x0/0x0/0x0)
[   17.883073] snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[   17.883073] snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
[   17.883074] snd_hda_codec_realtek hdaudioC0D0:    inputs:
[   17.883075] snd_hda_codec_realtek hdaudioC0D0:      Headphone Mic=0x1a
[   17.883075] snd_hda_codec_realtek hdaudioC0D0:      Headset Mic=0x19
[   17.883076] snd_hda_codec_realtek hdaudioC0D0:      Line=0x1b
[   18.056244] snd_hda_codec_realtek hdaudioC0D0: Failed to find dell wmi symbol dell_micmute_led_set
bekor@Linux1:~$ 
First Port of Call for Windows Refugees: https://switchtolinuxdesktop.wordpress.com/

otlichnik73
Level 2
Level 2
Posts: 84
Joined: Tue Mar 20, 2018 6:20 pm

Re: headphone and mic jack not working

Post by otlichnik73 » Wed Sep 11, 2019 6:30 am

I guess I could get a microphone and plug into that jack, and headphones into the other and use skype that way
but it would be nicer to get the damn headset working. I use same headset on HP Envy laptop with Mint 19 on it, no problem
First Port of Call for Windows Refugees: https://switchtolinuxdesktop.wordpress.com/

User avatar
MrEen
Level 13
Level 13
Posts: 4553
Joined: Mon Jun 12, 2017 8:39 pm

Re: headphone and mic jack not working

Post by MrEen » Wed Sep 11, 2019 6:57 am

Try selecting the Headphone Mic, even though it says unplugged, and unmuting it in alsamixer. Does that make any difference?

Also unmute the Headphone column right next to Master. You won't be able to increase volume on that one, it's just a switch.

If still no luck, I'll try to get a headset tonight and see what I can figure out.

otlichnik73
Level 2
Level 2
Posts: 84
Joined: Tue Mar 20, 2018 6:20 pm

Re: headphone and mic jack not working

Post by otlichnik73 » Wed Sep 11, 2019 7:21 am

MrEen wrote:
Wed Sep 11, 2019 6:57 am
Try selecting the even though it says unplugged, and unmuting it in alsamixer. Does that make any difference?

Also unmute the Headphone column right next to Master. You won't be able to increase volume on that one, it's just a switch.

If still no luck, I'll try to get a headset tonight and see what I can figure out.
no luck, sorry
what i did exactly (just see if I am missing somethinh)
in terminal: alsamixer
in the window that opens - unmuted everything
close window
open pulse, see if mic works on headset with headset mic selecetd
situation still same as in my last post
First Port of Call for Windows Refugees: https://switchtolinuxdesktop.wordpress.com/

User avatar
MrEen
Level 13
Level 13
Posts: 4553
Joined: Mon Jun 12, 2017 8:39 pm

Re: headphone and mic jack not working

Post by MrEen » Wed Sep 11, 2019 7:23 am

otlichnik73 wrote:
Wed Sep 11, 2019 7:21 am
MrEen wrote:
Wed Sep 11, 2019 6:57 am
Try selecting the even though it says unplugged, and unmuting it in alsamixer. Does that make any difference?

Also unmute the Headphone column right next to Master. You won't be able to increase volume on that one, it's just a switch.

If still no luck, I'll try to get a headset tonight and see what I can figure out.
no luck, sorry
what i did exactly (just see if I am missing somethinh)
in terminal: alsamixer
in the window that opens - unmuted everything
close window
open pulse, see if mic works on headset with headset mic selecetd
situation still same as in my last post
Gotcha.

Hopefully in about 8-10 hours I'll have something useful to share.

otlichnik73
Level 2
Level 2
Posts: 84
Joined: Tue Mar 20, 2018 6:20 pm

Re: headphone and mic jack not working

Post by otlichnik73 » Wed Sep 11, 2019 7:34 am

MrEen wrote:
Wed Sep 11, 2019 7:23 am


Hopefully in about 8-10 hours I'll have something useful to share.
Really appreciate that!
By the way, I still have that conf file edited with ..-dell-... line; I never changed that back
First Port of Call for Windows Refugees: https://switchtolinuxdesktop.wordpress.com/

User avatar
MrEen
Level 13
Level 13
Posts: 4553
Joined: Mon Jun 12, 2017 8:39 pm

Re: headphone and mic jack not working

Post by MrEen » Wed Sep 11, 2019 3:09 pm

I'm sorry but I could not get a headset to show at all. I even tried some new edits to alsa-base.conf and nothing worked over here.

I somewhat doubt we're going to get you working properly. While you eventually got a Headset Mic to show up, there was still no Headset. That leads me to believe you'll never get 2-way sound on that device. All I can suggest is to remove the line completely from alsa-base.conf and reboot. Then the buds should work as headphones in the Headphone only port, and you'll need to get something else for microphone input. I actually use a USB mic myself, today was the first day I tried that Mic/Combo port.

The only thing that could be still causing an impact as far as I know is if the machine is a dual boot with Windows, try the buds in Windows, then shut down completely. Wait a minute before booting up into Mint and see if there's any change.

Sorry I couldn't help any more than that.

User avatar
MrEen
Level 13
Level 13
Posts: 4553
Joined: Mon Jun 12, 2017 8:39 pm

Re: headphone and mic jack not working

Post by MrEen » Wed Sep 11, 2019 7:36 pm

Well, I have one potentially helpful option. Plugging the buds into this, then using both ports should work as you'd expect: https://www.amazon.com/KINGTOP-Headset- ... lp_pl_dp_1

otlichnik73
Level 2
Level 2
Posts: 84
Joined: Tue Mar 20, 2018 6:20 pm

Re: headphone and mic jack not working

Post by otlichnik73 » Thu Sep 12, 2019 10:08 am

MrEen wrote:
Wed Sep 11, 2019 7:36 pm
Well, I have one potentially helpful option. Plugging the buds into this, then using both ports should work as you'd expect: https://www.amazon.com/KINGTOP-Headset- ... lp_pl_dp_1
Thanks a lot for all your efforts anyway!
First Port of Call for Windows Refugees: https://switchtolinuxdesktop.wordpress.com/

User avatar
MrEen
Level 13
Level 13
Posts: 4553
Joined: Mon Jun 12, 2017 8:39 pm

Re: headphone and mic jack not working

Post by MrEen » Thu Sep 12, 2019 3:58 pm

You're quite welcome. Do let us know if you manage to work around this issue.

Just a heads up, I noticed pavucontrol's Input Devices tab always had Microphone (unplugged) even when something was plugged in to the port when I tried to add the Headset option. There are a couple of options that should fix that if you run into the same.

Good luck.

otlichnik73
Level 2
Level 2
Posts: 84
Joined: Tue Mar 20, 2018 6:20 pm

Re: headphone and mic jack not working

Post by otlichnik73 » Thu Sep 12, 2019 6:28 pm

MrEen wrote:
Thu Sep 12, 2019 3:58 pm
You're quite welcome. Do let us know if you manage to work around this issue.

Just a heads up, I noticed pavucontrol's Input Devices tab always had Microphone (unplugged) even when something was plugged in to the port when I tried to add the Headset option. There are a couple of options that should fix that if you run into the same.

Good luck.
I'll check. I am buying that gizmo you mentioned, should do the trick.
Funny it worked flawlessly on my HP laptop. Is it a hardware issue? Come to think of it, this PC was bought as "reconditioned"
Thanks again!
First Port of Call for Windows Refugees: https://switchtolinuxdesktop.wordpress.com/

User avatar
MrEen
Level 13
Level 13
Posts: 4553
Joined: Mon Jun 12, 2017 8:39 pm

Re: headphone and mic jack not working

Post by MrEen » Thu Sep 12, 2019 6:35 pm

otlichnik73 wrote:
Thu Sep 12, 2019 6:28 pm
I am buying that gizmo you mentioned, should do the trick.
I believe it will work great. Just may need a tweak or two.
otlichnik73 wrote:
Thu Sep 12, 2019 6:28 pm
Funny it worked flawlessly on my HP laptop. Is it a hardware issue?
Probably a different codec involved. One that has more/better/proper support.
otlichnik73 wrote:
Thu Sep 12, 2019 6:28 pm
Come to think of it, this PC was bought as "reconditioned"
Same here. My wife got the same model as you, but will lesser specs. She still uses Windows on it. My 6305 looks exactly the same as the 8300 (and others) and I even lucked into 2 USB3 ports that the description didn't include.
otlichnik73 wrote:
Thu Sep 12, 2019 6:28 pm
Thanks again!
You're most welcome!

Post Reply

Return to “Newbie Questions”