Updates gone bad

Quick to answer questions about finding your way around Linux Mint as a new user.
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
WesternSlope
Level 4
Level 4
Posts: 234
Joined: Mon Mar 11, 2013 10:32 am
Location: Westslope of Colorado

Updates gone bad

Post by WesternSlope »

I'm trying to get updates. This what I'm trying for:
https://screenrec.com/share/OAK4iDVc1t
and this is what I get:

Code: Select all

debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
Setting up libpam0g:amd64 (1.3.1-5ubuntu4.3) ...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
dpkg: error processing package libpam0g:amd64 (--configure):
 installed libpam0g:amd64 package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
 libpam0g:amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:
Setting up libpam0g:amd64 (1.3.1-5ubuntu4.3) ...
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable
dpkg: error processing package libpam0g:amd64 (--configure):
 installed libpam0g:amd64 package post-installation script subprocess returned error exit status 1
Processing triggers for libc-bin (2.31-0ubuntu9.2) ...
Errors were encountered while processing:
 libpam0g:amd64
How do I fix it?
Thanks
sleeper12
Level 17
Level 17
Posts: 7896
Joined: Thu May 25, 2017 3:22 pm

Re: Updates gone bad

Post by sleeper12 »

Do:

Code: Select all

 sudo fuser -v -k /var/cache/debconf/config.dat 
Then try the updates again.
WesternSlope
Level 4
Level 4
Posts: 234
Joined: Mon Mar 11, 2013 10:32 am
Location: Westslope of Colorado

Re: Updates gone bad

Post by WesternSlope »

Thank you! That got it.
WesternSlope
Level 4
Level 4
Posts: 234
Joined: Mon Mar 11, 2013 10:32 am
Location: Westslope of Colorado

Re: Updates gone bad

Post by WesternSlope »

Thank you! That got it.
motoryzen
Level 6
Level 6
Posts: 1089
Joined: Sun Dec 08, 2019 12:25 am

Re: Updates gone bad

Post by motoryzen »

WesternSlope wrote:
Wed Oct 13, 2021 7:16 pm
Thank you! That got it.
Also, and pardon me if this is a " yeah captain obvious..I knew that " or " yea captain obvious..I already tried that" moment, but sometimes it sneaks up on me that I already had a synaptic package manager window open and then I go to try checking or updates or installing them only to get that same error message you received. So also remember to check and ensure Synaptic package manager isn't running

Happy to read your problem is resolved :D.
Post Reply