I installed Linux Mint and laptop is very slow.

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
CSQ
Level 1
Level 1
Posts: 14
Joined: Mon Apr 30, 2012 3:24 pm

I installed Linux Mint and laptop is very slow.

Post by CSQ »

Hi, my name is Francesco (I'm italian)..

I have a Dell XPS 1330, I was using Ubuntu 11.10, before pass to Ubuntu 12.04 I decided to install Linux Mint 12 to try it.. but I don't know why for 10 minutes it works ok, but after it starts to slow down all my computer.. web browsing is always very slow, if I want to download Ubuntu 12.04 the downloading starts ok and then it stops automaticaly (never happened like this before).

The fan is on, and is pretty normal, and the laptop is not too hot.. I was thinking could it be the fan..?

Are there other things that can help me fix this problem..?

Thanks ciao.
halcyonGray
Level 1
Level 1
Posts: 5
Joined: Mon Apr 30, 2012 3:24 pm

Re: I installed Linux Mint and laptop is very slow.

Post by halcyonGray »

Are you dual booting with Linux and Ubuntu 11.10 or did you replace Ubuntu?
CSQ
Level 1
Level 1
Posts: 14
Joined: Mon Apr 30, 2012 3:24 pm

Re: I installed Linux Mint and laptop is very slow.

Post by CSQ »

halcyonGray wrote:Are you dual booting with Linux and Ubuntu 11.10 or did you replace Ubuntu?
I replaced Ubuntu.. now I just start the lap top and everything works fine.. but in a coupple of minuts the laptop starts to warm up and the OS go a little bit slower..

I don't why, but web browser (I use Google Chrome) is always slow.. some pages I have to refresh..

Look at this link (is in italian but I think you will understand what they tolking about) you think I have to do something like that..?? http://www.jdsblog.it/hardware/677/dell ... o-12-euro/

Thanks Ciao.
User avatar
DrHu
Level 17
Level 17
Posts: 7522
Joined: Wed Jun 17, 2009 8:20 pm

Re: I installed Linux Mint and laptop is very slow.

Post by DrHu »

Are you using power control features on the notebook, such that the CPU/FAN would slow down to conserver power
  • Mainly needed if using the system on batter, however power controls (apart from hibernation issues/problems) shouldn't affect the speed of the system overall.--should not be noticeable.
General browser speedup tip..
You can speed up browsing, your list of connected sites, by using a local DNS cache
http://embraceubuntu.com/2006/08/02/loc ... -browsing/
CSQ
Level 1
Level 1
Posts: 14
Joined: Mon Apr 30, 2012 3:24 pm

Re: I installed Linux Mint and laptop is very slow.

Post by CSQ »

DrHu wrote:Are you using power control features on the notebook, such that the CPU/FAN would slow down to conserver power
  • Mainly needed if using the system on batter, however power controls (apart from hibernation issues/problems) shouldn't affect the speed of the system overall.--should not be noticeable.
General browser speedup tip..
You can speed up browsing, your list of connected sites, by using a local DNS cache
http://embraceubuntu.com/2006/08/02/loc ... -browsing/

Hi, no.. I don't use power control.. I have the cable always plug..

I don't understand what the locald DNS does.. I think internet have some problem in the net to.. (even my phone some times have trouble with internet), but still the fact that my laptop go slow down by using..

I'm thinking, probably I should try to re-install Linux Mint 12 or I try to install Ubuntu 12.04 and see if I find the same problems..
mank_in
Level 6
Level 6
Posts: 1388
Joined: Wed Nov 16, 2011 2:29 pm
Location: Bali

Re: I installed Linux Mint and laptop is very slow.

Post by mank_in »

Maybe you can give us the output of :

Code: Select all

inxi -F
CSQ
Level 1
Level 1
Posts: 14
Joined: Mon Apr 30, 2012 3:24 pm

Re: I installed Linux Mint and laptop is very slow.

Post by CSQ »

mank_in wrote:Maybe you can give us the output of :

Code: Select all

inxi -F
csq@csq-XPS-M1330 ~ $ inxi -F
System: Host csq-XPS-M1330 Kernel 3.0.0-17-generic i686 (32 bit) Desktop Gnome Distro Linux Mint 12 Lisa
Machine: System Dell (portable) product XPS M1330
Mobo Dell model 0PU073 Bios Dell version A15 date 12/26/2008
CPU: Dual core Intel Core2 Duo CPU T7250 (-MCP-) cache 2048 KB flags (lm nx sse sse2 sse3 ssse3 vmx)
Clock Speeds: (1) 2001.00 MHz (2) 800.00 MHz
Graphics: Card: nVidia G86 [GeForce 8400M GS] X.Org 1.10.4 drivers nouveau unloaded: fbdev,vesa Resolution 1280x800@60.0hz
GLX Renderer Gallium 0.4 on NV86 GLX Version 2.1 Mesa 7.11
Audio: Card Intel 82801H (ICH8 Family) HD Audio Controller driver HDA Intel Sound: ALSA v: 1.0.24
Network: Card-1 Broadcom NetLink BCM5906M Fast Ethernet PCI Express driver tg3
IF: eth0 state: down speed: 65535 Mbps duplex: full mac: 00:15:c5:7f:f8:3d
Card-2 Intel PRO/Wireless 3945ABG [Golan] Network Connection driver iwl3945
IF: wlan0 state: up mac: 00:1c:bf:66:78:d1
Drives: HDD Total Size: 164.0GB (3.6% used) 1: /dev/sda WDC_WD1600BEKT 160.0GB
2: USB /dev/sdb Cruzer_Edge 4.0GB
Partition: ID:/ size: 145G used: 4.3G (4%) fs: ext4 ID:swap-1 size: 2.14GB used: 0.00GB (0%) fs: swap
Sensors: Error: You do not have the sensors app installed.
Info: Processes 153 Uptime 1:03 Memory 524.5/2012.4MB Client Shell inxi 1.7.7
CSQ
Level 1
Level 1
Posts: 14
Joined: Mon Apr 30, 2012 3:24 pm

Re: I installed Linux Mint and laptop is very slow.

Post by CSQ »

I installed Linux Mint 12 with UNetbootin, but the last version on it is the 10.. could be this the problem..??

even for Ubuntu the last version shows on Unetbooin is the 11.04..
User avatar
Danko8321
Level 4
Level 4
Posts: 206
Joined: Thu Sep 22, 2011 2:03 pm
Location: Colombia

Re: I installed Linux Mint and laptop is very slow.

Post by Danko8321 »

CSQ wrote:I installed Linux Mint 12 with UNetbootin, but the last version on it is the 10.. could be this the problem..??

even for Ubuntu the last version shows on Unetbooin is the 11.04..
You have an outdated version of UNetBootin. Maybe it has wrecked your installation. Try downloading a newer version and tell us how that goes. I have had *a lot* of problems with crappy USB installs and I can tell you that it could be a big problem. Also, how are you downloading the iso? Are you letting UNetBootin do that for you? If the answer is yes, my comment is bad, bad, bad. Try downloading the iso from a torrent using Transmission. It is usually faster, more reliable and it checks the integrity of the ISO on the go. Better stick with the torrent. My two cents.
Cheer up! Things are getting worse at a slower rate.
mank_in
Level 6
Level 6
Posts: 1388
Joined: Wed Nov 16, 2011 2:29 pm
Location: Bali

Re: I installed Linux Mint and laptop is very slow.

Post by mank_in »

You are using nouveau drivers ( open source ), nouveau have better compatibility but terrible performance, install NVIDIA proprietary driver from additional driver ( use NVIDIA current ).
If Gnome shell ( MGSE ) slow, try MATE DE . Logout and at login screen click at little cogwheel and select MATE or maybe gnome classic.
Or you can try cinnamon desktop , cinnamon is better option than MGSE .
Install with following command :

Code: Select all

sudo apt-get install cinnamon
you can select cinnamon from login screen too.
CSQ
Level 1
Level 1
Posts: 14
Joined: Mon Apr 30, 2012 3:24 pm

Re: I installed Linux Mint and laptop is very slow.

Post by CSQ »

Danko8321 wrote:
CSQ wrote:I installed Linux Mint 12 with UNetbootin, but the last version on it is the 10.. could be this the problem..??

even for Ubuntu the last version shows on Unetbooin is the 11.04..
You have an outdated version of UNetBootin. Maybe it has wrecked your installation. Try downloading a newer version and tell us how that goes. I have had *a lot* of problems with crappy USB installs and I can tell you that it could be a big problem. Also, how are you downloading the iso? Are you letting UNetBootin do that for you? If the answer is yes, my comment is bad, bad, bad. Try downloading the iso from a torrent using Transmission. It is usually faster, more reliable and it checks the integrity of the ISO on the go. Better stick with the torrent. My two cents.
Hi I downloaded the ISO with Torrent.. (is faster yes) but probably I will try to re-install Linux Mint 12 with the last UNebootin version, that supports Lisa..
CSQ
Level 1
Level 1
Posts: 14
Joined: Mon Apr 30, 2012 3:24 pm

Re: I installed Linux Mint and laptop is very slow.

Post by CSQ »

mank_in wrote:You are using nouveau drivers ( open source ), nouveau have better compatibility but terrible performance, install NVIDIA proprietary driver from additional driver ( use NVIDIA current ).
If Gnome shell ( MGSE ) slow, try MATE DE . Logout and at login screen click at little cogwheel and select MATE or maybe gnome classic.
Or you can try cinnamon desktop , cinnamon is better option than MGSE .
Install with following command :

Code: Select all

sudo apt-get install cinnamon
you can select cinnamon from login screen too.
Hi, yes I changed the drivers like you said, internet seems to me more faster now.. but the fan still running at same way.. the important is the pc is doing more fine then before..

when I have time I try cinnamon.. and let you know..

probably I have tu replace the thermal paste or the cooling system..
K7plus1
Level 2
Level 2
Posts: 55
Joined: Thu May 03, 2012 12:46 am

Re: I installed Linux Mint and laptop is very slow.

Post by K7plus1 »

if your system works fine after booting in but slows down after sometime, it might be some program that starts to run in the background.you can find out which program is consuming your cpu power by running

Code: Select all

top
CSQ
Level 1
Level 1
Posts: 14
Joined: Mon Apr 30, 2012 3:24 pm

Re: I installed Linux Mint and laptop is very slow.

Post by CSQ »

K7plus1 wrote:if your system works fine after booting in but slows down after sometime, it might be some program that starts to run in the background.you can find out which program is consuming your cpu power by running

Code: Select all

top

Hi, I don't think there are other programs running in the background.. after put the nvidia drivers the laptop is doing fine.. I can use gimp easy..

But some times the laptop is more warm then other days.. could be because I'm from Italy, (and I bought the laptop in Europe), but now I'm living in the U.S. and are different Voltages..

Today for the first time I had the laptop (6 years almost) I hear a strange noise from the fan.. during less than 10 minutes.. any suggestions..??

Thanks Ciao.
Post Reply

Return to “Newbie Questions”