emerald problem

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
shark62
Level 1
Level 1
Posts: 5
Joined: Fri Mar 07, 2008 12:49 pm

emerald problem

Post by shark62 »

I did a clean install of mint after removing gutsy
and now i cant get emerald to work right. Compiz fusion works fine though. when I type emerald replace in the terminal the theme cahanges to what is selected in emerald but when i close the terminal i lose the theme including the window name bar so i cant even drag the window. Am i going to have to format my drive and do another install? I've looked in all the forums and can't find a solution that works. did i screw up a setting in compiz maybe?

McLovin
Level 5
Level 5
Posts: 761
Joined: Thu Aug 23, 2007 6:53 pm
Contact:

Re: emerald problem

Post by McLovin »

is window decoration enabled in compiz? if so try starting emerald by hitting alt+f2, then enter

Code: Select all

emerald --replace
don't use the terminal to ebable, cause when you close the terminal you wil lose whatever you started with the terminal.

shark62
Level 1
Level 1
Posts: 5
Joined: Fri Mar 07, 2008 12:49 pm

Re: emerald problem

Post by shark62 »

No that does'nt work I've tried it about 20 times it will change to the currently selected theme now w/o losing border but the gui in emerald still does'nt work

McLovin
Level 5
Level 5
Posts: 761
Joined: Thu Aug 23, 2007 6:53 pm
Contact:

Re: emerald problem

Post by McLovin »

try removing emerald

Code: Select all

sudo apt-get remove emerald
and then reinstall it

Code: Select all

sudo apt-get install emerald
if you used the old command

Code: Select all

sudo apt-get install beryl-emerald-emrealdthemes
then that could be your issue, as that method is not compatible with compiz. just try uninstalling and reinstalling and see if that helps

shark62
Level 1
Level 1
Posts: 5
Joined: Fri Mar 07, 2008 12:49 pm

Re: emerald problem

Post by shark62 »

no that didnt help i think when i first installed it I may have used a command intended for kde
does that make any sense?

shark62
Level 1
Level 1
Posts: 5
Joined: Fri Mar 07, 2008 12:49 pm

Re: emerald problem

Post by shark62 »

Thanx e1 for trying to help. If I cant get it fixed sno big deal as the workaround with alt f2 is not that much of a hassle and besides how many times do you change themes anyway
every thing else works flawlessly so i guess i can live with it. Thanx again

McLovin
Level 5
Level 5
Posts: 761
Joined: Thu Aug 23, 2007 6:53 pm
Contact:

Re: emerald problem

Post by McLovin »

i think i understand the issue now, do you have XGL installed? I have this issue as well, where the theme wont apply automatically when you select it in emerald, you have to use the alt+f2 command to switch, this seems to be a bug in emerald when working with XGL, not sure what it is or how to fix, but it is livable.

Post Reply

Return to “Newbie Questions”