dark despair (solved at last !!!)

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
stumbles
Level 1
Level 1
Posts: 28
Joined: Mon Jun 04, 2012 4:21 pm

dark despair (solved at last !!!)

Post by stumbles » Sat Jun 09, 2012 5:16 pm

hi tried just about every variation of Ubuntu/Debian based O/S from around versions 11 to latest - each distro fails after the boot stage i.e black screen and nothing...can sometimes hear login sounds, see wireless indicators on my laptop flashing - but no screen at all except from the blackness.
Mint 9 and 10 both booted and worked without a single problem - but from 11 on Mint and all the above the same ...blackness on screen. I have an Intel graphics card which it appears are not recognized by the kernel drivers on the above systems .. I have nomodeset option but the resolution is bad when tried out - interestingly every single live CD/DVD worked like a dream when my friend tested them on his PC- is there anything I can do to fix this or do I have to move on to another Linux System outside the Ubuntu/Debian family in order for me to get my laptop working with full graphics the way it was with Mint 9 and 10...any feedback or pointers would be of help, this black screen issue seems to be rife amongst all of the forums...thank you for your time and help


Update this link below after lots of searching has fixed the above issue for me completely if you have same problems try it out hope it works for you the way it has for myself . . . good luck :)

http://linux-on-acer-aspire-5732z.blogs ... 1.html?m=1
Last edited by stumbles on Mon Sep 17, 2012 11:32 am, edited 4 times in total.

User avatar
oobetimer
Level 7
Level 7
Posts: 1878
Joined: Tue Jun 01, 2010 12:53 pm
Location: Finland / above the Arctic Circle
Contact:

Re: dark despair

Post by oobetimer » Sat Jun 09, 2012 6:01 pm

Mageia can bring light back to your life .. :wink:

http://distrowatch.com/table.php?distribution=mageia

Snow is white like Cristmas (debian / ubuntu based, but anyway) .. :lol:

http://www.snowlinux.de/download

Scientific Linux is stable like a rock .. :D

http://distrowatch.com/table.php?distri ... scientific

mmfzbd
Level 1
Level 1
Posts: 1
Joined: Sun Jun 10, 2012 3:19 am

Re: dark despair

Post by mmfzbd » Sun Jun 10, 2012 3:31 am

I had faced similar issue (Black/Blank Screen) in my acer aspire 4736z with Mint 12 KDE live USB. Googling returned things like: Adding kernel parameter: nomodeset; acpi_osi="Linux"; acpi off etc. Although, nomodeset option worked, but the resolution was 1024x768 with 0hz. Finally, I had done these steps :
1.When automatically boot in 10 seconds menu appeared I pressed a key to prevent automatic boot.
2. Pressed Fn+Left arrow to reduce display brightness to minimum.
3. Entered into "Start Linux Mint" live session.
4. Installed Mint (dual boot with 7).
5. Each time OS choice appears (GRUB) I have to adjust brightness to minimum (Fn+Left Arrow) and boot into MInt. Thanks.

stumbles
Level 1
Level 1
Posts: 28
Joined: Mon Jun 04, 2012 4:21 pm

Re: dark despair

Post by stumbles » Tue Jun 12, 2012 4:19 am

oobetimer wrote:Mageia can bring light back to your life .. :wink:

http://distrowatch.com/table.php?distribution=mageia

Snow is white like Cristmas (debian / ubuntu based, but anyway) .. :lol:

http://www.snowlinux.de/download

Scientific Linux is stable like a rock .. :D

http://distrowatch.com/table.php?distri ... scientific
hi tried the above same issues except the Scientific Disro but resolution is very bad - yikes...!

mastablasta
Level 4
Level 4
Posts: 314
Joined: Wed Dec 02, 2009 5:02 pm

Re: dark despair

Post by mastablasta » Wed Jun 13, 2012 7:48 am

hard to give and tips or pointers since you didn't really state your hardware.

stumbles
Level 1
Level 1
Posts: 28
Joined: Mon Jun 04, 2012 4:21 pm

Re: dark despair

Post by stumbles » Wed Jun 13, 2012 5:42 pm

mastablasta wrote:hard to give and tips or pointers since you didn't really state your hardware.
hi sorry here is some info

_______________________________________
.
.

.

00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 09)
00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 09)
00:1a.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 03)
00:1d.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.3 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1d.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation 82801IBM/IEM (ICH9M/ICH9M-E) 4 port SATA Controller [AHCI mode] (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
04:00.0 Network controller: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) (rev 01)
05:00.0 Ethernet controller: Atheros Communications Inc. AR8132 Fast Ethernet (rev c

running Mint 9 Isodora on an Acer 5332 laptop 64Bit Archetecture
250GB HD
Intel Celeron T3100 twin Processor
1.9GHz
3GB Memory

hope that helps...

mastablasta
Level 4
Level 4
Posts: 314
Joined: Wed Dec 02, 2009 5:02 pm

Re: dark despair (not solved)

Post by mastablasta » Mon Jun 18, 2012 6:59 am

i did some search and it seems thisa card does indeed have a problem with latest kernel in Ubuntu. you can use previous LTS instead or one version lower (in mint i think it's Mint 12).

alternativelly you could try to run with no 3D which seems to work. ie.e try mate version or xfce.

anyway a similar issue with possible solutions: https://answers.launchpad.net/ubuntu/+s ... ion/194568

Any also try with a few other boot parameters as mentioned in earlier thread.

a bug was filed and now unless you have the knowledge to fix it you will have to wait for it to be fixed. which is annoying.

but until they you can use older (supported) version as mentioned before. EDIT: no shame in that. i use debian stable. :-D anyway in Ubuntu you can just use PPA's if you need newer software.

grputland
Level 1
Level 1
Posts: 3
Joined: Wed May 16, 2012 7:33 am

Re: dark despair (not solved)

Post by grputland » Mon Jun 18, 2012 10:31 am

Have you tried the boot parameters "drm_kms_helper.poll=0 acpi_osi=Linux acpi_backlight=vendor"? Or maybe "legacy" instead of "vendor"? I've written it up at http://www.grputland.com/2012/05/linux- ... 0-use.html .

stumbles
Level 1
Level 1
Posts: 28
Joined: Mon Jun 04, 2012 4:21 pm

Re: dark despair (not solved)

Post by stumbles » Thu Jul 12, 2012 7:57 am

hi thanks for your time nothing has worked tried em all...maybe time to move onto another Distro... : :(

mastablasta
Level 4
Level 4
Posts: 314
Joined: Wed Dec 02, 2009 5:02 pm

Re: dark despair (not solved)

Post by mastablasta » Thu Jul 12, 2012 8:22 am

maybe, or as suggested go one version down, use PPA if you need latest software and then wait until bug is fixed before upgrading.

if it's kernel bug you will find it in all linux distributions that use new kernel.

stumbles
Level 1
Level 1
Posts: 28
Joined: Mon Jun 04, 2012 4:21 pm

Re: dark despair (not solved)

Post by stumbles » Fri Aug 17, 2012 8:22 am

hi does anyone know if this kernel bug has been fixed yet...?

dagon
Level 7
Level 7
Posts: 1673
Joined: Mon Dec 06, 2010 4:33 am
Location: Kungälv, Sweden
Contact:

Re: dark despair (not solved)

Post by dagon » Fri Aug 17, 2012 10:11 am

stumbles wrote:I have nomodeset option but the resolution is bad when tried out
And there is no option for higher resolution in the monitors preferences?

stumbles
Level 1
Level 1
Posts: 28
Joined: Mon Jun 04, 2012 4:21 pm

Re: dark despair (not solved)

Post by stumbles » Mon Aug 20, 2012 8:20 am

dagon wrote:
stumbles wrote:I have nomodeset option but the resolution is bad when tried out
And there is no option for higher resolution in the monitors preferences?

Hi yes there is but the buttons don't work when i try to change the resolution ... ;( I am in basic mode so not a lot working on it i will just have to wait and hope that they fix some of the kernel bugs re intel... thank you for your time...

Post Reply

Return to “Newbie Questions”