help starting lampp at login, please

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
MrKing
Level 1
Level 1
Posts: 10
Joined: Sun Oct 14, 2007 3:52 am
Location: Cumbria, UK

help starting lampp at login, please

Postby MrKing » Sat Mar 15, 2008 2:45 pm

I would like lampp to be started when a specific user logs in.

At present, the user opens a terminal and types 'sudo /opt/lampp/lampp start'
The user is asked for the sudo(?) password and then lampp starts ok.

Can somebody please let me know if it is possible for a script to be run to start lampp when that specific user logs in?

Many thanks

lakehousetech
Level 4
Level 4
Posts: 453
Joined: Wed Nov 07, 2007 3:34 pm
Location: Toronto, ON

Re: help starting lampp at login, please

Postby lakehousetech » Sun Mar 16, 2008 7:48 pm

Your the first person I have seen using Linux Mint for a server. Anyway, check out this site for a tutorial: http://alanedwardes.com/posts/installin ... ple-guide/

Hope this helps.

MrKing
Level 1
Level 1
Posts: 10
Joined: Sun Oct 14, 2007 3:52 am
Location: Cumbria, UK

Re: help starting lampp at login, please

Postby MrKing » Mon Mar 17, 2008 3:29 pm

I'm only using lampp to test and develop a local version of my hosted website.

The link you provided certainly starts lampp but it does it for all users and only at boot-up time. So, if user2 gets on the pc first, he can stop lampp. Then, when user1 logs in, he can't use lampp without doing 'sudo /opt/lampp/lampp start' in terminal.

Ideally, the script I am looking for will only start lampp when user1 logs in.

lakehousetech
Level 4
Level 4
Posts: 453
Joined: Wed Nov 07, 2007 3:34 pm
Location: Toronto, ON

Re: help starting lampp at login, please

Postby lakehousetech » Tue Mar 18, 2008 7:54 pm

Ok. I am sorry that I was not very helpful. I have some experience with LAMP via the Ubuntu server release and also on CentOS, but haven't had multiple users so it was never an issue...Have you checked other similar forums?


Return to “Newbie Questions”

Who is online

Users browsing this forum: dai_trying, flicpper, Paraboloyd and 14 guests