cannot change default text editor

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
abhithakur88
Level 1
Level 1
Posts: 2
Joined: Mon Feb 06, 2012 12:51 pm

cannot change default text editor

Post by abhithakur88 » Wed Jun 27, 2012 7:43 am

Hello,
How to change default text editor to gvim in linux mint 13 cinnamon.
I changed text/plain settings in defaults.list in /etc/gnome to gvim.desktop but after reboot it reverts back to gedit.

Thanks and regards,
Abhishek

User avatar
veggen
Level 4
Level 4
Posts: 398
Joined: Mon May 09, 2011 4:54 am
Contact:

Re: cannot change default text editor

Post by veggen » Wed Jun 27, 2012 8:50 am

Sorry if this is stupid, but have you tried to simply choose gedit from "open with" and ticking the "remember" option for text files? There should be no need to edit anything manually.

feodor
Level 1
Level 1
Posts: 23
Joined: Fri Mar 26, 2010 7:45 am

Re: cannot change default text editor

Post by feodor » Wed Jun 27, 2012 9:01 am

I am not sure if this solves the problem for you, as I am running Mint-KDE. But I have in the Advanced-tab in the system settings a File associations icon; in there I have successfully changed default file associations (in particular for text-files)

Feodor

The Big Headed One
Level 1
Level 1
Posts: 11
Joined: Mon Jun 25, 2012 11:30 pm

Re: cannot change default text editor

Post by The Big Headed One » Sun Jul 01, 2012 4:49 pm

I'm having the same problem. Since now Nautilus (or GNOME 3, I don't know exactly who mistakenly thought removing this would be a good idea) doesn't give you the option to set yourself the path of your default application, it needs to be installed the "traditional way" via synaptic/software manager, which isn't aways possible. In my case, I have a compiled version of Mypaint 1.1dev and a standalone Blender 2.63a that doesn't need a instaltion to work, just needs to be extracted.

I changed the defaults.list both from /usr/share/applications and from /etc/gnome/. It works, but only until I reboot and it goes back to how it was before I changed it. I changed them through sudo gedit defaults.list, and I don't know why it's going back to it's former stage after the reboot.

Could someone please help, I don't want to install thunar just to have something that should be simple as that solved.

User avatar
veggen
Level 4
Level 4
Posts: 398
Joined: Mon May 09, 2011 4:54 am
Contact:

Re: cannot change default text editor

Post by veggen » Mon Jul 02, 2012 5:26 am

Not sure if I'm understanding it correctly, but your problem seems different to me then the OP's. What's bugging you is the infamous "open with custom command" that's been axed in Gnome 3.
To get your custom app to show, you need to create a launcher (.desktop file) for it. Look at roger64's post here for details.
I was in the process of making a launcher creator app, but got sidetracked... I'll try getting back to it soon.

The Big Headed One
Level 1
Level 1
Posts: 11
Joined: Mon Jun 25, 2012 11:30 pm

Re: cannot change default text editor

Post by The Big Headed One » Mon Jul 02, 2012 2:29 pm

I was creating the .desktop correctly, and was changing the defaults.list correectly. It was working, but only until I rebooted.
BUT, the %U solution worked great, now they show under the applications menu to choose from, thank you very much, and sorry if I sounded aggressive :/

Post Reply

Return to “Newbie Questions”