Problems compiling Gimp (painter) 2.7, old babl

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
The Big Headed One
Level 1
Level 1
Posts: 11
Joined: Mon Jun 25, 2012 11:30 pm

Problems compiling Gimp (painter) 2.7, old babl

Post by The Big Headed One »

Hi guys and gals

I've been trying to compile Gimp Painter 2.7 using this guide: http://www.davidrevoy.com/data/document ... -1204.html
but there's a problem stoping me from successfully doing it.

The problem is similar to this: http://forums.linuxmint.com/viewtopic.p ... babl+0.1.1 (The topic was too old, so I decided to create a new one)

When I put command the command of "Last Gegl" section: ./autogen.sh --prefix=/opt/gimp-painter-2.7 --disable-gtk-doc --without-libavformat, I receive this wall of text: http://pastebin.com/sfmzJGFK, with this errors on the last lines:

Code: Select all

checking for BABL... no
configure: error: Package requirements (babl >= 0.1.10) were not met:

Requested 'babl >= 0.1.10' but version of babl is 0.0.22

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables BABL_CFLAGS
and BABL_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
Do you know any way to solve this under Linux Mint? The guy from the other topic didn't specify how he solved it, and I can't find a solution :/

Thank you in advance.
User avatar
I2k4
Level 5
Level 5
Posts: 709
Joined: Thu Feb 02, 2012 8:33 pm

Re: Problems compiling Gimp (painter) 2.7, old babl

Post by I2k4 »

I don't understand the "painter" thing - if it's different from ordinary GIMP. My understanding is that GIMP 2.8 is available for the recent versions of Ubuntu / Mint.

If like me you're using an older version: This unofficial compilation of the 2.7 beta (single window is one click in its Windows menu, but the setting doesn't save) is working fine on my Mint 10, 11 and Lubuntu 10.10 installs.

GIMP 2.7 for older Ubuntu versions (unofficial):

ppa:matthaeus123/mrw-gimp-svn

Not being good with terminal I simply added it to the Synaptic PM repositories, it replaces 2.6 and upgrades in the normal way. I left the extras and UFRaw plug ins as is and they work fine on 2.7.

Hope this is helpful.
TRUST BUT VERIFY any advice from anybody, including me. Mint/Ubuntu user since 10.04 LTS. LM20 64 bit XFCE (Dell 1520). Dual booting LM20 XFCE / Win7 (Lenovo desktop and Acer netbook).
The Big Headed One
Level 1
Level 1
Posts: 11
Joined: Mon Jun 25, 2012 11:30 pm

Re: Problems compiling Gimp (painter) 2.7, old babl

Post by The Big Headed One »

I've got it to work, here's how:

I decided to install GIMP 2.8 because I really needed it and couldn't wait to the gimp-painter to work. I was checking Synaptic and found that there were two babls insalled: a 0.0.22 and a 0.1.10. After I uninstalled the 0.0.22 and tried all the guide again, it worked :D

Maybe it was obvious, but I'm new in the "world of compiling", so I was afraid to mess up my Linux xD

Thank you guys!
User avatar
Deevad
Level 1
Level 1
Posts: 23
Joined: Mon Apr 13, 2009 2:22 pm
Location: Toulouse (31) - FRANCE
Contact:

Re: Problems compiling Gimp (painter) 2.7, old babl

Post by Deevad »

Hey ;)
Good you found out , so it was a problem related to the first line of my guide :
First remove all Gimp 2.6 of your system with your package manager.
For other who fall also on this topic and struggling ; we shared some comment with Raphael here ( starting from comment 43 ) about it :
http://www.davidrevoy.com/article116/ku ... 40518520-1

Happy compilation. :D ( and remember , it's not because it worked while published that it will work in the future, do it to your own risk ; code change on repository and systems too )
____________________________________
::: ::: portfolio ::: :::
Post Reply

Return to “Newbie Questions”