Page 1 of 1

[SOLVED] Changing default File Manager

Posted: Wed Sep 19, 2012 4:12 pm
by Amithiel
Hey guys, i Just installed the new cinnamon 1.6, along with nemo. but i can't set it as default file manager
Nautilus still pops up. I'm affraid of removing nautilus and can't work then.
I searched google but all i can find is big tutorials evolving command line and extense scripts. i mean... come on, issn't there an easy way to just set it as default?

Re: Changing default File Manager

Posted: Thu Sep 20, 2012 4:31 pm
by Amithiel
Its amazing, no matter how hard i search, i keep getting also other foruns with people asking this question and no replies. even on IRC, everybody avoids this question!
It's either so easy to do, that no one's bothering to help, Or, it's so hard that's impossible to do it!
I found a supposed way to make it work: " right click any folder, click open with... and select nemo, then mark to always open with it". There's no "open with nemo".
There is "open with (files)" that happens to be nemo, but there's no option to set it as default.
I saw a guy facing the same issue and decided to remove nautilus. the result was: Nemo not opening by default, he lost his file manager.
I would prefer avoiding that, but i guess i have to quit searching this. it's a dead end
Also, someone said on another blog, to go for "prefered applications list". I don't know what the hell these people are talking about!! there is a "List" going to preferences/details/default applications, but there's no "file manager" to choose! i must be blind here.
And then, theres another group of people that didn't even had to do anything at all! installed cinnamon 1.6, reboot and thei're using nemo as default!
this is driving me mad...

The way i updated my system was:
- enabling romeo on the update manager as suggested
- updating cinnamon
- reboot
- disable romeo again

That's it! no errors at all, no issues, just the damn nautilus still remains the default file manager!

Re: Changing default File Manager

Posted: Fri Sep 21, 2012 5:04 am
by sintetico
After that you go to Menu -> Preferences -> Software Manager ...search for Nautilus ...uninstall it ...restart your computer.
The desktop icons of Computer and Home have disappeared.
To restore them go to Menu -> Accessories ...right click on Files and click Add to desktop.
Now you have a shortcut to Nemo on your desktop, to change its right click on it -> Properties ...click on the icon and navigate to
/usr/share/icons/Mint-X/devices/128/computer.svg
Change the name of the shortcut to Computer and you are done.

Re: Changing default File Manager

Posted: Fri Sep 21, 2012 3:57 pm
by Amithiel
THANKS GOD! finally, a viable solution. Thanks so much man, seriously. afterall, no harm removing nautilus :)
Cheers dude!

Re: [SOLVED] Changing default File Manager

Posted: Wed Oct 03, 2012 10:54 am
by shnplr
Or...
Preferences --> Cinnamon Settings --> Desktop --> (make icons visible)

Re: [SOLVED] Changing default File Manager

Posted: Thu Nov 15, 2012 11:56 am
by cygnus

Re: [SOLVED] Changing default File Manager

Posted: Mon Nov 26, 2012 6:44 pm
by h.liem.n
Guys a much easier method and it worked for me is to right-click on the panel, Troubleshoot, Restore all settings to default. You will have to re-configure your favourite, panel, and shortcuts, etc.

Re: [SOLVED] Changing default File Manager

Posted: Thu Nov 29, 2012 6:21 am
by PiMinto
cygnus
This is what I did:

viewtopic.php?f=208&t=115611&p=648075#p648075
I followed those instructions and it worked. This is what I did (without removing nautilus):
Open /usr/share/applications/defaults.list (as admin)
search for the line with "nautilus" and replace with "nemo"
save, close, and nemo is now the default.

if anyone is helplessly clicking the 'files' icon in the panel and still encountering Nautilus, as I was, remember to remove the existing icon (Nautilus) and add Nemo.(look for it as "Files" in the menu, green folder icon and right click > add to panel)

Re: [SOLVED] Changing default File Manager

Posted: Wed Dec 05, 2012 9:44 am
by PiMinto
PiMinto wrote:
cygnus
This is what I did:

viewtopic.php?f=208&t=115611&p=648075#p648075
I followed those instructions and it worked. This is what I did (without removing nautilus):
Open /usr/share/applications/defaults.list (as admin)
search for the line with "nautilus" and replace with "nemo"
save, close, and nemo is now the default.

if anyone is helplessly clicking the 'files' icon in the panel and still encountering Nautilus, as I was, remember to remove the existing icon (Nautilus) and add Nemo.(look for it as "Files" in the menu, green folder icon and right click > add to panel)
The above change to defaults.list seems temporary - on reboot it's back to nautilus. Can this thread revert to unsolved?

Re: [SOLVED] Changing default File Manager

Posted: Sat Dec 08, 2012 6:39 pm
by zeddock
deafults.list seems to be temporary and resets after reboot for me. (I was trying to add another default proggy, but still.)

If anyone has solution to this please advise.

Zeddock

Re: [SOLVED] Changing default File Manager

Posted: Fri Dec 14, 2012 11:41 am
by cygnus
PiMinto wrote:
PiMinto wrote:
cygnus
This is what I did:

viewtopic.php?f=208&t=115611&p=648075#p648075
I followed those instructions and it worked. This is what I did (without removing nautilus):
Open /usr/share/applications/defaults.list (as admin)
search for the line with "nautilus" and replace with "nemo"
save, close, and nemo is now the default.

if anyone is helplessly clicking the 'files' icon in the panel and still encountering Nautilus, as I was, remember to remove the existing icon (Nautilus) and add Nemo.(look for it as "Files" in the menu, green folder icon and right click > add to panel)
The above change to defaults.list seems temporary - on reboot it's back to nautilus. Can this thread revert to unsolved?
I've rebooted many times and it never reverted back for me. Maybe something in the init scripts is overwriting it? For the record I'm using Ubuntu 12.04, not Mint.

Re: [SOLVED] Changing default File Manager

Posted: Fri Dec 14, 2012 6:00 pm
by zeddock
...Looks like you have to change this one too or it won’t survive reboot: sudo gedit /usr/share/linuxmint/common/artwork/mime/defaults.list

Re: [SOLVED] Changing default File Manager

Posted: Sun Jan 13, 2013 1:05 pm
by erie88
I found out the trick here http://www.fandigital.com/:
Open in terminal:

Code: Select all

xdg-mime query default inode/directory
(to check the default file manager)

Then write this:

Code: Select all

xdg-mime default nemo.desktop inode/directory application
hopefully this could help. May need with sudo.

Re: [SOLVED] Changing default File Manager

Posted: Tue Jan 29, 2013 11:26 am
by subxaero
erie88 wrote:I found out the trick here http://www.fandigital.com/:
Open in terminal:

Code: Select all

xdg-mime query default inode/directory
(to check the default file manager)

Then write this:

Code: Select all

xdg-mime default nemo.desktop inode/directory application
hopefully this could help. May need with sudo.
This works for me. Thanks.

Re: [SOLVED] Changing default File Manager

Posted: Mon Feb 11, 2013 8:36 pm
by dereism
erie88 wrote:I found out the trick here http://www.fandigital.com/:
Open in terminal:

Code: Select all

xdg-mime query default inode/directory
(to check the default file manager)

Then write this:

Code: Select all

xdg-mime default nemo.desktop inode/directory application
hopefully this could help. May need with sudo.
This appears to be working on a Fedora 18 install as well. Thank you so much!