video playback choppy and/or very fast

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
ablech
Level 1
Level 1
Posts: 11
Joined: Fri Sep 21, 2012 7:05 pm

video playback choppy and/or very fast

Postby ablech » Fri Sep 21, 2012 7:11 pm

I recently installed Linux Mint and am having issues with video playback. I originally installed Ubuntu and was having this issue as well, then I tried Mint and have the same issue. I thought it might be a flash problem, but I'm not convinced of that either. When I play a video, it often is choppy or "skips" for a couple of frames. Sometimes the audio and video are then not aligned. Sometimes the video inexplicably starts playing very fast, as if in fast forward. I've also had similar issues when streaming just audio, not video. When I stream a song, for example, it might also skip and/or go into fast forward mode. Couldn't find an answer to this anywhere. Any thoughts?

Linux Mint 13 Maya 64 bit
Intel 2500K (using on-board graphics, no separate video card)
Asus p8 z68 vlx mobo

ablech
Level 1
Level 1
Posts: 11
Joined: Fri Sep 21, 2012 7:05 pm

Re: video playback choppy and/or very fast

Postby ablech » Sat Sep 22, 2012 3:53 pm

Anyone?

jamvaru
Level 3
Level 3
Posts: 192
Joined: Thu Dec 15, 2011 11:53 pm

Re: video playback choppy and/or very fast

Postby jamvaru » Sat Sep 22, 2012 6:02 pm

well, im not sure what a 2500k is, but what I did was to remove the adobe files and just use the mintflash (mint-flashplugin) files, then install flash update, or 'Adobe Flash Player plugin installer'; this updates the mintflash files which seem to work good ( i guess )

you may have a problem with the proprietary video driver? which are you using?

post some more info about your system, ram, hdd size, etc.

ablech
Level 1
Level 1
Posts: 11
Joined: Fri Sep 21, 2012 7:05 pm

Re: video playback choppy and/or very fast

Postby ablech » Sun Sep 23, 2012 5:40 pm

Thanks for the info. Sorry for not being clear. I have the Intel Core i5 2500K processor, which has onboard graphics Intel HD 3000. Also using G.SKill Raw memory Ripjaw Series 8GB (2x4gb) ddr3. OS is loaded on Plextor 128 GB m5S SSD. Also have Samsung Spinpoint F3 1TB HDD, but that doesn't have anything on it as of now. 500W PC Power & Cooling Silencer MK III Modular 80 Plus Bronze power supply. But just using the onboard Intel processor graphics so no separate video card. I don't think there's a driver?

I'm not sure what you mean by "remove the adobe files and just use the mintflash." I'm talking about issues with, for example, youtube, hulu, other streaming sources, etc. Do you meant delete adobe altogether as a plugin? And replace with I've tried both firefox and chrome, and I have the same issue on both. (I'd prefer to stick with chrome.)

When I open the Software Manager, it shows that I already have mint-flashplugin-11 and adobe-flashplugin installed. Should I get rid of one?

Thanks again

ablech
Level 1
Level 1
Posts: 11
Joined: Fri Sep 21, 2012 7:05 pm

Re: video playback choppy and/or very fast

Postby ablech » Sun Sep 23, 2012 5:47 pm

also, if I disable the non mint-flashplugin plugins (there were two other shockwave flash plugins on chrome), then when I load a page that requires flash it won't run unless I click "run this time"

User avatar
palo
Level 4
Level 4
Posts: 459
Joined: Mon Jun 25, 2012 7:28 am
Location: Walking on sunshine

Re: video playback choppy and/or very fast

Postby palo » Sun Sep 23, 2012 6:13 pm

ablech wrote:I've also had similar issues when streaming just audio, not video. When I stream a song, for example, it might also skip and/or go into fast forward mode. Couldn't find an answer to this anywhere. Any thoughts?


How are you streaming audio? Just to elimiminate any question about flash - go to this site and opt in for the HTML5 trial - play some youtube videos and see if the problem is still there. It sounds odd that you have the same problem with just music.

ablech
Level 1
Level 1
Posts: 11
Joined: Fri Sep 21, 2012 7:05 pm

Re: video playback choppy and/or very fast

Postby ablech » Sun Sep 23, 2012 6:57 pm

I tried the html5 version, and it was telling me that "Adobe Flash Player was blocked because it is out of date." And the window where the video should be shows the puzzle piece and says "Flash is out of date." Not sure why it's doing this if this is not supposed to require Flash. But I can still click on "Run this time" and will play the video.

I've tried just audio on wearehunted.com, hypem.com, etc.

User avatar
palo
Level 4
Level 4
Posts: 459
Joined: Mon Jun 25, 2012 7:28 am
Location: Walking on sunshine

Re: video playback choppy and/or very fast

Postby palo » Sun Sep 23, 2012 7:26 pm

I tried your first audio link and there are no issues with it here. Re: HTML5 - not every video at YouTube will be available that way (if you are playing one just right click on it to find out). Here is one I picked at random to try http://www.youtube.com/watch?v=5ccZGp2YCPk&feature=b-cat-entertainment
What browser are you using and did you install any add-ons? You may want to go back to that site in my first post and verify that it shows you are currently in the HTML5 trial.

Also please provide some information about your hardware - CPU, Ram etc., and what type of internet connection.

Pat

ablech
Level 1
Level 1
Posts: 11
Joined: Fri Sep 21, 2012 7:05 pm

Re: video playback choppy and/or very fast

Postby ablech » Sun Sep 23, 2012 7:58 pm

Thanks. I tried that video and no issues, but doesn't mean the problem is solved. Sometimes videos will work for a bit and then go haywire. I've had the issue on both chrome and firefox. I'm currently using chrome. No extensions in use. Plugins include flash, remoting viewer, native client, chrome pdf viewer, vlc multimedia, windows media player, divx, quicktime, iced tea, realplayer, and mplayer. I didn't individually install any of these plugins, so i assume most/all are just stock plugins.

see post above for system info. i am using a wired connection (running at 50.46 mbps download, 5.8mbps up)

User avatar
palo
Level 4
Level 4
Posts: 459
Joined: Mon Jun 25, 2012 7:28 am
Location: Walking on sunshine

Re: video playback choppy and/or very fast

Postby palo » Mon Sep 24, 2012 5:22 am

Sorry I overlooked the specs you posted. I wonder if the stuttering music and stuttering video is just happening when there is some background task and the CPU is overloaded trying to process video information - which leads to the question of graphic drivers. I would agree that flash alone is not the problem. Video drivers for that chip is not something I have experience with and hopefully someone will drop in with knowledge on that issue. Sorry I couldn't be more help.
Please post output of

Code: Select all

inxi -Gx


Pat

Edit: Just a thought since you mentioned Chrome... If you keep the Chrome browser closed and just have Firefox open, do you still see the problems? When I used Chromium later builds I was finding that everything ran slow and performance was poor. The longer it was open and the more tabs there were the worse it became. Task Manager was loaded with running chrome processes. Never found a solution other than not use the browser anymore. Long shot for you maybe but worth trying.

And see if this applies:http://forums.linuxmint.com/viewtopic.php?f=48&t=106040

ablech
Level 1
Level 1
Posts: 11
Joined: Fri Sep 21, 2012 7:05 pm

Re: video playback choppy and/or very fast

Postby ablech » Mon Sep 24, 2012 10:15 pm

Thanks.

palo: as requested --


~ $ inxi -Gx
Graphics: Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller bus-ID: 00:02.0
X.Org: 1.11.3 drivers: intel (unloaded: vesa,fbdev) Resolution: 1920x1080@60.0hz
GLX Renderer: Mesa DRI Intel Sandybridge Desktop GLX Version: 3.0 Mesa 8.0.2 Direct Rendering: Yes


Pat: I' have had the same issue on Firefox as well as Chrome.

I've tried overloading the cpu, and I'm not sure if that's the issue. I looked at that link you posted as well, thanks. Unfortunately, I didn't have an HDMI audio profile selected, so that doesn't seem to apply.

Still having this issue. Although, now that I've disabled two of three Flash plugins, except for the one at this location /usr/lib/adobe-flashplugin/libflashplayer.so, I have not had the same sudden fast-forward issue in about a day. I'm assuming that had something to do with it but I can't be sure since I've tried a variety of "fixes." However, it still will skip/stutter unpredictably. And I won't be surprised if/when it starts fast-forwarding again. So, still looking for a solution!

homerscousin
Level 5
Level 5
Posts: 531
Joined: Fri May 25, 2012 2:43 pm
Location: Somewhere on planet Earth (mostly)

Re: video playback choppy and/or very fast

Postby homerscousin » Tue Sep 25, 2012 6:45 pm

You are running an i5 2500 with the onchip HD 3000 graphics. I am running an i5 3570k with the onchip HD4000 graphics. Almost identicle. You have problems, I don't. I assume you run Mint 13, some flavor. I run Mint 13 KDE. I have flash, realplayer, quicktime, mplayer, divx, iced tea, skype and windows media player as plugins enabled on Firefox 15.0. I have Adblock and Flashblock enabled as extensions. There are some differences in plug-ins. I'd look there first, maybe do a reinstall of Firefox or Chrome and eliminate the plugins or try disabling the ones I don't list. Without knowing complete details, our systems should run pretty much the same. I've never used Chrome. I really don't think it has anything to do with the Intel graphics. And, I know your CPU is not burdened by such a minor task as playing any video. I can play any You-tube 1080p video, and it plays perfectly, and the CPU always runs at idle speed. I would have to open around 10 1080p videos concurently to get near max.

I am not knowledgeable about the differences between Sandy Bridge and Ivy Bridge graphics drivers. But, I kinda thought they were almost identical.
i5 3570k, ASRock z77 Extreme 4, 8 Gb Ripjaws 1600, Antec 430w psu, HVR 1600 tv tuner, custom case- marble top, oak face. Carver & DCM Time Window sound system. Mint 14 KDE.

jamvaru
Level 3
Level 3
Posts: 192
Joined: Thu Dec 15, 2011 11:53 pm

Re: video playback choppy and/or very fast

Postby jamvaru » Wed Sep 26, 2012 1:50 am

well, if all else fails, perhaps the intel website/forum might be the place for answers, or possibly whatever your manufacturer is?
my problem was that flash would just stop, basically freeze, unclickable, though sometimes I could restart it, like on rt.com, click play again, or not, it was unpredictable... it might stop, and be able to restart a couple of times, then freeze... i got rid of the adobeflashplugins and just did the mint ones, then run the flashinstaller, which updates the mintones, i guess, cause it didn't install the adobe files... shrug, it works

hopefully intel or your manufacturer has a linux section; apparently adobe don't give a blarg about it

ablech
Level 1
Level 1
Posts: 11
Joined: Fri Sep 21, 2012 7:05 pm

Re: video playback choppy and/or very fast

Postby ablech » Sat Sep 29, 2012 6:10 pm

Thanks for the feedback. Still not having the "fast-forward" issues, but I am still having the "skipping" issues. It's annoying but much easier to live with. Sill trying to work out a fix though. Thanks for the input, and if anyone else has any ideas please let me know!

jamvaru
Level 3
Level 3
Posts: 192
Joined: Thu Dec 15, 2011 11:53 pm

Re: video playback choppy and/or very fast

Postby jamvaru » Sat Sep 29, 2012 6:31 pm

i still say uninstall adobe-flash and run flash-install again


Return to “Newbie Questions”