LinuxMint and 3G connection with Huawei 220

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Level 1
Level 1
Posts: 1
Joined: Tue Apr 22, 2008 4:22 pm

LinuxMint and 3G connection with Huawei 220

Postby davidm » Tue Apr 22, 2008 6:08 pm

I am new to linux, having bought an eeepc 2G about a month ago. However I have a lot of Unix experience, as root, and mostly using command line.

I was wrestling with various Linux distros, until I discovered LinuxMint on a magazine freebie this weekend. This ran successfully on the eeepc, with some limitations due to the small screen size. However it looks great, and has IMO a very clean and adjustable interface. I was so impressed that I immediately installed it straight into a 30Gb partition on my laptop (a Toshiba Satellite 2650).

The downside is that to be of any use, other than admiring its aesthetics, any Unix installation needs an internet connection. I don't have an ADSL connection, I use a wireless 3G modem - a HUAWEI e2220, supplied in my case by 02 Ireland, but available in various guises from many mobile phone companies, in particular all the Vodafones. It plugs into a USB port and is set up for Windows.

Not suprisingly, it did not work 'out of the box'. The main problem, for most Unix (but not the eeepc's version of Xandros), is that it contains both the modem and a pretend 'CD ROM' drive containing firmware, attached to the same USB connection. The OS detects the modem, then detects the memory stick, decides that it can be the latter only, and drops the modem connection.

The highly experimental answer, in my case, was to run the script, available from Despite the name, this works for any HUAWEI 220. I ran it as root from /root directory, but since it appears to use absolute addressing the location probably doesn't matter.

It installed without any problems, and inserted a new entry in Daryna > Applications > Internet > Vodafone Mobile Connect Card Driver for Linux. Before this would execute I had to change some security settings:

chmod -R 777 /opt/vmc/etc/ppp
chmod 660 /opt/vmc/etc/ppp/*-secrets

(as root, and it only needs vmc group access, but I couldn't be bothered with doing anything else)

This opens a window which invites you to enter ISP specific details, which I did, and .... it failed to connect.

However the script installs a number of useful goodies around the file system, such as drivers, and a program called
HuaweiAktBbo which resolves the USB port problem.

I then set up an /etc/wvdial.conf file:
[Dialer Defaults]
Modem = /dev/ttyUSB0
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Init3 = AT+CGDCONT=16,"IP","open.internet";
Modem Type = Analog Modem
Phone = *99#
isdn = 0
Username = gprs
Password = gprs
Baud = 460800

(the open.internet, and gprs user/password bits are ISP specific - your ISP should cough up this information, although they don't like the idea of non-standard, non-windows users much)

I executed wvdial as root

And voila - an elegant Unix which is USABLE!

Like most Unix work-rounds the above is using several bits of sledgehammer to crack a small but complex nut. There are no doubt more elegant solutions around. This one was quick and not over-technical, providing you are happy with command line interfaces.

The only remaining pitfall is whether the setup will survive one or more reboots. I will try it and append the results here. After that I think I will try installation on the eeepc.

Level 23
Level 23
Posts: 18703
Joined: Sun Feb 11, 2007 7:22 am
Location: Near Borås Sweden

Re: LinuxMint and 3G connection with Huawei 220

Postby Husse » Wed Apr 23, 2008 6:03 am

So you've solved it yourself :)
If you search for Huawei in the forum yo get some 23 matches this being one of them
That's also a 220 working
Don't fix it if it ain't broken, don't break it if you can't fix it

Return to “Newbie Questions”