analog sound not found

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
sherbert
Level 1
Level 1
Posts: 8
Joined: Tue May 11, 2010 7:57 pm

analog sound not found

Post by sherbert »

I posted this yesterday under a solved topic. I saw a post to say I had a better chance of getting an answer if I started a new topic.

Here goes. I'll go back for the previous reference number.

[Well Mads, must be the go to person on this topic. I have been looking high and low for a few hours.]

I upgraded today (11 to 13) but did not have the sound covered (did it at the office without speakers).
Now I find that although I have 2 cards, only the HDMI is recognised in sound settings.
Here is the result of inxi -F
>>
shane@homeoffice ~ $ inxi -F
System: Host: homeoffice Kernel: 3.2.0-23-generic x86_64 (64 bit) Desktop: Gnome Distro: Linux Mint 13 Maya
Machine: Mobo: Gigabyte model: GA-MA74GMT-S2 Bios: Award version: F8 date: 08/03/2010
CPU: Dual core AMD Athlon II X2 250 (-MCP-) cache: 2048 KB flags: (lm nx sse sse2 sse3 sse4a svm)
Clock Speeds: 1: 800.00 MHz 2: 800.00 MHz
Graphics: Card: Advanced Micro Devices [AMD] nee ATI Redwood PRO [Radeon HD 5500 Series]
X.Org: 1.11.3 drivers: ati,radeon (unloaded: vesa,fbdev) Resolution: 1280x1024@60.0hz
GLX Renderer: Gallium 0.4 on AMD REDWOOD GLX Version: 2.1 Mesa 8.0.4
Audio: Card-1: Advanced Micro Devices [AMD] nee ATI Redwood HDMI Audio [Radeon HD 5000 Series] driver: snd_hda_intel
Card-2: Avance Logic ALS4000 Audio Chipset
Sound: Advanced Linux Sound Architecture ver: 1.0.24
Network: Card: Realtek RTL8111/8168B PCI Express Gigabit Ethernet controller driver: r8169
IF: eth0 state: up speed: 100 Mbps duplex: full mac: 1c:6f:65:50:22:5e
Drives: HDD Total Size: 500.1GB (5.7% used) 1: /dev/sda ST3500418AS 500.1GB
Partition: ID: / size: 462G used: 27G (7%) fs: ext4 ID: swap-1 size: 4.29GB used: 0.00GB (0%) fs: swap
Sensors: System Temperatures: cpu: 25.5C mobo: N/A gpu: 61.0
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 151 Uptime: 1:37 Memory: 511.9/3952.7MB Client: Shell inxi: 1.7.33
shane@homeoffice ~ $

And here is a screenshot of the sound preferences: (sorry, can't figure out how to upload a screenshot, but only the HDMI card is offered as a configurable option)

And here is the print out of alsa-base conf
# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from being loaded as first soundcard
options snd-usb-audio index=-2
>>>>
All those -2 indexes!
Could you please tell me how to set the Avance card as the primary output device?
I had it loaded earlier, although searching my command history I cannot figure out what added it. Even so, everything was locked in mute and nothing would un-mute it.
Hope you can help.
thanks

sherbert
Level 1
Level 1

Posts: 3
Joined: Tue May 11, 2010 7:57 pm

User avatar
viking777
Level 14
Level 14
Posts: 5113
Joined: Mon Dec 01, 2008 11:21 am

Re: analog sound not found

Post by viking777 »

Fair enough, if this is where you want your topic, this is where it will stay. I will delete what is now a duplicate topic under Sound, Multimedia and codecs as cross posting is also contrary to forum rules.
Fujitsu Lifebook AH532. Intel i5 processor, 6Gb ram, Intel HD3000 graphics, Intel Audio/wifi. Realtek RTL8111/8168B Ethernet.Lubuntu 13.10,Ubuntu12.10 (Unity), Mint16 (Cinnamon), Manjaro (Xfce).

sherbert
Level 1
Level 1
Posts: 8
Joined: Tue May 11, 2010 7:57 pm

Re: analog sound not found

Post by sherbert »

Hi Viking, I had no idea I was in the wrong place. I do apologise. Please kindly direct me to the protocols page. I did read the "read this". I am not finding my way around very well. I had no idea that I was cross-posting, either. I have heard the term and, be assured, my infringement was not deliberate.
I would have sent a private message but I gather that is also deprecated (in the moral or legal sense).
I am happy to do the leg work, I just need a little direction. I do not see any issue numbers or other indexing system so I have been searching for various keywords and phrases. I will look in the department you have mentioned.
I was not notified that you had replied. I guess that means I have to check-in regularly. I should find a way of finding my way back to where I was.
thanks
SH

Post Reply

Return to “Newbie Questions”