How do I add additional keyboard language?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
sirusdark
Level 1
Level 1
Posts: 1
Joined: Mon Nov 26, 2012 1:12 am

How do I add additional keyboard language?

Postby sirusdark » Mon Nov 26, 2012 1:43 am

Hi!

Quick question:
-How do we add additional keyboard language in LinuxMint? And/or how to change it?

I'd like to be able to use other languages and to switch on the fly the keyboard's language so that I can use different localized characters... like for French. German, Spanish, etc. (In Windows it's a piece of cake to do, but in LinuxMint, I can't). Just to make it clear, I mean only the keyboard's language, not the OS.

All I see in the keyboard layout's setting menu is "English" choices (Menu > System Tools > System Settings > Keyboard Layout)

My Linux version : Linux LinuxMint12 3.0.0-12-generic #20-Ubuntu SMP


Thanks!
Sirus

User avatar
xenopeek
Level 23
Level 23
Posts: 19030
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: How do I add additional keyboard language?

Postby xenopeek » Tue Nov 27, 2012 6:00 am

sirusdark wrote:All I see in the keyboard layout's setting menu is "English" choices (Menu > System Tools > System Settings > Keyboard Layout)

That's just not true. What do you suppose the + (plus) icon on the bottom of the list would do? :D
Image

User avatar
Jim1938
Level 2
Level 2
Posts: 76
Joined: Thu Nov 29, 2012 8:49 pm
Location: USA

Re: How do I add additional keyboard language?

Postby Jim1938 » Sat Dec 01, 2012 6:03 pm

...
LM13xfce & a diy pc.

Here is how I was able to create a dual language (EN & DK) keyboard.
abc ...æøå
I change languages by pressing ctrl and shift together
with my left pinky finger. EZ PZ. :)
No desktop language indicator. :(

Go to etc/default/keyboard
XKBMODEL="pc105"
XKBLAYOUT="us,dk" <<== edit for your languages
XKBVARIANT=""
XKBOPTIONS="grp:ctrl_shift_toggle" <<== edit for your toggle key(s)

If this solves your issue, please edit your question as [SOLVED]
...
Wirth's law - Software is getting slower more rapidly than hardware becomes faster.


Return to “Newbie Questions”

Who is online

Users browsing this forum: blockhead47, gifft, MajorMuff, Pierre and 23 guests