asus nx1101 pci adapter does not get detected (solved)

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
User avatar
NissanNut
Level 1
Level 1
Posts: 31
Joined: Tue Jul 19, 2011 9:29 pm
Location: Texas

asus nx1101 pci adapter does not get detected (solved)

Post by NissanNut » Fri Dec 28, 2012 9:25 pm

My builtin NIC started having 50% packetloss. So I stuck in a usb to ethernet and it worked perfect. But for a permanent fix I bought a asus nx1101 pci adapter. I get a link light, but mint 14 does not detect this hardware. It there a way to make it detect it?

I turned off builtin in BIOS. Did not help.

I go in control panel no ethernet shows up.

Asus website says ubuntu support only. But the CD has linux drivers for fedora etc.

Not sure if this is because I use 64bit? Do I have to make my own drivers? I tried the instructions in the readme but it fails,

help!!!
Last edited by NissanNut on Tue Jan 08, 2013 8:02 pm, edited 1 time in total.
Mint 16 Cinnamon 64 bit - Server/Home PC
Mint 13 Mate 32 bit - Laptop IBM t42

mank_in
Level 6
Level 6
Posts: 1390
Joined: Wed Nov 16, 2011 2:29 pm
Location: Bali

Re: asus nx1101 pci adapter does not get detected

Post by mank_in » Sat Dec 29, 2012 11:32 am

If your card chipset is Realtek 8169, you can try this :
http://djlab.com/2010/10/fixing-rtl8111 ... nt-page-1/

to check your network card :

Code: Select all

lspci |grep Ethernet
Last edited by mank_in on Sat Dec 29, 2012 11:09 pm, edited 1 time in total.

User avatar
NissanNut
Level 1
Level 1
Posts: 31
Joined: Tue Jul 19, 2011 9:29 pm
Location: Texas

Re: asus nx1101 pci adapter does not get detected

Post by NissanNut » Sat Dec 29, 2012 12:22 pm

Thanks for the link.

I guess mine is a 8161

lspci |grep Ethernet
01:09.0 Ethernet controller: Realtek Semiconductor Co., Ltd. Device 8161 (rev 10)


Here is the temp one:
ethtool -i eth1
driver: asix
version: 08-Nov-2011
firmware-version: ASIX AX88772 USB 2.0 Ethernet
bus-info: usb-0000:01:0a.2-2
supports-statistics: no
supports-test: no
supports-eeprom-access: yes
supports-register-dump: no

Here is the asus

ethtool -i eth0
Cannot get driver information: No such device
Mint 16 Cinnamon 64 bit - Server/Home PC
Mint 13 Mate 32 bit - Laptop IBM t42

mank_in
Level 6
Level 6
Posts: 1390
Joined: Wed Nov 16, 2011 2:29 pm
Location: Bali

Re: asus nx1101 pci adapter does not get detected

Post by mank_in » Sat Dec 29, 2012 3:09 pm

can you give an output of:

Code: Select all

lspci -nn

User avatar
NissanNut
Level 1
Level 1
Posts: 31
Joined: Tue Jul 19, 2011 9:29 pm
Location: Texas

Re: asus nx1101 pci adapter does not get detected

Post by NissanNut » Sat Dec 29, 2012 5:32 pm

Sure. Thanks for helping.

lspci -nn
00:00.0 RAM memory [0500]: NVIDIA Corporation MCP67 Memory Controller [10de:0547] (rev a2)
00:01.0 ISA bridge [0601]: NVIDIA Corporation MCP67 ISA Bridge [10de:0548] (rev a2)
00:01.1 SMBus [0c05]: NVIDIA Corporation MCP67 SMBus [10de:0542] (rev a2)
00:01.2 RAM memory [0500]: NVIDIA Corporation MCP67 Memory Controller [10de:0541] (rev a2)
00:02.0 USB controller [0c03]: NVIDIA Corporation MCP67 OHCI USB 1.1 Controller [10de:055e] (rev a2)
00:02.1 USB controller [0c03]: NVIDIA Corporation MCP67 EHCI USB 2.0 Controller [10de:055f] (rev a2)
00:04.0 USB controller [0c03]: NVIDIA Corporation MCP67 OHCI USB 1.1 Controller [10de:055e] (rev a2)
00:04.1 USB controller [0c03]: NVIDIA Corporation MCP67 EHCI USB 2.0 Controller [10de:055f] (rev a2)
00:06.0 IDE interface [0101]: NVIDIA Corporation MCP67 IDE Controller [10de:0560] (rev a1)
00:07.0 Audio device [0403]: NVIDIA Corporation MCP67 High Definition Audio [10de:055c] (rev a1)
00:08.0 PCI bridge [0604]: NVIDIA Corporation MCP67 PCI Bridge [10de:0561] (rev a2)
00:09.0 IDE interface [0101]: NVIDIA Corporation MCP67 AHCI Controller [10de:0550] (rev a2)
00:0b.0 PCI bridge [0604]: NVIDIA Corporation MCP67 PCI Express Bridge [10de:0562] (rev a2)
00:0c.0 PCI bridge [0604]: NVIDIA Corporation MCP67 PCI Express Bridge [10de:0563] (rev a2)
00:0d.0 PCI bridge [0604]: NVIDIA Corporation MCP67 PCI Express Bridge [10de:0563] (rev a2)
00:0e.0 PCI bridge [0604]: NVIDIA Corporation MCP67 PCI Express Bridge [10de:0563] (rev a2)
00:0f.0 PCI bridge [0604]: NVIDIA Corporation MCP67 PCI Express Bridge [10de:0563] (rev a2)
00:10.0 PCI bridge [0604]: NVIDIA Corporation MCP67 PCI Express Bridge [10de:0563] (rev a2)
00:11.0 PCI bridge [0604]: NVIDIA Corporation MCP67 PCI Express Bridge [10de:0563] (rev a2)
00:12.0 VGA compatible controller [0300]: NVIDIA Corporation C68 [GeForce 7025 / nForce 630a] [10de:053e] (rev a2)
00:18.0 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration [1022:1100]
00:18.1 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map [1022:1101]
00:18.2 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller [1022:1102]
00:18.3 Host bridge [0600]: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control [1022:1103]
01:07.0 FireWire (IEEE 1394) [0c00]: Texas Instruments TSB43AB22A IEEE-1394a-2000 Controller (PHY/Link) [iOHCI-Lynx] [104c:8023]
01:09.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. Device [10ec:8161] (rev 10)
01:0a.0 USB controller [0c03]: NEC Corporation USB [1033:0035] (rev 43)
01:0a.1 USB controller [0c03]: NEC Corporation USB [1033:0035] (rev 43)
01:0a.2 USB controller [0c03]: NEC Corporation USB 2.0 [1033:00e0] (rev 04)
02:00.0 VGA compatible controller [0300]: NVIDIA Corporation G98 [GeForce 8400 GS] [10de:06e4] (rev a1)
Mint 16 Cinnamon 64 bit - Server/Home PC
Mint 13 Mate 32 bit - Laptop IBM t42

mank_in
Level 6
Level 6
Posts: 1390
Joined: Wed Nov 16, 2011 2:29 pm
Location: Bali

Re: asus nx1101 pci adapter does not get detected

Post by mank_in » Sat Dec 29, 2012 11:49 pm

First , i think there is an error here :
01:09.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. Device [10ec:8161] (rev 10)
PCI ID of your card is 10ec:8161
Full list is : PCI\\VEN_10EC&DEV_8161
10EC is realtek ID , with device model 8161
i check asus website and download driver for windows to see if PCI ID is correct ( your card is NX1101 V2 )
You can open rt64win7.inf , and you will see no PCI\\VEN_10EC&DEV_8161, and I think your card is realtek8169

If this is an error detection, you can try move your card to different PCI port in your Mainboard and check lspci -nn again.
and i think the linux driver in asus website not specific for fedora, because package format is tar.gz ( fedora package format is RPM )

You can examine physically your card to see what chipset in use.
for drivers : http://www.realtek.com.tw/downloads/dow ... Down=false

User avatar
NissanNut
Level 1
Level 1
Posts: 31
Joined: Tue Jul 19, 2011 9:29 pm
Location: Texas

Re: asus nx1101 pci adapter does not get detected

Post by NissanNut » Tue Jan 08, 2013 8:02 pm

Your good. I pulled the card. It is a 8169. I put in the other slot and now it works perfect.

lspci |grep Ethernet
01:0a.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8169 Gigabit Ethernet (rev 10)


Thanks!!!!
Mint 16 Cinnamon 64 bit - Server/Home PC
Mint 13 Mate 32 bit - Laptop IBM t42

Post Reply

Return to “Newbie Questions”