Can`t get programs installed

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
rober7
Level 1
Level 1
Posts: 11
Joined: Fri Mar 25, 2011 7:24 am

Can`t get programs installed

Post by rober7 »

Hy, i`m using Linux Mint 10 Julia and when I try to install ruby and ruby gems (and other porgrams too) it doesn`t work.
my source list is this:

Code: Select all

deb http://linux-mint.froonix.org/ julia main upstream import backport romeo
deb-src http://linux-mint.froonix.org/ julia main upstream import backport romeo #Added by software-properties
deb http://archive.ubuntu.com/ubuntu/ maverick main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ maverick-updates main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ maverick-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu/ maverick partner
deb http://packages.medibuntu.org/ maverick free non-free

deb http://archive.removed/ubuntu maverick-removed apps
deb http://archive.removed/ubuntu maverick-removed games
after i update

Code: Select all

Ign file: binary/ Release.gpg
Ign file:/usr/share/local-repository/ binary/ Translation-en                   
Ign file:/usr/share/local-repository/ binary/ Translation-en_US                
Ign file: binary/ Release                                                      
Ign file: binary/ Packages                                                     
Ign file: binary/ Packages                                                     
Hit http://dl.google.com stable Release.gpg                                    
Ign http://dl.google.com/linux/chrome/deb/ stable/main Translation-en          
Hit http://archive.canonical.com maverick Release.gpg                          
Ign http://archive.canonical.com/ubuntu/ maverick/partner Translation-en       
Ign http://archive.canonical.com/ubuntu/ maverick/partner Translation-en_US    
Ign http://dl.google.com/linux/chrome/deb/ stable/main Translation-en_US       
Hit http://linux-mint.froonix.org julia Release.gpg                            
Ign http://linux-mint.froonix.org/ julia/backport Translation-en               
Ign http://linux-mint.froonix.org/ julia/backport Translation-en_US            
Ign http://security.ubuntu.com maverick-security Release.gpg                   
Ign http://security.ubuntu.com/ubuntu/ maverick-security/main Translation-en   
Ign http://security.ubuntu.com/ubuntu/ maverick-security/main Translation-en_US
Ign http://security.ubuntu.com/ubuntu/ maverick-security/multiverse Translation-en
Ign http://security.ubuntu.com/ubuntu/ maverick-security/multiverse Translation-en_US
Ign http://security.ubuntu.com/ubuntu/ maverick-security/restricted Translation-en
Ign http://security.ubuntu.com/ubuntu/ maverick-security/restricted Translation-en_US
Ign http://security.ubuntu.com/ubuntu/ maverick-security/universe Translation-en
Ign http://security.ubuntu.com/ubuntu/ maverick-security/universe Translation-en_US
Ign http://archive.ubuntu.com maverick Release.gpg                             
Ign http://archive.ubuntu.com/ubuntu/ maverick/main Translation-en             
Ign http://archive.ubuntu.com/ubuntu/ maverick/main Translation-en_US          
Ign http://archive.ubuntu.com/ubuntu/ maverick/multiverse Translation-en       
Ign http://archive.ubuntu.com/ubuntu/ maverick/multiverse Translation-en_US    
Ign http://archive.ubuntu.com/ubuntu/ maverick/restricted Translation-en       
Ign http://archive.ubuntu.com/ubuntu/ maverick/restricted Translation-en_US    
Ign http://archive.ubuntu.com/ubuntu/ maverick/universe Translation-en         
Ign http://archive.ubuntu.com/ubuntu/ maverick/universe Translation-en_US      
Ign http://archive.ubuntu.com maverick-updates Release.gpg                     
Hit http://archive.canonical.com maverick Release                              
Ign http://linux-mint.froonix.org/ julia/import Translation-en                 
Ign http://linux-mint.froonix.org/ julia/import Translation-en_US              
Ign http://linux-mint.froonix.org/ julia/main Translation-en                   
Hit http://dl.google.com stable Release                                        
Ign http://ppa.launchpad.net maverick Release.gpg                              
Ign http://ppa.launchpad.net/lkjoel/fix404/ubuntu/ maverick/main Translation-en
Ign http://ppa.launchpad.net/lkjoel/fix404/ubuntu/ maverick/main Translation-en_US
Ign http://security.ubuntu.com maverick-security Release                       
Ign http://linux-mint.froonix.org/ julia/main Translation-en_US                
Ign http://linux-mint.froonix.org/ julia/romeo Translation-en                  
Ign http://linux-mint.froonix.org/ julia/romeo Translation-en_US               
Ign http://linux-mint.froonix.org/ julia/upstream Translation-en               
Ign http://archive.ubuntu.com/ubuntu/ maverick-updates/main Translation-en     
Ign http://archive.ubuntu.com/ubuntu/ maverick-updates/main Translation-en_US  
Ign http://archive.ubuntu.com/ubuntu/ maverick-updates/multiverse Translation-en
Ign http://archive.ubuntu.com/ubuntu/ maverick-updates/multiverse Translation-en_US
Ign http://archive.ubuntu.com/ubuntu/ maverick-updates/restricted Translation-en
Ign http://archive.ubuntu.com/ubuntu/ maverick-updates/restricted Translation-en_US
Ign http://archive.ubuntu.com/ubuntu/ maverick-updates/universe Translation-en 
Err http://archive.removed maverick-removed Release.gpg                      
  Could not connect to archive.removed:80 (209.105.191.78). - connect (113: No route to host)
Err http://archive.removed/ubuntu/ maverick-removed/apps Translation-en      
  Unable to connect to archive.removed:http:
Err http://archive.removed/ubuntu/ maverick-removed/apps Translation-en_US   
  Unable to connect to archive.removed:http:
Err http://archive.removed/ubuntu/ maverick-removed/games Translation-en     
  Unable to connect to archive.removed:http:
Err http://archive.removed/ubuntu/ maverick-removed/games Translation-en_US  
  Unable to connect to archive.removed:http:
Ign http://archive.removed maverick-removed Release                          
Ign http://archive.removed maverick-removed/apps i386 Packages               
Ign http://ppa.launchpad.net maverick Release.gpg                              
Ign http://ppa.launchpad.net/shnatsel/zram/ubuntu/ maverick/main Translation-en
Ign http://ppa.launchpad.net/shnatsel/zram/ubuntu/ maverick/main Translation-en_US
Ign http://archive.removed maverick-removed/games i386 Packages              
Ign http://archive.removed maverick-removed/apps i386 Packages               
Ign http://archive.removed maverick-removed/games i386 Packages              
Err http://archive.removed maverick-removed/apps i386 Packages               
  Unable to connect to archive.removed:http:
Err http://archive.removed maverick-removed/games i386 Packages              
  Unable to connect to archive.removed:http:
Ign http://ppa.launchpad.net maverick Release                                  
Ign http://security.ubuntu.com maverick-security/main i386 Packages/DiffIndex  
Ign http://linux-mint.froonix.org/ julia/upstream Translation-en_US            
Hit http://linux-mint.froonix.org julia Release                                
Hit http://archive.canonical.com maverick/partner i386 Packages                
Ign http://archive.ubuntu.com/ubuntu/ maverick-updates/universe Translation-en_US
Ign http://archive.ubuntu.com maverick Release                                 
Ign http://ppa.launchpad.net maverick Release                                  
Ign http://security.ubuntu.com maverick-security/restricted i386 Packages/DiffIndex
Ign http://security.ubuntu.com maverick-security/universe i386 Packages/DiffIndex
Ign http://security.ubuntu.com maverick-security/multiverse i386 Packages/DiffIndex
Hit http://dl.google.com stable/main i386 Packages                             
Hit http://packages.medibuntu.org maverick Release.gpg                         
Ign http://linux-mint.froonix.org julia/main Sources                           
Ign http://archive.ubuntu.com maverick-updates Release                         
Ign http://security.ubuntu.com maverick-security/main i386 Packages            
Ign http://security.ubuntu.com maverick-security/restricted i386 Packages      
Ign http://security.ubuntu.com maverick-security/universe i386 Packages        
Ign http://ppa.launchpad.net maverick/main Sources                             
Ign http://ppa.launchpad.net maverick/main i386 Packages                       
Ign http://linux-mint.froonix.org julia/upstream Sources                       
Ign http://linux-mint.froonix.org julia/import Sources                         
Ign http://linux-mint.froonix.org julia/backport Sources                       
Ign http://linux-mint.froonix.org julia/romeo Sources                          
Ign http://linux-mint.froonix.org julia/main i386 Packages                     
Ign http://archive.ubuntu.com maverick/main i386 Packages/DiffIndex            
Ign http://archive.ubuntu.com maverick/restricted i386 Packages/DiffIndex      
Ign http://linux-mint.froonix.org julia/upstream i386 Packages                 
Ign http://linux-mint.froonix.org julia/import i386 Packages                   
Ign http://security.ubuntu.com maverick-security/multiverse i386 Packages      
Ign http://security.ubuntu.com maverick-security/main i386 Packages            
Ign http://ppa.launchpad.net maverick/main Sources                             
Ign http://ppa.launchpad.net maverick/main i386 Packages                       
Ign http://ppa.launchpad.net maverick/main Sources                             
Ign http://linux-mint.froonix.org julia/backport i386 Packages                 
Ign http://linux-mint.froonix.org julia/romeo i386 Packages          
Ign http://packages.medibuntu.org/ maverick/free Translation-en                
Ign http://linux-mint.froonix.org julia/main Sources                           
Ign http://linux-mint.froonix.org julia/upstream Sources                       
Ign http://linux-mint.froonix.org julia/import Sources                         
Ign http://linux-mint.froonix.org julia/backport Sources                       
Ign http://archive.ubuntu.com maverick/universe i386 Packages/DiffIndex        
Ign http://archive.ubuntu.com maverick/multiverse i386 Packages/DiffIndex      
Ign http://linux-mint.froonix.org julia/romeo Sources                          
Ign http://security.ubuntu.com maverick-security/restricted i386 Packages      
Ign http://ppa.launchpad.net maverick/main i386 Packages                       
Ign http://ppa.launchpad.net maverick/main Sources                             
Ign http://ppa.launchpad.net maverick/main i386 Packages                       
Ign http://linux-mint.froonix.org julia/main i386 Packages                     
Ign http://linux-mint.froonix.org julia/upstream i386 Packages                 
Ign http://linux-mint.froonix.org julia/import i386 Packages                   
Ign http://linux-mint.froonix.org julia/backport i386 Packages                 
Ign http://security.ubuntu.com maverick-security/universe i386 Packages        
Ign http://security.ubuntu.com maverick-security/multiverse i386 Packages      
Ign http://archive.ubuntu.com maverick-updates/main i386 Packages/DiffIndex    
Ign http://archive.ubuntu.com maverick-updates/restricted i386 Packages/DiffIndex
Ign http://archive.ubuntu.com maverick-updates/universe i386 Packages/DiffIndex
Ign http://archive.ubuntu.com maverick-updates/multiverse i386 Packages/DiffIndex
Ign http://archive.ubuntu.com maverick/main i386 Packages                      
Err http://ppa.launchpad.net maverick/main Sources                             
  404  Not Found
Err http://ppa.launchpad.net maverick/main i386 Packages                       
  404  Not Found
Err http://ppa.launchpad.net maverick/main Sources                             
  404  Not Found
Ign http://linux-mint.froonix.org julia/romeo i386 Packages                    
Hit http://linux-mint.froonix.org julia/main Sources                           
Hit http://linux-mint.froonix.org julia/upstream Sources                       
Hit http://linux-mint.froonix.org julia/import Sources                         
Hit http://linux-mint.froonix.org julia/backport Sources                       
Err http://security.ubuntu.com maverick-security/main i386 Packages            
  404  Not Found
Ign http://packages.medibuntu.org/ maverick/free Translation-en_US             
Hit http://linux-mint.froonix.org julia/romeo Sources                          
Hit http://linux-mint.froonix.org julia/main i386 Packages                     
Ign http://archive.ubuntu.com maverick/restricted i386 Packages                
Ign http://archive.ubuntu.com maverick/universe i386 Packages                  
Hit http://linux-mint.froonix.org julia/upstream i386 Packages                 
Hit http://linux-mint.froonix.org julia/import i386 Packages                   
Err http://ppa.launchpad.net maverick/main i386 Packages                       
  404  Not Found
Hit http://linux-mint.froonix.org julia/backport i386 Packages                 
Err http://security.ubuntu.com maverick-security/restricted i386 Packages      
  404  Not Found
Err http://security.ubuntu.com maverick-security/universe i386 Packages        
  404  Not Found
Hit http://linux-mint.froonix.org julia/romeo i386 Packages                    
Ign http://archive.ubuntu.com maverick/multiverse i386 Packages                
Ign http://archive.ubuntu.com maverick-updates/main i386 Packages              
Ign http://archive.ubuntu.com maverick-updates/restricted i386 Packages        
Ign http://archive.ubuntu.com maverick-updates/universe i386 Packages          
Ign http://archive.ubuntu.com maverick-updates/multiverse i386 Packages        
Err http://security.ubuntu.com maverick-security/multiverse i386 Packages      
  404  Not Found
Ign http://packages.medibuntu.org/ maverick/non-free Translation-en  
Ign http://archive.ubuntu.com maverick/main i386 Packages                      
Ign http://archive.ubuntu.com maverick/restricted i386 Packages                
Ign http://archive.ubuntu.com maverick/universe i386 Packages                  
Ign http://archive.ubuntu.com maverick/multiverse i386 Packages                
Ign http://archive.ubuntu.com maverick-updates/main i386 Packages              
Ign http://archive.ubuntu.com maverick-updates/restricted i386 Packages        
Ign http://archive.ubuntu.com maverick-updates/universe i386 Packages          
Ign http://packages.medibuntu.org/ maverick/non-free Translation-en_US         
Ign http://archive.ubuntu.com maverick-updates/multiverse i386 Packages        
Err http://archive.ubuntu.com maverick/main i386 Packages                      
  404  Not Found [IP: 91.189.92.202 80]
Err http://archive.ubuntu.com maverick/restricted i386 Packages                
  404  Not Found [IP: 91.189.92.202 80]
Err http://archive.ubuntu.com maverick/universe i386 Packages                  
  404  Not Found [IP: 91.189.92.202 80]
Err http://archive.ubuntu.com maverick/multiverse i386 Packages                
  404  Not Found [IP: 91.189.92.202 80]
Err http://archive.ubuntu.com maverick-updates/main i386 Packages              
  404  Not Found [IP: 91.189.92.202 80]
Err http://archive.ubuntu.com maverick-updates/restricted i386 Packages        
  404  Not Found [IP: 91.189.92.202 80]
Hit http://packages.medibuntu.org maverick Release                             
Err http://archive.ubuntu.com maverick-updates/universe i386 Packages
  404  Not Found [IP: 91.189.92.202 80]
Err http://archive.ubuntu.com maverick-updates/multiverse i386 Packages
  404  Not Found [IP: 91.189.92.202 80]
Hit http://packages.medibuntu.org maverick/free i386 Packages
Hit http://packages.medibuntu.org maverick/non-free i386 Packages
W: Failed to fetch http://archive.removed/ubuntu/dists/maverick-removed/Release.gpg  Could not connect to archive.removed:80 (209.105.191.78). - connect (113: No route to host)

W: Failed to fetch http://archive.removed/ubuntu/dists/maverick-removed/apps/i18n/Translation-en.bz2  Unable to connect to archive.removed:http:

W: Failed to fetch http://archive.removed/ubuntu/dists/maverick-removed/apps/i18n/Translation-en_US.bz2  Unable to connect to archive.removed:http:

W: Failed to fetch http://archive.removed/ubuntu/dists/maverick-removed/games/i18n/Translation-en.bz2  Unable to connect to archive.removed:http:

W: Failed to fetch http://archive.removed/ubuntu/dists/maverick-removed/games/i18n/Translation-en_US.bz2  Unable to connect to archive.removed:http:

W: Failed to fetch http://archive.removed/ubuntu/dists/maverick-removed/apps/binary-i386/Packages.gz  Unable to connect to archive.removed:http:

W: Failed to fetch http://archive.removed/ubuntu/dists/maverick-removed/games/binary-i386/Packages.gz  Unable to connect to archive.removed:http:

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/maverick-security/main/binary-i386/Packages.gz  404  Not Found

W: Failed to fetch http://ppa.launchpad.net/lkjoel/fix404/ubuntu/dists/maverick/main/source/Sources.gz  404  Not Found

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/maverick-security/restricted/binary-i386/Packages.gz  404  Not Found

W: Failed to fetch http://ppa.launchpad.net/lkjoel/fix404/ubuntu/dists/maverick/main/binary-i386/Packages.gz  404  Not Found

W: Failed to fetch http://ppa.launchpad.net/shnatsel/zram/ubuntu/dists/maverick/main/source/Sources.gz  404  Not Found

W: Failed to fetch http://ppa.launchpad.net/shnatsel/zram/ubuntu/dists/maverick/main/binary-i386/Packages.gz  404  Not Found

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/maverick-security/universe/binary-i386/Packages.gz  404  Not Found

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/maverick-security/multiverse/binary-i386/Packages.gz  404  Not Found

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/maverick/main/binary-i386/Packages.gz  404  Not Found [IP: 91.189.92.202 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/maverick/restricted/binary-i386/Packages.gz  404  Not Found [IP: 91.189.92.202 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/maverick/universe/binary-i386/Packages.gz  404  Not Found [IP: 91.189.92.202 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/maverick/multiverse/binary-i386/Packages.gz  404  Not Found [IP: 91.189.92.202 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/maverick-updates/main/binary-i386/Packages.gz  404  Not Found [IP: 91.189.92.202 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/maverick-updates/restricted/binary-i386/Packages.gz  404  Not Found [IP: 91.189.92.202 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/maverick-updates/universe/binary-i386/Packages.gz  404  Not Found [IP: 91.189.92.202 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/maverick-updates/multiverse/binary-i386/Packages.gz  404  Not Found [IP: 91.189.92.202 80]

E: Some index files failed to download, they have been ignored, or old ones used instead.
Any ideea why it doesn`t work and how i can fix it?
p.s. : i`m a newbie
Bloggeries - open blog.
rober7
Level 1
Level 1
Posts: 11
Joined: Fri Mar 25, 2011 7:24 am

Re: Can`t get programs installed

Post by rober7 »

another exemple :

Code: Select all

sudo apt-get install openssh-server
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libyaml-0-2 libreadline5
Use 'apt-get autoremove' to remove them.
Suggested packages:
  rssh molly-guard openssh-blacklist openssh-blacklist-extra
The following NEW packages will be installed:
  openssh-server
0 upgraded, 1 newly installed, 0 to remove and 118 not upgraded.
Need to get 302kB of archives.
After this operation, 819kB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
  openssh-server
Install these packages without verification [y/N]? y
Err http://archive.ubuntu.com/ubuntu/ maverick/main openssh-server i386 1:5.5p1-4ubuntu4
  404  Not Found [IP: 91.189.92.156 80]
Failed to fetch http://archive.ubuntu.com/ubuntu/pool/main/o/openssh/openssh-server_5.5p1-4ubuntu4_i386.deb  404  Not Found [IP: 91.189.92.156 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
Bloggeries - open blog.
eric k
Level 3
Level 3
Posts: 109
Joined: Tue Feb 16, 2010 7:44 pm
Location: South Florida

Re: Can`t get programs installed

Post by eric k »

Linux Mint 10 was based upon Ubuntu 10.10 Maverick Meercat, neither of which are still supported.

That's why you can't install anything, the repositories you're attempting to use don't exist any longer.

"This note is just to confirm that the support period for Ubuntu 10.10 (Maverick Meerkat) formally ends on April 10, 2012 and Ubuntu Security Notices no longer includes information or updated packages for Ubuntu 10.10."

https://lists.ubuntu.com/archives/ubunt ... 00158.html
GIGABYTE GA-P35-DS3L LGA 775, Xeon 3.0 Ghz Core 2 Duo, 4 GB DDR2-800, EVGA 8800GT, WD Caviar 250 GB SATA-2

Ubuntu 12.04 LTS, Crunchbang Waldorf, Mint 13 w/Cinnamon, Elementary Luna Beta, Puppy
Post Reply

Return to “Newbie Questions”