Mint opening up my partitions after boot [SOLVED]

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Surreal
Level 1
Level 1
Posts: 23
Joined: Fri Jan 07, 2011 10:24 am
Location: the Netherlands

Mint opening up my partitions after boot [SOLVED]

Post by Surreal » Wed Jan 02, 2013 9:53 am

I have Mint 14.1 Mate Edition installed (64bit) and ever since i have been using this new version i have this problem;

After each boot when i logon, Mint automatically opens up my 3 (auto) mounted NTFS partitions in Caja.

Now i don't reboot my computer that often but this started to occur after installing the latest Mint version and i can't figure
out why it's doing this...
Last edited by Surreal on Wed Jan 02, 2013 5:45 pm, edited 1 time in total.
'There are only 2 kinds of opinions in this world, mine and the wrong one', -Jeremy Clarkson

altair4
Level 19
Level 19
Posts: 9187
Joined: Tue Feb 03, 2009 10:27 am

Re: Mint opening up my partitions after boot

Post by altair4 » Wed Jan 02, 2013 1:01 pm

After each boot when i logon, Mint automatically opens up my 3 (auto) mounted NTFS partitions in Caja.
By "opens" you mean it launches the file manager to that partition's mount point or does it place 3 mount icon's on the desktop?

The latter will happen if you mount the partition to either /media or your home directory. Not sure what would cause the launching of caja. Almost sounds like it thinks it's a removable media like a USB stick or DVD?

Post the output of the following so folks here can see how you are set up:

Code: Select all

cat /etc/fstab

Code: Select all

mount
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

User avatar
Flemur
Level 16
Level 16
Posts: 6058
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Mint opening up my partitions after boot

Post by Flemur » Wed Jan 02, 2013 1:13 pm

After each boot when i logon, Mint automatically opens up my 3 (auto) mounted NTFS partitions in Caja.
See if Caja is one of your startup programs.
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 18.3 Xfce/fluxbox/pulse-less
Xubuntu 17.10/fluxbox/pulse-less

Orbmiser
Level 6
Level 6
Posts: 1498
Joined: Thu Oct 18, 2012 5:16 pm
Location: Portland,Oregon
Contact:

Re: Mint opening up my partitions after boot

Post by Orbmiser » Wed Jan 02, 2013 1:22 pm

For me have 5 Ntfs partitions 2 are usb external. And nemo shows them in file manager on boot up.

But they are not really mounted until I click on them. Check by mousing over one of them or right clicking.
If at the bottom of right click menu it says mount then they aren't mounted until you click on them. It's just nemo is aware of them there and giving you a easier gui way to mount them.

Also nemo runs on startup in processes even tho it's hasn't been launched. This is because Nemo is responsible for drawing and displaying devices on desktop.

Maybe same situation for Caja?
.

Surreal
Level 1
Level 1
Posts: 23
Joined: Fri Jan 07, 2011 10:24 am
Location: the Netherlands

Re: Mint opening up my partitions after boot

Post by Surreal » Wed Jan 02, 2013 1:30 pm

By opens i mean it opens the file manager to the mount point yes. I have disabled the partition icons to be shown on my desktop.

The partitions are mounted in my /home directory, during the installation process where you define your mount points i select the
NTFS partitions and type in the mount point there. For example my Music partition i type in "/home/stephan/Muziek" and so on for the other partitions.

Things is i have been doing it this way for as long as i can remember i have never seen this behaviour before when starting up my laptop.
It looks like what happens when you insert a USB drive, where the file manager launches and show you the content of that disk.

I have checked if Caja is among the startup programs but that isn't the case.

Here's my fstab file:

Code: Select all

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda2 during installation
UUID=6bd7f6c1-1023-46e5-bbd4-eb831fa14afe /               ext4    errors=remount-ro 0       1
# /home was on /dev/sda5 during installation
UUID=9dd3f602-64fa-4fa8-8dfd-29e7acac370b /home           ext4    defaults        0       2
# /home/stephan/Documenten was on /dev/sda7 during installation
UUID=0DBEF6BB45DB5FDD /home/stephan/Documenten ntfs    defaults,umask=007,gid=46 0       0
# /home/stephan/Muziek was on /dev/sda8 during installation
UUID=29259FB86F26ADF5 /home/stephan/Muziek ntfs    defaults,umask=007,gid=46 0       0
# /home/stephan/Opslag was on /dev/sda9 during installation
UUID=452DEEF45943BDA1 /home/stephan/Opslag ntfs    defaults,umask=007,gid=46 0       0
# swap was on /dev/sda6 during installation
UUID=21a746b1-ff9f-48f7-b308-281a85539fbf none            swap    sw              0       0
Here's my mount output;

Code: Select all

/dev/sda2 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
none on /run/user type tmpfs (rw,noexec,nosuid,nodev,size=104857600,mode=0755)
/dev/sda5 on /home type ext4 (rw)
/dev/sda7 on /home/stephan/Documenten type fuseblk (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096)
/dev/sda8 on /home/stephan/Muziek type fuseblk (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096)
/dev/sda9 on /home/stephan/Opslag type fuseblk (rw,nosuid,nodev,allow_other,default_permissions,blksize=4096)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfsd-fuse on /run/user/stephan/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,user=stephan)
'There are only 2 kinds of opinions in this world, mine and the wrong one', -Jeremy Clarkson

altair4
Level 19
Level 19
Posts: 9187
Joined: Tue Feb 03, 2009 10:27 am

Re: Mint opening up my partitions after boot

Post by altair4 » Wed Jan 02, 2013 2:02 pm

I'm trying without success to reproduce this symptom in a Mate install I have in VBox.

Your fstab looks textbook correct so I don't think it that. Just out of curiosity if you were to disable "Browse media when inserted" ( caja > Edit > Preferences > Media ) , logout and login again does it go away?
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

Surreal
Level 1
Level 1
Posts: 23
Joined: Fri Jan 07, 2011 10:24 am
Location: the Netherlands

Re: Mint opening up my partitions after boot

Post by Surreal » Wed Jan 02, 2013 5:44 pm

altair4 wrote:I'm trying without success to reproduce this symptom in a Mate install I have in VBox.

Your fstab looks textbook correct so I don't think it that. Just out of curiosity if you were to disable "Browse media when inserted" ( caja > Edit > Preferences > Media ) , logout and login again does it go away?
I have followed the steps you described, after that i logged out a few times and i have rebooted my laptop a few times also.
The issue seems to be gone now :D

Thanks alot for your help altair4, and everyone else offcourse :)
'There are only 2 kinds of opinions in this world, mine and the wrong one', -Jeremy Clarkson

altair4
Level 19
Level 19
Posts: 9187
Joined: Tue Feb 03, 2009 10:27 am

Re: Mint opening up my partitions after boot [SOLVED]

Post by altair4 » Thu Jan 03, 2013 7:20 am

I'm glad it resolved your issue but this brings up two issues / problems:

** When you insert a USB device it won't automatically launch caja anymore either.

** The bigger issue is why the heck is your OS treating these internal NTFS partitions like external USB partitions. Somethings discombobulated somewhere and I'm not sure where to look.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

Surreal
Level 1
Level 1
Posts: 23
Joined: Fri Jan 07, 2011 10:24 am
Location: the Netherlands

Re: Mint opening up my partitions after boot [SOLVED]

Post by Surreal » Thu Jan 03, 2013 10:18 am

altair4 wrote:I'm glad it resolved your issue but this brings up two issues / problems:

** When you insert a USB device it won't automatically launch caja anymore either.

** The bigger issue is why the heck is your OS treating these internal NTFS partitions like external USB partitions. Somethings discombobulated somewhere and I'm not sure where to look.
The fact that it doesn't launch Caja doesn't bother me that much, however the solution is a work-a-round instead of actually addressing the problem.
What i failed to mention (makes me really feel stupid) is that i have a dual boot set up using Windows 7 + Mint, however this has never caused me any problems.
'There are only 2 kinds of opinions in this world, mine and the wrong one', -Jeremy Clarkson

Tombu
Level 1
Level 1
Posts: 2
Joined: Tue Jan 08, 2013 11:55 am
Location: Finland

Re: Mint opening up my partitions after boot [SOLVED]

Post by Tombu » Tue Jan 08, 2013 12:03 pm

I also have my NTFS partitions launcing in Caja on login. Clean install, dualboots WinXP. Added the partitions in fstab manually. Edited the Caja settings as per instructions, now works as expected.

Code: Select all

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda5 during installation
UUID=2dcf2396-9235-4670-8877-b238f8c5e9cf /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda6 during installation
#UUID=a0d22920-18ac-443e-befa-3553a981596b none            swap    sw              0       0
#/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0
/dev/mapper/cryptswap1 none swap sw 0 0
UUID=FED0D4F3D0D4B35F /media/Windows ntfs defaults,nls=utf8,umask=000,uid=1000,windows_names 0 0
UUID=A8C47500C474D1D4 /media/Viihde ntfs defaults,nls=utf8,umask=000,uid=1000,windows_names 0 0
UUID=72E4653BE4650329 /media/Sekalaista ntfs defaults,nls=utf8,umask=000,uid=1000,windows_names 0 0
Mint 14.1 Mate

Post Reply

Return to “Newbie Questions”