PM: Device 00:08 failed to resume: error -19

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
jms
Level 1
Level 1
Posts: 21
Joined: Wed Jan 02, 2013 1:36 pm

PM: Device 00:08 failed to resume: error -19

Post by jms »

Hi, when Mint thaws from suspend, the following error message is displayed:

Code: Select all

[97616.379490] dpm_run_callback(): pnp_bus_resume+0x0/0x80 returns -19
[97616.379492] PM: Device 00:08 failed to resume: error -19
So far everything on the system seems to be running fine, but I'd like to understand what this means and how to fix it if possible. Any ideas what to do?

The error message was retrieved with the following command:

Code: Select all

dmesg -l err
Thanks!
vmanint
Level 1
Level 1
Posts: 1
Joined: Thu Jan 10, 2013 4:25 am

Re: PM: Device 00:08 failed to resume: error -19

Post by vmanint »

I get exactly the same error on my Acer E1-531 notebook. Everything seems to be working fine though.
jms
Level 1
Level 1
Posts: 21
Joined: Wed Jan 02, 2013 1:36 pm

Re: PM: Device 00:08 failed to resume: error -19

Post by jms »

Same here, but I'd like to fix the issue anyways whatever it is (and probably learn a lot in the process).

Does anyone know how to go about trouble shooting it?
rafi
Level 1
Level 1
Posts: 21
Joined: Wed Jan 02, 2013 11:46 pm

Re: PM: Device 00:08 failed to resume: error -19

Post by rafi »

Just to confirm that on a fresh install of Linux Mint 14 Nadia on a Dell Inspiron 13z the almost-same error occurs upon restart from suspend:

Code: Select all

dpm_run_callback(): pnp_bus_resume+0x0/0x80 returns -19
PM: Device 00:07 failed to resume: error -19
although everything seems to work alright anyway.

Cheers,
Rafi
RavanH
Level 2
Level 2
Posts: 53
Joined: Sun Jan 17, 2010 6:24 am

Re: PM: Device 00:08 failed to resume: error -19

Post by RavanH »

I see the same thing happening on a fresh Ubuntu GNOME 13.04 installation -- sorry for offending anyone here, I like Gnome Shell ;) -- on an Acer Aspire V5 with touch screen and EFI after resume from suspend to ram in the syslog:

Code: Select all

dpm_run_callback(): pnp_bus_resume+0x0/0x80 returns -19
PM: Device 00:07 failed to resume: error -19
All seems to function after resume but it still would be nice to figure out where this is coming from. How to find out which device we're talking about here?
I tried:

Code: Select all

$ cat /proc/devices
Character devices:
...

Block devices:
...
  7 loop
...
[code]
but I don not think this is what I'm looking for... Or is it?
Post Reply

Return to “Newbie Questions”